Community discussions

MikroTik App
 
LdB
Member Candidate
Member Candidate
Topic Author
Posts: 142
Joined: Thu May 20, 2021 4:23 pm

Virtual Node .. how to do

Wed Jan 05, 2022 4:33 am

I am trying to do this with live IP's there is no NAT's at all on router except for private access
balance_inout.jpg
I can do each part on it's own with a real port but virtual node is doing my head in

I tried creating a bridge entry as the virtual node and while it looks correct nothing routes
As an example here is what I am doing minus the pppoe server with sanitized IP's (6.6.6.0/24 would be network on 2nd links out)
what I expected was to be able to pass traffic .. so am I on right track ?
/interface bridge
add name=raw_internet_node

/interface vlan
add name=VLAN305 vlan-id=305 interface=ether3
add name=VLAN306 vlan-id=306 interface=ether3
add name=VLAN307 vlan-id=307 interface=ether4
add name=VLAN308 vlan-id=308 interface=ether4

/ip address
add address=1.1.1.2 network=1.1.1.3 interface=VLAN305
add address=2.2.2.2 network=2.2.2.3 interface=VLAN306
add address=3.3.3.2 network=3.3.3.3 interface=VLAN307
add address=4.4.4.2 network=4.4.4.3 interface=VLAN308
add address=5.5.5.65/27 network=5.5.5.64 interface=raw_internet_node

/ip firewall mangle
add chain=prerouting in-interface=VLAN305 connection-mark=no-mark action=mark-connection new-connection-mark=WAN1_conn
add chain=prerouting in-interface=VLAN306 connection-mark=no-mark action=mark-connection new-connection-mark=WAN2_conn
add chain=prerouting  in-interface=raw_internet_node connection-mark=no-mark dst-address-type=!local per-connection-classifier=both-addresses:2/0 action=mark-connection new-connection-mark=WAN1_conn 
add chain=prerouting  in-interface=raw_internet_node connection-mark=no-mark dst-address-type=!local per-connection-classifier=both-addresses:2/1 action=mark-connection new-connection-mark=WAN2_conn
add chain=prerouting connection-mark=WAN1_conn in-interface=raw_internet_node action=mark-routing new-routing-mark=to_WAN1
add chain=prerouting connection-mark=WAN2_conn in-interface=raw_internet_node action=mark-routing new-routing-mark=to_WAN2
add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1     
add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2

/ip route
add dst-address=0.0.0.0/0 gateway=1.1.1.3 routing-mark=to_WAN1 check-gateway=ping 
add dst-address=0.0.0.0/0 gateway=2.2.2.3 routing-mark=to_WAN2 check-gateway=ping 
add dst-address=6.6.6.0/24 gateway=3.3.3.3,4.4.4.3 check-gateway=ping
You do not have the required permissions to view the files attached to this post.

Who is online

Users browsing this forum: No registered users and 30 guests