Community discussions

MikroTik App
 
sky4
just joined
Topic Author
Posts: 8
Joined: Thu Oct 08, 2020 10:00 pm

is this the right way to set packet prioritization and qos in vlans?

Wed Jan 05, 2022 10:58 am

i have a rb4011 r2

port 1 is set as pppoe, vlan 835 (1 Gb)

there are 3 vlans on the bridge

port 2,3,4 have vid 10
port 5 has vid 20
port 6 has vid 30

vlan 10 ip x.x.1.x
vlan 20 ip x.x.0.x
vlan 30 ip x.x.2.x

I want to prioritize traffic for gaming purposes
to prioritize traffic i market packets like this
/ip firewall mangle add action=mark-connection chain=prerouting comment=pc new-connection-mark=pcpassthrough=yes src-address-list=pc
/ip firewall mangle add action=mark-packet chain=prerouting connection-mark=pc new-packet-mark=pcprepk passthrough=no
to limit bandwidth i marked them in the forward chain
/ip firewall mangle add action=mark-packet chain=forward comment=xboxpk connection-mark=pc new-packet-mark=pcuppk passthrough=no src-address-list=pc
/ip firewall mangle add action=mark-packet chain=forward comment=xboxpk connection-mark=pc dst-address-list=pc new-packet-mark=pcdwpk passthrough=no
i created 3 queue trees, one for prioritization, one to limit download and one to limit upload

priotization queue has the queue value set as default and its something like
/queue tree add name=global1 parent=global priority=1 queue=default
/queue tree add name=pcpre packet-mark=pcprepk parent=global1 priority=1 queue=default
/queue tree add name=pc1pre packet-mark=pc1prepk parent=global1 priority=2 queue=default
to limit download and upload i created two pcq queue types
download
/queue type add kind=pcq name=pcqdw100M pcq-classifier=dst-address pcq-rate=100M
upload
/queue type add kind=pcq name=pcqup100M pcq-classifier=src-address pcq-rate=100M
and then created two queue trees like this
/queue tree add max-limit=200M name=download parent=bridge priority=2 queue=pcqdw200m
/queue tree add name=pc packet-mark=pcdwpk parent=download priority=1 queue=pcqdw100M
/queue tree add name=pc packet-mark=pc1dwpk parent=download priority=2 queue=pcqdw100M

/queue tree add max-limit=200M name=upload parent=vlan835 priority=2 queue=pcqup200M
/queue tree add name=pc packet-mark=pcuppk parent=upload priority=1 queue=pcqup100M
/queue tree add name=pc packet-mark=pc1uppk parent=upload priority=2 queue=pcqup100M
im wondering if prioritization and bandwidth queues are set correctly or if there is a better way to do it?

Who is online

Users browsing this forum: diamuxin, Experimentator, ichyre, johnb175a, Sob, TeWe and 57 guests