Community discussions

MikroTik App
 
jorgb
just joined
Topic Author
Posts: 19
Joined: Wed Jun 18, 2014 12:33 am

OSPF load balancing broken in v7.1.1 ?

Wed Jan 19, 2022 6:06 pm

We have quite a few paths we load balance by using the same ospf cost on both links. This has worked without any issues in RouterOS v6.x.x.
We are now starting to roll out RouterOS v7.1.1 on CCR2004 routers, but it seems that ospf load balancing doesn't seem to work in RouterOS v7.1.1.
After upgrading to v7.1.1, I've reconfigured ospf and triple checked to make sure the ospf cost and priority is equal between the 2 routers/links, yet traffic seems to only flow through one link.

...also, I've tried v7.2rc1 but that completely broke my ospf and I had to go back to v7.1.1.

Has anyone got this to work on v7.1.1?
 
aleksis
just joined
Posts: 23
Joined: Wed Apr 30, 2014 12:13 pm

Re: OSPF load balancing broken in v7.1.1 ?

Fri Jan 21, 2022 10:32 am

Load balancing should work. Is the ecmp route missing from the routing table?
 
jorgb
just joined
Topic Author
Posts: 19
Joined: Wed Jun 18, 2014 12:33 am

Re: OSPF load balancing broken in v7.1.1 ?

Fri Jan 21, 2022 10:54 pm

In RouterOS 6.x.x once you have equal ospf costs on 2 paths to the same router, the gateway for that (ospf) route will now show the two gateways:

> ip route print detail
0 ADo dst-address=0.0.0.0/0 gateway=172.16.1.93,172.16.0.141
gateway-status=172.16.1.93 reachable via ether11 - path (2),172.16.0.141 reachable via ether1 - path (1) distance=110 scope=20 target-scope=10
route-tag=1 ospf-metric=41 ospf-type=external-type-2

However, in RouterOS 7.1.1 it looks like this:

> ip route print detail
DAo + dst-address=0.0.0.0/0 routing-table=main
gateway=172.16.1.193%ether11 - path (2)
immediate-gw=172.16.1.193%ether11 - path (2) distance=110 scope=20
target-scope=10 suppress-hw-offload=no
DAo + dst-address=0.0.0.0/0 routing-table=main
gateway=172.16.0.141%ether1 - path (1)
immediate-gw=172.16.0.141%ether1 - path (1) distance=110 scope=20
target-scope=10 suppress-hw-offload=no

So, clearly something either changed in RouterOs 7 or there is a bug...

I get the same results in version 7.2rc1... and ospf MD5 authentication is also busted in 7.2rc1

Any input?
Last edited by jorgb on Sun Jan 23, 2022 1:59 am, edited 2 times in total.
 
User avatar
clambert
newbie
Posts: 42
Joined: Wed Jun 12, 2019 5:04 am

Re: OSPF load balancing broken in v7.1.1 ?

Sat Jan 22, 2022 12:40 am

> ip route print detail
DAo + dst-address=0.0.0.0/0 routing-table=main
gateway=172.16.1.93%ether11 - path (2)
immediate-gw=172.16.1.193%ether11 - path (2) distance=110 scope=20
target-scope=10 suppress-hw-offload=no
DAo + dst-address=0.0.0.0/0 routing-table=ma=172.16.1.193in
gateway=172.16.0.141 %ether1 - path (1)
immediate-gw=172.16.0.141 %ether1 - path (1) distance=110 scope=20
target-scope=10 suppress-hw-offload=no
Why does it show the immediate-gw=172.16.1.193 and gateway=172.16.1.93. Is it a typo?
 
jorgb
just joined
Topic Author
Posts: 19
Joined: Wed Jun 18, 2014 12:33 am

Re: OSPF load balancing broken in v7.1.1 ?

Sat Jan 22, 2022 1:13 am

Yes, that was a typo... sorry :(

It's now corrected in the original post...
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 6601
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: OSPF load balancing broken in v7.1.1 ?

Sun Jan 23, 2022 10:46 pm

In your example OSPF have installed ECMP route.
Read more on v7 ECMP routes here:
https://help.mikrotik.com/docs/display/ ... CMP)routes
 
jorgb
just joined
Topic Author
Posts: 19
Joined: Wed Jun 18, 2014 12:33 am

Re: OSPF load balancing broken in v7.1.1 ?

Tue Jan 25, 2022 12:49 am

In your example OSPF have installed ECMP route.
Read more on v7 ECMP routes here:
https://help.mikrotik.com/docs/display/ ... CMP)routes

Thank you for the link... I have set this up in my lab:

Router A |=============| Router B


Both routers are on RouterOS 7.1.1 and are connected via 2 short ethernet cables.
Ospf is established and happy (ie no errors):

Router A (# /routing route print):
Columns: DST-ADDRESS, GATEWAY, AFI, DISTANCE, SCOPE, TARGET-SCOPE, IMMEDIATE-GW
DST-ADDRESS GATEWAY AFI DISTANCE SCOPE TARGET-SCOPE IMMEDIATE-GW
Ao+ 0.0.0.0/0 172.16.0.214%sfp-sfpplus10 - test 1 ip4 110 20 10 172.16.0.214%sfp-sfpplus10 - test 1
Ao+ 0.0.0.0/0 172.16.1.78%sfp-sfpplus11 - test 2 ip4 110 20 10 172.16.1.78%sfp-sfpplus11 - test 2

ECMP route is present... links are equal (cost, speed, etc).

#/routing/ospf/export
/routing ospf instance
add name=default originate-default=never redistribute=connected,static router-id=10.255.2.57 routing-table=main
/routing ospf area
add area-id=0.0.0.2 instance=default name="test area"
/routing ospf interface-template
add area="test area" auth=md5 auth-id=1 auth-key=xxxxxx cost=10 interfaces=all networks=172.16.0.0/24,172.16.1.0/24 priority=1

As you can see, the config is rather simple.

#/routing/ospf/area/print
Flags: X - disabled, I - inactive, D - dynamic; T - transit-capable
0 name="test area" instance=default area-id=0.0.0.2 type=default
[admin@routera] /routing/ospf/interface print
Flags: D - dynamic
0 D address=172.16.0.213%sfp-sfpplus10 - test 1 area=test area state=bdr network-type=broadcast dr=172.16.0.214 cost=10 priority=1 retransmit-interval=5s transmit-delay=1s hello-interval=10s dead-interval=40s
1 D address=172.16.1.77%sfp-sfpplus11 - test 2 area=test area state=bdr network-type=broadcast dr=172.16.1.78 cost=10 priority=1 retransmit-interval=5s transmit-delay=1s hello-interval=10s dead-interval=40s


With the config above, traffic is NOT balanced even though the ecmp route is installed in the main routing table. Traffic will only flow through one interface. Now, downgrading to version 6.48.x will "fix" the issue and traffic will be load balanced correctly.

Either I'm missing something in the v 7.1.1 ospf setup or something is broken.
 
olgale
MikroTik Support
MikroTik Support
Posts: 6
Joined: Mon Oct 14, 2019 3:33 pm

Re: OSPF load balancing broken in v7.1.1 ?  [SOLVED]

Mon Feb 21, 2022 12:04 pm

Hello!

The issue with ECMP on CCR2004 will be fixed in next releases.

Who is online

Users browsing this forum: No registered users and 5 guests