Community discussions

MikroTik App
 
bongo15
just joined
Topic Author
Posts: 4
Joined: Fri Apr 10, 2015 12:32 pm

Problem Reset RG951G-2HnD

Wed Jan 26, 2022 1:20 pm

hello forum,

Briefly about the process: I reset the above-mentioned device immediately after buying it and set it up nicely as a router from scratch. The device has the act. Firmware 6.49.2 on it and setup was well documented. I wanted to install the device on site a good week later and had to find out that the first 14 digits of the 16 digits in the documentation had disappeared when I copied the password. Bad luck, however, a user error with Ctrl+C and Ctrl+V. Many conceivable combinations of a possible password have already been tried without success. The set up password is gone, there is no access to the device

Now to the problem: the device does not reset as expected. The original Mikrotik instructions for a full reset and the 30/30/30 rule do not apply either. The device starts permanently with the selected setup for which the login password is missing. The function of the reset switch in the device was not changed during setup. Even if the reset button of the device remains pressed (even for a very long time) after a restart: the device does not reset itself. Many reset combinations have been tried without success.

The device has an opening on the underside with which you can (if the reset button on the front is defective) generate a short circuit as a reset signal: this does not lead to success either.

I equipped the UART PIN header on the board and connected it with a corresponding converter (3.3 V TTL to UART to USB, just as usual, just as documented, as far as I know) to access a serial console to get. That doesn't work either. This serial console access feature should have been enabled in the initial setup and was not done. Access is even not possible.

Now to the question: how do I get access to the device again or how do I reset it somehow?

If that still doesn't work, the next step would be to otherwise dispose of the part, which I don't think is good in principle.
 
Zacharias
Forum Guru
Forum Guru
Posts: 3281
Joined: Tue Dec 12, 2017 12:58 am
Location: Greece

Re: Problem Reset RG951G-2HnD

Wed Jan 26, 2022 11:04 pm

Try pressing the reset button before power is applied.
With the reset button pressed apply power to the device.
Only when you see the user button flash, release the reset button.
 
bongo15
just joined
Topic Author
Posts: 4
Joined: Fri Apr 10, 2015 12:32 pm

Re: Problem Reset RG951G-2HnD

Thu Jan 27, 2022 10:55 am

Hello,
thank you for reply.

Only when you see the user button flash
There is no user button.

As I said
Many reset combinations have been tried without success.
this doesn't work.

Boot without reset: https://www.file-upload.net/download-14 ... 5.mp4.html
Boot with reset: https://www.file-upload.net/download-14 ... 6.mp4.html

Different reset timings (I tried many, really) doesn't change anything. No CAPs or Netinstall mode possible.

After every boot the device works properly. But i can't log in.
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 2137
Joined: Mon Apr 08, 2019 1:16 am

Re: Problem Reset RG951G-2HnD

Thu Jan 27, 2022 12:36 pm

Is the LED blinking slowly (1 per second) ? Then RouterBoot protection is on, and resetting has been disabled unless you know the time-limt that has been set.

viewtopic.php?t=181158
 
bongo15
just joined
Topic Author
Posts: 4
Joined: Fri Apr 10, 2015 12:32 pm

Re: Problem Reset RG951G-2HnD

Thu Jan 27, 2022 3:41 pm

Yes, maybe, that was the problem. I dont know - because:

As I read the post about Protected Router Boot Mode I think to myself: sure, I'll check that even if i didn't turned this on. As I start the device normally (without resetting) while I'm reading, the power LED will light up at some point, ACT doesn't light up, but WLAN flashes every second - because it's set up and switched on.

I continue reading, then I just plug the device around again and it is briefly disconnected from the power supply. Device reboots, WIFI lamp stays off. What? Waited a while - nothing. WiFi stays off, WiFi is not visible.

Network cable plugged in: device is found by winbox, has gotten a DHCP address - what? I connect without a password: it works. Simply that way. The dialog for changing the password appears, I enter something and I'm in. I look at the configuration: all gone. Wonderful.

I use Winbox to go to the /system routerboard settings menu described: there is no way to switch on the Protected Router Boot Mode. It's getting better and better. Looked in the shell: there is this possibility, but it is also switched off. In the end I don't care, the device is usable again even if I don't really know why I couldn't reset it for a long time because I didn't turn on this function.

The explanation why it's just going like this is probably: when I made the videos yesterday, I had the clamp on the reset for a really, really long time. I may have (with a lot of luck) caught the phase in which the device reformatted itself. This was carried out on the next boot, but it also takes a very long time. A little while ago that was the moment when it was finished. Still, it's all a bit weird.
 
Zacharias
Forum Guru
Forum Guru
Posts: 3281
Joined: Tue Dec 12, 2017 12:58 am
Location: Greece

Re: Problem Reset RG951G-2HnD

Thu Jan 27, 2022 11:58 pm

From your description protected routerboot was not enabled...
It seems you were not following the correct procedure for a reset....
 
bongo15
just joined
Topic Author
Posts: 4
Joined: Fri Apr 10, 2015 12:32 pm

Re: Problem Reset RG951G-2HnD

Fri Jan 28, 2022 12:31 am

Yes, maybe, it looks like that to you, but it's not like that.

Believe me, I can read, including manuals (because I write them elsewhere) - and I've done that.

It repeatedly failed in any usual, given and described way.

Have you looked at the linked videos in post #3 - especially the second one? You can see what flashes and what doesn't.

Bonus: if I now set something and try a reset with the switch according to the instructions, that doesn't work either. The LED does not flash. I can only reset the device after a successful login (which is currently possible). An export does not show any protected router board settings. A corresponding get in system routerboard settings is empty.

Lastly: still the same problem.
[admin@MikroTik] > export
# jan/02/1970 00:41:12 by RouterOS 6.49.2
# software id = 3RI8-RGJT
#
# model = RB951G-2HnD
# serial number = foobar
/interface bridge
add name=bridge1
/interface wireless
set [ find default-name=wlan1 ] ssid=MikroTik
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
add bridge=bridge1 interface=wlan1
/ip dhcp-client
add disabled=no interface=bridge1
[admin@MikroTik] > /system routerboard settings print
              auto-upgrade: no
                init-delay: 0s
               boot-device: nand-if-fail-then-ethernet
             cpu-frequency: 600MHz
             boot-protocol: bootp
       force-backup-booter: no
               silent-boot: no
      protected-routerboot: disabled
      reformat-hold-button: 20s
  reformat-hold-button-max: 10m
[admin@MikroTik] > 
And no: reset longer than 20 s after a cold start / power on does still not reset the device nor does it the usual reset as described in https://wiki.mikrotik.com/wiki/Manual:Reset.

Who is online

Users browsing this forum: Baidu [Spider], Bing [Bot], brg3466, Semrush [Bot] and 19 guests