Community discussions

MikroTik App
 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 865
Joined: Thu Dec 11, 2014 8:53 am

v7.5beta [testing] is released!

Wed Jul 27, 2022 9:43 am

RouterOS version 7.5beta4 has been released "v7 testing" channel!

Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

What's new in 7.5beta4 (2022-Jul-22 12:46):

*) bgp - fixed remote refuse capability options, max prefix limit errors and administrative stop;
*) capsman - added randomized range option for "reselect-interval" parameter (CLI only);
*) container - added tun/tap support for containers;
*) container - fixed handling of mounted directories;
*) container - fixed imported tar image path logging message;
*) defconf - fixed loading of default configuration on RB4011 with WifiWave2 package enabled;
*) dhcpv6-client - moved invalid lifetime logging message from "debug" to "error" topic;
*) dhcpv6-relay - fixed relay forwarding (introduced in v7.1.5);
*) dhcpv6-server - improved stability when acquiring binding;
*) dns - added "match-subdomain" option for static entries (CLI only);
*) firewall - added support for RTSP helper;
*) lora - do not ignore negative sign for spoofed GPS coordinates;
*) lte - added "SIM not inserted" and "SIM failure" messages to "status" and "monitor" commands for AT modems;
*) lte - added at-chat and NMEA port support for Simcom modems, USB composition (device id - 0x9003);
*) lte - added at-chat support for Simcom modems, USB composition (device id - 0x9005);
*) lte - changed cell ID info display to short format for 3G connections;
*) lte - fixed LTE interface presence for Telit LN940;
*) lte - improved antenna scan for Chateau devices with switchable antennas;
*) lte - improved configuration export when multiple LTE interfaces are present;
*) lte - modem dialer, do not reset dialing sequence if modem reply with error to user set init-string;
*) netinstall - fixed Netinstall procedure for ARM devices;
*) netwatch - automatically start migrated probes from previous RouterOS versions;
*) netwatch - changed ICMP default packet loss fail threshold to 85%;
*) ospf - improved stability when interface is being disabled during database exchange;
*) ovpn - fixed encryption key renewal process which caused periodic session disconnects;
*) ovpn - improved system stability when hardware acceleration is used on ARM64 devices;
*) ovpn - moved disconnected user logging message from "debug" to "info" topic;
*) port - added support for D-Link DWM-222 in serial/PPP mode (device id - 0xac01/0x7e3d);
*) port - added support for Huawei/ZTE K5006z in serial/PPP mode (device id - 0x1017/0x1018);
*) ptp - improved system stability on CRS devices;
*) quickset - removed PPTP and SSTP server addition for "VPN" checkbox;
*) route-filter - fixed "delete bgp-communities" command;
*) sfp - fixed QSFP+ and QSFP28 interface disable when using breakout cable;
*) snmp - fixed usage of VRF after system startup;
*) socks - fixed "dst-port" usage when checking access list;
*) ssh - fixed importing of public keys;
*) ssh - fixed minor typo issue when importing public key;
*) sstp - fixed client stuck in "nonce matching" state;
*) switch - fixed ACL rules for 98DXxxxx switches with more than 28 ports (introduced in v7.3);
*) traceroute - added "do-not-fragment" parameter support (CLI only);
*) traceroute - increased packet size limit to 65535;
*) webfig - fixed displaying of grahs in status pages;
*) webfig - fixed floating point field's negative value in -0.*** format;
*) wifiwave2 - added "sae-pwe" parameter with hash-to-element mechanism for SAE PWE derivation;
*) wifiwave2 - added support for 802.11k;
*) wifiwave2 - fixed displaying of AKM in scan results;
*) wifiwave2 - fixed duplicated AKM in RSN message;
*) wifiwave2 - fixed incorrect AKM usage for FT-WPA3-EAP-192;
*) wifiwave2 - fixed reassociation response sending for fast transition over DS;
*) wifiwave2 - fixed setting of "ft-nas-identifier" parameter;
*) winbox - do not show previously attached LTE interfaces while establishing LTE connection;
*) winbox - fixed "Enable", "Disable" and "Comment" functions for L2TP-ether type interfaces;
*) winbox - fixed "Next Run" parameter displaying under "System/Scheduler" menu;
*) winbox - fixed "Type" and "Value" field displaying under "System/Health" sub-menu's;
*) winbox - show warning messages for BGP connection entries;
*) x86 - fixed advertising of 2500M and 5000M link speeds on ixgbe driver;

To upgrade, click "Check for updates" at /system package in your RouterOS configuration interface, or head to our download page: http://www.mikrotik.com/download

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after some problem has appeared on device

Please keep this forum topic strictly related to this particular RouterOS release.
 
wispmikrotik
Frequent Visitor
Frequent Visitor
Posts: 87
Joined: Tue Apr 25, 2017 10:43 am

Re: v7.5beta [testing] is released!

Wed Jul 27, 2022 9:52 am

😍 Thanks!
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 8014
Joined: Tue Feb 25, 2014 12:49 pm
Location: 🇮🇹, my 💔 is in 🇺🇦

Re: v7.5beta [testing] is released!

Wed Jul 27, 2022 9:59 am

Is possible to have more detail about «fixed Netinstall procedure for ARM devices», please?

Why would I want to know? To prevent any problems with previous stable versions, until stable 7.5.x is available.

Thanks and good work.
✂ Rextended Fragments of Snippets

Vld4UmVHUkdhelJUTTJzOQ==
 
User avatar
slimmerwifi
just joined
Posts: 14
Joined: Tue Aug 01, 2017 6:05 pm
Location: Netherlands

Re: v7.5beta [testing] is released!

Wed Jul 27, 2022 10:17 am

Nice to see the work at wifiwave2!
 
nescafe2002
Forum Veteran
Forum Veteran
Posts: 867
Joined: Tue Aug 11, 2015 12:46 pm
Location: Netherlands

Re: v7.5beta [testing] is released!

Wed Jul 27, 2022 10:48 am

*) dns - added "match-subdomain" option for static entries (CLI only);

This is a nice addition!

E.g. to delegate a domain + subnet without having to use regexp:

/ip dns static 
add forward-to=192.168.89.2 match-subdomain=yes name=otherdomain.lan type=FWD
add forward-to=192.168.89.2 match-subdomain=yes name=89.168.192.in-addr.arpa type=FWD
add forward-to=2001:db8:200::1 match-subdomain=yes name=0.0.2.0.8.b.d.0.1.0.0.2.ip6.arpa type=FWD

Will forward otherdomain.lan, *.otherdomain.lan and reverse lookups (192.168.89.*) to 192.168.89.2 and reverse ipv6 lookups (2001:db8:200::/48) to 2001:db8:200::1.
 
User avatar
osc86
Member Candidate
Member Candidate
Posts: 173
Joined: Wed Aug 09, 2017 1:15 pm

Re: v7.5beta [testing] is released!

Wed Jul 27, 2022 10:56 am

does this now also work when DoH is enabled?
 
elbob2002
Member Candidate
Member Candidate
Posts: 160
Joined: Tue May 15, 2018 8:15 pm
Location: Ireland

Re: v7.5beta [testing] is released!

Wed Jul 27, 2022 11:24 am

*) container - added tun/tap support for containers;
This brings us one step closer to Zerotier on CHR. Is there any documentation on how to enable tun/tap devices for a container?
 
Rox169
Frequent Visitor
Frequent Visitor
Posts: 90
Joined: Sat Sep 04, 2021 1:47 am

Re: v7.5beta [testing] is released!

Wed Jul 27, 2022 11:33 am

Hi,

*) wifiwave2 - added support for 802.11k;

it is nice to see that Mikrotik is working on few years old wifi standards. Finally we have 802.11 r and 802.11 k only one left 802.11 v I hope they will not forget this standard.

The last question is where is HW on which I could run this roaming?

Only HAP AC3 and Audience?? That is very sad that MT is not possible to deploy this wifiwave to CAP HW....
 
hecatae
Member Candidate
Member Candidate
Posts: 149
Joined: Thu May 21, 2020 2:34 pm

Re: v7.5beta [testing] is released!

Wed Jul 27, 2022 11:34 am

Is possible to have more detail about «fixed Netinstall procedure for ARM devices», please?

Why would I want to know? To prevent any problems with previous stable versions, until stable 7.5.x is available.

Thanks and good work.
Here's hoping we get a detailed reply, I'm not updating a single ARM device until this is clarified.
 
elbob2002
Member Candidate
Member Candidate
Posts: 160
Joined: Tue May 15, 2018 8:15 pm
Location: Ireland

Re: v7.5beta [testing] is released!

Wed Jul 27, 2022 11:36 am

Figured out Tun/tap devices. Just add them as environment variables
ZTTUNTAP.png
You do not have the required permissions to view the files attached to this post.
 
mkx
Forum Guru
Forum Guru
Posts: 8005
Joined: Thu Mar 03, 2016 10:23 pm

Re: v7.5beta [testing] is released!

Wed Jul 27, 2022 12:25 pm

The last question is where is HW on which I could run this roaming?

Only HAP AC3 and Audience?? That is very sad that MT is not possible to deploy this wifiwave to CAP HW....
I guess we'll be blessed with CAPsMAN working with wifiwave2 driver in 7.8 or something. Roaming will then get into another dimension (right now it's 1D, it'll become 3D).
 
dksoft
Member Candidate
Member Candidate
Posts: 117
Joined: Thu Dec 06, 2012 8:56 am
Location: Germany

Re: v7.5beta [testing] is released!

Wed Jul 27, 2022 12:29 pm

*) firewall - added support for RTSP helper;

Works! Great, thank you.
I will try with multiple cameras and come back.

Edit: I have multiple cams on the camera site (7.4) which are NATed with different ports x, y, z ... By simply adding all the ports in the "rtsp" entry under "service ports" on the viewing site (7.5b4) they all work now. Did not work before the RTSP helper. I needed to create a VPN to directly access the cameras back then.
 
User avatar
Znevna
Forum Veteran
Forum Veteran
Posts: 822
Joined: Mon Sep 23, 2019 1:04 pm

Re: v7.5beta [testing] is released!

Wed Jul 27, 2022 1:03 pm

Is possible to have more detail about «fixed Netinstall procedure for ARM devices», please?

Why would I want to know? To prevent any problems with previous stable versions, until stable 7.5.x is available.

Thanks and good work.
Probably it means just that, that they fixed some problems reported in v7 regarding netinstall and arm devices.
How is this stopping you from doing upgrades?
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 8014
Joined: Tue Feb 25, 2014 12:49 pm
Location: 🇮🇹, my 💔 is in 🇺🇦

Re: v7.5beta [testing] is released!

Wed Jul 27, 2022 1:05 pm

That do not stop me to use upgrade inside routeros.
I ask details for «prevent any problems with previous stable versions» when netinstall is used...
✂ Rextended Fragments of Snippets

Vld4UmVHUkdhelJUTTJzOQ==
 
User avatar
Znevna
Forum Veteran
Forum Veteran
Posts: 822
Joined: Mon Sep 23, 2019 1:04 pm

Re: v7.5beta [testing] is released!

Wed Jul 27, 2022 1:14 pm

I don't know what that means.
 
hecatae
Member Candidate
Member Candidate
Posts: 149
Joined: Thu May 21, 2020 2:34 pm

Re: v7.5beta [testing] is released!

Wed Jul 27, 2022 2:34 pm

I don't know what that means.
Nor do we, that's why rextended is asking for clarity.
 
User avatar
anav
Forum Guru
Forum Guru
Posts: 12497
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada
Contact:

Re: v7.5beta [testing] is released!

Wed Jul 27, 2022 2:48 pm

Im with rextended, not literally,
What is wrong with my netwinstall processes for ARM on current firmware
Also curious as to what was fail threshold before and why changed............

*) netinstall - fixed Netinstall procedure for ARM devices;
*) netwatch - changed ICMP default packet loss fail threshold to 85%;
Last edited by anav on Wed Jul 27, 2022 3:29 pm, edited 1 time in total.
 
User avatar
Znevna
Forum Veteran
Forum Veteran
Posts: 822
Joined: Mon Sep 23, 2019 1:04 pm

Re: v7.5beta [testing] is released!

Wed Jul 27, 2022 2:58 pm

There's nothing in the changelog about netinstall and "previous versions" so please explain, rextended.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 8014
Joined: Tue Feb 25, 2014 12:49 pm
Location: 🇮🇹, my 💔 is in 🇺🇦

Re: v7.5beta [testing] is released!

Wed Jul 27, 2022 3:02 pm

*) netinstall - fixed Netinstall procedure for ARM devices;
Is simple: if on THIS version the "Netinstall procedure for ARM devices" is fixed,
it is implied that in one or more previous versions (and it is not explained "from which version")
there was something "broken", otherwise why "fix" it?
I, and the others, just want to know what is this problem because we use 7.4 (stable) which apparently has this problem.

.
✂ Rextended Fragments of Snippets

Vld4UmVHUkdhelJUTTJzOQ==
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1491
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v7.5beta [testing] is released!

Wed Jul 27, 2022 3:26 pm

rextended - If you tried to Netinstall ARM device and it either freezes before the installation process (you could see that on a serial console) or reboots itself before the installation process is started, then this fix should be the one that helps. In general, the fix should be safe enough so you could use v7.5beta Netinstall for any RouterOS installation.
 
User avatar
anav
Forum Guru
Forum Guru
Posts: 12497
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada
Contact:

Re: v7.5beta [testing] is released!

Wed Jul 27, 2022 3:30 pm

There's nothing in the changelog about netinstall and "previous versions" so please explain, rextended.
Sorry, there is nothing in the v7.5 beta that improves eyesight or literacy ;-PP
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 8014
Joined: Tue Feb 25, 2014 12:49 pm
Location: 🇮🇹, my 💔 is in 🇺🇦

Re: v7.5beta [testing] is released!

Wed Jul 27, 2022 3:38 pm

@strods !!!
Oh, how nice, this confirms the habit I already have: I always use the latest netinstall even to install older versions...
Thanks for the reply, have all a nice day.

[
for three reasons:
it leaves nothing of itself after installation
the new version supports more hardware, for sure
if there is a problem they have solved it, even if it is not in the changelog
]

*************

@anav :lol:
✂ Rextended Fragments of Snippets

Vld4UmVHUkdhelJUTTJzOQ==
 
haedertowfeq
just joined
Posts: 11
Joined: Thu Nov 19, 2020 5:58 pm

Re: v7.5beta [testing] is released!

Wed Jul 27, 2022 5:26 pm

802.11k support
How can configure that?
 
Guscht
Member Candidate
Member Candidate
Posts: 138
Joined: Thu Jul 01, 2010 5:32 pm

Re: v7.5beta [testing] is released!

Wed Jul 27, 2022 5:29 pm

*) dns - added "match-subdomain" option for static entries (CLI only);
Please explain this function! Do I understand it correct w/o this, test.com will match only, but site1.test.com not. If I enable this all under "test.com" will match. Like: site1.test.com, site2.test.com. abc.test.com 123.test.com...???

*) firewall - added support for RTSP helper;
What is a "RTSP-Helper"? I know RTSP is some kind of Video-Straming Protocol. Why do I need a "helper" and for what reason?
 
pe1chl
Forum Guru
Forum Guru
Posts: 8632
Joined: Mon Jun 08, 2015 12:09 pm

Re: v7.5beta [testing] is released!

Wed Jul 27, 2022 5:57 pm

BGP: sessions screen in winbox (3.37) shows an uptime of 497d 02:23:00 shortly after the reboot at installation, ticking DOWN instead of UP!
It also does not reflect the actual uptime of the session, it is just the same for all sessions.
Remote ID is shown as 0.0.0.0 for all sessions.
Is BGP session monitoring now getting worse in preparation for it getting much better??
 
dksoft
Member Candidate
Member Candidate
Posts: 117
Joined: Thu Dec 06, 2012 8:56 am
Location: Germany

Re: v7.5beta [testing] is released!

Wed Jul 27, 2022 6:31 pm

*) firewall - added support for RTSP helper;
What is a "RTSP-Helper"? I know RTSP is some kind of Video-Straming Protocol. Why do I need a "helper" and for what reason?
-> viewtopic.php?t=172168
 
pe1chl
Forum Guru
Forum Guru
Posts: 8632
Joined: Mon Jun 08, 2015 12:09 pm

Re: v7.5beta [testing] is released!

Wed Jul 27, 2022 6:49 pm

BGP: well, now at least it logs the message "HoldTimer expiredsessionname" when a session times out.
A space between the word expired and the sessionname would be great! But it is better than "Session *=0x30100010" as it was before!
 
batarang
just joined
Posts: 4
Joined: Wed Oct 26, 2016 6:08 am
Location: Manila

Re: v7.5beta [testing] is released!

Wed Jul 27, 2022 7:37 pm

Getting permission error using plain nginx image.
 jul/28 00:33:10 container,info,debug /docker-entrypoint.sh: /docker-entrypoint.d/ is not empty, will attempt to perform configuration
 jul/28 00:33:10 container,info,debug /docker-entrypoint.sh: Looking for shell scripts in /docker-entrypoint.d/
 jul/28 00:33:12 container,info,debug /docker-entrypoint.sh: Launching /docker-entrypoint.d/10-listen-on-ipv6-by-default.sh
 jul/28 00:33:16 container,info,debug 10-listen-on-ipv6-by-default.sh: info: Getting the checksum of /etc/nginx/conf.d/default.conf
 jul/28 00:33:22 container,info,debug 10-listen-on-ipv6-by-default.sh: info: Enabled listen on IPv6 in /etc/nginx/conf.d/default.conf
 jul/28 00:33:22 container,info,debug /docker-entrypoint.sh: Launching /docker-entrypoint.d/20-envsubst-on-templates.sh
 jul/28 00:33:29 container,info,debug /docker-entrypoint.sh: Launching /docker-entrypoint.d/30-tune-worker-processes.sh
 jul/28 00:33:29 container,info,debug /docker-entrypoint.sh: Configuration complete; ready for start up
 jul/28 00:33:31 container,info,debug nginx: [alert] could not open error log file: open() "/var/log/nginx/error.log" failed (13: Permission denied)
 jul/28 00:33:31 container,info,debug 2022/07/27 16:33:31 [emerg] 1#1: open() "/var/log/nginx/error.log" failed (13: Permission denied)
root-dir=disk1/nginx. /var/log/nginx is not mounted.
 
fragtion
Member Candidate
Member Candidate
Posts: 188
Joined: Fri Nov 13, 2009 10:08 pm
Location: Johannesburg, South Africa

Re: v7.5beta [testing] is released!

Wed Jul 27, 2022 9:50 pm

Getting permission error using plain nginx image.
...
root-dir=disk1/nginx. /var/log/nginx is not mounted.
I guess this is expected. Until 7.4beta5 it was possible to write into non-mounted directories (internal container directories as extracted from tar file), which should not be permitted. I guess you'll either need to mount /var/log, or modify the docker file to mount it as tmpfs. Maybe Mikrotik should allow us to write to those directories but just not save the changes, like docker does
 
pants6000
Frequent Visitor
Frequent Visitor
Posts: 74
Joined: Fri Sep 26, 2014 5:30 am

Re: v7.5beta [testing] is released!

Wed Jul 27, 2022 10:57 pm


*) ovpn - fixed encryption key renewal process which caused periodic session disconnects;

This seemed to have fixed my hourly-disconnect problem! I thought it had to do with the "reneg-secs" OVPN parameter but I see that's still set to 3600. In any case, a client/config that wouldn't make it past 60 mins before is now at the 90 minute mark.

Thanks!!!
 
rpingar
Long time Member
Long time Member
Posts: 588
Joined: Fri May 28, 2004 2:46 pm
Location: Italy

Re: v7.5beta [testing] is released!

Thu Jul 28, 2022 9:07 am

any official words from MT about icmp/ping issue?
in 7.4 netwatch was fixed, but ping tool doesn't.

regards
Ros
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 8014
Joined: Tue Feb 25, 2014 12:49 pm
Location: 🇮🇹, my 💔 is in 🇺🇦

Re: v7.5beta [testing] is released!

Thu Jul 28, 2022 11:21 am

any official words from MT about icmp/ping issue?
in 7.4 netwatch was fixed, but ping tool doesn't.

regards
Ros
Check/Update your ticket SUP-67221
✂ Rextended Fragments of Snippets

Vld4UmVHUkdhelJUTTJzOQ==
 
User avatar
slimmerwifi
just joined
Posts: 14
Joined: Tue Aug 01, 2017 6:05 pm
Location: Netherlands

Re: v7.5beta [testing] is released!

Thu Jul 28, 2022 12:48 pm

802.11k support
How can configure that?
It's added in the documentation:

https://help.mikrotik.com/docs/display/ROS/WifiWave2
 
kobuki
Member Candidate
Member Candidate
Posts: 181
Joined: Sat Apr 02, 2011 5:59 pm

Re: v7.5beta [testing] is released!

Thu Jul 28, 2022 1:05 pm

Containers: is it possible to create mounts that the container can write into? My current tests with this beta show that it's not possible (permission error). It's an important function for many containers.
 
antonsb
MikroTik Support
MikroTik Support
Posts: 273
Joined: Sun Jul 24, 2016 3:12 pm
Location: Riga, Latvia

Re: v7.5beta [testing] is released!

Thu Jul 28, 2022 1:37 pm

Containers: is it possible to create mounts that the container can write into? My current tests with this beta show that it's not possible (permission error). It's an important function for many containers.
stop/start newly created and started container and mounts should appear. We will fully fix this in next releases.
 
wispmikrotik
Frequent Visitor
Frequent Visitor
Posts: 87
Joined: Tue Apr 25, 2017 10:43 am

Re: v7.5beta [testing] is released!

Thu Jul 28, 2022 2:58 pm

BGP: sessions screen in winbox (3.37) shows an uptime of 497d 02:23:00 shortly after the reboot at installation, ticking DOWN instead of UP!
+1

Image

Regards,
 
kobuki
Member Candidate
Member Candidate
Posts: 181
Joined: Sat Apr 02, 2011 5:59 pm

Re: v7.5beta [testing] is released!

Thu Jul 28, 2022 3:03 pm

Containers: is it possible to create mounts that the container can write into? My current tests with this beta show that it's not possible (permission error). It's an important function for many containers.
stop/start newly created and started container and mounts should appear. We will fully fix this in next releases.

Mounts do appear, that's not the issue. The problem is, the CT cannot write to the mounted directory, I get permission errors.
 
hecatae
Member Candidate
Member Candidate
Posts: 149
Joined: Thu May 21, 2020 2:34 pm

Re: v7.5beta [testing] is released!

Thu Jul 28, 2022 5:37 pm

rb2011il-rm updated without issue
 
rpingar
Long time Member
Long time Member
Posts: 588
Joined: Fri May 28, 2004 2:46 pm
Location: Italy

Re: v7.5beta [testing] is released!

Thu Jul 28, 2022 7:19 pm

any official words from MT about icmp/ping issue?
in 7.4 netwatch was fixed, but ping tool doesn't.

regards
Ros
Check/Update your ticket SUP-67221
no update since a month ago :(
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 8014
Joined: Tue Feb 25, 2014 12:49 pm
Location: 🇮🇹, my 💔 is in 🇺🇦

Re: v7.5beta [testing] is released!

Thu Jul 28, 2022 10:15 pm

Try to contact again, on same ticket...
✂ Rextended Fragments of Snippets

Vld4UmVHUkdhelJUTTJzOQ==
 
pe1chl
Forum Guru
Forum Guru
Posts: 8632
Joined: Mon Jun 08, 2015 12:09 pm

Re: v7.5beta [testing] is released!

Thu Jul 28, 2022 10:23 pm

On the other hand, I found and reported (above) 3 new issues in BGP and none of them are even remotely related to a "What's new" item about BGP in the opening post.
So clearly there are changes that do not appear in there. It could well be that BFD has been added in this release and we would not have noticed.
 
urbanserj
just joined
Posts: 2
Joined: Sun Oct 24, 2021 2:34 am

Re: v7.5beta [testing] is released!

Thu Jul 28, 2022 11:23 pm

iOS devices still have hard time with 802.11r [1]. They can't re-connect to AP after the latter gets restarted or when wifi interfaces are on -> off -> on. The logs show the same:

mac-address@wifi2 rejected, can't find PMKSA
mac-address@wifi1 rejected, can't find PMKSA
mac-address@wifi2 rejected, can't find PMKSA
mac-address@wifi1 rejected, can't find PMKSA
mac-address@wifi2 rejected, can't find PMKSA
mac-address@wifi1 rejected, can't find PMKSA

[1] viewtopic.php?p=943402#p943214
 
whatever
Member Candidate
Member Candidate
Posts: 230
Joined: Thu Jun 21, 2018 9:29 pm

Re: v7.5beta [testing] is released!

Fri Jul 29, 2022 3:39 pm

802.11k support
How can configure that?
It's added in the documentation:

https://help.mikrotik.com/docs/display/ROS/WifiWave2
I only find an on/off switch for the feature.
Isn't 802.11k supposed to provide the client with a list of neighboring APs? Where does this list come from? I suppose the list should either be manually configurable (I think this is possible in OpenWRT), created by a centralized management solution (like capsman) or populated by the AP itself by scanning its neighborhood (might cause short outages while scanning other channels).
 
pe1chl
Forum Guru
Forum Guru
Posts: 8632
Joined: Mon Jun 08, 2015 12:09 pm

Re: v7.5beta [testing] is released!

Fri Jul 29, 2022 4:13 pm

I only find an on/off switch for the feature.
Isn't 802.11k supposed to provide the client with a list of neighboring APs? Where does this list come from? I suppose the list should either be manually configurable (I think this is possible in OpenWRT), created by a centralized management solution (like capsman) or populated by the AP itself by scanning its neighborhood (might cause short outages while scanning other channels).
The current 802.11k/r functionality is just a work in progress in preparation for future use in real applications.
At the moment, it only knows about the 2 interfaces of the same AP (2 GHz and 5 GHz) to roam between them. More or less a toy.
Of course for real usability it has to have a "backbone interconnect" between the involved APs, yes. That would likely be part of a new CAPsMAN2 that manages them.
 
Naecken
Posts: 0
Joined: Fri Oct 09, 2020 2:44 pm

Re: v7.5beta [testing] is released!

Fri Jul 29, 2022 9:31 pm

WPA3 on 2.4GHz hAP AC3 stopped working after update from 7.4 - there is no error info in log.
 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 865
Joined: Thu Dec 11, 2014 8:53 am

Re: v7.5beta [testing] is released!

Mon Aug 01, 2022 2:39 pm

What's new in 7.5beta5 (2022-Jul-28 10:59):

*) health - renamed "CPU" to "switch" for temperature reading information on CRS518-16XS-2XQ;
*) l3hw - fixed HW offloaded NAT;
*) ppp - improved service stability under high load;
*) ppp - use /32 as default netmask if not specified for "routes" parameter;
*) sfp - fixed "eeprom" reading on single SFP port ARM devices;
*) sfp - fixed unresponsive "sfp1" interface after disabling "ether1" on NetMetal devices;
*) swos - enabled SwitchOS support for CRS310-1G-5S-4S+;
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 2012
Joined: Mon Jan 14, 2008 1:53 pm
Location: Over the Rainbow
Contact:

Re: v7.5beta [testing] is released!

Mon Aug 01, 2022 3:02 pm

That would likely be part of a new CAPsMAN2 that manages them.
I'm showing my age, but the current Capsman is V2 😉
Mikrotik MTCNA, MTCRE, MTCINE
http://thebrotherswisp.com/
 
Solear
just joined
Posts: 6
Joined: Sat Jun 08, 2019 9:27 pm

Re: v7.5beta [testing] is released!

Mon Aug 01, 2022 9:28 pm

Maybe a stupid question: Is create folders in mounted folders in container possible/fixed? I cant get Adguardhome to work because the mkdir-permission-error.
 
User avatar
Znevna
Forum Veteran
Forum Veteran
Posts: 822
Joined: Mon Sep 23, 2019 1:04 pm

Re: v7.5beta [testing] is released!

Mon Aug 01, 2022 9:29 pm

Not yet.
 
User avatar
npeca75
Frequent Visitor
Frequent Visitor
Posts: 65
Joined: Thu Aug 03, 2017 3:12 pm

Re: v7.5beta [testing] is released!

Tue Aug 02, 2022 7:30 am

*) sfp - fixed "eeprom" reading on single SFP port ARM devices;
maybe one day rb760 igs SFP port will have (again) SFP status ?
 
mmc
newbie
Posts: 34
Joined: Wed Dec 29, 2004 1:44 am

Re: v7.5beta [testing] is released!

Thu Aug 04, 2022 10:15 am

hi,

with ros 7.5beta4 all the sfp and DAC cables still don't work under ccr2116 & ccr2004. the link just flaps endless, whatever setting you make. reported to support since months now, but still no fix.

even original mikrotik DAC cable doesn't work anymore since ros 7.3. latest working version in terms of sfp support was 7.2.3.

those are the one we have tested in all combinations and are not working in the top of the line mikrotik hardware with the 'stable' ros7 versions:
- mikrotik DAC cable Q+BC0003-S+
- fs.com DAC cable Q-4SPC01
- fs.com DAC cable Q-4SPC03
- fs.com MTP PLFI SM Cable with fs.com sfp
 
rpingar
Long time Member
Long time Member
Posts: 588
Joined: Fri May 28, 2004 2:46 pm
Location: Italy

Re: v7.5beta [testing] is released!

Thu Aug 04, 2022 10:24 am

hi,

with ros 7.5beta4 all the sfp and DAC cables still don't work under ccr2116 & ccr2004. the link just flaps endless, whatever setting you make. reported to support since months now, but still no fix.

even original mikrotik DAC cable doesn't work anymore since ros 7.3. latest working version in terms of sfp support was 7.2.3.

those are the one we have tested in all combinations and are not working in the top of the line mikrotik hardware with the 'stable' ros7 versions:
- mikrotik DAC cable Q+BC0003-S+
- fs.com DAC cable Q-4SPC01
- fs.com DAC cable Q-4SPC03
- fs.com MTP PLFI SM Cable with fs.com sfp
MT seems able to identify and fix the issue, producing a test release. I am not able to test it because I don't have spare parts.
Ask MT about this release to test.
regards
Ros
 
hecatae
Member Candidate
Member Candidate
Posts: 149
Joined: Thu May 21, 2020 2:34 pm

Re: v7.5beta [testing] is released!

Thu Aug 04, 2022 4:09 pm

Chateau 5G successfully updated to 7.5beta5
 
User avatar
nithinkumar2000
Member Candidate
Member Candidate
Posts: 142
Joined: Wed Sep 11, 2019 7:42 am
Location: Coimbatore
Contact:

Re: v7.5beta [testing] is released!

Fri Aug 05, 2022 7:51 am

Any Chance of Adding Advertisements in BGP Option. Really Useful to Check what is getting Advertised to peers.
Currently in ROSv7 its very difficult to find our the Advertisements compared to ROSv6.

Please Mikrotik Team Look in to it....
 
mafiosa
Member Candidate
Member Candidate
Posts: 253
Joined: Fri Dec 09, 2016 8:10 pm
Location: Kolkata, India
Contact:

Re: v7.5beta [testing] is released!

Fri Aug 05, 2022 11:31 am

Any Chance of Adding Advertisements in BGP Option. Really Useful to Check what is getting Advertised to peers.
Currently in ROSv7 its very difficult to find our the Advertisements compared to ROSv6.

Please Mikrotik Team Look in to it....
+1
 
adithepocz
just joined
Posts: 1
Joined: Tue Apr 12, 2022 5:05 am

Re: v7.5beta [testing] is released!

Fri Aug 05, 2022 5:38 pm

Any Chance of Adding Advertisements in BGP Option. Really Useful to Check what is getting Advertised to peers.
Currently in ROSv7 its very difficult to find our the Advertisements compared to ROSv6.

Please Mikrotik Team Look in to it....
+1
 
pe1chl
Forum Guru
Forum Guru
Posts: 8632
Joined: Mon Jun 08, 2015 12:09 pm

Re: v7.5beta [testing] is released!

Fri Aug 05, 2022 5:45 pm

This is just one small detail of the general "improve monitoring capabilities for BGP"...
 
User avatar
armandfumal
Member Candidate
Member Candidate
Posts: 145
Joined: Wed Apr 25, 2012 5:50 pm
Location: Weiswampach,LUX
Contact:

Re: v7.5beta [testing] is released!

Fri Aug 05, 2022 10:11 pm

Any Chance of Adding Advertisements in BGP Option. Really Useful to Check what is getting Advertised to peers.
Currently in ROSv7 its very difficult to find our the Advertisements compared to ROSv6.

Please Mikrotik Team Look in to it....
+1
 
ech1965
just joined
Posts: 12
Joined: Wed Mar 20, 2019 3:53 pm

Re: v7.5beta [testing] is released!

Sat Aug 06, 2022 12:31 pm

What am I doing wrong
admin@rb-00] /system/package/update> /system/device-mode/print
       mode: enterprise
  container: yes
[admin@rb-00] /system/package/update> /console/ # no /container command !
clear-history  inspect
[admin@rb-00] /system/package/update> /system/package/
update  disable  downgrade  enable  export  find  print  uninstall  unschedule
[admin@rb-00] /system/package/update> /system/package/print
Columns: NAME, VERSION
# NAME      VERSION 
0 routeros  7.5beta5

 
pe1chl
Forum Guru
Forum Guru
Posts: 8632
Joined: Mon Jun 08, 2015 12:09 pm

Re: v7.5beta [testing] is released!

Sat Aug 06, 2022 12:36 pm

What am I doing wrong
You are providing console output without any question.
Assuming you want container function, you first need to install the container package.
 
ech1965
just joined
Posts: 12
Joined: Wed Mar 20, 2019 3:53 pm

Re: v7.5beta [testing] is released!

Sat Aug 06, 2022 2:09 pm

What am I doing wrong
You are providing console output without any question.
Assuming you want container function, you first need to install the container package.
Thanks you very much for reading my mind... ;-)
Documentation is not yet clear ;-)
* https://help.mikrotik.com/docs/display/ ... quirements page says "container package must be installed" but does not tell you how
* There is no /system/package/install command
* no package repository configured in routeros to list available packages
* https://help.mikrotik.com/docs/display/ROS/Packages does not tell anything about existence of a "container" package
* in https://mikrotik.com/download there is no such thing as a "container" package. only an "main" an an extra package
* which architecture do I need to select ? it's not shown in /system/routerboard nor in /system/identiy not in /system/package
* how to ship package inside router ?
 
nescafe2002
Forum Veteran
Forum Veteran
Posts: 867
Joined: Tue Aug 11, 2015 12:46 pm
Location: Netherlands

Re: v7.5beta [testing] is released!

Sat Aug 06, 2022 2:16 pm

ech1965, get architecture via /system resource print, download Extra packages, upload container-*.npk via ftp, scp or winbox and reboot to trigger the installation.
Container package is compatible with arm arm64 and x86 architectures.
 
ech1965
just joined
Posts: 12
Joined: Wed Mar 20, 2019 3:53 pm

Re: v7.5beta [testing] is released!

Sat Aug 06, 2022 2:31 pm

ech1965, get architecture via /system resource print, download Extra packages, upload container-*.npk via ftp, scp or winbox and reboot to trigger the installation.
Container package is compatible with arm arm64 and x86 architectures.
MANY Thanks !!! glad we have people like you on this forum, because... doc writers have a lot to catch up at mikrotik !
 
holvoetn
Forum Guru
Forum Guru
Posts: 1380
Joined: Tue Apr 13, 2021 2:14 am
Location: Belgium

Re: v7.5beta [testing] is released!

Sat Aug 06, 2022 2:54 pm


MANY Thanks !!! glad we have people like you on this forum, because... doc writers have a lot to catch up at mikrotik !

Hmmm... I wonder which part of these instructions on the help page was not clear.
https://help.mikrotik.com/docs/display/ROS/Container
Container package needs to be installed
 
pe1chl
Forum Guru
Forum Guru
Posts: 8632
Joined: Mon Jun 08, 2015 12:09 pm

Re: v7.5beta [testing] is released!

Sat Aug 06, 2022 3:43 pm

Documentation is not yet clear ;-)
* https://help.mikrotik.com/docs/display/ ... quirements page says "container package must be installed" but does not tell you how
* There is no /system/package/install command
* no package repository configured in routeros to list available packages
I agree with you (and I have proposed several times) that the package menu should have some sort of listing of available packages and a way to install them by command (both commandline and the GUI version) instead of having to fiddle with zip files and uploading.
It should be easy to do, as the required packages are available from the upgrade server. The device knows how to download them when you do an upgrade. So why not when initially adding them?
No idea.
 
holvoetn
Forum Guru
Forum Guru
Posts: 1380
Joined: Tue Apr 13, 2021 2:14 am
Location: Belgium

Re: v7.5beta [testing] is released!

Sat Aug 06, 2022 4:04 pm

I will apologize, you are correct.

https://help.mikrotik.com/docs/display/ROS/Packages
That page does NOT indicate HOW a package should be installed ...

But that's nothing new related to this release, is it ?
 
volkirik
Member Candidate
Member Candidate
Posts: 119
Joined: Sat Jul 23, 2016 2:03 pm

Re: v7.5beta [testing] is released!

Sat Aug 06, 2022 4:59 pm

bug report:

ppp on-up and on-down scripts do not run when they have empty line after their (script)name in profile window.

please fix it. it was annoying.
 
nescafe2002
Forum Veteran
Forum Veteran
Posts: 867
Joined: Tue Aug 11, 2015 12:46 pm
Location: Netherlands

Re: v7.5beta [testing] is released!

Sat Aug 06, 2022 5:37 pm

volkirik, your issue is not related to 7.5beta.

E.g. on 6.48.6:

/system script add name=test policy=test source=":log info test"
/system scheduler add interval=10s name=test on-event="test\r\n" policy=test

Will not run, but

/system script add name=test policy=test source=":log info test"
/system scheduler add interval=10s name=test on-event="test" policy=test

Will.

The newline makes the difference between a script (name) and actual code. I think this is by design.
So if you reference to a script (name) in any code window (ppp/dhcp/scheduler/...), make sure you don't append a newline.
 
volkirik
Member Candidate
Member Candidate
Posts: 119
Joined: Sat Jul 23, 2016 2:03 pm

Re: v7.5beta [testing] is released!

Sat Aug 06, 2022 5:43 pm

this design must be fixed sir!
 
User avatar
eworm
Forum Veteran
Forum Veteran
Posts: 961
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: v7.5beta [testing] is released!

Sat Aug 06, 2022 5:53 pm

No, it must not. If you want a newline, use this:
/system/scheduler/add interval=10s name=test on-event="/system/script/run test\r\n" policy=test
Should work...
 
volkirik
Member Candidate
Member Candidate
Posts: 119
Joined: Sat Jul 23, 2016 2:03 pm

Re: v7.5beta [testing] is released!

Sun Aug 07, 2022 4:54 pm

is 7.5beta6 going to be released soon?

what are new fixes and new features?
 
holvoetn
Forum Guru
Forum Guru
Posts: 1380
Joined: Tue Apr 13, 2021 2:14 am
Location: Belgium

Re: v7.5beta [testing] is released!

Sun Aug 07, 2022 4:56 pm

Patience, little padawan.

It'll come when they think it's ready.
 
volkirik
Member Candidate
Member Candidate
Posts: 119
Joined: Sat Jul 23, 2016 2:03 pm

Re: v7.5beta [testing] is released!

Sun Aug 07, 2022 5:02 pm

i propose they open daily snapshot builds in development channel

so we can brick the stuff :D ;P
 
pe1chl
Forum Guru
Forum Guru
Posts: 8632
Joined: Mon Jun 08, 2015 12:09 pm

Re: v7.5beta [testing] is released!

Mon Aug 08, 2022 3:02 pm

Hopefully there will soon be a new beta that fixes this:
What's new in 7.4.1 (2022-Aug-04 14:48):

*) firewall - fixed "in-interface-list" matcher when VRF is used;
My VRF experiment stranded on this bug but I am running beta version...

Who is online

Users browsing this forum: eworm and 9 guests