Community discussions

MikroTik App
 
mahdi
just joined
Topic Author
Posts: 2
Joined: Wed Nov 06, 2013 1:31 pm
Location: Baghdad

Load balancing (6 WAN) using PCC method - slow browsing and more

Wed Sep 14, 2022 1:03 am

I use CCR RB1016 for combine 6 WAN connections using PCC method, every wan with speed 20 Mbps ,
the result i expect for Combine ( 6 WAN ) to become the result of the combination 120 Mbps , but i get from 20 to 30 Mbps.
with slow browsing .

Please, anyone have some suggestions on how I could resolve these issues?



# sep/12/2022 13:30:42 by RouterOS 7.3.1
# software id = IZPS-EY4W
#
# model = CCR1016-12G
# serial number = D5440D9C1027
/interface bridge
add name=bridge1_lan
/interface ethernet
set [ find default-name=ether1 ] name=ether1_wan1
set [ find default-name=ether2 ] name=ether2_wan2
set [ find default-name=ether3 ] name=ether3_wan3
set [ find default-name=ether4 ] name=ether4_wan4
set [ find default-name=ether5 ] name=ether5_wan5
set [ find default-name=ether6 ] name=ether6_wan6
/disk
set usb1 disabled=no
set usb1-part1 disabled=no name=disk1
/interface lte apn
set [ find default=yes ] ip-type=ipv4 use-network-apn=no
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp_pool0 ranges=10.5.50.2-10.5.50.254
/ip dhcp-server
add address-pool=dhcp_pool0 interface=bridge1_lan name=dhcp1
/port
set 0 name=serial0
set 1 name=serial1
/routing table
add disabled=no fib name=to_wan1
add disabled=no fib name=to_wan2
add disabled=no fib name=to_wan3
add disabled=no fib name=to_wan4
add disabled=no fib name=to_wan5
add disabled=no fib name=to_wan6
/interface bridge port
add bridge=bridge1_lan interface=ether9
add bridge=bridge1_lan interface=ether10
add bridge=bridge1_lan interface=ether11
add bridge=bridge1_lan interface=ether12
/ip settings
set max-neighbor-entries=8192
/ipv6 settings
set disable-ipv6=yes max-neighbor-entries=8192
/interface ovpn-server server
set auth=sha1,md5
/ip address
add address=192.168.1.10/24 interface=ether1_wan1 network=192.168.1.0
add address=192.168.2.10/24 interface=ether2_wan2 network=192.168.2.0
add address=192.168.3.10/24 interface=ether3_wan3 network=192.168.3.0
add address=192.168.4.10/24 interface=ether4_wan4 network=192.168.4.0
add address=192.168.5.10/24 interface=ether5_wan5 network=192.168.5.0
add address=192.168.6.10/24 interface=ether6_wan6 network=192.168.6.0
add address=10.5.50.1/24 interface=bridge1_lan network=10.5.50.0
/ip dhcp-server network
add address=10.5.50.0/24 dns-server=8.8.8.8 gateway=10.5.50.1
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
/ip firewall mangle
add action=accept chain=prerouting dst-address=192.168.1.0/24 in-interface=\
    bridge1_lan
add action=accept chain=prerouting dst-address=192.168.2.0/24 in-interface=\
    bridge1_lan
add action=accept chain=prerouting dst-address=192.168.3.0/24 in-interface=\
    bridge1_lan
add action=accept chain=prerouting dst-address=192.168.4.0/24 in-interface=\
    bridge1_lan
add action=accept chain=prerouting dst-address=192.168.5.0/24 in-interface=\
    bridge1_lan
add action=accept chain=prerouting dst-address=192.168.6.0/24 in-interface=\
    bridge1_lan
add action=mark-connection chain=prerouting connection-mark=no-mark \
    in-interface=ether1_wan1 new-connection-mark=wan1
add action=mark-connection chain=prerouting connection-mark=no-mark \
    in-interface=ether2_wan2 new-connection-mark=wan2
add action=mark-connection chain=prerouting connection-mark=no-mark \
    in-interface=ether3_wan3 new-connection-mark=wan3
add action=mark-connection chain=prerouting connection-mark=no-mark \
    in-interface=ether4_wan4 new-connection-mark=wan4
add action=mark-connection chain=prerouting connection-mark=no-mark \
    in-interface=ether5_wan5 new-connection-mark=wan5
add action=mark-connection chain=prerouting connection-mark=no-mark \
    in-interface=ether6_wan6 new-connection-mark=wan6 passthrough=yes
add action=mark-connection chain=prerouting connection-mark=no-mark \
    dst-address-type=!local in-interface=bridge1_lan new-connection-mark=wan1 \
    per-connection-classifier=src-address-and-port:6/0
add action=mark-connection chain=prerouting connection-mark=no-mark \
    dst-address-type=!local in-interface=bridge1_lan new-connection-mark=wan2 \
    per-connection-classifier=src-address-and-port:6/1
add action=mark-connection chain=prerouting connection-mark=no-mark \
    dst-address-type=!local in-interface=bridge1_lan new-connection-mark=wan3 \
    per-connection-classifier=src-address-and-port:6/2
add action=mark-connection chain=prerouting connection-mark=no-mark \
    dst-address-type=!local in-interface=bridge1_lan new-connection-mark=wan4 \
    per-connection-classifier=src-address-and-port:6/3
add action=mark-connection chain=prerouting connection-mark=no-mark \
    dst-address-type=!local in-interface=bridge1_lan new-connection-mark=wan5 \
    per-connection-classifier=src-address-and-port:6/4
add action=mark-connection chain=prerouting connection-mark=no-mark \
    dst-address-type=!local in-interface=bridge1_lan new-connection-mark=wan6 \
    per-connection-classifier=src-address-and-port:6/5
add action=mark-routing chain=prerouting connection-mark=wan1 in-interface=\
    bridge1_lan new-routing-mark=to_wan1
add action=mark-routing chain=prerouting connection-mark=wan2 in-interface=\
    bridge1_lan new-routing-mark=to_wan2
add action=mark-routing chain=prerouting connection-mark=wan3 in-interface=\
    bridge1_lan new-routing-mark=to_wan3
add action=mark-routing chain=prerouting connection-mark=wan4 in-interface=\
    bridge1_lan new-routing-mark=to_wan4
add action=mark-routing chain=prerouting connection-mark=wan5 in-interface=\
    bridge1_lan new-routing-mark=to_wan5
add action=mark-routing chain=prerouting connection-mark=wan6 in-interface=\
    bridge1_lan new-routing-mark=to_wan6
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1_wan1
add action=masquerade chain=srcnat out-interface=ether2_wan2
add action=masquerade chain=srcnat out-interface=ether3_wan3
add action=masquerade chain=srcnat out-interface=ether4_wan4
add action=masquerade chain=srcnat out-interface=ether5_wan5
add action=masquerade chain=srcnat out-interface=ether6_wan6
/ip route
add check-gateway=ping disabled=no dst-address=0.0.0.0/0 gateway=192.168.1.1 \
    routing-table=to_wan1 suppress-hw-offload=no
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    192.168.2.1 pref-src=0.0.0.0 routing-table=to_wan2 scope=30 \
    suppress-hw-offload=no target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    192.168.3.1 pref-src=0.0.0.0 routing-table=to_wan3 scope=30 \
    suppress-hw-offload=no target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    192.168.4.1 pref-src=0.0.0.0 routing-table=to_wan4 scope=30 \
    suppress-hw-offload=no target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    192.168.5.1 pref-src=0.0.0.0 routing-table=to_wan5 scope=30 \
    suppress-hw-offload=no target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    192.168.6.1 pref-src=0.0.0.0 routing-table=to_wan6 scope=30 \
    suppress-hw-offload=no target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    192.168.1.1 routing-table=main suppress-hw-offload=no
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    192.168.2.1 pref-src=0.0.0.0 routing-table=main scope=30 \
    suppress-hw-offload=no target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    192.168.3.1 pref-src=0.0.0.0 routing-table=main scope=30 \
    suppress-hw-offload=no target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    192.168.4.1 pref-src=0.0.0.0 routing-table=main scope=30 \
    suppress-hw-offload=no target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    192.168.5.1 pref-src=0.0.0.0 routing-table=main scope=30 \
    suppress-hw-offload=no target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    192.168.6.1 pref-src=0.0.0.0 routing-table=main scope=30 \
    suppress-hw-offload=no target-scope=10
/ip smb
set domain=share enabled=yes
/ip smb shares
set [ find default=yes ] directory=/share
/ip smb users
add name=admin
add name=it
/system clock
set time-zone-name=Asia/Baghdad
 
User avatar
anav
Forum Guru
Forum Guru
Posts: 19323
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada
Contact:

Re: Load balancing (6 WAN) using PCC method - slow browsing and more

Wed Sep 14, 2022 2:36 am

You dont get it.................
Load balancing is so that users have equal opportunity to access the available EXTRA bandwidth available from having 6 ISPs.
Any session in progress cannot be more than the throughput of the ISP the user is connected to for that particular session.
The good thing is that there is more bandwidth to share, not faster speeds for any single user.

In other words, the speed of any one session is not combined!! Where did you get this false idea???

Who is online

Users browsing this forum: AimiSayo and 72 guests