Community discussions

MikroTik App
 
HighTower
just joined
Topic Author
Posts: 16
Joined: Wed Feb 18, 2015 4:06 pm

ROS7.6 BGP announce bridge ipv6 subnet

Wed Sep 21, 2022 10:30 am

Hello,

I have ros 7.6b7
ebgp connection to "bird v2" on ubuntu in dual mode ipv4\ipv6 routes
with ipv4 there is no problems, ros receives and announce routes,
but with with ipv6 problem - it only receive but not announce
/ip/address/print where interface=bridge
Columns: ADDRESS, NETWORK, INTERFACE
# ADDRESS NETWORK INTERFACE
;;; defconf
0 10.10.50.10/24 10.10.50.0 bridge
this ipv4 subnet is announced
and this one is not
/ipv6/address/print where interface=bridge
Flags: D - DYNAMIC; G, L - LINK-LOCAL
Columns: ADDRESS, FROM-POOL, INTERFACE, ADVERTISE
# ADDRESS FROM-POOL INTERFACE ADVERTISE
0 G fd50::50/64 pool-ipv6 bridge yes
1 DL fe80::6e3b:6bff:feb7:1f78/64 bridge no
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 8992
Joined: Tue Feb 25, 2014 12:49 pm
Location: 🇮🇹, my 💔 is in 🇺🇦

Re: ROS7.6 BGP announce bridge ipv6 subnet

Wed Sep 21, 2022 11:43 am

What about the rest of the setup?
You may have forgotten something, post the export for review.
✂ Rextended Fragments of Snippets

Vld4UmVHUkdhelJUTTJzOQ==
 
HighTower
just joined
Topic Author
Posts: 16
Joined: Wed Feb 18, 2015 4:06 pm

Re: ROS7.6 BGP announce bridge ipv6 subnet

Wed Sep 21, 2022 1:24 pm

what exactly to show?
here is bgp part:
/routing bgp template
add address-families=ip,ipv6 as=65150 disabled=no input.filter=in-home name=template-home \
nexthop-choice=force-self output.filter-chain=notexport_wg_helpers_nets router-id=10.10.88.50 routing-table=main

/routing bgp connection
add address-families=ip,ipv6 as=65150 disabled=no hold-time=3m input.filter=in-home keepalive-time=1m20s local.role=ebgp name=\
bgp-home nexthop-choice=default output.filter-chain=notexport_wg_helpers_nets .redistribute=connected remote.address=\
10.10.150.10/32 .as=65001 router-id=10.10.88.50 routing-table=main templates=template-home

/routing filter rule
add chain=in-home disabled=no rule="if (dst == 0.0.0.0/0) {\r\
\n reject\r\
\n} else {\r\
\n accept\r\
\n}"

add chain=notexport_wg_helpers_nets disabled=no rule="if (dst == 0.0.0.0/0 or dst == 10.10.88.48/30 or dst == 10.10.150.8/30 or \
\r\
\n (bgp-input-remote-addr != 10.10.88.49 and bgp-input-remote-addr != 10.10.150.50) or\r\
\n dst == ::/0) {\r\
\n reject\r\
\n} else {\r\
\n accept\r\
\n}"
 
HighTower
just joined
Topic Author
Posts: 16
Joined: Wed Feb 18, 2015 4:06 pm

Re: ROS7.6 BGP announce bridge ipv6 subnet

Tue Sep 27, 2022 3:15 pm

any ideas?

Who is online

Users browsing this forum: gotsprings and 10 guests