Community discussions

MikroTik App
 
Denuro
just joined
Topic Author
Posts: 4
Joined: Tue Dec 10, 2013 2:32 pm

Service VLAN on swOS

Thu Jul 20, 2017 12:06 am

Hello,

I was testing and found out that the swOS 2.4 does not read a QinQ Service VLAN tag.
Setting the port as VLAN Mode Enabled and VLAN Receive Only Tagged does not work with Service Vlans, had to set the Vlan Receive to any for it to work.

Tested with a CSS326-24G-2S+RM, setting up the vlan tunneling with a CRS125-24G-1S-IN and a CRS326-24G-2S+RM, both with routerOS.

Also noticed the swOS 2.3 does not work with QinQ vlans at all, not even setting the port as Vlan Receive any.

Is this the expected behavior on the CSS software?
 
becs
MikroTik Support
MikroTik Support
Posts: 493
Joined: Thu Jul 07, 2011 8:26 am

Re: Service VLAN on swOS

Thu Jul 20, 2017 10:08 am

Currently, MikroTik switches with SwOS do not support Q-in-Q VLANs.
 
Denuro
just joined
Topic Author
Posts: 4
Joined: Tue Dec 10, 2013 2:32 pm

Re: Service VLAN on swOS

Thu Jul 20, 2017 3:21 pm

Currently, MikroTik switches with SwOS do not support Q-in-Q VLANs.
Thanks for the reply.
Are there any plans to implement this in a future release?
 
bmv
just joined
Posts: 17
Joined: Sun Aug 15, 2010 1:15 pm

Re: Service VLAN on swOS

Wed Oct 25, 2017 7:14 pm

+1.
Surely QinQ is something standard to implement
 
4lex
just joined
Posts: 4
Joined: Mon Jan 15, 2018 8:39 pm

Re: Service VLAN on swOS

Wed Sep 16, 2020 12:55 pm

Any updates in this question?
 
User avatar
k6ccc
Forum Guru
Forum Guru
Posts: 1062
Joined: Fri May 13, 2016 12:01 am
Location: Glendora, CA, USA (near Los Angeles)

Re: Service VLAN on swOS

Wed Sep 16, 2020 10:43 pm

I don't remember seeing any mention of it in any updates. Push really comes to shove, I likely could test in here.
RB4011iGS+, RB750Gr3, RB750r2, CRS326-24G-2S (in SwitchOS), CSS326-24G-2S, CSS106-5G-1S, RB260GS
Not sure if I beat them into submission, or they beat me into submission

Warning: I know enough to be dangerous...

Jim
 
User avatar
etdijarwanto
just joined
Posts: 5
Joined: Fri Jan 26, 2018 3:34 am
Location: Indonesia

Re: Service VLAN on swOS

Sat Nov 06, 2021 8:13 pm

Currently, MikroTik switches with SwOS do not support Q-in-Q VLANs.
does that mean if you want to support QinQ CRS you have to boot into RouterOS, right?
 
dencow
just joined
Posts: 2
Joined: Wed Jul 08, 2009 3:46 am

Re: Service VLAN on swOS

Sun Oct 02, 2022 3:57 am

moderator note: do not quote preceding post, use "post Reply".
AFAIK CSS switches can't boot with RouterOS. It must use SwOS as discussed in this topic.
 
semaja2
newbie
Posts: 29
Joined: Wed Sep 08, 2021 3:50 pm

Re: Service VLAN on swOS

Wed Oct 19, 2022 1:31 am

Is anyone able to confirm if this is a "SwOS wont pass/forward QinQ tagged packets" or if its more "SwOS wont do QinQ tagging"? Really hope its the latter as the switch shouldnt be look at the second vlan tag for forwarding

Who is online

Users browsing this forum: No registered users and 0 guests