Community discussions

MikroTik App
 
mlacomb
newbie
Topic Author
Posts: 44
Joined: Wed Aug 17, 2022 10:01 pm

CRS326-24S+2Q+ LACP+VLAN Trunk to Dell 4048ON

Sun Oct 02, 2022 6:04 am

All:

I'm trying to get a bond + VLAN trunk to work with a Dell S4048T-ON and having issues. I've tested this configuration in eve-ng with a single cisco vios switch with no issue. Routeros 6.49.6.

Port sfp-sfpplus1 has a directly attached switch, untagged with an ip address on it. When I don't have the below configuration applied AND I have an IP address on the direct interface, I can ping between the two devices. sfp23 and sfp24 are the 2x10gig LACP bond, and are coming up as appropriate on both sides (Bonding_to_R2).

After removing the IP address and applying the below config, I cannot reach either Dell Switch IP address for ping at all. Thoughts?

Mikrotik:
# model = CRS326-24S+2Q+
/interface bridge
add frame-types=admit-only-vlan-tagged name=bridge1 vlan-filtering=yes
/interface ethernet
set [ find default-name=sfp-sfpplus1 ] name=s1
/interface bonding
add mode=802.3ad name=Bonding_to_R2 slaves=sfp-sfpplus23,sfp-sfpplus24
/interface bridge port
add bridge=bridge1 frame-types=admit-only-vlan-tagged interface=Bonding_to_R2
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged interface=s1
/interface bridge vlan
add bridge=bridge1 tagged=Bonding_to_R2 vlan-ids=599


Switch 1:

interface TenGigabitEthernet 1/46
description To_MT P23
no ip address
!
port-channel-protocol LACP
port-channel 51 mode active
no shutdown
!
interface Port-channel 51
description PC_Backup_P2P
no ip address
switchport
vlt-peer-lag port-channel 51
no shutdown
!
interface Vlan 599
description Backup_P2P
ip address 10.4.0.13/29
tagged Port-channel 12,51
no shutdown
!


Switch 2:
interface TenGigabitEthernet 1/46
description To_MT P24
no ip address
!
port-channel-protocol LACP
port-channel 51 mode active
no shutdown
!
interface Port-channel 51
description PC_Backup_P2P
no ip address
switchport
vlt-peer-lag port-channel 51
no shutdown
!
interface Vlan 599
description Backup_P2P
ip address 10.4.0.14/29
tagged Port-channel 12,51
no shutdown
!
 
User avatar
mkx
Forum Guru
Forum Guru
Posts: 11438
Joined: Thu Mar 03, 2016 10:23 pm

Re: CRS326-24S+2Q+ LACP+VLAN Trunk to Dell 4048ON

Sun Oct 02, 2022 11:42 am

And what is intended membership of s1? If it should be access port of VLAN 599, configuration misses proper PVID setting (default is 1):
/interface bridge port
add bridge=bridge1 frame-types=admit-only-vlan-tagged interface=Bonding_to_R2
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged interface=s1 pvid=599

Conceptually s1 should be then added to ports members of VLAN 599 as untagged member (in the /interface bridge vlan section), but that's done automatically when port has pvid set.
 
mlacomb
newbie
Topic Author
Posts: 44
Joined: Wed Aug 17, 2022 10:01 pm

Re: CRS326-24S+2Q+ LACP+VLAN Trunk to Dell 4048ON

Sun Oct 02, 2022 4:17 pm

Thanks for the quick assist! Unfortunately, still no dice on getting this link to work. So here's what I've done:

I've removed LACP as a component. I'm linking the Mikrotik up to a single Dell with one leg only. Untagged link - pings are fine. Tagged? Nothing works between MT and Dell. It's still possible I have a misconfiguration here, but I'm really trying to just figure out how to trunk a port between these two to start with a single VLAN. I understand that the Mikrotik configuration is much more powerful and prone to mistakes on my part, but I'm just out of ideas here - following the Mikrotik guides as close as possible.

Take 1:
No LACP - Untagged - can ping across to switch

Mikrotik - sfp-sfpplus1 = to host, sfp-sfpplus23 = to switch

/interface bridge
add name=bridge1
/interface ethernet
set [ find default-name=sfp-sfpplus1 ] name=s1
/interface bridge port
add bridge=bridge1 interface=s1
add bridge=bridge1 interface=sfp-sfpplus23
/ip address
add address=10.4.0.10/29 interface=bridge1 network=10.4.0.8

Dell: Te1/46 with vlan599 as untagged interface:

interface TenGigabitEthernet 1/46
no ip address
switchport
no shutdown
interface Vlan 599
ip address 10.4.0.14/29
untagged TenGigabitEthernet 1/46
no shutdown

MT"
ping 10.4.0.14
SEQ HOST SIZE TTL TIME STATUS
0 10.4.0.14 56 255 0ms
1 10.4.0.14 56 255 0ms
2 10.4.0.14 56 255 0ms
3 10.4.0.14 56 255 0ms
4 10.4.0.14 56 255 0ms
sent=5 received=5 packet-loss=0% min-rtt=0ms avg-rtt=0ms max-rtt=0ms

Dell:
ping 10.4.0.10

Type Ctrl-C to abort.

Sending 5, 100-byte ICMP Echos to 10.4.0.10, timeout is 2 seconds:
!!!!!
Success rate is 100.0 percent (5/5), round-trip min/avg/max = 0/0/0 (ms)


Take 2:
No LACP - adding Tagged config as shown in examples - cannot ping across to switch or vice versa

MT:
/interface bridge
add frame-types=admit-only-vlan-tagged name=bridge1 vlan-filtering=yes
/interface ethernet
set [ find default-name=sfp-sfpplus1 ] name=s1
/interface vlan
add interface=bridge1 name=VLAN599 vlan-id=599
/interface bridge port
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged interface=s1 pvid=599
add bridge=bridge1 frame-types=admit-only-vlan-tagged interface=sfp-sfpplus23
/interface bridge vlan
add bridge=bridge1 tagged=sfp-sfpplus23 untagged=s1 vlan-ids=599
/ip address
add address=10.4.0.10/29 interface=VLAN599 network=10.4.0.8

DELL:
interface TenGigabitEthernet 1/46
no ip address
switchport
no shutdown
interface Vlan 599
ip address 10.4.0.14/29
tagged TenGigabitEthernet 1/46
no shutdown


#I was initially concerned that maybe the Dell wasn't tagging the egress for some reason, but this confirms the switch appears set up correctly:

show interfaces switchport te1/46

Codes: U - Untagged, T - Tagged
x - Dot1x untagged, X - Dot1x tagged
G - GVRP tagged, M - Trunk
i - Internal untagged, I - Internal tagged, v - VLT untagged, V - VLT tagged

Name: TenGigabitEthernet 1/46
Description:
802.1QTagged: True
Vlan membership:
Q Vlans
T 599
 
User avatar
mkx
Forum Guru
Forum Guru
Posts: 11438
Joined: Thu Mar 03, 2016 10:23 pm

Re: CRS326-24S+2Q+ LACP+VLAN Trunk to Dell 4048ON

Sun Oct 02, 2022 4:48 pm

You need bridge1 interface set as tagged member of vlan 599 (under /interface bridge vlan) in order to allow ROS to interact with said VLAN.
 
mlacomb
newbie
Topic Author
Posts: 44
Joined: Wed Aug 17, 2022 10:01 pm

Re: CRS326-24S+2Q+ LACP+VLAN Trunk to Dell 4048ON

Sun Oct 02, 2022 6:02 pm

Thank you so much; I now have pings from MT and Switch responding... I can now build out what I know on the other sides to see what other pieces I'm missing!
 
mlacomb
newbie
Topic Author
Posts: 44
Joined: Wed Aug 17, 2022 10:01 pm

Re: CRS326-24S+2Q+ LACP+VLAN Trunk to Dell 4048ON

Sun Oct 02, 2022 10:17 pm

OK - baby steps! Just turned up LACP and re-applied that new interface to the bridge and VLANs, all good! Dell and Mikrotik interconnectivity success!!!

The last piece... I can't get the untagged interface (s1) to spit out any real packets other than LLDP. Packet captures show no ARPs egressing towards the other equipment (bridge capture shows the arps), and I still can't ping the VLAN ip of 10.4.0.10 from a directly attached device.


/interface bridge
add frame-types=admit-only-vlan-tagged name=bridge1 vlan-filtering=yes
/interface ethernet
set [ find default-name=sfp-sfpplus1 ] name=s1
/interface vlan
add interface=bridge1 name=VLAN599 vlan-id=599
/interface bonding
add mode=802.3ad name=LACP_to_R2 slaves=sfp-sfpplus23,sfp-sfpplus24 transmit-hash-policy=layer-2-and-3
/interface bridge port
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged interface=s1 pvid=599
add bridge=bridge1 frame-types=admit-only-vlan-tagged interface=LACP_to_R2 pvid=599
/interface bridge vlan
add bridge=bridge1 tagged=sfp-sfpplus23,bridge1,LACP_to_R2 untagged=s1 vlan-ids=599
/ip address
add address=10.4.0.10/29 interface=VLAN599 network=10.4.0.8
 
User avatar
mkx
Forum Guru
Forum Guru
Posts: 11438
Joined: Thu Mar 03, 2016 10:23 pm

Re: CRS326-24S+2Q+ LACP+VLAN Trunk to Dell 4048ON

Sun Oct 02, 2022 11:19 pm

I don't know why s1 doesn't transmit any untagged frames. However there's an error in shown config: sfp-sfpplus23 is still listed as tagged member of VLAN 599 even though it's member of LACP bond. I can imagine some unexpected behaviour due to that.
 
mlacomb
newbie
Topic Author
Posts: 44
Joined: Wed Aug 17, 2022 10:01 pm

Re: CRS326-24S+2Q+ LACP+VLAN Trunk to Dell 4048ON

Wed Oct 12, 2022 3:36 pm

mkx: Thank you so much for all your help. I had a thought regarding spanning tree and a potential conflict - I ended up disabling spanning tree towards the carrier interfaces and they started passing IP traffic as appropriate. I'm not really well versed unfortunately in troubleshooting the Mikrotiks - so I'll have to leave that for another time, but at this point the solution stands as required!
 
User avatar
StubArea51
Trainer
Trainer
Posts: 1739
Joined: Fri Aug 10, 2012 6:46 am
Location: stubarea51.net
Contact:

Re: CRS326-24S+2Q+ LACP+VLAN Trunk to Dell 4048ON

Wed Oct 12, 2022 4:05 pm

One thing to be aware of regarding the Dell switches is they generally have issues when doing interop for Rapid STP with other vendors. We generally use MSTP if interop between MikroTik and Dell or other vendors is needed.

Here's a doc that goes over some of the issues as it relates to Dell and Cisco interop for STP.

https://i.dell.com/sites/csdocuments/Sh ... bility.pdf

Who is online

Users browsing this forum: Ahrefs [Bot], nescafe2002 and 72 guests