Community discussions

MikroTik App
 
qatar2022
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 92
Joined: Mon Aug 24, 2020 11:12 am

Pihole makes me craze

Tue Jan 24, 2023 10:13 am

Dear all
I'm going to tell you my experience about installing pihole docker container on my MK RB5009
I follow all instruction step by step latter by latter but when I run container interface, I can't get internet from the holl of my Wi-Fi and ether port.
I adjust my 5G router DNS to auto
I create bridge /interface/bridge/add name=dockers
I add new address /ip/address/add address=172.17.0.1/24 interface=dockers
I create VETH and givt it an adress /interface/veth/add name=veth1 address=172.17.0.2/24 gateway=172.17.0.1
I create new rolls /ip/firewall/nat/add chain=srcnat action=masquerade src-address=172.17.0.0/24
I Configured the container:
/container/envs/add name=pihole_envs key=TZ value="Europe/Riga"
/container/envs/add name=pihole_envs key=WEBPASSWORD value="mysecurepassword"
/container/envs/add name=pihole_envs key=DNSMASQ_USER value="root"
/container/mounts/add name=etc_pihole src=disk1/etc dst=/etc/pihole
/container/mounts/add name=dnsmasq_pihole src=disk1/etc-dnsmasq.d dst=/etc/dnsmasq.d
/container/config/set registry-url=https://registry-1.docker.io tmpdir=disk1/pull
/container/add remote-image=pihole/pihole:latest interface=veth1 root-dir=disk1/pihole mounts=dnsmasq_pihole,etc_pihole envlist=pihole_envs
And then I create new NAT roll:
/ip firewall nat
add action=dst-nat chain=dstnat dst-address=192.168.88.1 dst-port=888 protocol=tcp to-addresses=172.17.0.2 to-ports=80
I adjust my MK IP-DNS to the IP that I already created on IP-Address (for example 172.17.0.2)
I adjust my MK IP-DHCP Server-Networks-DNS to 172.17.0.2

After all this setting I can't get an internet and I can't open pihole page )192.168.88.1:888/admin)
I remember one time only pihole work and after that I don't know what's wrong.
Please is there any thing missing? I spend more than a week try to solve this issue.

Best Regards
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 25408
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Pihole makes me craze

Tue Jan 24, 2023 11:21 am

Does it work if you go to 172.17.0.2/admin ?
Did you follow our video? It has quite clear step by step guide: https://www.youtube.com/watch?v=UMcJs4oyHDk
 
qatar2022
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 92
Joined: Mon Aug 24, 2020 11:12 am

Re: Pihole makes me craze

Tue Jan 24, 2023 3:07 pm

No it's not working and no internet as well and I reset my MK to factory and reconfigure it again and seam issue
 
qatar2022
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 92
Joined: Mon Aug 24, 2020 11:12 am

Re: Pihole makes me craze

Wed Jan 25, 2023 6:48 am

Dear all

I would like to thank myself for helping me regarding pihole
finally, I solve the issue that I was connect my PC to my MK via sfp-sfpplus1 port and I change it to ethernet port and its work great.
 
gabacho4
Member Candidate
Member Candidate
Posts: 190
Joined: Mon Dec 28, 2020 12:30 pm
Location: Earth

Re: Pihole makes me craze

Wed Jan 25, 2023 12:23 pm

You seem to forget that none of us are paid support and have jobs/life/other interests. That said, if you can't use your SPF port you have a configuration issue. I'm sure you can figure that out by yourself as well.
 
qatar2022
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 92
Joined: Mon Aug 24, 2020 11:12 am

Re: Pihole makes me craze

Fri Jan 27, 2023 8:10 pm

as I mention that I have Huawei 5G router which is connected to MK RB5009

NO ONE even mention that I have to change the DNS from Huawei router to Pihole DNS
 
User avatar
BartoszP
Forum Guru
Forum Guru
Posts: 2393
Joined: Mon Jun 16, 2014 1:13 pm
Location: Poland

Re: Pihole makes me craze

Fri Jan 27, 2023 8:21 pm

Image
 
gabacho4
Member Candidate
Member Candidate
Posts: 190
Joined: Mon Dec 28, 2020 12:30 pm
Location: Earth

Re: Pihole makes me craze

Fri Jan 27, 2023 8:26 pm

That's like networking 101. You're using a Mikrotik device and doing more advanced configurations and we were supposed to remind you to change your DNS to the pihole DNS server on a downstream device? Anyway...

Who is online

Users browsing this forum: No registered users and 1 guest