/routing rule {
add action=lookup disabled=$norules dst-address=10.0.0.0/8 table=main
add action=lookup disabled=$norules dst-address=172.16.0.0/12 table=main
add action=lookup disabled=$norules dst-address=192.168.0.0/16 table=main
}
/ip route rule
#"LAN Destinations that should only use main (active) routing table. ISP1 when not in failover state."
add action=lookup-only-in-table dst-address=10.1.1.0/24 table=main
add action=lookup-only-in-table dst-address=10.2.2.0/24 table=main
#"PBX Server and VideoStreamer force out ISP2. Change action to "lookup" if there is a desire to failover to ISP1 if ISP2 is down"
add action=lookup src-address=10.2.2.20/32 table=ISP2_Route
add action=lookup src-address=10.1.1.50/32 table=ISP2_Route
Yeah that is a missing item in the /routing/rules – it certainly be nice to define the subnets used in one place & not have to update the routing rules as add'l step. Now if added, be nice if "print" showing generated "address list dynamic rules" for troubleshooting (e.g. an address-list may have LOT of various address, still like to see the "resolved" list of rules with IPs in /routing/rule/print)I wish MT would add address lists as an entry for Routing Rules!!
ChatGPT's @anav hallucination goes off-topic...but fair point about WG and PBR I think...[...] Wireguard [...]
/ip firewall mangle
add action=accept chain=prerouting comment="NO BALANCEAR TRAFICO PRIVADO" dst-address-list=RFC1918 src-address-list=RFC1918
add action=accept chain=prerouting comment="INICIO PCC A ROUTER FTTH" dst-address=172.18.1.0/24 in-interface-list=LAN
add action=accept chain=prerouting dst-address=172.18.2.0/24 in-interface-list=LAN
add action=accept chain=prerouting dst-address=172.18.3.0/24 in-interface-list=LAN
add action=accept chain=prerouting dst-address=172.18.4.0/24 in-interface-list=LAN
add action=accept chain=prerouting dst-address=172.18.5.0/24 in-interface-list=LAN
add action=accept chain=prerouting dst-address=172.18.6.0/24 in-interface-list=LAN
add action=accept chain=prerouting comment="INICIO PCC A ENLACE ROTA" dst-address=195.53.96.0/23 in-interface-list=LAN
add action=mark-connection chain=input comment="MARCADO DE CONEXIONES ORIGINADAS EN INTERNET" connection-mark=no-mark in-interface=pppoe-out_FTTH_01 new-connection-mark=hacia-FTTH_01-conn passthrough=yes
add action=mark-connection chain=input connection-mark=no-mark in-interface=pppoe-out_FTTH_02 new-connection-mark=hacia-FTTH_02-conn passthrough=yes
add action=mark-connection chain=input connection-mark=no-mark in-interface=ether3-FTTH_03 new-connection-mark=hacia-FTTH_03-conn passthrough=yes
add action=mark-connection chain=input connection-mark=no-mark in-interface=pppoe-out_FTTH_04 new-connection-mark=hacia-FTTH_04-conn passthrough=yes
add action=mark-connection chain=input connection-mark=no-mark in-interface=pppoe-out_FTTH_05 new-connection-mark=hacia-FTTH_05-conn passthrough=yes
add action=mark-connection chain=input connection-mark=no-mark in-interface=pppoe-out_FTTH_06 new-connection-mark=hacia-FTTH_06-conn passthrough=yes
add action=mark-connection chain=prerouting connection-mark=no-mark disabled=yes in-interface=BR_NO-CGNAT new-connection-mark=hacia-ENLACE-ROTA-conn passthrough=yes
add action=mark-connection chain=input connection-mark=no-mark in-interface=BR_NO-CGNAT new-connection-mark=hacia-ENLACE-ROTA-conn passthrough=yes
add action=mark-routing chain=output comment="MARCADO DE TRAFICO DE RESPUESTA DEL ROUTER A INTERNET" connection-mark=hacia-FTTH_01-conn new-routing-mark=hacia-FTTH_01 passthrough=no
add action=mark-routing chain=output connection-mark=hacia-FTTH_02-conn new-routing-mark=hacia-FTTH_02 passthrough=no
add action=mark-routing chain=output connection-mark=hacia-FTTH_03-conn new-routing-mark=hacia-FTTH_03 passthrough=no
add action=mark-routing chain=output connection-mark=hacia-FTTH_04-conn new-routing-mark=hacia-FTTH_04 passthrough=no
add action=mark-routing chain=output connection-mark=hacia-FTTH_05-conn new-routing-mark=hacia-FTTH_05 passthrough=no
add action=mark-routing chain=output connection-mark=hacia-FTTH_06-conn new-routing-mark=hacia-FTTH_06 passthrough=no
add action=mark-routing chain=output connection-mark=hacia-ENLACE-ROTA-conn new-routing-mark=hacia-ENLACE-ROTA passthrough=no
add action=mark-connection chain=prerouting comment="MARCAR CONEXIONES DESDE LA LAN PARA DISTRIBUIR BALANCEADO PROPORCIONAL" connection-mark=no-mark disabled=yes dst-address-type=!local hotspot=auth in-interface-list=LAN \
new-connection-mark=hacia-FTTH_01-conn passthrough=yes per-connection-classifier=both-addresses-and-ports:7/0
add action=mark-connection chain=prerouting connection-mark=no-mark disabled=yes dst-address-type=!local hotspot=auth in-interface-list=LAN new-connection-mark=hacia-FTTH_02-conn passthrough=yes per-connection-classifier=\
both-addresses-and-ports:7/1
add action=mark-connection chain=prerouting comment="MARCAR CONEXIONES DESDE LA LAN PARA DISTRIBUIR BALANCEADO PROPORCIONAL (directo)" connection-mark=no-mark dst-address-type=!local hotspot=auth in-interface-list="LAN_GUEST-01 (HS-FREE)" \
new-connection-mark=hacia-FTTH_01-conn passthrough=yes
add action=mark-connection chain=prerouting connection-mark=no-mark disabled=yes dst-address-type=!local hotspot=auth in-interface-list=LAN new-connection-mark=hacia-FTTH_03-conn passthrough=yes per-connection-classifier=\
both-addresses-and-ports:7/2
add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-type=!local hotspot=auth in-interface-list="LAN_GUEST-03 (PAY-B119)" new-connection-mark=hacia-FTTH_03-conn passthrough=yes
add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-type=!local hotspot=auth in-interface-list="LAN_GUEST-02 (PAY-B114)" new-connection-mark=hacia-FTTH_02-conn passthrough=yes
add action=mark-connection chain=prerouting connection-mark=no-mark disabled=yes dst-address-type=!local hotspot=auth in-interface-list=LAN new-connection-mark=hacia-FTTH_04-conn passthrough=yes per-connection-classifier=\
both-addresses-and-ports:7/3
add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-type=!local in-interface-list="LAN_GUEST-04 (GPON)" new-connection-mark=hacia-FTTH_04-conn passthrough=yes
add action=mark-connection chain=prerouting connection-mark=no-mark disabled=yes dst-address-type=!local hotspot=auth in-interface-list=LAN new-connection-mark=hacia-FTTH_05-conn passthrough=yes per-connection-classifier=\
both-addresses-and-ports:7/4
add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-type=!local in-interface-list="LAN_GUEST-05 (LAN-B311 & MERAKI)" new-connection-mark=hacia-FTTH_05-conn passthrough=yes
add action=mark-connection chain=prerouting connection-mark=no-mark disabled=yes dst-address-type=!local hotspot=auth in-interface-list=LAN new-connection-mark=hacia-FTTH_06-conn passthrough=yes per-connection-classifier=\
both-addresses-and-ports:7/5
add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-type=!local in-interface-list=LAN_GUEST-06 new-connection-mark=hacia-FTTH_06-conn passthrough=yes
add action=mark-connection chain=prerouting connection-mark=no-mark disabled=yes dst-address-type=!local hotspot=auth in-interface-list=LAN new-connection-mark=hacia-ENLACE-ROTA-conn passthrough=yes per-connection-classifier=\
both-addresses-and-ports:7/6
add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-type=!local in-interface-list="LAN_GUEST-07 (ENLACE ROTA NO-CGNAT)" new-connection-mark=hacia-ENLACE-ROTA-conn passthrough=yes
add action=mark-routing chain=prerouting comment="MARCADO DE RUTAS A TODOS LOS PAQUETES QUE TENGAN MARCAS DE CONEXION EN LA LAN" connection-mark=hacia-FTTH_01-conn in-interface-list="LAN_GUEST-01 (HS-FREE)" new-routing-mark=hacia-FTTH_01 \
passthrough=no
add action=mark-routing chain=prerouting connection-mark=hacia-FTTH_02-conn in-interface-list="LAN_GUEST-02 (PAY-B114)" new-routing-mark=hacia-FTTH_02 passthrough=no
add action=mark-routing chain=prerouting connection-mark=hacia-FTTH_03-conn in-interface-list="LAN_GUEST-03 (PAY-B119)" new-routing-mark=hacia-FTTH_03 passthrough=no
add action=mark-routing chain=prerouting connection-mark=hacia-FTTH_04-conn in-interface-list="LAN_GUEST-04 (GPON)" new-routing-mark=hacia-FTTH_04 passthrough=no
add action=mark-routing chain=prerouting connection-mark=hacia-FTTH_05-conn in-interface-list="LAN_GUEST-05 (LAN-B311 & MERAKI)" new-routing-mark=hacia-FTTH_05 passthrough=no
add action=mark-routing chain=prerouting connection-mark=hacia-FTTH_06-conn in-interface-list=LAN_GUEST-06 new-routing-mark=hacia-FTTH_06 passthrough=no psd=21,3s,3,1
add action=mark-routing chain=prerouting connection-mark=hacia-ENLACE-ROTA-conn in-interface-list="LAN_GUEST-07 (ENLACE ROTA NO-CGNAT)" new-routing-mark=hacia-ENLACE-ROTA passthrough=no
/ip route
add comment="RUTA PRINCIPAL MARCAS FTTH_01" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out_FTTH_01 pref-src="" routing-table=hacia-FTTH_01 scope=30 suppress-hw-offload=no target-scope=10
add comment="RUTA PRINCIPAL MARCAS FTTH_02" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out_FTTH_02 pref-src="" routing-table=hacia-FTTH_02 scope=30 suppress-hw-offload=no target-scope=10
add comment="RUTA PRINCIPAL MARCAS FTTH_03" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=172.18.3.1 pref-src="" routing-table=hacia-FTTH_03 scope=30 suppress-hw-offload=no target-scope=10
add comment="RUTA PRINCIPAL MARCAS FTTH_04" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out_FTTH_04 pref-src="" routing-table=hacia-FTTH_04 scope=30 suppress-hw-offload=no target-scope=10
add comment="RUTA PRINCIPAL MARCAS FTTH_05" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out_FTTH_05 pref-src="" routing-table=hacia-FTTH_05 scope=30 suppress-hw-offload=no target-scope=10
add comment="RUTA PRINCIPAL MARCAS FTTH_06" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out_FTTH_06 pref-src="" routing-table=hacia-FTTH_06 scope=30 suppress-hw-offload=no target-scope=10
add comment="RUTA PPAL PARA MIKROTIK - MAIN" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out_FTTH_06 pref-src="" routing-table=main scope=30 suppress-hw-offload=no target-scope=10
@mrz kinda starts with that assumption. I've never know if it was "better or worse" – I use them more for explainability to someone who knows networking but not RouterOS ("go to the firewall to change routing" vs goto /routing/rules) since concept exist in linux/macOS.I have always used Mangle to mark traffic to different routes, but I don't know without the routing rules it is better, worse or a different way to do it.
Can you explain this more fully please.set min-prefix=4294967295 if you are going to use Routing->Rules, to disable suppress feature.
It is a known bug, by default, it suppress default route (/0 and ::/0)