Community discussions

MikroTik App
 
JustAnAccount
just joined
Topic Author
Posts: 9
Joined: Mon Jun 20, 2022 4:02 pm

QoS while downloading

Thu Mar 23, 2023 1:29 pm

Good afternoon

Currently, when I download I cannot game on my computer at the same time. It does take all the bandwidth. Most game launcher allow to cap the download at 5MB/s or 10MB/s but nothing in between... While my internet connection is around 80Mbps (10MB/s). If I set the limit in the launcher it uses my whole bandwidth, if I set it at 5MB/s it takes twice the time to download.

When I am alone I can organize myself around this "issue" but soon my partner is moving in. Being a gamer too, she will want a stable connection in her games and while she streams while I download a game or update and vice verse. :)

Is there a way I can apply some QOS on our network where it prioritizes/fastrack gaming traffic (I assume it is mainly UDP packets?) while still allowing to download as fast at possible rate without affecting the gaming experience?
 
pe1chl
Forum Guru
Forum Guru
Posts: 10195
Joined: Mon Jun 08, 2015 12:09 pm

Re: QoS while downloading

Thu Mar 23, 2023 3:24 pm

There is not much you can do on your side w.r.t. QoS of "download" because that is all happening at the ISP, not in your router.
When you limit your download speed using queues, you still have bursts at the ISP side that can ruin interactive behavior.
To get this corrected, you would need to tell the people operating the download server to set a DSCP tag indicating lower priority (e.g. 8 or 16) and tell your provider to respect DSCP. Or to implement "fair queue".
 
Rox169
Member
Member
Posts: 433
Joined: Sat Sep 04, 2021 1:47 am

Re: QoS while downloading

Thu Mar 23, 2023 4:51 pm

try QOS - CAKE
 
optio
Long time Member
Long time Member
Posts: 655
Joined: Mon Dec 26, 2022 2:57 pm

Re: QoS while downloading

Thu Mar 23, 2023 9:28 pm

Try with Queue Trees, works for me at least for streaming while downloading (even when torrent is active). I even have additional issue, variable internet speed in big range (down: 20-120Mbit, up: 5 - 60Mbit), depending on day hours.
You will need to mark packets using mangle rules depending on connection, connection can be identified by src/dst ports, ip address, etc. I spent some time identifying connections or configuring ports of mine applications, when you find what you need mark that and add it into tree by some priority.
Here my configuration of mangle rules and queue tree, customized for my needs, but you can get insight for creating something for your needs.

Mangle:
Note: some rules depends on address list (src-address-list/dst-address-list) which are not in this export.
/ip firewall mangle add action=set-priority chain=postrouting comment="WMM / DSCP" new-priority=from-dscp-high-3-bits passthrough=yes
/ip firewall mangle add action=accept chain=prerouting comment="Skip mangle for non WAN" in-interface-list=!WAN
/ip firewall mangle add action=accept chain=postrouting out-interface-list=!WAN
/ip firewall mangle add action=mark-connection chain=prerouting comment=DNS connection-mark=no-mark connection-state=new dst-port=53 new-connection-mark=DNS passthrough=yes protocol=udp
/ip firewall mangle add action=mark-connection chain=prerouting connection-mark=no-mark connection-state=new dst-port=53 new-connection-mark=DNS passthrough=yes protocol=tcp
/ip firewall mangle add action=mark-connection chain=prerouting comment="-- Unbound DNS container connections" connection-mark=no-mark connection-state=new new-connection-mark=DNS passthrough=yes protocol=udp src-address-list=UNBOUND
/ip firewall mangle add action=mark-connection chain=prerouting connection-mark=no-mark connection-state=new new-connection-mark=DNS passthrough=yes protocol=tcp src-address-list=UNBOUND
/ip firewall mangle add action=mark-packet chain=prerouting comment=-- connection-mark=DNS new-packet-mark=DNS_D passthrough=no
/ip firewall mangle add action=mark-connection chain=postrouting connection-mark=no-mark connection-state=new dst-port=53 new-connection-mark=DNS passthrough=yes protocol=udp
/ip firewall mangle add action=mark-connection chain=postrouting connection-mark=no-mark connection-state=new dst-port=53 new-connection-mark=DNS passthrough=yes protocol=tcp
/ip firewall mangle add action=mark-connection chain=postrouting comment="-- Unbound DNS container connections" connection-mark=no-mark connection-state=new new-connection-mark=DNS passthrough=yes protocol=udp src-address-list=UNBOUND
/ip firewall mangle add action=mark-connection chain=postrouting connection-mark=no-mark connection-state=new new-connection-mark=DNS passthrough=yes protocol=tcp src-address-list=UNBOUND
/ip firewall mangle add action=mark-packet chain=postrouting comment=-- connection-mark=DNS new-packet-mark=DNS_U passthrough=no
/ip firewall mangle add action=mark-packet chain=prerouting comment=ACK new-packet-mark=ACK_D packet-size=0-123 passthrough=no protocol=tcp tcp-flags=ack
/ip firewall mangle add action=mark-packet chain=postrouting new-packet-mark=ACK_U packet-size=0-123 passthrough=no protocol=tcp tcp-flags=ack
/ip firewall mangle add action=mark-connection chain=prerouting comment="COMM / VOIP -- DSCP 46,34" connection-mark=no-mark connection-state=new dscp=46 new-connection-mark=VOIP passthrough=yes protocol=udp
/ip firewall mangle add action=mark-connection chain=prerouting connection-mark=no-mark connection-state=new dscp=34 new-connection-mark=VOIP passthrough=yes protocol=udp
/ip firewall mangle add action=mark-connection chain=prerouting connection-mark=no-mark connection-state=new dscp=46 new-connection-mark=VOIP passthrough=yes protocol=tcp
/ip firewall mangle add action=mark-connection chain=prerouting connection-mark=no-mark connection-state=new dscp=34 new-connection-mark=VOIP passthrough=yes protocol=tcp
/ip firewall mangle add action=mark-connection chain=prerouting comment="-- SIP (5060-5062,5353,10000-10050), VIBER (5243,9785), ZOOM (3478,3479,8801-8810)" connection-mark=no-mark connection-state=new dst-port=3478,3479,5060-5062,5243,5353,8801-8810,9785,10000-10050 new-connection-mark=VOIP passthrough=yes protocol=udp
/ip firewall mangle add action=mark-connection chain=prerouting comment="-- VIBER (4244,5242), ZOOM (8801-8810), PUSH (5222,5223,5228)" connection-mark=no-mark connection-state=new dst-port=4244,5222,5223,5228,5242,8801-8810 new-connection-mark=VOIP passthrough=yes protocol=tcp
/ip firewall mangle add action=mark-connection chain=prerouting comment="-- MS TEAMS" connection-mark=no-mark connection-state=new new-connection-mark=VOIP passthrough=yes protocol=udp src-port=50000-50059
/ip firewall mangle add action=mark-connection chain=prerouting connection-mark=no-mark connection-state=new new-connection-mark=VOIP passthrough=yes protocol=tcp src-port=50000-50059
/ip firewall mangle add action=mark-connection chain=prerouting comment="-- REMOTE_DESKTOP Address List" connection-mark=no-mark connection-state=new dst-address-list=REMOTE_DESKTOP new-connection-mark=VOIP passthrough=yes protocol=tcp
/ip firewall mangle add action=mark-packet chain=prerouting comment=-- connection-mark=VOIP new-packet-mark=VOIP_D passthrough=no
/ip firewall mangle add action=mark-connection chain=postrouting comment="-- DSCP 46,34" connection-mark=no-mark connection-state=new dscp=46 new-connection-mark=VOIP passthrough=yes protocol=udp
/ip firewall mangle add action=mark-connection chain=postrouting connection-mark=no-mark connection-state=new dscp=34 new-connection-mark=VOIP passthrough=yes protocol=udp
/ip firewall mangle add action=mark-connection chain=postrouting connection-mark=no-mark connection-state=new dscp=46 new-connection-mark=VOIP passthrough=yes protocol=tcp
/ip firewall mangle add action=mark-connection chain=postrouting connection-mark=no-mark connection-state=new dscp=34 new-connection-mark=VOIP passthrough=yes protocol=tcp
/ip firewall mangle add action=mark-connection chain=postrouting comment="-- SIP (5060-5062,5353,10000-10050), VIBER (5243,9785), ZOOM (3478,3479,8801-8810)" connection-mark=no-mark connection-state=new dst-port=3478,3479,5060-5062,5243,5353,8801-8810,9785,10000-10050 new-connection-mark=VOIP passthrough=yes protocol=udp
/ip firewall mangle add action=mark-connection chain=postrouting comment="-- VIBER (4244,5242), ZOOM (8801-8810), PUSH (5222,5223,5228)" connection-mark=no-mark connection-state=new dst-port=4244,5222,5223,5228,5242,8801-8810 new-connection-mark=VOIP passthrough=yes protocol=tcp
/ip firewall mangle add action=mark-connection chain=postrouting comment="-- MS TEAMS" connection-mark=no-mark connection-state=new new-connection-mark=VOIP passthrough=yes protocol=udp src-port=50000-50059
/ip firewall mangle add action=mark-connection chain=postrouting connection-mark=no-mark connection-state=new new-connection-mark=VOIP passthrough=yes protocol=tcp src-port=50000-50059
/ip firewall mangle add action=mark-connection chain=postrouting comment="-- REMOTE_DESKTOP Address List" connection-mark=no-mark connection-state=new dst-address-list=REMOTE_DESKTOP new-connection-mark=VOIP passthrough=yes protocol=tcp
/ip firewall mangle add action=mark-packet chain=postrouting comment=-- connection-mark=VOIP new-packet-mark=VOIP_U passthrough=no
/ip firewall mangle add action=mark-connection chain=prerouting comment="STREAMING / IPTV -- DSCP 32" connection-mark=no-mark connection-state=new dscp=32 new-connection-mark=STREAMING passthrough=yes protocol=udp
/ip firewall mangle add action=mark-connection chain=prerouting connection-mark=no-mark connection-state=new dscp=32 new-connection-mark=STREAMING passthrough=yes protocol=tcp
/ip firewall mangle add action=mark-connection chain=prerouting comment="-- STREAMING Address List" connection-mark=no-mark connection-state=new dst-address-list=STREAMING new-connection-mark=STREAMING passthrough=yes protocol=tcp
/ip firewall mangle add action=mark-connection chain=prerouting comment="-- ACESTREAM" connection-mark=no-mark connection-state=new dst-port=8621 new-connection-mark=STREAMING passthrough=yes protocol=tcp
/ip firewall mangle add action=mark-connection chain=prerouting connection-mark=no-mark connection-state=new dst-port=8621 new-connection-mark=STREAMING passthrough=yes protocol=udp
/ip firewall mangle add action=mark-packet chain=prerouting comment=-- connection-mark=STREAMING new-packet-mark=STREAMING_D passthrough=no
/ip firewall mangle add action=mark-connection chain=postrouting comment="-- DSCP 32" connection-mark=no-mark connection-state=new dscp=32 new-connection-mark=STREAMING passthrough=yes protocol=tcp
/ip firewall mangle add action=mark-connection chain=postrouting connection-mark=no-mark connection-state=new dscp=32 new-connection-mark=STREAMING passthrough=yes protocol=udp
/ip firewall mangle add action=mark-connection chain=postrouting comment="-- STREAMING Address List" connection-mark=no-mark connection-state=new dst-address-list=STREAMING new-connection-mark=STREAMING passthrough=yes protocol=tcp
/ip firewall mangle add action=mark-connection chain=postrouting comment="-- ACESTREAM" connection-mark=no-mark connection-state=new dst-port=8621 new-connection-mark=STREAMING passthrough=yes protocol=tcp
/ip firewall mangle add action=mark-connection chain=postrouting connection-mark=no-mark connection-state=new dst-port=8621 new-connection-mark=STREAMING passthrough=yes protocol=udp
/ip firewall mangle add action=mark-packet chain=postrouting comment=-- connection-mark=STREAMING new-packet-mark=STREAMING_U passthrough=no
/ip firewall mangle add action=mark-connection chain=prerouting comment=BTEST connection-mark=no-mark connection-state=new dst-port=2000 new-connection-mark=BTEST passthrough=yes protocol=udp
/ip firewall mangle add action=mark-connection chain=prerouting connection-mark=no-mark connection-state=new dst-port=2000 new-connection-mark=BTEST passthrough=yes protocol=tcp
/ip firewall mangle add action=mark-connection chain=prerouting connection-mark=no-mark connection-state=new dst-address-list=BTEST new-connection-mark=BTEST passthrough=yes
/ip firewall mangle add action=mark-packet chain=prerouting connection-mark=BTEST new-packet-mark=BTEST_D passthrough=no
/ip firewall mangle add action=mark-connection chain=postrouting connection-mark=no-mark connection-state=new dst-port=2000 new-connection-mark=BTEST passthrough=yes protocol=udp
/ip firewall mangle add action=mark-connection chain=postrouting connection-mark=no-mark connection-state=new dst-port=2000 new-connection-mark=BTEST passthrough=yes protocol=tcp
/ip firewall mangle add action=mark-connection chain=postrouting connection-mark=no-mark connection-state=new dst-address-list=BTEST new-connection-mark=BTEST passthrough=yes
/ip firewall mangle add action=mark-packet chain=postrouting connection-mark=BTEST new-packet-mark=BTEST_U passthrough=no
/ip firewall mangle add action=mark-connection chain=prerouting comment=HTTP connection-mark=no-mark connection-state=new dst-port=80,8080,443 new-connection-mark=HTTP passthrough=yes protocol=tcp
/ip firewall mangle add action=mark-connection chain=prerouting connection-bytes=10000000-0 connection-mark=HTTP new-connection-mark=LARGE_TRANSFER passthrough=yes protocol=tcp
/ip firewall mangle add action=mark-packet chain=prerouting connection-mark=LARGE_TRANSFER new-packet-mark=LARGE_TRANSFER_D passthrough=no
/ip firewall mangle add action=mark-packet chain=prerouting connection-mark=HTTP new-packet-mark=HTTP_D passthrough=no
/ip firewall mangle add action=mark-connection chain=postrouting connection-mark=no-mark connection-state=new dst-port=80,8080,443 new-connection-mark=HTTP passthrough=yes protocol=tcp
/ip firewall mangle add action=mark-connection chain=postrouting connection-bytes=10000000-0 connection-mark=HTTP new-connection-mark=LARGE_TRANSFER passthrough=yes protocol=tcp
/ip firewall mangle add action=mark-packet chain=postrouting connection-mark=LARGE_TRANSFER new-packet-mark=LARGE_TRANSFER_U passthrough=yes
/ip firewall mangle add action=mark-packet chain=postrouting connection-mark=HTTP new-packet-mark=HTTP_U passthrough=no
/ip firewall mangle add action=mark-connection chain=prerouting comment=QUIC connection-mark=no-mark connection-state=new dst-port=80,443 new-connection-mark=QUIC passthrough=yes protocol=udp
/ip firewall mangle add action=mark-connection chain=prerouting connection-bytes=10000000-0 connection-mark=QUIC new-connection-mark=LARGE_TRANSFER passthrough=yes protocol=udp
/ip firewall mangle add action=mark-packet chain=prerouting connection-mark=LARGE_TRANSFER new-packet-mark=LARGE_TRANSFER_D passthrough=no
/ip firewall mangle add action=mark-packet chain=prerouting connection-mark=QUIC new-packet-mark=QUIC_D passthrough=no
/ip firewall mangle add action=mark-connection chain=postrouting connection-mark=no-mark connection-state=new dst-port=80,443 new-connection-mark=QUIC passthrough=yes protocol=udp
/ip firewall mangle add action=mark-connection chain=postrouting connection-bytes=10000000-0 connection-mark=QUIC new-connection-mark=LARGE_TRANSFER passthrough=yes protocol=udp
/ip firewall mangle add action=mark-packet chain=postrouting connection-mark=LARGE_TRANSFER new-packet-mark=LARGE_TRANSFER_U passthrough=no
/ip firewall mangle add action=mark-packet chain=postrouting connection-mark=QUIC new-packet-mark=QUIC_U passthrough=no
/ip firewall mangle add action=mark-connection chain=input comment=VPN connection-state=new dst-port=7533 new-connection-mark=VPN passthrough=yes protocol=tcp
/ip firewall mangle add action=mark-connection chain=input connection-mark=no-mark connection-state=new dst-port=11723 new-connection-mark=VPN passthrough=yes protocol=udp
/ip firewall mangle add action=mark-packet chain=input connection-mark=VPN new-packet-mark=VPN_D passthrough=no
/ip firewall mangle add action=mark-connection chain=postrouting connection-state=new dst-port=7533 new-connection-mark=VPN passthrough=yes protocol=tcp
/ip firewall mangle add action=mark-connection chain=postrouting connection-mark=no-mark connection-state=new dst-port=11723 new-connection-mark=VPN passthrough=yes protocol=udp
/ip firewall mangle add action=mark-packet chain=postrouting connection-mark=VPN new-packet-mark=VPN_U passthrough=no
/ip firewall mangle add action=mark-connection chain=prerouting comment=SSH connection-mark=no-mark connection-state=new dst-port=22,2222,22222 new-connection-mark=SSH passthrough=yes protocol=tcp
/ip firewall mangle add action=mark-packet chain=prerouting connection-mark=SSH new-packet-mark=SSH_D passthrough=no
/ip firewall mangle add action=mark-connection chain=postrouting connection-mark=no-mark connection-state=new dst-port=22,2222,22222 new-connection-mark=SSH passthrough=yes protocol=tcp
/ip firewall mangle add action=mark-packet chain=postrouting connection-mark=SSH new-packet-mark=SSH_U passthrough=no
/ip firewall mangle add action=mark-connection chain=prerouting comment=FTP connection-mark=no-mark connection-state=new dst-port=21,2121 new-connection-mark=FTP passthrough=yes protocol=tcp
/ip firewall mangle add action=mark-connection chain=prerouting connection-bytes=10000000-0 connection-mark=FTP new-connection-mark=LARGE_TRANSFER passthrough=yes protocol=tcp
/ip firewall mangle add action=mark-packet chain=prerouting connection-mark=LARGE_TRANSFER new-packet-mark=LARGE_TRANSFER_D passthrough=no
/ip firewall mangle add action=mark-packet chain=prerouting connection-mark=FTP new-packet-mark=FTP_D passthrough=no
/ip firewall mangle add action=mark-connection chain=postrouting connection-mark=no-mark connection-state=new dst-port=21,2121 new-connection-mark=FTP passthrough=yes protocol=tcp
/ip firewall mangle add action=mark-connection chain=postrouting connection-bytes=10000000-0 connection-mark=FTP new-connection-mark=LARGE_TRANSFER passthrough=yes protocol=tcp
/ip firewall mangle add action=mark-packet chain=postrouting connection-mark=LARGE_TRANSFER new-packet-mark=LARGE_TRANSFER_U passthrough=no
/ip firewall mangle add action=mark-packet chain=postrouting connection-mark=FTP new-packet-mark=FTP_U passthrough=no
/ip firewall mangle add action=mark-connection chain=prerouting comment=P2P connection-mark=no-mark connection-state=new dst-port=18221,30410,41953,62891-62899,41238,41239,51377,53220-53320 new-connection-mark=P2P passthrough=yes protocol=tcp
/ip firewall mangle add action=mark-connection chain=prerouting connection-mark=no-mark connection-state=new dst-port=18221,30410,41953,62891-62899,33975,41238,51133,51380,53220-53320 new-connection-mark=P2P passthrough=yes protocol=udp
/ip firewall mangle add action=mark-packet chain=prerouting connection-mark=P2P new-packet-mark=P2P_D passthrough=no
/ip firewall mangle add action=mark-connection chain=postrouting connection-mark=no-mark connection-state=new dst-port=4661,4662,4667,4675,4711,7561,7571,6881-6887,28221 new-connection-mark=P2P passthrough=yes protocol=tcp
/ip firewall mangle add action=mark-connection chain=postrouting connection-state=new new-connection-mark=P2P passthrough=yes protocol=tcp src-port=18221,30410,41953,62891-62899,53220-53320
/ip firewall mangle add action=mark-connection chain=postrouting connection-mark=no-mark connection-state=new dst-port=4665,4672,6881-6887 new-connection-mark=P2P passthrough=yes protocol=udp
/ip firewall mangle add action=mark-connection chain=postrouting connection-state=new new-connection-mark=P2P passthrough=yes protocol=udp src-port=18221,30410,41953,62891-62899,53220-53320
/ip firewall mangle add action=mark-packet chain=postrouting connection-mark=P2P new-packet-mark=P2P_U passthrough=no
/ip firewall mangle add action=mark-connection chain=prerouting comment=UDP connection-mark=no-mark connection-state=new new-connection-mark=UDP passthrough=yes protocol=udp
/ip firewall mangle add action=mark-packet chain=prerouting connection-mark=UDP new-packet-mark=UDP_D passthrough=no
/ip firewall mangle add action=mark-connection chain=postrouting connection-mark=no-mark connection-state=new new-connection-mark=UDP passthrough=yes protocol=udp
/ip firewall mangle add action=mark-packet chain=postrouting connection-mark=UDP new-packet-mark=UDP_U passthrough=no
/ip firewall mangle add action=mark-connection chain=prerouting comment=ICMP connection-mark=no-mark connection-state=new new-connection-mark=ICMP passthrough=yes protocol=icmp
/ip firewall mangle add action=mark-packet chain=prerouting connection-mark=ICMP new-packet-mark=ICMP_D passthrough=no
/ip firewall mangle add action=mark-connection chain=postrouting connection-mark=no-mark connection-state=new new-connection-mark=ICMP passthrough=yes protocol=icmp
/ip firewall mangle add action=mark-packet chain=postrouting connection-mark=ICMP new-packet-mark=ICMP_U passthrough=no
/ip firewall mangle add action=mark-connection chain=prerouting comment=MAIL connection-mark=no-mark connection-state=new dst-port=143,465,587,993,995 new-connection-mark=MAIL passthrough=yes protocol=tcp
/ip firewall mangle add action=mark-packet chain=prerouting connection-mark=MAIL new-packet-mark=OTHER_D passthrough=no
/ip firewall mangle add action=mark-connection chain=postrouting connection-mark=no-mark connection-state=new dst-port=143,465,587,993,995 new-connection-mark=MAIL passthrough=yes protocol=tcp
/ip firewall mangle add action=mark-packet chain=postrouting connection-mark=MAIL new-packet-mark=OTHER_U passthrough=no
/ip firewall mangle add action=mark-connection chain=prerouting comment=OTHER connection-mark=no-mark new-connection-mark=OTHER passthrough=yes
/ip firewall mangle add action=mark-packet chain=prerouting connection-mark=OTHER new-packet-mark=OTHER_D passthrough=no
/ip firewall mangle add action=mark-connection chain=postrouting connection-mark=no-mark new-connection-mark=OTHER passthrough=yes
/ip firewall mangle add action=mark-packet chain=postrouting connection-mark=OTHER new-packet-mark=OTHER_U passthrough=no
Queue tree:
/queue type add kind=red name=red-custom red-avg-packet=1514
/queue type add kind=fq-codel name=default-fq-codel
/queue tree add max-limit=120M name=D parent=bridge queue=default-fq-codel
/queue tree add max-limit=60M name=U parent=lte1 queue=default-fq-codel
/queue tree add max-limit=120M name=1_D parent=D priority=1 queue=hotspot-default
/queue tree add limit-at=120M max-limit=120M name=1.1_D packet-mark=VOIP_D parent=1_D priority=1 queue=hotspot-default
/queue tree add limit-at=1M max-limit=120M name=1.5_D packet-mark=BTEST_D parent=1_D priority=2 queue=hotspot-default
/queue tree add limit-at=120M max-limit=120M name=1.2_D packet-mark=DNS_D parent=1_D priority=1 queue=hotspot-default
/queue tree add limit-at=120M max-limit=120M name=1.3_D packet-mark=UDP_D parent=1_D priority=1 queue=hotspot-default
/queue tree add limit-at=10M max-limit=120M name=2_D packet-mark=ACK_D parent=D priority=2 queue=hotspot-default
/queue tree add max-limit=120M name=3_D parent=D priority=3 queue=hotspot-default
/queue tree add limit-at=30M max-limit=120M name=3.1_D packet-mark=STREAMING_D parent=3_D priority=1 queue=hotspot-default
/queue tree add limit-at=1M max-limit=120M name=3.2_D packet-mark=SSH_D parent=3_D priority=2 queue=hotspot-default
/queue tree add limit-at=1M max-limit=120M name=4_D packet-mark=ICMP_D parent=D priority=4 queue=hotspot-default
/queue tree add limit-at=120M max-limit=120M name=1.4_D packet-mark=VPN_D parent=1_D priority=1 queue=hotspot-default
/queue tree add max-limit=120M name=5_D parent=D priority=5 queue=hotspot-default
/queue tree add limit-at=1M max-limit=120M name=5.1_D packet-mark=FTP_D parent=5_D priority=1 queue=hotspot-default
/queue tree add limit-at=10M max-limit=120M name=5.2_D packet-mark=HTTP_D parent=5_D priority=2 queue=hotspot-default
/queue tree add limit-at=10M max-limit=120M name=5.3_D packet-mark=QUIC_D parent=5_D priority=3 queue=hotspot-default
/queue tree add limit-at=1M max-limit=120M name=6_D packet-mark=LARGE_TRANSFER_D parent=D priority=6 queue=red-custom
/queue tree add limit-at=1M max-limit=120M name=7_D packet-mark=OTHER_D parent=D priority=7 queue=hotspot-default
/queue tree add limit-at=1M max-limit=120M name=8_D packet-mark=P2P_D parent=D queue=hotspot-default
/queue tree add max-limit=60M name=1_U parent=U priority=1 queue=hotspot-default
/queue tree add limit-at=20M max-limit=60M name=1.1_U packet-mark=VOIP_U parent=1_U priority=1 queue=hotspot-default
/queue tree add limit-at=1M max-limit=60M name=1.3_U packet-mark=BTEST_U parent=1_U priority=3 queue=hotspot-default
/queue tree add limit-at=1M max-limit=60M name=2_U packet-mark=DNS_U parent=U priority=2 queue=hotspot-default
/queue tree add max-limit=60M name=3_U parent=U priority=3 queue=hotspot-default
/queue tree add limit-at=1M max-limit=60M name=3.1_U packet-mark=ACK_U parent=3_U priority=1 queue=hotspot-default
/queue tree add limit-at=1M max-limit=60M name=3.2_U packet-mark=SSH_U parent=3_U priority=2 queue=hotspot-default
/queue tree add limit-at=10M max-limit=60M name=3.3_U packet-mark=UDP_U parent=3_U priority=3 queue=hotspot-default
/queue tree add limit-at=1M max-limit=60M name=4_U packet-mark=ICMP_U parent=U priority=4 queue=hotspot-default
/queue tree add max-limit=60M name=5_U parent=U priority=5 queue=hotspot-default
/queue tree add limit-at=1M max-limit=60M name=5.1_U packet-mark=FTP_U parent=5_U priority=1 queue=hotspot-default
/queue tree add limit-at=1M max-limit=60M name=5.2_U packet-mark=HTTP_U parent=5_U priority=2 queue=hotspot-default
/queue tree add limit-at=1M max-limit=60M name=5.3_U packet-mark=QUIC_U parent=5_U priority=3 queue=hotspot-default
/queue tree add limit-at=1M max-limit=60M name=6_U packet-mark=LARGE_TRANSFER_U parent=U priority=6 queue=red-custom
/queue tree add limit-at=1M max-limit=60M name=7_U packet-mark=OTHER_U,STREAMING_U parent=U priority=7 queue=hotspot-default
/queue tree add limit-at=1M max-limit=60M name=8_U packet-mark=P2P_U parent=U queue=hotspot-default
/queue tree add limit-at=10M max-limit=60M name=1.2_U packet-mark=VPN_U parent=1_U priority=2 queue=hotspot-default
And this how it looks like in Winbox:
winbox_queue_tree.png
You do not have the required permissions to view the files attached to this post.
 
JustAnAccount
just joined
Topic Author
Posts: 9
Joined: Mon Jun 20, 2022 4:02 pm

Re: QoS while downloading

Fri Mar 24, 2023 1:16 pm

Thank you all for the answers.
 
nahihua535
just joined
Posts: 1
Joined: Fri Mar 24, 2023 3:16 pm

Re: QoS while downloading

Fri Mar 24, 2023 3:18 pm

Do not use the Adaptive QoS however - it will treat Steam downloads as if they are a game and give maximum priority to it, making the issue even worse instead of better.
 
optio
Long time Member
Long time Member
Posts: 655
Joined: Mon Dec 26, 2022 2:57 pm

Re: QoS while downloading

Sat Apr 01, 2023 9:36 pm

...
One solution you can consider is to use Tube mate apk, ...
apk trojan?
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 11982
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: QoS while downloading

Tue Jul 04, 2023 1:30 pm

where is my post?

Maybe the new moderators are randomly making posts disappear?

I've already seen this story on Reddit (from 8 months ago), let's see who they blame this time...

Who is online

Users browsing this forum: Google [Bot] and 62 guests