Community discussions

MikroTik App
 
FosCo
just joined
Topic Author
Posts: 1
Joined: Sat Mar 25, 2023 9:18 pm

[Snippet] Update DDNS IPv4 and IPv6 on all-inkl.com

Thu Apr 06, 2023 11:46 am

Hi,

after some reading, I wrote a working script to update my DDNS at my all-inkl.com managed domain.
Maybe somebody can adapt this without long google-fu and forum search.

The WAN interface is ether8 in my case (obviously) and I only get one global IPv6, which leads to a straight forward approach:
:local ips [/ip address get [find interface="ether8"] address];
:local ip6s [/ipv6 address get [find interface="ether8" and global] address];
:local ip [:pick $ips 0 [:find $ips "/"]];
:local ip6 [:pick $ip6s 0 [:find $ip6s "/"]];
#:put "IP: $ip";
#:put "IPv6: $ip6";
tool fetch url="https://<user>:<password>@dyndns.kasserver.com/index.php?myip=$ip&myip6=$ip6" keep-result=no

Who is online

Users browsing this forum: No registered users and 15 guests