Community discussions

 
jbfavre
just joined
Topic Author
Posts: 4
Joined: Mon Mar 17, 2014 11:10 am

DHCPv6 PD not working

Mon Jan 25, 2016 9:15 am

Hello,
I got a fiber connection from my ISP (Orange, in France), on their new architecture, which provides both IPv4 (through DHCP) & IPv6 (not sure how exactly, might be prefix delegation).

I manage to replace my ISP's box (livebox) with a Mikrotik for IPv4, configuring DHCP client with relevant options (77 & 90), with commands:
    /ip dhcp-client option
    add code=77 name=userclass value=0xZZZZZZZ
    add code=90 name=authsend value=0xYYYYYYY

    /ip dhcp-client
    add interface=vlan832-orange disabled=no add-default-route=yes default-route-distance=1 use-peer-dns=yes use-peer-ntp=yes dhcp-options=hostname,clientid,authsend,userclass
Now, I'm screwed with IPv6. It seems I have to send DHCP options as well, so that I can be "authentified" on ISP side. But, as far as I can see, there's no way to send them with /ipv6 dhp-client.
I tried:
    /ipv6 dhcp-client
    add interface=vlan832-orange pool-name="IPv6-pool" pool-prefix-length=64 prefix-hint=::/0
When checking, dhcp-client is always searching.

Any idea welcome.
Regards
 
jbfavre
just joined
Topic Author
Posts: 4
Joined: Mon Mar 17, 2014 11:10 am

Re: DHCPv6 PD not working

Mon Jan 25, 2016 11:46 pm

I digged into that problem a little further.

My ISP provides IPv6 through prefix delegation.
For this to work, I need to send DHCPv6 options 11, 15 & 16 to be somewhat authenticated on the network.

What I understand for now is that Mikrotik/RouterOS does not allow options with DHCPv6 client.

Is there any place I could fill a feature request for that ?
 
Sob
Forum Guru
Forum Guru
Posts: 4041
Joined: Mon Apr 20, 2009 9:11 pm

Re: DHCPv6 PD not working

Tue Jan 26, 2016 11:34 pm

You should ask support@mikrotik.com. You can post it here (you already did), but they can miss it. And even if not, they don't comment on everything, so if you want an answer, ask them directly.
 
jbfavre
just joined
Topic Author
Posts: 4
Joined: Mon Mar 17, 2014 11:10 am

Re: DHCPv6 PD not working

Mon Feb 01, 2016 2:56 pm

Hi Sob,
Thanks for answering. I've sent an email to support.
Will update this post with their answer.

Thanks !
 
jbfavre
just joined
Topic Author
Posts: 4
Joined: Mon Mar 17, 2014 11:10 am

Re: DHCPv6 PD not working

Sun Feb 07, 2016 1:13 pm

Here is the answer from Mikrotik support:
Hello,

DHCPv6 and DHCP-PD client options are planned. If everything goes as planned
that might even land in RouterOS 6.x branch.

Regards,
Which means I'll have to be patient before getting IPv6 :)
 
fouinix
just joined
Posts: 3
Joined: Wed Feb 10, 2016 10:13 am

Re: DHCPv6 PD not working

Wed Feb 10, 2016 10:15 am

+1 I'm also interested about this feature.
 
pe1chl
Forum Guru
Forum Guru
Posts: 5192
Joined: Mon Jun 08, 2015 12:09 pm

Re: DHCPv6 PD not working

Wed Feb 10, 2016 11:54 am

It must be something specific to your provider, as I have IPv6 using DHCPv6 PD as well and it works fine here
with the current MikroTik firmware. This is on the Dutch provider XS4ALL.
/ipv6 dhcp-client
add add-default-route=yes interface=pppoe-xs4all-inet pool-name=\
    xs4all-v6prefix request=prefix
 
Florian
Frequent Visitor
Frequent Visitor
Posts: 57
Joined: Sun Mar 13, 2016 9:45 am
Location: France

Re: DHCPv6 PD not working

Sun Mar 13, 2016 9:48 am

Yes, Orange needs DHCPv6 options.

I hope we will have them soon :D
- Sorry for my english -
 
fouinix
just joined
Posts: 3
Joined: Wed Feb 10, 2016 10:13 am

Re: DHCPv6 PD not working

Sat Nov 05, 2016 5:33 pm

Do you have news?
 
Florian
Frequent Visitor
Frequent Visitor
Posts: 57
Joined: Sun Mar 13, 2016 9:45 am
Location: France

Re: DHCPv6 PD not working

Sat Nov 05, 2016 6:03 pm

If I remember correctly, they said it will be in RouterOS v7.
- Sorry for my english -
 
fouinix
just joined
Posts: 3
Joined: Wed Feb 10, 2016 10:13 am

Re: DHCPv6 PD not working

Tue Apr 25, 2017 8:16 pm

If I remember correctly, they said it will be in RouterOS v7.
I Mikrotik,

No plan to add this feature in 6.x branch?
 
k750
Frequent Visitor
Frequent Visitor
Posts: 65
Joined: Fri Feb 19, 2016 4:40 pm
Location: France / Paris

Re: DHCPv6 PD not working

Tue Apr 25, 2017 11:32 pm

Visiblement rien est encore prévu :twisted:
CCR1009-8G-1S-1S+PC - RouterOS 6.40.5

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 63 guests