Community discussions

 
PeterDoBrasil
Member Candidate
Member Candidate
Topic Author
Posts: 134
Joined: Sun Aug 23, 2015 6:55 pm

No default Channel setup for Atheros 92xx 5 Ghz

Sat Mar 12, 2016 2:17 am

# Special Channel Auto Setup for Atheros AR92xx Chips v.2 faster connect time #
{
:global mac
:global type
:global name
:global wlansetup
:foreach x in=[/interface wireless find ] do={
:set type [/interface wireless get $x interface-type ];
:if ([/interface wireless find where interface-type="Atheros AR92xx" ] = "" ) do={
:put ("ERROR, WRONG CHIP TYPE -> $type");
:log error ("ERROR, WRONG CHIP TYPE -> $type");
} else={
:if ([/interface wireless find where (scan-list~"Stage") ] = "" ) do={
/interface wireless channels
add band=5ghz-a/n extension-channel=Ce frequency=4800 list=\
"Stage 0" name="4.80 Ghz Stage 0" width=20
add band=5ghz-a/n extension-channel=Ce frequency=4810 list=\
"Stage 0" name="4.81 Ghz Stage 0" width=20
add band=5ghz-a/n extension-channel=Ce frequency=4820 list=\
"Stage 0" name="4.82 Ghz Stage 0" width=20
add band=5ghz-a/n extension-channel=Ce frequency=4830 list=\
"Stage 0" name="4.83 Ghz Stage 0" width=20
add band=5ghz-a/n extension-channel=Ce frequency=4840 list=\
"Stage 0" name="4.84 Ghz Stage 0" width=20
add band=5ghz-a/n extension-channel=Ce frequency=4850 list=\
"Stage 0" name="4.85 Ghz Stage 0" width=20
add band=5ghz-a/n extension-channel=Ce frequency=4860 list=\
"Stage 0" name="4.86 Ghz Stage 0" width=20
add band=5ghz-a/n extension-channel=Ce frequency=4870 list=\
"Stage 0" name="4.87 Ghz Stage 0" width=20
add band=5ghz-a/n extension-channel=Ce frequency=4880 list=\
"Stage 0" name="4.88 Ghz Stage 0" width=20
add band=5ghz-a/n extension-channel=Ce frequency=4890 list=\
"Stage 0" name="4.89 Ghz Stage 0" width=20
add band=5ghz-a/n extension-channel=Ce frequency=4900 list=\
"Stage 0" name="4.90 Ghz Stage 0" width=20
add band=5ghz-a/n extension-channel=Ce frequency=4910 list=\
"Stage 0" name="4.91 Ghz Stage 0" width=20
add band=5ghz-a/n extension-channel=Ce frequency=4920 list=\
"Stage 1" name="4.92 Ghz Stage 1" width=20
add band=5ghz-a/n extension-channel=Ce frequency=4930 list=\
"Stage 1" name="4.93 Ghz Stage 1" width=20
add band=5ghz-a/n extension-channel=Ce frequency=4940 list=\
"Stage 1" name="4.94 Ghz Stage 1" width=20
add band=5ghz-a/n extension-channel=Ce frequency=4950 list=\
"Stage 1" name="4.95 Ghz Stage 1" width=20
add band=5ghz-a/n extension-channel=Ce frequency=4960 list=\
"Stage 1" name="4.96 Ghz Stage 1" width=20
add band=5ghz-a/n extension-channel=Ce frequency=4970 list=\
"Stage 1" name="4.97 Ghz Stage 1" width=20
add band=5ghz-a/n extension-channel=Ce frequency=4980 list=\
"Stage 1" name="4.98 Ghz Stage 1" width=20
add band=5ghz-a/n extension-channel=Ce frequency=4990 list=\
"Stage 1" name="4.99 Ghz Stage 1" width=20
add band=5ghz-a/n extension-channel=Ce frequency=5000 list=\
"Stage 2" name="5.00 Ghz Stage 2" width=20
add band=5ghz-a/n extension-channel=Ce frequency=5010 list=\
"Stage 2" name="5.01 Ghz Stage 2" width=20
add band=5ghz-a/n extension-channel=Ce frequency=5020 list=\
"Stage 2" name="5.02 Ghz Stage 2" width=20
add band=5ghz-a/n extension-channel=Ce frequency=5030 list=\
"Stage 2" name="5.03 Ghz Stage 2" width=20
add band=5ghz-a/n extension-channel=Ce frequency=5040 list=\
"Stage 2" name="5.04 Ghz Stage 2" width=20
add band=5ghz-a/n extension-channel=Ce frequency=5050 list=\
"Stage 2" name="5.05 Ghz Stage 2" width=20
add band=5ghz-a/n extension-channel=Ce frequency=5060 list=\
"Stage 2" name="5.06 Ghz Stage 2" width=20
add band=5ghz-a/n extension-channel=Ce frequency=5070 list=\
"Stage 2" name="5.07 Ghz Stage 2" width=20
add band=5ghz-a/n extension-channel=Ce frequency=5080 list=\
"Stage 2" name="5.08 Ghz Stage 2" width=20
add band=5ghz-a/n extension-channel=Ce frequency=5090 list=\
"Stage 2" name="5.09 Ghz Stage 2" width=20
add band=5ghz-a/n extension-channel=Ce frequency=5100 list=\
"Stage 2" name="5.10 Ghz Stage 2" width=20
add band=5ghz-a/n extension-channel=Ce frequency=5110 list=\
"Stage 2" name="5.11 Ghz Stage 2" width=20
add band=5ghz-a/n extension-channel=Ce frequency=5120 list=\
"Stage 2" name="5.12 Ghz Stage 2" width=20
add band=5ghz-a/n extension-channel=Ce frequency=5130 list=\
"Stage 2" name="5.13 Ghz Stage 2" width=20
add band=5ghz-a/n extension-channel=Ce frequency=5140 list=\
"Stage 2" name="5.14 Ghz Stage 2" width=20
add band=5ghz-a/n extension-channel=Ce frequency=5150 list=\
"Stage 2" name="5.15 Ghz Stage 2" width=20
add band=5ghz-a/n extension-channel=Ce frequency=5850 list=\
"Stage 3" name="5.85 Ghz Stage 3" width=20
add band=5ghz-a/n extension-channel=Ce frequency=5860 list=\
"Stage 3" name="5.86 Ghz Stage 3" width=20
add band=5ghz-a/n extension-channel=Ce frequency=5870 list=\
"Stage 3" name="5.87 Ghz Stage 3" width=20
add band=5ghz-a/n extension-channel=Ce frequency=5880 list=\
"Stage 3" name="5.88 Ghz Stage 3" width=20
add band=5ghz-a/n extension-channel=Ce frequency=5890 list=\
"Stage 3" name="5.89 Ghz Stage 3" width=20
add band=5ghz-a/n extension-channel=Ce frequency=5900 list=\
"Stage 3" name="5.90 Ghz Stage 3" width=20
add band=5ghz-a/n extension-channel=Ce frequency=5910 list=\
"Stage 3" name="5.91 Ghz Stage 3" width=20
add band=5ghz-a/n extension-channel=Ce frequency=5920 list=\
"Stage 3" name="5.92 Ghz Stage 3" width=20
add band=5ghz-a/n extension-channel=Ce frequency=5930 list=\
"Stage 3" name="5.93 Ghz Stage 3" width=20
add band=5ghz-a/n extension-channel=Ce frequency=5940 list=\
"Stage 3" name="5.94 Ghz Stage 3" width=20
add band=5ghz-a/n extension-channel=Ce frequency=5950 list=\
"Stage 3" name="5.95 Ghz Stage 3" width=20
add band=5ghz-a/n extension-channel=Ce frequency=5960 list=\
"Stage 3" name="5.96 Ghz Stage 3" width=20
add band=5ghz-a/n extension-channel=Ce frequency=5970 list=\
"Stage 3" name="5.97 Ghz Stage 3" width=20
add band=5ghz-a/n extension-channel=Ce frequency=5980 list=\
"Stage 3" name="5.98 Ghz Stage 3" width=20
add band=5ghz-a/n extension-channel=Ce frequency=5990 list=\
"Stage 3" name="5.99 Ghz Stage 3" width=20
add band=5ghz-a/n extension-channel=Ce frequency=6000 list=\
"Stage 4" name="6.00 Ghz Stage 4" width=20
add band=5ghz-a/n extension-channel=Ce frequency=6010 list=\
"Stage 4" name="6.01 Ghz Stage 4" width=20
add band=5ghz-a/n extension-channel=Ce frequency=6020 list=\
"Stage 4" name="6.02 Ghz Stage 4" width=20
add band=5ghz-a/n extension-channel=Ce frequency=6030 list=\
"Stage 4" name="6.03 Ghz Stage 4" width=20
add band=5ghz-a/n extension-channel=Ce frequency=6040 list=\
"Stage 4" name="6.04 Ghz Stage 4" width=20
add band=5ghz-a/n extension-channel=Ce frequency=6050 list=\
"Stage 4" name="6.05 Ghz Stage 4" width=20
add band=5ghz-a/n extension-channel=Ce frequency=6060 list=\
"Stage 4" name="6.06 Ghz Stage 4" width=20
add band=5ghz-a/n extension-channel=Ce frequency=6070 list=\
"Stage 4" name="6.07 Ghz Stage 4" width=20
add band=5ghz-a/n extension-channel=Ce frequency=6080 list=\
"Stage 4" name="6.08 Ghz Stage 4" width=20
:set mac [/interface wireless get $x mac-address ];
:set name [/interface wireless get $x name ];
:set wlansetup [/interface wireless set [ find where mac-address=$mac ] band="5ghz-a/n" channel-width="20/40mhz-Ce" frequency="4.92 Ghz" \
scan-list="Stage 1" frequency-mode="superchannel" country="no_country_set" ];
:put ("SETUP COMPLETE $name with Mac $mac");
:log warning ("SETUP COMPLETE $name with Mac $mac");
} else={
:set mac [/interface wireless get $x mac-address ];
:set name [/interface wireless get $x name ];
:put ("Advanced Setup for Mac->$mac and Name->$name already exist !!!");
:log warning ("Advanced Setup for Mac->$mac and Name->$name already exist !!!");
}}}}
 
omar731993
just joined
Posts: 1
Joined: Sat Dec 08, 2018 5:56 am

Re: No default Channel setup for Atheros 92xx 5 Ghz

Sat Dec 08, 2018 6:00 am

hi sir
how can i do the same thing (adding extra band ) for my rb912

Who is online

Users browsing this forum: No registered users and 8 guests