Community discussions

MikroTik App
 
Bishop
just joined
Topic Author
Posts: 19
Joined: Thu Aug 21, 2008 3:40 pm

ipv6 and PPtP

Thu Mar 24, 2016 10:05 am

Hello , help solve the problem . Not binding ipv6 addr on pptp client.


My Example:

(PPtP Server) [Mikrotik] <------- PPtP --------- [Windows 7 Host ] (PPtP Client)

Task: Bind real ipv6 address for the client from pool.

My config:
Pool:
/ipv6 pool add name=IPv6-Pool prefix=2002:c311:11bb:2::/64 prefix-length=80
--
Profile:
/ppp profile add dhcpv6-pd-pool=IPv6-Pool local-address=10.100.100.1 name=MyProfile-ipv6 remote-ipv6-prefix-pool=IPv6-Pool use-encryption=yes
--
/ppp secret add name=tester password=test profile=MyProfile-ipv6 service=pptp

After connection:
/ipv6 dhcp-server  print 
Flags: D - dynamic, X - disabled, I - invalid 
 #    NAME                        INTERFACE                        ADDRESS-POOL                        PREFERENCE LEASE-TIME
 0 D  <pptp-tester>               <pptp-tester>                    IPv6-Pool                                  255 3d       
 
 /ipv6 pool used print 
POOL                              PREFIX                                      OWNER                              INFO                             
IPv6-Pool                         2002:c311:11bb:2::/80                       PPTP<195.19.1.207>               tester 
But:
 ipv6 dhcp-server binding print 
Flags: X - disabled, D - dynamic 
 #   ADDRESS                                                               DUID                           SERVER                           STATUS
 
Windows Client settings.
s1.png
s3.png
s4.png
You do not have the required permissions to view the files attached to this post.
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: ipv6 and PPtP

Thu Mar 24, 2016 10:52 am

first, if your clients are end user hosts, you do not need to set up pool for PD.
 
Bishop
just joined
Topic Author
Posts: 19
Joined: Thu Aug 21, 2008 3:40 pm

Re: ipv6 and PPtP

Thu Mar 24, 2016 11:09 am

first, if your clients are end user hosts, you do not need to set up pool for PD.
Sorry, i will correct scheme.

(PPtP Server) [Mikrotik] <-------( Internet )--------- [Windows 7 Host ] (PPtP Client)
If "not need to set up pool for PD" as client will then get the address ?
Such a scheme will work?
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: ipv6 and PPtP

Thu Mar 24, 2016 12:36 pm

also, what you see in the logs?
 
Bishop
just joined
Topic Author
Posts: 19
Joined: Thu Aug 21, 2008 3:40 pm

Re: ipv6 and PPtP

Thu Mar 24, 2016 3:04 pm

No Error!
15:49:19 pptp,info TCP connection established from 19.19.16.207 
15:49:19 pptp,info PPP: TCP connection established from 19.19.16.207 
15:49:19 pptp,debug,packet PPP: rcvd Start-Control-Connection-Request from 19.19.16.207 
15:49:19 pptp,debug,packet PPP:     protocol-version=0x0100 
15:49:19 pptp,debug,packet PPP:     framing-capabilities=1 
15:49:19 pptp,debug,packet PPP:     bearer-capabilities=1 
15:49:19 pptp,debug,packet PPP:     maximum-channels=0 
15:49:19 pptp,debug,packet PPP:     firmware-revision=0 
15:49:19 pptp,debug,packet PPP:     host-name= 
15:49:19 pptp,debug,packet PPP:     vendor-name=Microsoft 
15:49:19 pptp,debug,packet PPP: sent Start-Control-Connection-Reply to 19.19.16.207 
15:49:19 pptp,debug,packet PPP:     protocol-version=0x0100 
15:49:19 pptp,debug,packet PPP:     result-code=1 
15:49:19 pptp,debug,packet PPP:     error-code=0 
15:49:19 pptp,debug,packet PPP:     framing-capabilities=2 
15:49:19 pptp,debug,packet PPP:     bearer-capabilities=0 
15:49:19 pptp,debug,packet PPP:     maximum-channels=0 
15:49:19 pptp,debug,packet PPP:     firmware-revision=1 
15:49:19 pptp,debug,packet PPP:     host-name=MikroTik 
15:49:19 pptp,debug,packet PPP:     vendor-name=MikroTik 
15:49:19 pptp,debug,packet PPP: rcvd Outgoing-Call-Request from 19.19.16.207 
15:49:19 pptp,debug,packet PPP:     call-id=39186 
15:49:19 pptp,debug,packet PPP:     call-serial-number=30 
15:49:19 pptp,debug,packet PPP:     minimum-bps=300 
15:49:19 pptp,debug,packet PPP:     maximum-bps=100000000 
15:49:19 pptp,debug,packet PPP:     bearer-type=3 
15:49:19 pptp,debug,packet PPP:     framing-type=3 
15:49:19 pptp,debug,packet PPP:     packet-recv-window-size=64 
15:49:19 pptp,debug,packet PPP:     packet-processing-delay=0 
15:49:19 pptp,debug,packet PPP:     phone-number-length=0 
15:49:19 pptp,debug,packet PPP:     phone-number= 
15:49:19 pptp,debug,packet PPP:     subaddress= 
15:49:19 pptp,ppp,debug PPP: <48>: LCP lowerup 
15:49:19 pptp,ppp,debug PPP: <48>: LCP open 
15:49:19 pptp,debug,packet PPP: sent Outgoing-Call-Reply to 19.19.16.207 
15:49:19 pptp,debug,packet PPP:     call-id=48 
15:49:19 pptp,debug,packet PPP:     peers-call-id=39186 
15:49:19 pptp,debug,packet PPP:     result-code=1 
15:49:19 pptp,debug,packet PPP:     error-code=0 
15:49:19 pptp,debug,packet PPP:     cause-code=0 
15:49:19 pptp,debug,packet PPP:     connect-speed=100000 
15:49:19 pptp,debug,packet PPP:     packet-recv-window-size=100 
15:49:19 pptp,debug,packet PPP:     packet-processing-delay=0 
15:49:19 pptp,debug,packet PPP:     physical-channel-id=0 
15:49:19 pptp,debug,packet PPP: rcvd Set-Link-Info from 19.19.16.207 
15:49:19 pptp,debug,packet PPP:     peers-call-id=48 
15:49:19 pptp,debug,packet PPP:     send-accm=0xffffffff 
15:49:19 pptp,debug,packet PPP:     receive-accm=0xffffffff 
15:49:19 pptp,debug,packet PPP: sent Set-Link-Info to 19.19.16.207 
15:49:19 pptp,debug,packet PPP:     peers-call-id=39186 
15:49:19 pptp,debug,packet PPP:     send-accm=0xffffffff 
15:49:19 pptp,debug,packet PPP:     receive-accm=0xffffffff 
15:49:19 pptp,ppp,debug,packet PPP:  <48>: rcvd LCP ConfReq id=0x0 
15:49:19 pptp,ppp,debug,packet PPP:    <mru 1400> 
15:49:19 pptp,ppp,debug,packet PPP:    <magic 0x5afd0118> 
15:49:19 pptp,ppp,debug,packet PPP:    <pcomp> 
15:49:19 pptp,ppp,debug,packet PPP:    <accomp> 
15:49:19 pptp,ppp,debug,packet PPP:    <callback 0x06> 
15:49:19 pptp,ppp,debug,packet PPP:  <48>: sent LCP ConfReq id=0x1 
15:49:19 pptp,ppp,debug,packet PPP:    <mru 1280> 
15:49:19 pptp,ppp,debug,packet PPP:    <magic 0x68f3ca83> 
15:49:19 pptp,ppp,debug,packet PPP:    <auth  mschap2> 
15:49:19 pptp,ppp,debug,packet PPP:    <mrru 1600> 
15:49:19 pptp,ppp,debug,packet PPP:  <48>: sent LCP ConfRej id=0x0 
15:49:19 pptp,ppp,debug,packet PPP:    <pcomp> 
15:49:19 pptp,ppp,debug,packet PPP:    <accomp> 
15:49:19 pptp,ppp,debug,packet PPP:  <48>: rcvd LCP ConfRej id=0x1 
15:49:19 pptp,ppp,debug,packet PPP:    <mrru 1600> 
15:49:19 pptp,ppp,debug,packet PPP:  <48>: sent LCP ConfReq id=0x2 
15:49:19 pptp,ppp,debug,packet PPP:    <mru 1280> 
15:49:19 pptp,ppp,debug,packet PPP:    <magic 0x68f3ca83> 
15:49:19 pptp,ppp,debug,packet PPP:    <auth  mschap2> 
15:49:19 pptp,ppp,debug,packet PPP:  <48>: rcvd LCP ConfReq id=0x1 
15:49:19 pptp,ppp,debug,packet PPP:    <mru 1400> 
15:49:19 pptp,ppp,debug,packet PPP:    <magic 0x5afd0118> 
15:49:19 pptp,ppp,debug,packet PPP:    <callback 0x06> 
15:49:19 pptp,ppp,debug,packet PPP:  <48>: sent LCP ConfAck id=0x1 
15:49:19 pptp,ppp,debug,packet PPP:    <mru 1400> 
15:49:19 pptp,ppp,debug,packet PPP:    <magic 0x5afd0118> 
15:49:19 pptp,ppp,debug,packet PPP:    <callback 0x06> 
15:49:19 pptp,ppp,debug,packet PPP:  <48>: rcvd LCP ConfAck id=0x2 
15:49:19 pptp,ppp,debug,packet PPP:    <mru 1280> 
15:49:19 pptp,ppp,debug,packet PPP:    <magic 0x68f3ca83> 
15:49:19 pptp,ppp,debug,packet PPP:    <auth  mschap2> 
15:49:19 pptp,ppp,debug,packet PPP:    <magic 0x5afd0118> 
15:49:19 pptp,ppp,debug,packet PPP:    <callback 0x06> 
15:49:19 pptp,ppp,debug,packet PPP:  <48>: rcvd LCP ConfAck id=0x2 
15:49:19 pptp,ppp,debug,packet PPP:    <mru 1280> 
15:49:19 pptp,ppp,debug,packet PPP:    <magic 0x68f3ca83> 
15:49:19 pptp,ppp,debug,packet PPP:    <auth  mschap2> 
15:49:19 pptp,ppp,debug PPP: <48>: LCP opened 
15:49:19 pptp,ppp,debug,packet PPP:  <48>: sent CHAP Challenge id=0x1 
15:49:19 pptp,ppp,debug,packet PPP:     <challenge len=16> 
15:49:19 pptp,ppp,debug,packet PPP:     <name MikroTik> 
15:49:19 pptp,ppp,debug,packet PPP:  <48>: rcvd LCP Ident id=0x2 
15:49:19 pptp,ppp,debug,packet PPP:     <magic 0x5afd0118> 
15:49:19 pptp,ppp,debug,packet PPP:     MSRASV5.20 
15:49:19 pptp,ppp,debug,packet PPP:  <48>: rcvd LCP Ident id=0x3 
15:49:19 pptp,ppp,debug,packet PPP:     <magic 0x5afd0118> 
15:49:19 pptp,ppp,debug,packet PPP:     MSRAS-0-BISHOP-\8F\8A 
15:49:19 pptp,debug,packet PPP: rcvd Set-Link-Info from 19.19.16.207 
15:49:19 pptp,debug,packet PPP:     peers-call-id=48 
15:49:19 pptp,debug,packet PPP:     send-accm=0xffffffff 
15:49:19 pptp,debug,packet PPP:     receive-accm=0xffffffff 
15:49:19 pptp,debug,packet PPP: sent Set-Link-Info to 19.19.16.207 
15:49:19 pptp,debug,packet PPP:     peers-call-id=39186 
15:49:19 pptp,debug,packet PPP:     send-accm=0xffffffff 
15:49:19 pptp,debug,packet PPP:     receive-accm=0xffffffff 
15:49:19 pptp,ppp,debug,packet PPP:  <48>: rcvd LCP Ident id=0x4 
15:49:19 pptp,ppp,debug,packet PPP:     <magic 0x5afd0118> 
15:49:19 pptp,ppp,debug,packet PPP:     \C3\A8\F85\C6\82\E6I\AA\0B\E9hZ.\B4w 
15:49:19 pptp,ppp,debug,packet PPP:  <48>: rcvd CHAP Response id=0x1 
15:49:19 pptp,ppp,debug,packet PPP:     <response len=49> 
15:49:19 pptp,ppp,debug,packet PPP:     <name tester> 
15:49:19 pptp,ppp,info,account tester logged in, 0.0.0.0 
15:49:19 pptp,ppp,info,account PPP: tester logged in, 0.0.0.0 
15:49:19 pptp,ppp,debug,packet PPP:  <48>: sent CHAP Success id=0x1 
15:49:19 pptp,ppp,debug,packet PPP:     S=F3A3FFAF50D205E4B2618CA5E7234BF8C67DA9F1 
15:49:19 pptp,ppp,debug,packet PPP:  <48>: sent CBCP CallbackReq id=0x0 
15:49:19 pptp,ppp,debug,packet PPP:      01 02 
15:49:19 pptp,ppp,debug,packet PPP:  <48>: rcvd CBCP CallbackResp id=0x0 
15:49:19 pptp,ppp,debug,packet PPP:      01 02 
15:49:19 pptp,ppp,debug,packet PPP:  <48>: sent CBCP CallbackAck id=0x1 
15:49:19 pptp,ppp,debug,packet PPP:      01 02 
15:49:19 pptp,ppp,info <pptp-tester>: authenticated 
15:49:19 pptp,ppp,info PPP: <pptp-tester>: authenticated 
15:49:19 pptp,ppp,debug PPP: <48>: IPCP lowerup 
15:49:19 pptp,ppp,debug PPP: <48>: IPCP open 
15:49:19 pptp,ppp,debug,packet PPP:  <48>: sent IPCP ConfReq id=0x1 
15:49:19 pptp,ppp,debug,packet PPP:     <addr 10.100.100.1> 
15:49:19 pptp,ppp,debug PPP: <48>: IPV6CP lowerup 
15:49:19 pptp,ppp,debug PPP: <48>: IPV6CP open 
15:49:19 pptp,ppp,debug,packet PPP:  <48>: sent IPV6CP ConfReq id=0x1 
15:49:19 pptp,ppp,debug,packet PPP:     <interface-identifier 0:0:f0:30> 
15:49:19 pptp,ppp,debug PPP: <48>: MPLSCP lowerup 
15:49:19 pptp,ppp,debug PPP: <48>: MPLSCP open 
15:49:19 pptp,ppp,debug,packet PPP:  <48>: sent MPLSCP ConfReq id=0x1 
15:49:19 pptp,ppp,debug PPP: <48>: BCP open 
15:49:19 pptp,ppp,debug PPP: <48>: CCP lowerup 
15:49:19 pptp,ppp,debug PPP: <48>: CCP open 
15:49:19 pptp,ppp,debug,packet PPP:  <48>: sent CCP ConfReq id=0x1 
15:49:19 pptp,ppp,debug,packet PPP:     <mppe 1000040> 
15:49:19 pptp,ppp,debug,packet PPP:  <48>: rcvd IPV6CP ConfReq id=0x5 
15:49:19 pptp,ppp,debug,packet PPP:     <interface-identifier dc18:5864:d56c:64c7> 
15:49:19 pptp,ppp,debug,packet PPP:  <48>: sent IPV6CP ConfAck id=0x5 
15:49:19 pptp,ppp,debug,packet PPP:     <interface-identifier dc18:5864:d56c:64c7> 
15:49:19 pptp,ppp,debug,packet PPP:  <48>: rcvd CCP ConfReq id=0x6 
15:49:19 pptp,ppp,debug,packet PPP:     <mppe 1000040> 
15:49:19 pptp,ppp,debug,packet PPP:  <48>: sent CCP ConfAck id=0x6 
15:49:19 pptp,ppp,debug,packet PPP:     <mppe 1000040> 
15:49:19 pptp,ppp,debug,packet PPP:  <48>: rcvd LCP ProtRej id=0x7 
15:49:19 pptp,ppp,debug,packet PPP:      80 21 01 01 00 0a 03 06 0a 64 64 01 
15:49:19 pptp,ppp,debug PPP: <48>: IPCP lowerdown 
15:49:19 pptp,ppp,debug,packet PPP:  <48>: rcvd IPV6CP ConfAck id=0x1 
15:49:19 pptp,ppp,debug,packet PPP:     <interface-identifier 0:0:f0:30> 
15:49:19 pptp,ppp,debug PPP: <48>: IPV6CP opened 
15:49:19 pptp,ppp,info <pptp-tester>: connected 
15:49:19 pptp,ppp,info PPP: <pptp-tester>: connected 
15:49:19 pptp,ppp,debug,packet PPP:  <48>: rcvd LCP ProtRej id=0x8 
15:49:19 pptp,ppp,debug,packet PPP:      82 81 01 01 00 04 
15:49:19 pptp,ppp,debug,packet PPP:  <48>: rcvd CCP ConfAck id=0x1 
15:49:19 pptp,ppp,debug,packet PPP:     <mppe 1000040> 
15:49:19 pptp,ppp,debug PPP: <48>: CCP opened 
15:49:19 pptp,ppp,info <pptp-tester>: using encoding - MPPE128 stateless 
15:49:19 pptp,ppp,info PPP: <pptp-tester>: using encoding - MPPE128 stateless 
15:49:39 pptp,debug,packet PPP: rcvd Set-Link-Info from 19.19.16.207 
15:49:39 pptp,debug,packet PPP:     peers-call-id=48 
15:49:39 pptp,debug,packet PPP:     send-accm=0xffffffff 
15:49:39 pptp,debug,packet PPP:     receive-accm=0xffffffff 
15:49:39 pptp,debug,packet PPP: sent Set-Link-Info to 19.19.16.207 
15:49:39 pptp,debug,packet PPP:     peers-call-id=39186 
15:49:39 pptp,debug,packet PPP:     send-accm=0xffffffff 
15:49:39 pptp,debug,packet PPP:     receive-accm=0xffffffff 
15:49:39 pptp,ppp,debug,packet PPP:  <48>: rcvd LCP TermReq id=0x9 
15:49:39 pptp,ppp,debug,packet PPP:     Z\FD\01\18\00<\CDt\00\00\00\00 
15:49:39 pptp,ppp,debug PPP: <48>: LCP closed 
15:49:39 pptp,ppp,debug PPP: <48>: CCP lowerdown 
15:49:39 pptp,ppp,debug PPP: <48>: CCP closed 
15:49:39 pptp,ppp,debug PPP: <48>: BCP lowerdown 
15:49:39 pptp,ppp,debug PPP: <48>: BCP down event in starting state 
15:49:39 pptp,ppp,debug PPP: <48>: IPCP lowerdown 
15:49:39 pptp,ppp,debug PPP: <48>: IPCP down event in starting state 
15:49:39 pptp,ppp,debug PPP: <48>: IPV6CP lowerdown 
15:49:39 pptp,ppp,debug PPP: <48>: IPV6CP closed 
15:49:39 pptp,ppp,debug PPP: <48>: MPLSCP lowerdown 
15:49:39 pptp,ppp,debug,packet PPP:  <48>: sent LCP TermAck id=0x9 
15:49:39 pptp,ppp,debug PPP: <48>: LCP lowerdown 
15:49:39 pptp,ppp,info <pptp-tester>: terminating... 
15:49:39 pptp,ppp,info PPP: <pptp-tester>: terminating... 
15:49:39 pptp,ppp,debug PPP: <48>: LCP lowerdown 
15:49:39 pptp,ppp,debug PPP: <48>: LCP down event in starting state 
15:49:39 pptp,ppp,info,account tester logged out, 20 5791 682 30 12 
15:49:39 pptp,ppp,info,account PPP: tester logged out, 20 5791 682 30 12 
15:49:39 pptp,ppp,info <pptp-tester>: disconnected 
15:49:39 pptp,ppp,info PPP: <pptp-tester>: disconnected 

Who is online

Users browsing this forum: Bing [Bot] and 74 guests