Community discussions

MUM Europe 2020
 
Soli98
just joined
Topic Author
Posts: 4
Joined: Fri Jun 10, 2016 6:29 am

How to set my Huawei E3372 LTE Dongle to work?

Fri Jun 10, 2016 6:35 am

Hello,
Let me say this first: I'm thoroughly noob.
I've gone through a lot of topics that are related to problems with 3G of 4G modems; but they're just "Problems".
I just need a complete walkthrough to help me set this LTE modem up and use it.
My dongle is a Huawei E3372 4G modem and I'm using an RB951Ui.
Thanks for your replies.
Last edited by Soli98 on Fri Jun 10, 2016 8:27 pm, edited 1 time in total.
 
pe1chl
Forum Guru
Forum Guru
Posts: 5977
Joined: Mon Jun 08, 2015 12:09 pm

Re: How to set my Huawei E3372 LTE Dongle to work?

Fri Jun 10, 2016 10:14 am

Have you updated the RouterOS to 6.35.2 ?
Do you see the lte1 interface in the interfaces list?
 
irghost
Member Candidate
Member Candidate
Posts: 282
Joined: Sun Feb 21, 2016 1:49 pm

Re: How to set my Huawei E3372 LTE Dongle to work?

Fri Jun 10, 2016 1:33 pm

update your modem firmware to hilink mode and just plug it you will see lte1 interface (if not reboot ur rb951) then u just need to add dhcp-client for lte1 interface and NAT your network
MTCNA MTCRE MTCTCE MTCUME MTCWE MTCIPv6E MTCINE
 
pe1chl
Forum Guru
Forum Guru
Posts: 5977
Joined: Mon Jun 08, 2015 12:09 pm

Re: How to set my Huawei E3372 LTE Dongle to work?

Fri Jun 10, 2016 2:11 pm

When the modem has no hilink firmware I would recommend not to change that, as the other
firmware has the advantage that you will not be behind another NAT.
I have hilink firmware but I would prefer the other, however it is too complicated to change it.
 
Soli98
just joined
Topic Author
Posts: 4
Joined: Fri Jun 10, 2016 6:29 am

Re: How to set my Huawei E3372 LTE Dongle to work?

Fri Jun 10, 2016 8:20 pm

Have you updated the RouterOS to 6.35.2 ?
Do you see the lte1 interface in the interfaces list?
Yes, the version is 6.35.2.
Yes again. The lte1 appears in the interfaces list.
What's next?
 
Soli98
just joined
Topic Author
Posts: 4
Joined: Fri Jun 10, 2016 6:29 am

Re: How to set my Huawei E3372 LTE Dongle to work?

Fri Jun 10, 2016 8:24 pm

update your modem firmware to hilink mode and just plug it you will see lte1 interface (if not reboot ur rb951) then u just need to add dhcp-client for lte1 interface and NAT your network
I have tried this method and it works; but seems not to be a proper solution.
I just feel that there is a lot of unstability in terms of connection speed rather than connecting the dongle directly to my pc/laptop. Any ideas?
 
pe1chl
Forum Guru
Forum Guru
Posts: 5977
Joined: Mon Jun 08, 2015 12:09 pm

Re: How to set my Huawei E3372 LTE Dongle to work?

Mon Jun 13, 2016 2:12 pm

When you have the lte1 interface you should add a DHCP client to that interface.
Then it should all work.
 
irghost
Member Candidate
Member Candidate
Posts: 282
Joined: Sun Feb 21, 2016 1:49 pm

Re: How to set my Huawei E3372 LTE Dongle to work?

Tue Jun 14, 2016 7:21 pm

update your modem firmware to hilink mode and just plug it you will see lte1 interface (if not reboot ur rb951) then u just need to add dhcp-client for lte1 interface and NAT your network
I have tried this method and it works; but seems not to be a proper solution.
I just feel that there is a lot of unstability in terms of connection speed rather than connecting the dongle directly to my pc/laptop. Any ideas?
Cuz RB951 USB does not have enough Power for this modem ( i have same problem  that lte1 interface disappear when i start download ) so you must use USB Powered HUB  or use RB2011
MTCNA MTCRE MTCTCE MTCUME MTCWE MTCIPv6E MTCINE
 
Soli98
just joined
Topic Author
Posts: 4
Joined: Fri Jun 10, 2016 6:29 am

Re: How to set my Huawei E3372 LTE Dongle to work?

Sun Jul 24, 2016 3:12 pm

update your modem firmware to hilink mode and just plug it you will see lte1 interface (if not reboot ur rb951) then u just need to add dhcp-client for lte1 interface and NAT your network
I have tried this method and it works; but seems not to be a proper solution.
I just feel that there is a lot of unstability in terms of connection speed rather than connecting the dongle directly to my pc/laptop. Any ideas?
Cuz RB951 USB does not have enough Power for this modem ( i have same problem  that lte1 interface disappear when i start download ) so you must use USB Powered HUB  or use RB2011
Yes! That's exactly my problem. The modem seems to disconnect after some time and it won't reconnect again until I replug it in or reboot the routerboard.
What usb hub model do you suggest? The problem is WAY annoying :(

Who is online

Users browsing this forum: No registered users and 37 guests