Community discussions

 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 278
Joined: Thu Dec 11, 2014 8:53 am

v6.36.3 [current] is released!

Tue Sep 06, 2016 1:14 pm

To upgrade, click "Check for updates" at /system package in your RouterOS configuration interface, or head to our download page: http://www.mikrotik.com/download

What's new in 6.36.3 (2016-Sep-05 08:09):

*) arp - fixed crash that caused Ethernet frames to go out via wrong interface;
*) fastpath - fixed kernel crash on interface disable/remove;
*) fetch - fixed bug with incomplete files in https mode;
*) ipsec - don't log authtype mismatch as critical;
*) ipsec - fixed xauth parameter printing in terminal;
*) pppoe - fixed kernel crash caused by dial-on-demand when used with fastpath;
*) pppoe - fixed master interface l2mtu check, could result in assumption that master interface can handle 14 byte bigger packet than it actually can (broken in 6.36);
*) simple queues - fixed issue which caused additional/unnecessary CPU load;
*) vlan - do not allow to add new vlan interface with mtu higher than l2mtu;
*) tile - fixed rare kernel crash when usb device is being attached;

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1794
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: v6.36.3 [current] is released!

Tue Sep 06, 2016 2:19 pm

Great work.

I'm hoping to see 6.36.x in bugfix soon :)
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
pe1chl
Forum Guru
Forum Guru
Posts: 4865
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.36.3 [current] is released!

Tue Sep 06, 2016 2:35 pm

Great work.

I'm hoping to see 6.36.x in bugfix soon :)
I surely hope not!
Put 6.35.4 in bugfix while 6.36 is new in stable.
 
User avatar
hknet
Frequent Visitor
Frequent Visitor
Posts: 86
Joined: Sun Jul 17, 2016 6:05 pm
Location: Vienna, Austria
Contact:

Re: v6.36.3 [current] is released!

Tue Sep 06, 2016 4:17 pm

Hi
it seems the dude client is missing for now?

Regards
hk
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Posts: 879
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: v6.36.3 [current] is released!

Tue Sep 06, 2016 5:50 pm

Re: *) arp - fixed crash that caused Ethernet frames to go out via wrong interface;

Would somebody please enlighten me on the ramifications of ARP issue?

Is this a serious problem or a sometimes-a-problem?
I would like to understand more about the ARP crash prior to upgrading.

North Idaho Tom Jones
 
Beone
Member Candidate
Member Candidate
Posts: 236
Joined: Fri Feb 11, 2011 1:11 pm

Re: v6.36.3 [current] is released!

Wed Sep 07, 2016 10:02 am

We are still on 6.34.6 as 6.35 and 6.36 broke our routing-marks for multi-wan setups...

Is this issue fixed again?
 
pe1chl
Forum Guru
Forum Guru
Posts: 4865
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.36.3 [current] is released!

Wed Sep 07, 2016 11:40 am

We are still on 6.34.6 as 6.35 and 6.36 broke our routing-marks for multi-wan setups...

Is this issue fixed again?
Can't you fix that by turning off fastpath?
 
Rudios
Forum Veteran
Forum Veteran
Posts: 966
Joined: Mon Mar 11, 2013 12:58 pm
Location: The Netherlands

Re: v6.36.3 [current] is released!

Wed Sep 07, 2016 12:45 pm

We are still on 6.34.6 as 6.35 and 6.36 broke our routing-marks for multi-wan setups...

Is this issue fixed again?
Can't you fix that by turning off fastpath?
I have a setup running with a 4-WAN config and did not experience any problems while running 6.36
My test-setup is running 6.36.2 and also there no problems.
I did not change any IP settings from their defaults, only added mangle and nat rules.
No firewall filter rules are in place, does that make a difference
Testing setup with: 2 x RB750UP | 2 x RB750GL | 1 x RB951G-2HnD | 1 x RB2011UiAS-IN
 
opteron
just joined
Posts: 3
Joined: Tue Sep 06, 2016 4:36 pm

Re: v6.36.3 [current] is released!

Wed Sep 07, 2016 2:19 pm

Hi guys,

I still miss Hardware Support for Supermicro SYS-5018A-MLTN4 with C2000 SoC I354 Quad GbE controllers (MACs)....
Please let me know if there is any Change in the next Releases.

Thx
Steve
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1688
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: v6.36.3 [current] is released!

Wed Sep 07, 2016 3:36 pm

Hi guys,

I still miss Hardware Support for Supermicro SYS-5018A-MLTN4 with C2000 SoC I354 Quad GbE controllers (MACs)....
Please let me know if there is any Change in the next Releases.

Thx
Steve
AFAIK you will have to wait till RouterOS v7, all newest drivers require newest linux kernel.
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 278
Joined: Thu Dec 11, 2014 8:53 am

Re: v6.36.3 [current] is released!

Wed Sep 07, 2016 3:53 pm

We are still on 6.34.6 as 6.35 and 6.36 broke our routing-marks for multi-wan setups...

Is this issue fixed again?
If disabling FastTrack does not resolve this issue, please send supout.rif file to support@mikrotik.com
 
opteron
just joined
Posts: 3
Joined: Tue Sep 06, 2016 4:36 pm

Re: v6.36.3 [current] is released!

Wed Sep 07, 2016 4:00 pm

...ANY IDEAS WHEN ???.....i wait now more than 1 year.... :( :? .!!!.....

Hi guys,

I still miss Hardware Support for Supermicro SYS-5018A-MLTN4 with C2000 SoC I354 Quad GbE controllers (MACs)....
Please let me know if there is any Change in the next Releases.

Thx
Steve
AFAIK you will have to wait till RouterOS v7, all newest drivers require newest linux kernel.
 
Beone
Member Candidate
Member Candidate
Posts: 236
Joined: Fri Feb 11, 2011 1:11 pm

Re: v6.36.3 [current] is released!

Wed Sep 07, 2016 8:40 pm

@emils

We never used fasttrack in our configurations, only fastpaths stuff...

The problem we had was ip routes with marking becoming unavailable after awhile (status goes not active anymore) even though the actual route and gateway was reachable outside the marking
 
elgrandiegote
newbie
Posts: 38
Joined: Tue Feb 05, 2013 6:02 am
Location: Buenos Aires, Argentina

Re: v6.36.3 [current] is released!

Thu Sep 08, 2016 12:01 am

I tried it in version v6.36.3 and feel the same, I copy it posted in the thread version v6.36.2
He added that after a few hours the 100% cpu and low memory after repeatedly magically comes to life


Hello, I see that the problem 100% CPU utilization comes by the side of the email, and imagine the ssl process for the TLS ...
Attached images with crazy error messages.
observe CPU utilization and increases in seconds the memory usage..
if downgrade to 6.35.4 works fine!
any idea about it?


Image

and seconds later....

Image
 
jrpaz
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Wed Jun 05, 2013 5:54 am

Re: v6.36.3 [current] is released!

Thu Sep 08, 2016 4:01 am

PPPoE on 6.36.3 does fast track work?

Currently on 6.36 debating if I should upgrade.
 
Maestrosoft
just joined
Posts: 3
Joined: Sun May 29, 2011 12:32 pm

Re: v6.36.3 [current] is released!

Thu Sep 08, 2016 9:20 am

Problems with server l2tp!!!
 
makstex
newbie
Posts: 40
Joined: Fri Mar 27, 2009 6:31 am

Re: v6.36.3 [current] is released!

Thu Sep 08, 2016 1:24 pm

OVPN Client and Server Status interface: not showing Local and Remote address.
 
User avatar
pukkita
Trainer
Trainer
Posts: 2975
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: v6.36.3 [current] is released!

Thu Sep 08, 2016 3:16 pm

Had some issues after upgrading a SXT Lite 5 and a SXT 5 AC Lite (checked and firmware was up to date).

SXT5 Lite:
wireless dissapeared on main winbox toolbar. wireless-cm2 was installed, and installation check reported fine. A reset to no defaults fixed it.

SXT5 AC Lite:
No wireless button on main toolbar... (driver loading issue?).

a second reset it to no defaults fixed it.

Probably my fault (didn't check if wireless-fp was enabled), posting just in case someone else experiences the same.
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
User avatar
pukkita
Trainer
Trainer
Posts: 2975
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: v6.36.3 [current] is released!

Thu Sep 08, 2016 4:19 pm

Confirmed issue is happening again, RouterBOARD SXT 5HacD 2n r2 no Wireless on main toolbar; wlan devices does indead appear on interfaces:
RouterBOARD SXT 5HacD 2n r2-6.36.3-bug.png
Ten minutes later, going to generate a supout, notice wireless button does appear back again. Not sure if related to ROS 6.36.3, Winbox 3.5, or the two combined?
You do not have the required permissions to view the files attached to this post.
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
User avatar
hknet
Frequent Visitor
Frequent Visitor
Posts: 86
Joined: Sun Jul 17, 2016 6:05 pm
Location: Vienna, Austria
Contact:

Re: v6.36.3 [current] is released!

Sat Sep 10, 2016 3:37 am

ahem, is there by design no dude-client for 6.36.3?
(just let me know if going back to 6.36.2 is the way to go pls)
 
User avatar
hknet
Frequent Visitor
Frequent Visitor
Posts: 86
Joined: Sun Jul 17, 2016 6:05 pm
Location: Vienna, Austria
Contact:

Re: v6.36.3 [current] is released!

Sun Sep 11, 2016 7:17 am

Problems with server l2tp!!!
fyi - tested l2tp-server on CHR v6.36.3 - works fine - maybe you should elaborate your problem.

regards
hk
 
User avatar
hknet
Frequent Visitor
Frequent Visitor
Posts: 86
Joined: Sun Jul 17, 2016 6:05 pm
Location: Vienna, Austria
Contact:

Re: v6.36.3 [current] is released!

Sun Sep 11, 2016 12:50 pm

Hi
to add to our l2tp-server experience: we have fastpath active - fine.
We also "allow fastpath" for the l2tp-server.

Though as soon as a client connects fastpath is deactivated.

edit: fixed it, got to set "change tcp mss" to no it seems, not quite sure if this is a working way to go...

best,
hk
 
User avatar
pukkita
Trainer
Trainer
Posts: 2975
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: v6.36.3 [current] is released!

Sun Sep 11, 2016 2:44 pm

FastPath speeds up performance because:
Fast path allows to forward packets without additional processing in the Linux kernel. It improves forwarding speeds significantly.
The moment you manipulate the packets (change tcp MSS) you cannot "bypass" them any longer, so there's no other way to go... whether it will work or not, it will depend on the network being suitable for unclamped TCP packets or not.
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
Zorro
Long time Member
Long time Member
Posts: 676
Joined: Wed Apr 16, 2014 2:43 pm

Re: v6.36.3 [current] is released!

Mon Sep 12, 2016 4:22 am

netinstall for 636.3 version had "-tile" suffix, which is wrong or mistake i think(misleading , but dunno).
 
Grickos
newbie
Posts: 30
Joined: Thu Aug 06, 2015 2:57 am

Re: v6.36.3 [current] is released!

Mon Sep 12, 2016 4:39 pm

ver6.36.3 Cap client does not work. Certificates is marked in red. Returned to 6.36.2, everything works Fine.
 
pe1chl
Forum Guru
Forum Guru
Posts: 4865
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.36.3 [current] is released!

Tue Sep 13, 2016 2:22 pm

I updated my 2011 from 6.35.4 to 6.36.3 and after the upgrade all IPv4 firewall filter and NAT rules were gone.
Mangle rules still there. IPv6 firewall rules also still there.
I could recover them by cut/paste from an export I did before. Diff shows no changes now for IPv4.
(for IPv6 all rules were changed to add action=accept which was previously omitted as default)
 
Abuhajir
just joined
Posts: 23
Joined: Tue Sep 29, 2015 11:37 pm

Re: v6.36.3 [current] is released!

Tue Sep 13, 2016 3:18 pm

Hello people ..

I updated my 912 basebox to to v6.36.3 and the "Wireless" icon has disappeared from the main menu of the Winbox .. help pleasE?
 
jarda
Forum Guru
Forum Guru
Posts: 7560
Joined: Mon Oct 22, 2012 4:46 pm

Re: v6.36.3 [current] is released!

Tue Sep 13, 2016 4:51 pm

What wireless package is installed and active?
 
snipersix
just joined
Posts: 2
Joined: Wed Feb 03, 2016 12:01 am

Re: v6.36.3 [current] is released!

Wed Sep 14, 2016 4:23 pm

Hi,
i found a problem when using IPsec. When i set Proposal Auth. Algorithm sha256 option. SAs cert. are created but communication LAN to LAN is not working. When i set different Auth. Algorithm it works fine.

Details:
ROS 6.34.6 (mipsbe) and 6.36.3 (mipsbe) where tested.
HW: RB951-2n and RB951G-2HnD
 
Grickos
newbie
Posts: 30
Joined: Thu Aug 06, 2015 2:57 am

Re: v6.36.3 [current] is released!

Thu Sep 15, 2016 10:48 am

ver6.36.3 Cap client does not work. Certificates is marked in red. Returned to 6.36.2, everything works Fine.
Correction. CAP client does not work on Winbox 3.5 and ROS6.36.3. Bugfix 6.34.6. does not work with wireless-rep package. I have not tested other versions.
Last edited by Grickos on Thu Sep 15, 2016 3:01 pm, edited 1 time in total.
 
kichsolo
just joined
Posts: 9
Joined: Mon Dec 20, 2010 11:16 am

Re: v6.36.3 [current] is released!

Thu Sep 15, 2016 1:33 pm

Hi

RB2011UiAS-2hnd [6.36.3] Still have no ZTE MF823 support i.e.no LTE interface. [6.35.4] works fine.
 
User avatar
nichky
Member
Member
Posts: 425
Joined: Tue Jun 23, 2015 2:35 pm

Re: v6.36.3 [current] is released!

Fri Sep 16, 2016 11:45 pm

i've upgraded my RB433AH to v6.36.3 [current] is released, and know i see that the ports are on different group.
ether1 PoE know is ether 2, ether2 know is ether1, just ether 3 is same. The new version did that or???

Thanks
o0`Safe Mode is your friend.`0o
 
User avatar
Deantwo
Member Candidate
Member Candidate
Posts: 246
Joined: Tue Sep 30, 2014 4:07 pm

Re: v6.36.3 [current] is released!

Mon Sep 19, 2016 5:05 pm

i've upgraded my RB433AH to v6.36.3 [current] is released, and know i see that the ports are on different group.
ether1 PoE know is ether 2, ether2 know is ether1, just ether 3 is same. The new version did that or???

Thanks
What version did you upgrade from?
Did you confirm the default-names are the same as the current names?

Try this:
{
    :put "name - default-name"
    :foreach eIf in=[/interface ethernet find] do={
        :put ([/interface ethernet get $eIf name] . " - " . [/interface ethernet get $eIf default-name])
    }
}
I wish my FTP was FTL.
 
kmok1
newbie
Posts: 43
Joined: Wed Nov 28, 2012 6:49 pm
Location: Windsor ON Canada
Contact:

Re: v6.36.3 [current] is released!

Mon Sep 19, 2016 7:37 pm

From version 6.35.x to 6.36.3, the UPS package crashes my RB750UP or Omnitik U-5HnD when UPS switches to battery power.
The latest version that worked is 6.34.6.
 
User avatar
nichky
Member
Member
Posts: 425
Joined: Tue Jun 23, 2015 2:35 pm

Re: v6.36.3 [current] is released!

Tue Sep 20, 2016 6:30 am

after reset all good

Thanks
o0`Safe Mode is your friend.`0o
 
IntrusDave
Forum Guru
Forum Guru
Posts: 1266
Joined: Fri May 09, 2014 4:36 am
Location: Rancho Cucamonga, CA

Re: v6.36.3 [current] is released!

Tue Sep 20, 2016 7:10 am

Hi,
i found a problem when using IPsec. When i set Proposal Auth. Algorithm sha256 option. SAs cert. are created but communication LAN to LAN is not working. When i set different Auth. Algorithm it works fine.

Details:
ROS 6.34.6 (mipsbe) and 6.36.3 (mipsbe) where tested.
HW: RB951-2n and RB951G-2HnD
It's likely a stuck SA on either side, or an incorrect configuration. Reboot both sides of the tunnel when changing enc or auth.

I have 37 Mikrotiks all using aes256cbc & sha256 with no issues.
David Joyce
Network & Security Engineer
Intrus Technologies, LLC.
Rancho Cucamonga, CA, USA
 
IntrusDave
Forum Guru
Forum Guru
Posts: 1266
Joined: Fri May 09, 2014 4:36 am
Location: Rancho Cucamonga, CA

Re: v6.36.3 [current] is released!

Tue Sep 20, 2016 7:11 am

after reset all good

Thanks
I should have finished the thread before replying... :)
David Joyce
Network & Security Engineer
Intrus Technologies, LLC.
Rancho Cucamonga, CA, USA
 
esmir
just joined
Posts: 10
Joined: Tue Sep 20, 2016 12:45 pm

Re: v6.36.3 [current] is released!

Tue Sep 20, 2016 12:55 pm

Hi,

in The Dude version 6.36 I noticed a problem with Panels. Basically with version 6.36 there is no possibility to select more charts and show this carts on one panel.

Is this bug fixed in version 6.36.3?

Regards,
 
snipersix
just joined
Posts: 2
Joined: Wed Feb 03, 2016 12:01 am

Re: v6.36.3 [current] is released!

Wed Sep 21, 2016 2:31 pm

Hi,
i found a problem when using IPsec. When i set Proposal Auth. Algorithm sha256 option. SAs cert. are created but communication LAN to LAN is not working. When i set different Auth. Algorithm it works fine.

Details:
ROS 6.34.6 (mipsbe) and 6.36.3 (mipsbe) where tested.
HW: RB951-2n and RB951G-2HnD
It's likely a stuck SA on either side, or an incorrect configuration. Reboot both sides of the tunnel when changing enc or auth.

I have 37 Mikrotiks all using aes256cbc & sha256 with no issues.
TNX for your interest,
so i did. Flush SAs, kill connections, reboot devices, upgrade/downgrade ROS,even try to turn it off and on again (everithing on both sides). But communication LAN to LAN starts only when i change algorithm and flush SAs. I played with it almost 3 hours.
When i now try it with different HW, it works ok. Strange...
Anyway, thanks for info.
 
pe1chl
Forum Guru
Forum Guru
Posts: 4865
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.36.3 [current] is released!

Wed Sep 21, 2016 3:44 pm

When i now try it with different HW, it works ok. Strange...
Different router manufacturer, or different router from MikroTik?
IPsec can sometimes be *very frustrating*. Usually it works fine, sometimes it refuses to work
for no apparent reason. Feverishly searching for a solution also does not seem to help things:
once a stable solution is found it often remains stable, even when you are *sure* that you have
tried it before and it did not work or was unstable.
 
IPTel
just joined
Posts: 5
Joined: Fri Jun 13, 2014 9:35 am

Re: v6.36.3 [current] is released!

Wed Sep 21, 2016 8:47 pm

After upgrading from 6.34.6 to 6.36 (6.36.2, 6.36.3) disk memory using inreased
on router 1 (750G) from ~3000 to ~7 400 sectors/day
on router 2 (750GL) from ~2 000 to ~4 000 sectors/day

without changing of configuration, of course

Tools -> Graphing -> Graphing Setting -> Store every = 24h

---------------------------------------------
The same story was here:
http://forum.mikrotik.com/viewtopic.php ... 32#p439032

Then it has been fixed.
 
sger
just joined
Posts: 18
Joined: Thu Sep 22, 2016 1:36 pm

Re: v6.36.3 [current] is released!

Thu Sep 22, 2016 1:45 pm

HI all,
From v6.36 my ZTE MF90 (LTE portable router) stopped working: it's correctly identified but no LTE interface was created and no port appear under port list...
It was OK up to v6.35.x

Regards!
 
LynxChaus
just joined
Posts: 22
Joined: Tue Jul 08, 2014 2:24 pm

Re: v6.36.3 [current] is released!

Thu Sep 22, 2016 11:12 pm

After upgrade from 6.36 to 6.36.3 - ipv6 package disabled. Why?
 
strods
MikroTik Support
MikroTik Support
Posts: 1365
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.36.3 [current] is released!

Fri Sep 23, 2016 11:53 am

Who is online

Users browsing this forum: No registered users and 4 guests