Community discussions

** WE WANT A LTE BRIDGE-MODE **

YES
72 (90%)
NO
8 (10%)
 
Total votes: 80
 
mikrolte
just joined
Topic Author
Posts: 14
Joined: Mon Oct 17, 2016 5:01 pm

** WE WANT A LTE BRIDGE-MODE **

Mon Oct 17, 2016 8:06 pm

Dear MikroTik,

we, your truly customers, have a great wish.

We would like to add a LTE interface to a BRIDGE to create a bridge-mode to get our public IP from the LTE interface to our ETHERNET interface.

Please speed up your development and add this to your next update.

Thank you very much!
  • EDIT: I got an answer from the MikroTik-Team: They set it on their TODO-list and it will be implementet in the near future!
Last edited by mikrolte on Tue Oct 18, 2016 10:35 pm, edited 1 time in total.
 
User avatar
ErfanDL
Member Candidate
Member Candidate
Posts: 275
Joined: Thu Sep 29, 2016 9:13 am
Location: IRAN
Contact:

Re: ** WE WANT A LTE BRIDGE-MODE **

Mon Oct 17, 2016 9:03 pm

ROS is already have this feature

Sent from my C6833 using Tapatalk
 
mikrolte
just joined
Topic Author
Posts: 14
Joined: Mon Oct 17, 2016 5:01 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Mon Oct 17, 2016 9:13 pm

ROS is already have this feature

Sent from my C6833 using Tapatalk
really? how to set it up? when I am inside the bridge settings on the tab "ports" I am not able to add the LTE interface to my bridge!

Maybe you can tell us how to add the LTE interface to a bridge. Thank you!
 
IntrusDave
Forum Guru
Forum Guru
Posts: 1290
Joined: Fri May 09, 2014 4:36 am
Location: Rancho Cucamonga, CA

Re: ** WE WANT A LTE BRIDGE-MODE **

Mon Oct 17, 2016 9:18 pm

Use an LTE device that supports it.
David Joyce
Network & Security Engineer
Intrus Technologies, LLC.
Rancho Cucamonga, CA, USA
 
mikrolte
just joined
Topic Author
Posts: 14
Joined: Mon Oct 17, 2016 5:01 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Mon Oct 17, 2016 9:24 pm

Does the "Huawei ME909s-120" supports it?
If not which mini-PCIe card supports it? I need 150-down and 50-up speed support.

Thank you!
 
User avatar
sergeyklenov
just joined
Posts: 9
Joined: Mon May 05, 2014 7:04 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Tue Jan 24, 2017 11:58 pm

+1
Need bridge mode.
OpenWRT already can do it!
 
uldis
MikroTik Support
MikroTik Support
Posts: 3425
Joined: Mon May 31, 2004 2:55 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Thu Jan 26, 2017 10:10 am

If you want us to make the LTE bridge more we need more information on the requirements for that.
For example, when the LTE interface is in the bridge mode, do you need connection to the Router as well as the Router now just passes the IP from the LTE network to the ethernet host?
 
vilts
just joined
Posts: 7
Joined: Fri Jan 20, 2017 9:43 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Fri Jan 27, 2017 5:15 pm

+1 for the bridge mode. Just this week got LTE connection and set up bridge connection from Zyxel router to MikroTik. Would buy the SXTLTE in a heartbeat and return the provider router+antenna.
If you want us to make the LTE bridge more we need more information on the requirements for that.
For example, when the LTE interface is in the bridge mode, do you need connection to the Router as well as the Router now just passes the IP from the LTE network to the ethernet host?
Well, there would have to be a way to manage the router when in bridge mode, as long as that is possible and bridge works, I would be happy. In current setup I get the external public IP from ISP via DHCP client to MikroTik. I also can access the bridging router with its internal IP, so I can manage it.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3425
Joined: Mon May 31, 2004 2:55 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Fri Jan 27, 2017 6:15 pm

Well, there would have to be a way to manage the router when in bridge mode, as long as that is possible and bridge works, I would be happy. In current setup I get the external public IP from ISP via DHCP client to MikroTik. I also can access the bridging router with its internal IP, so I can manage it.
So you get the Public IP from your LTE connection via the Zyxel to the MikroTik Router?
And to manage the Zyxel router you need to assign static IP on the MikroTik router and use the internal static IP for the Zyxel?
When you connect to the Zyxel router it doesn't have access to the Internet as the IP is bridged to the MikroTik device?
 
vilts
just joined
Posts: 7
Joined: Fri Jan 20, 2017 9:43 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Fri Jan 27, 2017 11:09 pm

So you get the Public IP from your LTE connection via the Zyxel to the MikroTik Router?
Yes
And to manage the Zyxel router you need to assign static IP on the MikroTik router and use the internal static IP for the Zyxel?
When you connect to the Zyxel router it doesn't have access to the Internet as the IP is bridged to the MikroTik device?
Now here it gets interesting. I haven't had time to look deeper into it, but right now the working config is as follows.
> /ip address print 
#   ADDRESS            NETWORK         INTERFACE
0   10.10.10.1/24      10.10.10.0      bridge
1 D 1.2.3.98/30    1.2.3.96    ether1

/ip dhcp-client print 
 #   INTERFACE                            USE-PEER-DNS ADD-DEFAULT-ROUTE STATUS        ADDRESS
 0   ether1                               yes          yes               bound         1.2.3.98/30
 
 /ip route print 
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADS  0.0.0.0/0                          1.2.3.97              0
 1 ADC  10.10.10.0/24      10.10.10.1      bridge                    0
 2 ADC  1.2.3.96/30    1.2.3.98    ether1                    0
 
I don't have the 192.168.1.0/24 range IP attached to Mikrotik. I did try this at first, but that acted weird. However that range (192.168.1.1 is Zyxel) is available from both MT and from my local 10.x network. Traceroute shows one hop at the 192.168.1.1 as well.
 /tool traceroute 8.8.8.8
 # ADDRESS                          LOSS SENT    LAST     AVG    BEST   WORST STD-DEV STATUS
 1 192.168.1.1                        0%    8   0.2ms     0.3     0.2     0.7     0.2
 2                                  100%    8 timeout
 3 90.190.153.44                      0%    8  24.8ms    55.8    20.9    77.9    20.5
 4 194.126.123.2                      0%    8  34.6ms    25.8    19.9    34.6     4.8
I don't have a way to test internet connectivity from zyxel. However, it does have the external IP and gateway attached to it, or at least shows it at the WAN info page... Same external IP on both MT and zyxel... ARP table shows that external GW and 192.168.1.1 are available on ether1
/ip arp print    
 #    ADDRESS         MAC-ADDRESS       INTERFACE                      
 ...                                        
 9 DC 1.2.3.97    90:EF:68:D4:50:7B ether1                                                
...
12 DC 192.168.1.1     90:EF:68:D4:50:7B ether1
 
uldis
MikroTik Support
MikroTik Support
Posts: 3425
Joined: Mon May 31, 2004 2:55 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Mon Jan 30, 2017 10:18 am

When you had the 192.168.1.x network on the router what exactly was acting weird?
let us know if you were able to connect to connect to Zyxel an check if it can connect to the Internet and what does it shows as WAN connection.
 
Larsa
Member Candidate
Member Candidate
Posts: 119
Joined: Sat Aug 29, 2015 7:40 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Thu Feb 09, 2017 10:51 am

If you want us to make the LTE bridge more we need more information on the requirements for that.
For example, when the LTE interface is in the bridge mode, do you need connection to the Router as well as the Router now just passes the IP from the LTE network to the ethernet host?
Another business case is when you cope with fail-over solutions using 4G/LTE.

Without digging into to much specific technical details about what might be required, the main objective is you want to have full control on what’s happening on the backup link from the connected router to be able to take further actions like checking the link status and ip address, alter routes, change DDNS records for external DNS-server to redirect incoming services using the backup link, sending alarms, etc.

A "virtual" LTE interface would be very nice with the ability to execute scripts on events such as link-up, link-down and address-change etc.
 
User avatar
matiaszon
Member
Member
Posts: 305
Joined: Mon Jul 09, 2012 9:26 am

Re: ** WE WANT A LTE BRIDGE-MODE **

Thu Feb 23, 2017 12:46 am

+1 for bridge mode

However, I have temporarly fixed that problem. I am now using dovado tiny router with E3372s dongle in USB. Dovado gives the possibility to bridge USB device with LAN/WLAN ports. As the result you have the IP address from your ISP assigned to the device directly connected to dovado router. So, if you connect you laptop by wifi, your IP will be redirected to your wireless connection. If the connected device is Mirkotik router, then you have that IP assigned to your ether1 (WAN) port.

The only disadvantage I have encountered is that it takes approx. 5-6 minutes for dovado to establish connection. I don't know what the problem is. I have tried on 2 different dongles (E3372s and M-150 which is actually E3372 too) and it is the same. Both HiLinks, and both connect to the Internet immediately when connected directly to laptop.

I would get rid of any additional equipment, if Mikrotik would support getting Public IP directly on WAN instead of using old RAS modems and PPP connections.
 
Kola
newbie
Posts: 46
Joined: Fri Aug 02, 2013 11:42 am

Re: ** WE WANT A LTE BRIDGE-MODE **

Tue Mar 21, 2017 9:24 am

Tried last RC and still couldn't add lte into bridge! When we will?
 
FIPTech
Member
Member
Posts: 469
Joined: Tue Dec 22, 2009 1:53 am

Re: ** WE WANT A LTE BRIDGE-MODE **

Sat Mar 25, 2017 8:43 pm

+1 to be able to put an LTE interface inside a bridge.

But this will not remove the biggest problem, the NAT inside the LTE 4G modem. To remove that limitation we need bridge mode inside the modem, or IP passthrough.

The USB LTE 4G modem i tried, a E3372h from Huawei, can't deliver the WAN ip address through IP passthrough. Router mode is mandatory and DMZ or port forwarding is not available in the modem configuration (through web interface). So in the end we get a 192.168.8.0/24 nated subnetwork from this modem. Very bad when we use a Mikrotik for advanced network management. We end with a double NAT setup without possibility to configure any port forwarding.

The best we could do here, is to flash a modified web GUI in the modem, to give access to port forwarding and DMZ settings. But router mode and NAT will stay anyway enabled. More this flashing is not supported by the modem vendor. This is a terrible solution.

Flashing the E3372h in Stick mode (it become an E3372s modem) , an USB port appear inside Router OS, but PPP connection on this port does not work for me (Mikrotik HAP RB951, Router OS 6.38.5).
The same modem works under Windows 7 and deliver the WAN address through RNDIS interface. So it seems to be a driver problem inside Router OS.

Anyway the ppp connection is really slower than LTE and is CPU hungry. So this is not a good solution technically.

So would it be possible to switch those modems in bridge mode (using QMI commands ?), so that we can get the wan ip (through DHCP ?) on the LTE interface ? Then accessing the modem web management interface should not be a problem, adding a static IP address in the 192.168.8.0/24 range on the LTE interface. I did that for PPPoE DSL modems in bridge mode linked through Ethernet to a Mikrotik port. Adding a static IP to the Ethernet port of the Mikrotik gave access to web GUI even with the modem in bridge mode. The wan address going to the PPPoE interface on this same Mikrotik Ethernet Port.
As it is not easy to modify the routing table in the modem, adding a masquerading rule on the Mikrotik Ethernet port where the modem is connected give access to the modem from other subnetworks without touching the modem routing table. It is even possible to distribute this modem administration IP subnetwork through a routing protocol to get access to the modem Web interface from everywhere in the network.

II suppose it is the same in LTE 4G routers, the modem ip (192.168.x.x) certainly stay available even if the modem is in bridge mode. The only difference is that the modem internal DHCP server is disabled, so it cannot deliver an address for the web interface (if enabled there would be two DHCP servers, a local one and the provider one and they will conflict).

Some 4G LTE modems do allow bridge mode to be configured from their web management interface, for example the Netgear LB1111. But it is a Ethernet port modem, not an USB one.

So it seems definitely possible technically, some advanced users seems to get it working on OpenWRT using QMI commands.

Edit :

Some modems in Ip passthrough mode seems to use a trick to enable two DHCP servers (local and wan) in the setup. In this case :

A reduced (two minutes) dhcp lease time is assigned to the modem local DHCP server. When there is no wan connection, a local IP address is delivered to the client host to allow for modem administration.

When wan connection is active, the modem local DHCP server is disabled (i suppose) and the client host can get a wan address and gateway, this time delivered by the wan side DHCP server.

See here : https://www.att.com/gen/general?pid=23697
You do not have the required permissions to view the files attached to this post.
 
tknuutil
just joined
Posts: 12
Joined: Tue Apr 02, 2013 2:56 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Thu May 11, 2017 2:34 pm

More +'s for the LTE bridge.

I think I saw a while ago (some weeks) LTE in brtidge port list after playing with some "Quick Set".

However, now when I tried to do the bridging on purpose, I could not add LTE interface to bridge. OS 6.40rc5 /RB922UAGS
Tried with Sierrawireless MC7710 and Huawei ME909s-120.
Is it just my imagination, or has there been such possibility already?

Uldis asked biz case / requirements:

I would need that in order to get the cellular network assigned IP to the host attached to Ethernet port (DHCP).
This is required in order to access the host from the network. As one cannot use routing behind the cellular network, this is the only option.
(Sure you could play with NAT & port translation, but that's not the solution)
 
ega2002
just joined
Posts: 15
Joined: Fri Sep 23, 2016 4:58 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Tue May 16, 2017 12:39 am

+1 for LTE bridge mode in RouterOS
While waiting for this to be implemented, I'm currently using OpenWrt, where it can be easily configured without any problem.
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1818
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: ** WE WANT A LTE BRIDGE-MODE **

Tue May 16, 2017 1:19 am

Guys this solution from Netgear looks to be almost perfect https://www.netgear.com/images/datashee ... LB1121.pdf
It supports POE in for power, has bridge mode and the styling is fantastic.

Unfortunately for me, it does not support Bands 3 or 28 which are what NZ providers use :(

I really wish Mikrotik would implement an LTE bridge mode! If a product like the wAP LTE or ltAP Mini had LTE bridge mode, we would have already purchased over a thousand of them.
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
W4WN
just joined
Posts: 9
Joined: Mon Jul 07, 2014 6:09 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Tue Jun 13, 2017 3:54 am

+1

Any news? I have several RB912UAG-2HPnD's with Sierra Wireless MC7700 Mini-PCIe LTE aircards I'm trying to use for an IoT project. They are very stable and work great except for the inability to remote into them from outside. If I could get the LTE Public IP out to the ether1 & wlan it would be awesome. I'd be happy to provide any logs or information.
You do not have the required permissions to view the files attached to this post.
 
User avatar
cdiedrich
Forum Veteran
Forum Veteran
Posts: 905
Joined: Thu Feb 13, 2014 2:03 pm
Location: Basel, Switzerland // Bremen, Germany
Contact:

Re: ** WE WANT A LTE BRIDGE-MODE **

Tue Jun 13, 2017 1:44 pm

Probably just a stupid idea for a LTE bridge workaround and not tested:
Could netmap together with HotSpot one-to-one NAT work when LTE-Client and router are not the same device (i.e. a SXT LTE connected to another routerOS device?

-Chris
Christopher Diedrich
MTCNA, MTCUME, MTCWE
Basel, Switzerland
Bremen, Germany

There are 10 types of people: Those who understand binary and those who don't.
There are two types of people: Those who can extrapolate from incomplete data
 
W4WN
just joined
Posts: 9
Joined: Mon Jul 07, 2014 6:09 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Wed Jun 14, 2017 12:45 am

Guys this solution from Netgear looks to be almost perfect https://www.netgear.com/images/datashee ... LB1121.pdf
It supports POE in for power, has bridge mode and the styling is fantastic.

Unfortunately for me, it does not support Bands 3 or 28 which are what NZ providers use :(

I really wish Mikrotik would implement an LTE bridge mode! If a product like the wAP LTE or ltAP Mini had LTE bridge mode, we would have already purchased over a thousand of them.

Netgear box does look interesting. Don't know why it only supports B2, 4, 5, 12. Seems to be for Verizon only here in the US? Leaves me out or I'd get one to try.
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1818
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: ** WE WANT A LTE BRIDGE-MODE **

Wed Jun 14, 2017 12:59 pm

I believe Mikrotik are working on this feature request.

Hopefully they can make it happen :)

We would really like to be use the new wAP LTE, ltAP and ltAP Mini to bridge LTE to their ethernet interfaces.
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
User avatar
juliokato
Member Candidate
Member Candidate
Posts: 229
Joined: Mon Oct 26, 2015 4:27 pm
Location: Brazil

Re: ** WE WANT A LTE BRIDGE-MODE **

Wed Jun 14, 2017 2:31 pm

+1. When? In this century?
I apologize my grammatical errors, my english not so good, I am not a native speaker.
Wiki is maintained in English. I use Google translator. 8)
 
jupiter95
just joined
Posts: 8
Joined: Tue Aug 30, 2016 9:32 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Tue Jun 27, 2017 2:53 pm

+1 LTE bridge mode.

Mikrotik if you treat your customers seriously and respect them please tell us on your plans to implement LTE bridge mode! We are waiting for your message!
 
uldis
MikroTik Support
MikroTik Support
Posts: 3425
Joined: Mon May 31, 2004 2:55 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Tue Jun 27, 2017 4:06 pm

We are currently looking into this feature but I can't comment when or what lte interfaces will support that feature.
 
W4WN
just joined
Posts: 9
Joined: Mon Jul 07, 2014 6:09 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Tue Jun 27, 2017 4:53 pm

Thanks for the update. Hope this feature can be added, please keep us posted.
 
NoWaY
just joined
Posts: 8
Joined: Mon Apr 18, 2016 11:33 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Sat Jul 29, 2017 4:41 am

+1 LTE bridge mode.


for sxt-lte model please
 
przemo
just joined
Posts: 2
Joined: Wed May 11, 2016 9:44 am

Re: ** WE WANT A LTE BRIDGE-MODE **

Wed Aug 02, 2017 12:10 pm

+1 - for: wAP LTE kit :D (I know, not yet released :) but it support all bands in my country )


Imagination switch on ;) : wAP LTE (on outside wall) with RB2011UiAS-2HnD-IN - Purrrrfect for me :twisted:
 
tknuutil
just joined
Posts: 12
Joined: Tue Apr 02, 2013 2:56 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Wed Aug 09, 2017 11:04 am

Any status update on bridged LTE?

As discussed earlier, this feature starts to be in many LTE routers and is needed especially when one needs to connect to the end device from the network.
More advanced devices can use multiple PDN connections (many APN:s). In this case one IP can be terminated to the router and remote management done directly via that.
LTE-bridge-multiple-bearers.png
You do not have the required permissions to view the files attached to this post.
 
W4WN
just joined
Posts: 9
Joined: Mon Jul 07, 2014 6:09 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Sat Aug 19, 2017 8:06 pm

Couldn't wait any longer, replaced my RB912UAG-2HPnD's with Net gear LTE modems. IP Pass-through works great on them and so far as stable as the RB's.

Sent from my SAMSUNG-SM-G900A using Tapatalk
 
uldis
MikroTik Support
MikroTik Support
Posts: 3425
Joined: Mon May 31, 2004 2:55 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Mon Aug 21, 2017 8:59 am

Starting from RouterOS v6.41rc16 you can use the LTE passthough mode to pass the traffic from the modem directly to a host on some routers interface.
tknuutil Multiple APN support like you posted in the picture will be supported only with WAP LTE modem.

Information how to use the option is listed in this wiki section:
https://wiki.mikrotik.com/wiki/Manual:I ... assthrough
Information on the supported list for this feature will be listed in this wiki section. If you have a modem that works with the passthrough please report to us, we will update the list.
https://wiki.mikrotik.com/wiki/Supporte ... and_modems

Since we passthough all the data traffic from the modem to the host we can't comment how well the modem firmware works as on the router we just initiate the data-connection which then will be passed to the specified interface/host.
 
kd6icz
Frequent Visitor
Frequent Visitor
Posts: 67
Joined: Wed Jun 15, 2016 11:29 pm

Re: RE: Re: ** WE WANT A LTE BRIDGE-MODE **

Mon Aug 21, 2017 8:32 pm


Netgear box does look interesting. Don't know why it only supports B2, 4, 5, 12. Seems to be for Verizon only here in the US? Leaves me out or I'd get one to try.
Those are the AT&T bands. Verizon would be 2, 4, 5, 13, and 66.


Sent from my XT1650 using Tapatalk
 
irghost
Member Candidate
Member Candidate
Posts: 281
Joined: Sun Feb 21, 2016 1:49 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Tue Aug 22, 2017 8:32 am

Starting from RouterOS v6.41rc16 you can use the LTE passthough mode to pass the traffic from the modem directly to a host on some routers interface.
tknuutil Multiple APN support like you posted in the picture will be supported only with WAP LTE modem.

Information how to use the option is listed in this wiki section:
https://wiki.mikrotik.com/wiki/Manual:I ... assthrough
Information on the supported list for this feature will be listed in this wiki section. If you have a modem that works with the passthrough please report to us, we will update the list.
https://wiki.mikrotik.com/wiki/Supporte ... and_modems

Since we passthough all the data traffic from the modem to the host we can't comment how well the modem firmware works as on the router we just initiate the data-connection which then will be passed to the specified interface/host.
What about SXT LTE
No Passthrough !!!!
MTCNA MTCRE MTCTCE MTCUME MTCWE MTCIPv6E MTCINE
 
eriitguy
Member Candidate
Member Candidate
Posts: 197
Joined: Thu Jan 26, 2017 1:16 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Tue Aug 22, 2017 10:35 am

uldis,

Thank you very much your team to this feature implementation!
It may be very usefully in our case.

Before starting to use it, we are looking how may we verify if LTE is working fine and pass the traffic?
On recent solutions we using script like this:
:local PINGCOUNT 5;
:local PINGADDRESS "8.8.8.8";
:local INTERFACE "lte1";
:local DELAY "8"
#
:log info message="----> Ping to $PINGADDRESS Started";
#
:local PINGRESULT [/ping interface=$INTERFACE address=$PINGADDRESS count=$PINGCOUNT];
#
:if ($PINGRESULT > 0) do={
 :log info message="----> Ping to $PINGADDRESS OK";
} else={
:log info message="--------> Ping to $PINGADDRESS FAIL --------> USB Power Reset";
:beep frequency=800 length=1;
/system routerboard usb power-reset duration=3;
:log info message="--------> Power reseted on USB";
:log info message="--------> Waiting $DELAY seconds";
:delay $DELAY;
:log info message="--------> Enable interface $INTERFACE";
/interface lte enable lte1;
}
 
eriitguy
Member Candidate
Member Candidate
Posts: 197
Joined: Thu Jan 26, 2017 1:16 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Tue Aug 22, 2017 12:34 pm

uldis,

Another question, is it possible to assign second IP to wAP LTE itself in order to manage it?
 
uldis
MikroTik Support
MikroTik Support
Posts: 3425
Joined: Mon May 31, 2004 2:55 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Wed Aug 23, 2017 11:00 am

uldis,

Another question, is it possible to assign second IP to wAP LTE itself in order to manage it?
You can manage the WAP LTE from another interface like vlan or wireless interface that is not a part of the passthrough interface.
 
eriitguy
Member Candidate
Member Candidate
Posts: 197
Joined: Thu Jan 26, 2017 1:16 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Thu Aug 24, 2017 9:17 am

uldis,

No chance to manage it remotely then it physically is inaccessible, in another City for example?
We should be able to log in to verify or configure settings when something may be wrong.

Thank you!
 
smiller
just joined
Posts: 2
Joined: Fri Aug 25, 2017 7:27 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Fri Aug 25, 2017 7:32 pm

So I assume that when in LTE passthrough mode there can be no features such as traffic shaping or WAN failover, etc. since the MikroTik is no longer acting as a router and is only transparently passing traffic from the LTE device?
 
uldis
MikroTik Support
MikroTik Support
Posts: 3425
Joined: Mon May 31, 2004 2:55 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Mon Aug 28, 2017 3:26 pm

uldis,

No chance to manage it remotely then it physically is inaccessible, in another City for example?
We should be able to log in to verify or configure settings when something may be wrong.

Thank you!
WAP LTE kit will have option to activate multiple APN at the same time (if the provider supports) and then you can pass-though one and the second terminate locally.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3425
Joined: Mon May 31, 2004 2:55 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Mon Aug 28, 2017 3:31 pm

So I assume that when in LTE passthrough mode there can be no features such as traffic shaping or WAN failover, etc. since the MikroTik is no longer acting as a router and is only transparently passing traffic from the LTE device?
Correct, queues will not work in this configuration - you can only enable/disable the lte interface or change the configuration of the lte interface.
 
W4WN
just joined
Posts: 9
Joined: Mon Jul 07, 2014 6:09 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Tue Aug 29, 2017 3:38 am

Starting from RouterOS v6.41rc16 you can use the LTE passthough mode to pass the traffic from the modem directly to a host on some routers interface.
tknuutil Multiple APN support like you posted in the picture will be supported only with WAP LTE modem.

Information how to use the option is listed in this wiki section:
https://wiki.mikrotik.com/wiki/Manual:I ... assthrough
Information on the supported list for this feature will be listed in this wiki section. If you have a modem that works with the passthrough please report to us, we will update the list.
https://wiki.mikrotik.com/wiki/Supporte ... and_modems

Since we passthough all the data traffic from the modem to the host we can't comment how well the modem firmware works as on the router we just initiate the data-connection which then will be passed to the specified interface/host.

Upgraded a couple RB912UAG-2HPnD's to v6.41rc18 and IP Passthrough does not seem to work with Sierra Wireless MC7700 as mentioned in the Supported LTE Aircards list. Log indicates it does not like the apn1/ether1. Does anyone have a log to share showing what a successful IP Passthrough connection looks like? Doesn't look like any North American Band LTE MiniPCI-e cards are supported. I don't suppose you could share which MiniPCI-e card you will be shipping in the wAP LTE kit-US?
 
smiller
just joined
Posts: 2
Joined: Fri Aug 25, 2017 7:27 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Tue Aug 29, 2017 6:41 am

Log indicates it does not like the apn1/ether1.
I think you are supposed to substitute the APN that your carrier uses in the apn field, not literally use 'apn1', IOW the command should read something like: /interface lte set lte1 apn=<your carrier APN>/ether1 (or whatever ethernet port you are using.)
Last edited by smiller on Tue Aug 29, 2017 7:25 pm, edited 1 time in total.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3425
Joined: Mon May 31, 2004 2:55 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Tue Aug 29, 2017 9:58 am

Starting from RouterOS v6.41rc16 you can use the LTE passthough mode to pass the traffic from the modem directly to a host on some routers interface.
tknuutil Multiple APN support like you posted in the picture will be supported only with WAP LTE modem.

Information how to use the option is listed in this wiki section:
https://wiki.mikrotik.com/wiki/Manual:I ... assthrough
Information on the supported list for this feature will be listed in this wiki section. If you have a modem that works with the passthrough please report to us, we will update the list.
https://wiki.mikrotik.com/wiki/Supporte ... and_modems

Since we passthough all the data traffic from the modem to the host we can't comment how well the modem firmware works as on the router we just initiate the data-connection which then will be passed to the specified interface/host.

Upgraded a couple RB912UAG-2HPnD's to v6.41rc18 and IP Passthrough does not seem to work with Sierra Wireless MC7700 as mentioned in the Supported LTE Aircards list. Log indicates it does not like the apn1/ether1. Does anyone have a log to share showing what a successful IP Passthrough connection looks like? Doesn't look like any North American Band LTE MiniPCI-e cards are supported. I don't suppose you could share which MiniPCI-e card you will be shipping in the wAP LTE kit-US?
In the wiki page you can see that the Sierra modems do not support the Passthrough option.
 
W4WN
just joined
Posts: 9
Joined: Mon Jul 07, 2014 6:09 pm

Re: RE: Re: ** WE WANT A LTE BRIDGE-MODE **

Tue Aug 29, 2017 2:16 pm

Log indicates it does not like the apn1/ether1.
I think you are supposed to substitute the APN that your carrier uses in the apn field, not literally use 'apn1', IOW the command should read something like: /interface lte set lte1 apn=<your carrier APN>/ether1 (or whatever ethernet port you are using.) But I'm not certain (?)
Right: I was using apn=broadband/ether1. But as uldis points out the Sierra cards don't support ip pass-through. I'd be very interested in hearing about any MiniPCI-e cards which do work. I have been trying a Sierra EM7455 but can't get RB to recognize it at all, I think there may be an issue with the adapter card I'm using to make it fit.

Sent from my SAMSUNG-SM-G900A using Tapatalk
 
MikroGik
just joined
Posts: 14
Joined: Tue Dec 23, 2014 3:23 am

Re: ** WE WANT A LTE BRIDGE-MODE **

Tue Sep 05, 2017 3:49 pm

Uldis et al,

I'm not sure why you guys consider Sierra Wireless cards, such as the MC7700 or the USB AirCard 313U, not being capable of doing IP passthrough. I can give you two specific examples from my personal use of these functioning beautifully in that mode.

The CradlePoint IBR600 router, which I've owned and used for serveral years before I hopped onto MikroTik, specifically has an IP passthrough mode. Once in that mode, all other features are turned off and the router essentially becomes an LTE-to-ethernet dongle, passing the external IP address through either of the ether ports. Mine had an MC7700 card in it as the factory option. Worked perfectly.

My other example is Proxicast's PocketPort2 dongle, wich I have used for many years for this very purpose with a Sierra Wireless AirCard 313U card on both AT&T and T-Mobile. Plug the USB modem into one end, an ethernet cable to, let's say, a wired-only router in the other, and bam, the router is getting the outside LTE IP address.

TEST: Over the weekend I tried the new IP passthrough feature in ROS 6.41 RC23 with both cards above installed/plugged into two routerboards, and indeed, they did not work at all with the new feature and the modified APN. (Note that otherwise both work flawlessly with the regular APN on any Routerboard that can accomodate one or the other.)

I hope my two examples will help you guys in experimenting some more to make these cards work with the new ROS feature.
 
MikroGik
just joined
Posts: 14
Joined: Tue Dec 23, 2014 3:23 am

Re: ** WE WANT A LTE BRIDGE-MODE **

Tue Sep 05, 2017 4:38 pm

+1

Any news? I have several RB912UAG-2HPnD's with Sierra Wireless MC7700 Mini-PCIe LTE aircards I'm trying to use for an IoT project. They are very stable and work great except for the inability to remote into them from outside. If I could get the LTE Public IP out to the ether1 & wlan it would be awesome. I'd be happy to provide any logs or information.
W4WN,

My apologies in advance if I misunderstood your post. Nonetheless...

Your screenshot above suggests that you are subscribed to a cellular connection which gets you a dynamic IP address. Getting IP passthrough working on the MC7700 will not, on its own, allow you to remote in from the outside. The problem is that the IP address doled out by the cellular carriers is, on purpose, not routable (hence the weird message pointed to by the red arrow). If it were, you could still remote in without IP passthrough using DDNS and port forwarding into the router, just like with a home/office dynamic IP scenario.

To solve this, with or without IP passthrough, you have two options:

1. Get a static IP address from your carrier, which I've done and worked great for remoting in, but often expensive.
2. The better solution is to create a VPN setup whereby the LTE gadget, as soon as it's turned on, dials out to the serving router and initiates a tunnel. Once the tunnel is up, you can, at any time, remote in via the local IP address on the LTE gadget side. It's essentially the LTE gadget remoting into the server side router and stands ready for you to reach back in.

Hope this helps.
 
nikc
Member Candidate
Member Candidate
Posts: 181
Joined: Wed Jul 13, 2016 6:05 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Sat Sep 09, 2017 9:26 pm

Anyone have any idea what this is ?

Latest RC build - 6.41rc26

lte - added Passthrough support (CLI only);

Spotted it in the notes ....
 
W4WN
just joined
Posts: 9
Joined: Mon Jul 07, 2014 6:09 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Mon Sep 11, 2017 4:10 am

+1

Any news? I have several RB912UAG-2HPnD's with Sierra Wireless MC7700 Mini-PCIe LTE aircards I'm trying to use for an IoT project. They are very stable and work great except for the inability to remote into them from outside. If I could get the LTE Public IP out to the ether1 & wlan it would be awesome. I'd be happy to provide any logs or information.
W4WN,

My apologies in advance if I misunderstood your post. Nonetheless...

Your screenshot above suggests that you are subscribed to a cellular connection which gets you a dynamic IP address. Getting IP passthrough working on the MC7700 will not, on its own, allow you to remote in from the outside. The problem is that the IP address doled out by the cellular carriers is, on purpose, not routable (hence the weird message pointed to by the red arrow). If it were, you could still remote in without IP passthrough using DDNS and port forwarding into the router, just like with a home/office dynamic IP scenario.

To solve this, with or without IP passthrough, you have two options:

1. Get a static IP address from your carrier, which I've done and worked great for remoting in, but often expensive.
2. The better solution is to create a VPN setup whereby the LTE gadget, as soon as it's turned on, dials out to the serving router and initiates a tunnel. Once the tunnel is up, you can, at any time, remote in via the local IP address on the LTE gadget side. It's essentially the LTE gadget remoting into the server side router and stands ready for you to reach back in.

Hope this helps.
Thanks MikroGik, your help is much appreciated. I see what you're saying about a cellular carrier assigned IP being un-routable.
I will attempt to learn how to implement your suggested VPN option. Unfortunately I'm not an IP networking expert - if you could point me in the direction of some information on how to setup a tunnel I'd appreciate it. One question that comes to mind: would the VPN client in the LTE gadget need a server side router on a static IP to "dial out" to or could DDNS be made to work on both ends?
 
MikroGik
just joined
Posts: 14
Joined: Tue Dec 23, 2014 3:23 am

Re: ** WE WANT A LTE BRIDGE-MODE **

Tue Sep 12, 2017 6:12 pm

Thanks MikroGik, your help is much appreciated. I see what you're saying about a cellular carrier assigned IP being un-routable.
I will attempt to learn how to implement your suggested VPN option. Unfortunately I'm not an IP networking expert - if you could point me in the direction of some information on how to setup a tunnel I'd appreciate it. One question that comes to mind: would the VPN client in the LTE gadget need a server side router on a static IP to "dial out" to or could DDNS be made to work on both ends?
W4WN,

Your question first: On the server end, yes, you can use DDNS, no need for static IP. On the client side, you don't care what IP address the gadget receives from the cellular provider, as long as the LTE gadget knows, once its online, to dial into the DDNS address of the the server router. Once it does, the tunnel will be established. And since you will have entered into the server router the fixed local IP address you've chosen for the LTE gadget, it can reach out at any time, once the tunnel is up, to the same local address. Consequently, there's no need for ddns on the client side.

So, the VPN we're talking about is in fact a "site-to-site" VPN. Which means that on both ends there is a local network of multiple possible host machines behind the router, even if it's only one (here, the LTE gadget). So not just the server side, but also the LTE gadget side must be a router.

I recommend chosing L2TP over IPSec site-to-site VPN. With the latest versions of ROS, it's much easier to set up and has the added advantage that you can also a remote-access VPN in from either a Win or Mac laptop, both of which can easily support L2TP over IPSec.

I recommend going over this MT manual page and its diagrams first to familiarize yourself with whole thing: https://wiki.mikrotik.com/wiki/Manual:I ... -Site_L2TP. Sections 5.1 and 5.2. Take care when googling MikroTik site-to-site L2TP/IPsec as most info out there is now obsolete given the latest ease-of-use modifications by MikroTik in setting up this type of VPN.

Happy to answer further questions.
 
cpu
just joined
Posts: 4
Joined: Mon Sep 25, 2017 10:20 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Mon Sep 25, 2017 10:27 pm

I've got question regarding WAP LTE KIT:
To set it in passthrough mode I need:
/interface lte apn add name=internet passthrough-interface=bridge
/interface lte set lte1 apn=internet

??
I'ts running bridge mode - will be connected to ether1 on hAP AC and latest RC firmware is there too so I'm checking what's missing. Cheers!
 
uldis
MikroTik Support
MikroTik Support
Posts: 3425
Joined: Mon May 31, 2004 2:55 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Tue Sep 26, 2017 9:46 am

I've got question regarding WAP LTE KIT:
To set it in passthrough mode I need:
/interface lte apn add name=internet passthrough-interface=bridge
/interface lte set lte1 apn=internet

??
I'ts running bridge mode - will be connected to ether1 on hAP AC and latest RC firmware is there too so I'm checking what's missing. Cheers!
Yes. those are the correct commands. You will have only the hap ac connected to the wap lte? If not, then you need to specify the passthrough-mac aswell with the hap ac ether1 mac address.
Also note that you will not be able to connect to the wap lte via the passthrough host, so my suggestion would be to create a vlan between the wap lte and hap ac or maybe remove the wlan1 from the bridge on the wap lte so you can later connect to the wap lte via wireless if you would like to change the configuration.
 
cpu
just joined
Posts: 4
Joined: Mon Sep 25, 2017 10:20 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Tue Sep 26, 2017 10:22 am

Thank you for reply.

My situation looks like this:
I've got hAP AC, WAP LTE and HEX PoE. Building house right now and idea for network is to connect:
hAP AC and HEX PoE using SFP <- HEX PoE will be acting as a switch so all ethernet interfaces will be in bridge as I need extra 3-4 ports with PoE to power my RPi in different rooms (they will be together in one room)
WAP LTE will be in the attic connected to that pair I've just mentioned using PoE, I think I'll assign static IP and direct all traffic from LAN (in hAP AC) to that IP address

So hAP AC + HEX PoE using SFP gives me 10 ethernet ports with PoE on 6 on them (I need 3-4 PoE), hAP AC acts as a router for LAN.
To get internet hAP will be connected with WAP LTE (using VLAN?) and WAP LTE will have static IP assigned that will be my gateway IP.

If anyone can comment any of those ideas would be great.

## EDIT
Passthrough is postponed as I need to get public IP from my cellular provider.
 
User avatar
matiaszon
Member
Member
Posts: 305
Joined: Mon Jul 09, 2012 9:26 am

Re: ** WE WANT A LTE BRIDGE-MODE **

Sun Oct 08, 2017 3:23 pm

I have spare RB951G that I wanted to try with Huawei E3372s-153 (Megafon provider). After puting commands with passthrough, apn etc. on ether1, and connecting ether1 to my laptop, my computer doesn't get any IP form MikroTik. Is this modem supported or am I missing something?
/system resource usb print detail 
 0 device="1:1" vendor="Linux 3.3.5 ehci_hcd" name="RB400 EHCI" serial-number="rb400_usb" 
   vendor-id="0x1d6b" device-id="0x0002" speed="480 Mbps" ports=1 usb-version="2.00" 

 1 device="1:3" vendor="HUAWEI_MOBILE" name="HUAWEI_MOBILE" vendor-id="0x12d1" 
   device-id="0x14dc" speed="480 Mbps" ports=0 usb-version="2.10"
Eveyrthing seems to be fine according to list of supported modems?
 
eriitguy
Member Candidate
Member Candidate
Posts: 197
Joined: Thu Jan 26, 2017 1:16 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Mon Oct 09, 2017 9:30 am

matiaszon,

We have tried similar modem and get similar issue.
Mikrotik support replied that they found an issue and it was fixed in v6.41rc39. We are waiting this to be published in order to test it.


Thank you!
 
User avatar
matiaszon
Member
Member
Posts: 305
Joined: Mon Jul 09, 2012 9:26 am

Re: ** WE WANT A LTE BRIDGE-MODE **

Mon Oct 09, 2017 10:55 am

Thanks for the info!
 
eriitguy
Member Candidate
Member Candidate
Posts: 197
Joined: Thu Jan 26, 2017 1:16 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Wed Oct 11, 2017 3:38 pm

Thanks for the info!
We still can't get it working with 6.41rc44.
Applied configuration:
#
# /system reset-configuration skip-backup=yes
#
/system logging add topics=lte
#
/interface lte apn print
/interface lte apn add apn=profile1 passthrough-interface=ether3
/interface lte set lte1 apn=profile1
#
/interface lte apn set 0 name=profile1
/interface lte apn set 0 apn=internet
#
# /system sup-output name=supout-05-Huawei-E3372h-153-LTE-passtrough-6.41rc44
#
"[Ticket#2017100222000413] RE: LTE Passtrough with Huawei 3372 LTE modem".
Waiting additional information from support.


Thank you!
 
User avatar
matiaszon
Member
Member
Posts: 305
Joined: Mon Jul 09, 2012 9:26 am

Re: ** WE WANT A LTE BRIDGE-MODE **

Fri Oct 13, 2017 10:55 pm

I got it working with rc44 but not the way I was thinking it will work. My laptop got IP from Huawei's LAN range (198.168.8.0/24). I thought it will get IP directly from ISP...
 
User avatar
matiaszon
Member
Member
Posts: 305
Joined: Mon Jul 09, 2012 9:26 am

Re: ** WE WANT A LTE BRIDGE-MODE **

Sun Oct 15, 2017 1:34 pm

So, is this the proper way it is should work, or am I missing something? In my opinion it doesn't make sense. NAT is USB modem anyway, and we all wanted to have one and only NAT on MikroTik.
 
eriitguy
Member Candidate
Member Candidate
Posts: 197
Joined: Thu Jan 26, 2017 1:16 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Mon Oct 16, 2017 5:36 pm

I got it working with rc44 but not the way I was thinking it will work. My laptop got IP from Huawei's LAN range (198.168.8.0/24). I thought it will get IP directly from ISP...
May you please provide a configuration which is working for you?


Thank you!
 
User avatar
matiaszon
Member
Member
Posts: 305
Joined: Mon Jul 09, 2012 9:26 am

Re: ** WE WANT A LTE BRIDGE-MODE **

Tue Oct 17, 2017 7:17 pm

I got it working with rc44 but not the way I was thinking it will work. My laptop got IP from Huawei's LAN range (198.168.8.0/24). I thought it will get IP directly from ISP...
May you please provide a configuration which is working for you?


Thank you!
This one on wiki works good, but not the way I wanted...

https://wiki.mikrotik.com/wiki/Manual:I ... assthrough
 
User avatar
Ferrograph
Frequent Visitor
Frequent Visitor
Posts: 65
Joined: Wed Mar 07, 2012 4:05 am

Re: ** WE WANT A LTE BRIDGE-MODE **

Mon Oct 23, 2017 5:14 pm

+1 for LTE bridge mode.
But, I made a post here with some information on possible standardised solution to this bridge mode thing collated from hours and hours of tinkering and research. Unfortunately I didnt give the post a very good title and forgot to put anything to do with LTE in the title. Oh well. Here it is...

"CDC_NCM Support should be possible?"
viewtopic.php?f=1&t=126263&p=621335&hilit=e3372#p621335
 
uldis
MikroTik Support
MikroTik Support
Posts: 3425
Joined: Mon May 31, 2004 2:55 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Mon Oct 23, 2017 11:20 pm

CDC_NCM is in our to-do list but I can't comment when we will start to work on that.
 
User avatar
Ferrograph
Frequent Visitor
Frequent Visitor
Posts: 65
Joined: Wed Mar 07, 2012 4:05 am

Re: ** WE WANT A LTE BRIDGE-MODE **

Wed Oct 25, 2017 2:15 am

CDC_NCM is in our to-do list but I can't comment when we will start to work on that.
On the todo list will do for me! Thanks uldis.
 
vytas86
just joined
Posts: 3
Joined: Sun Jan 28, 2018 5:23 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Sun Jan 28, 2018 11:47 pm

Hello, as I see Rb working in passthrough mode can not work as a router in this case it can not ping any IP using ping tool. So I can not write script which could reboot system if it stops pinging i.e.8.8.8.8. So is there a way to reboot it without pinging, just on lte1 interface link goes down?
 
opkky
just joined
Posts: 4
Joined: Mon Jan 02, 2017 8:19 am

Re: ** WE WANT A LTE BRIDGE-MODE **

Mon Feb 05, 2018 2:10 pm

Guys,

has anybody tested if Telewell USB modem works in bridge mode with Mikrotik?
https://www.telewell.fi/en/product/3g4g ... at-4-modem

Yesterday I chatted with Telewell support and they told that pass through mode is supported by their modem but not sure if Mikrotik can recognize this modem.

Any ideas?

Great thanks for support.
 
Forage
just joined
Posts: 14
Joined: Tue Aug 22, 2017 8:39 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Sat Feb 24, 2018 8:16 pm

I've got question regarding WAP LTE KIT:
To set it in passthrough mode I need:
/interface lte apn add name=internet passthrough-interface=bridge
/interface lte set lte1 apn=internet

??
I'ts running bridge mode - will be connected to ether1 on hAP AC and latest RC firmware is there too so I'm checking what's missing. Cheers!
Yes. those are the correct commands. You will have only the hap ac connected to the wap lte? If not, then you need to specify the passthrough-mac aswell with the hap ac ether1 mac address.
Also note that you will not be able to connect to the wap lte via the passthrough host, so my suggestion would be to create a vlan between the wap lte and hap ac or maybe remove the wlan1 from the bridge on the wap lte so you can later connect to the wap lte via wireless if you would like to change the configuration.
I'm basically trying to do the same, combining the two devices with an LTE modem, but without the need for passthrough. Would you mind elaborating a bit more on the subject in the thread I created for discussing this?
 
User avatar
spippan
Member Candidate
Member Candidate
Posts: 100
Joined: Wed Nov 12, 2014 1:00 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Mon Feb 26, 2018 12:06 pm

need working passthrough on a SXT LTE (rOS 6.41.2 stable)

--> viewtopic.php?f=2&t=113562&p=644608#p644608
---
raiffeisen data center infrastructure and security
...stay curious
 
uldis
MikroTik Support
MikroTik Support
Posts: 3425
Joined: Mon May 31, 2004 2:55 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Mon Feb 26, 2018 12:54 pm

need working passthrough on a SXT LTE (rOS 6.41.2 stable)

--> viewtopic.php?f=2&t=113562&p=644608#p644608
SXT LTE doesn't have pass-though support.
 
User avatar
spippan
Member Candidate
Member Candidate
Posts: 100
Joined: Wed Nov 12, 2014 1:00 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Tue Mar 20, 2018 3:11 pm

need working passthrough on a SXT LTE (rOS 6.41.2 stable)

--> viewtopic.php?f=2&t=113562&p=644608#p644608
SXT LTE doesn't have pass-though support.
but why? is it a software limitation or is it because of hardware boundaries?? this is a pitty, because the SXT LTE would be THE perfect device for that!
---
raiffeisen data center infrastructure and security
...stay curious
 
uldis
MikroTik Support
MikroTik Support
Posts: 3425
Joined: Mon May 31, 2004 2:55 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Tue Mar 20, 2018 4:43 pm

need working passthrough on a SXT LTE (rOS 6.41.2 stable)

--> viewtopic.php?f=2&t=113562&p=644608#p644608
SXT LTE doesn't have pass-though support.
but why? is it a software limitation or is it because of hardware boundaries?? this is a pitty, because the SXT LTE would be THE perfect device for that!
The driver that is used for the SXT LTE modem doesn't have such functionality - so we can't add that option.
 
Admonishesdavid
just joined
Posts: 1
Joined: Sun Apr 15, 2018 7:12 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Sun Apr 15, 2018 7:26 pm

I am on a current project useing 8 lte hotspot router throught hawiu.
I Only have 2 cell carrer runing only gsm T-Mobile at@t I am wonder if I brige 4 at@t sim on 4 hawiu router/moden 4g lte through 4 different VPN Clint at different point and run 4 T-Mobile sim on 4 hawiu router/modem 4g lte throught 4 different VPN Clint point

Thank you
 
kfc173
just joined
Posts: 4
Joined: Tue Apr 24, 2018 11:09 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Tue Apr 24, 2018 11:24 pm

I have noticed with the new bridges that you can add an interface list as a bridge port .. and add a lte interface to a list
Ayone tried to add a lte interface inside the LAN bridge via a list ? I could try but dont want to brick my device :)
 
ZAFER
just joined
Posts: 1
Joined: Wed May 02, 2018 9:06 am

Re: ** WE WANT A LTE BRIDGE-MODE **

Sat May 05, 2018 8:45 pm

Hello there;
I live the same problem. mf 190 or pppout client running different brand and model 3g modems port forwarding is done without problems. I can not port forward when I want to use a 4g or 3g lte usb modem to get higher speed. I have tried many products from many brands, but the modems I have found have wan ip address on it and take the iprot address as a client. I could not find a device that works in Bridge mode. I am using 4g / 3g modems mf831 - huawei e3131cs-2 - huawei k5160 - huawei e 3531 - huawei e353. Does anyone know how to run these modems in bridge mode or port for a usb modem running lte?
 
Watermaniak
just joined
Posts: 1
Joined: Thu Jun 07, 2018 12:42 am

Re: ** WE WANT A LTE BRIDGE-MODE **

Thu Jun 07, 2018 12:55 am

I've got question regarding WAP LTE KIT:
To set it in passthrough mode I need:
/interface lte apn add name=internet passthrough-interface=bridge
/interface lte set lte1 apn=internet

??
I'ts running bridge mode - will be connected to ether1 on hAP AC and latest RC firmware is there too so I'm checking what's missing. Cheers!
Yes. those are the correct commands. You will have only the hap ac connected to the wap lte? If not, then you need to specify the passthrough-mac aswell with the hap ac ether1 mac address.
Also note that you will not be able to connect to the wap lte via the passthrough host, so my suggestion would be to create a vlan between the wap lte and hap ac or maybe remove the wlan1 from the bridge on the wap lte so you can later connect to the wap lte via wireless if you would like to change the configuration.
Hi uldis, this is exactly what I would like to achieve this. so besides the above commands, which commands do I need to execute to achieve the above situation?
 
User avatar
sebastia
Forum Guru
Forum Guru
Posts: 1776
Joined: Tue Oct 12, 2010 3:23 am
Location: Antwerp, BE

Re: ** WE WANT A LTE BRIDGE-MODE **

Mon Jul 30, 2018 3:33 pm

The vlan interface created on the "host" (client machine) needs to be wrapped in a bridge to allow the change of MAC. Current impl of pass-through (SXT lte kit with 6.42.2) hijacks all traffic by mac (of the host), disregarding the vlan tags.

Like so: https://wiki.mikrotik.com/wiki/Change_M ... _interface
 
User avatar
spippan
Member Candidate
Member Candidate
Posts: 100
Joined: Wed Nov 12, 2014 1:00 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Wed Aug 01, 2018 11:21 am

need working passthrough on a SXT LTE (rOS 6.41.2 stable)

--> viewtopic.php?f=2&t=113562&p=644608#p644608
SXT LTE doesn't have pass-though support.
but why? is it a software limitation or is it because of hardware boundaries?? this is a pitty, because the SXT LTE would be THE perfect device for that!
The driver that is used for the SXT LTE modem doesn't have such functionality - so we can't add that option.
okay so this concerns the PASSTHROUGH mode, right? but what about the option to add the "ether1" and "lte" interface to a BRIDGE via CLI or WINBOX?
---
raiffeisen data center infrastructure and security
...stay curious
 
archerious
just joined
Posts: 11
Joined: Sun Aug 26, 2018 7:50 am

Re: ** WE WANT A LTE BRIDGE-MODE **

Fri Aug 31, 2018 1:40 pm

+1 for LTE bridge mode in RouterOS
While waiting for this to be implemented, I'm currently using OpenWrt, where it can be easily configured without any problem.
How?
 
User avatar
spippan
Member Candidate
Member Candidate
Posts: 100
Joined: Wed Nov 12, 2014 1:00 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Thu Oct 18, 2018 4:12 pm

need working passthrough on a SXT LTE (rOS 6.41.2 stable)

--> viewtopic.php?f=2&t=113562&p=644608#p644608
SXT LTE doesn't have pass-though support.
but why? is it a software limitation or is it because of hardware boundaries?? this is a pitty, because the SXT LTE would be THE perfect device for that!
The driver that is used for the SXT LTE modem doesn't have such functionality - so we can't add that option.
okay so this concerns the PASSTHROUGH mode, right? but what about the option to add the "ether1" and "lte" interface to a BRIDGE via CLI or WINBOX?
please let me know how this would be possible on a SXTLTE (not the LTE Kit version)...
---
raiffeisen data center infrastructure and security
...stay curious
 
Kola
newbie
Posts: 46
Joined: Fri Aug 02, 2013 11:42 am

Re: ** WE WANT A LTE BRIDGE-MODE **

Thu Nov 22, 2018 1:46 pm

The vlan interface created on the "host" (client machine) needs to be wrapped in a bridge to allow the change of MAC. Current impl of pass-through (SXT lte kit with 6.42.2) hijacks all traffic by mac (of the host), disregarding the vlan tags.
Thank you, sebastia! This important info should be in the Wiki! I've spent quite a time trying to figure it out why vlan doesn't work.
 
User avatar
sebastia
Forum Guru
Forum Guru
Posts: 1776
Joined: Tue Oct 12, 2010 3:23 am
Location: Antwerp, BE

Re: ** WE WANT A LTE BRIDGE-MODE **

Thu Nov 22, 2018 1:51 pm

Another suggested solution from support: bridge lte to a vlan interface.
I haven't tested it though.
 
nicolash
just joined
Posts: 3
Joined: Mon Aug 20, 2018 1:27 pm

Re: ** WE WANT A LTE BRIDGE-MODE **

Wed Dec 26, 2018 8:53 pm

CDC_NCM is in our to-do list but I can't comment when we will start to work on that.
Hi @uldis, last year you were mentionning CDC_NCM is on your todo-list, I tried some time ago to use a Huawei e3372 in "stick" mode (CDC_NCM) instead of HiLink mode, but no luck, besides using it in PPP mode. Have you made any progress on CDC_NCM, or still working on it?

Thanks!

Who is online

Users browsing this forum: No registered users and 90 guests