Community discussions

 
conchalnet
Member Candidate
Member Candidate
Topic Author
Posts: 274
Joined: Thu Nov 03, 2005 1:44 pm
Location: Brazil

Renew IP address of PPPoE client

Tue Jan 17, 2017 3:14 pm

Hi,

I need to change an IP address of one customer that is connected to our network throught a PPPoE server configurated on a CCR1036. But every time the customer connects the Mikrotik give him the same IP address!

How can I force the Mikrotik to renew the IP address of PPPoE connections on every reconnection???

Regards

Fabrício
 
boardman
Member Candidate
Member Candidate
Posts: 260
Joined: Fri May 28, 2004 11:10 pm
Location: Mexico
Contact:

Re: Renew IP address of PPPoE client

Thu Dec 06, 2018 12:28 am

Hello,

Did you ever found the solution for this?

Best
 
evince
Member Candidate
Member Candidate
Posts: 293
Joined: Thu Jul 05, 2012 12:11 pm
Location: Weiswampach - Luxemburg
Contact:

Re: Renew IP address of PPPoE client

Thu Dec 06, 2018 12:37 pm

Hello,

try to first remove his entry in the DHCP Lease, and then reconnect it.
 
boardman
Member Candidate
Member Candidate
Posts: 260
Joined: Fri May 28, 2004 11:10 pm
Location: Mexico
Contact:

Re: Renew IP address of PPPoE client

Thu Dec 06, 2018 7:29 pm

Hello,

try to first remove his entry in the DHCP Lease, and then reconnect it.
Thanks for your reply, but this is PPPoE not DHCP, IP's are taken from an IP-pool, not DHCP

Still stuck on this one.

Best
 
User avatar
amt
Member
Member
Posts: 471
Joined: Fri Jan 16, 2015 2:05 pm

Re: Renew IP address of PPPoE client

Fri Dec 07, 2018 10:41 am

Hi,

I need to change an IP address of one customer that is connected to our network throught a PPPoE server configurated on a CCR1036. But every time the customer connects the Mikrotik give him the same IP address!

How can I force the Mikrotik to renew the IP address of PPPoE connections on every reconnection???

Regards

Fabrício
divide your ip pool in many pool, I tested before and its change when device disconnect and connect again
 
boardman
Member Candidate
Member Candidate
Posts: 260
Joined: Fri May 28, 2004 11:10 pm
Location: Mexico
Contact:

Re: Renew IP address of PPPoE client

Sat Dec 08, 2018 4:42 am

Thanks for your answer,

What do you mean with "I tested before and its change"

"divide your ip pool in many pool, I tested before and its change when device disconnect and connect again"

Sorry, I don't understand what you mean, I understand on how to divide into many pools but the rest of the phrase I don't.
 
User avatar
amt
Member
Member
Posts: 471
Joined: Fri Jan 16, 2015 2:05 pm

Re: Renew IP address of PPPoE client

Sat Dec 08, 2018 9:39 am

I mean if you use /24 for pppoe pool divide it to /25 and create 2 x ip pool and use next pool option

here is an example
/ip pool
add name=PPPoE_Pool-1 ranges=100.64.16.0/25  next-pool=pool1
add name=pppoe_pool-2 ranges=100.64.16.128/25
 
boardman
Member Candidate
Member Candidate
Posts: 260
Joined: Fri May 28, 2004 11:10 pm
Location: Mexico
Contact:

Re: Renew IP address of PPPoE client

Sat Dec 08, 2018 10:56 pm

Thanks, will try this.
 
ciberica
just joined
Posts: 14
Joined: Mon Mar 19, 2018 6:22 am

Re: Renew IP address of PPPoE client

Sun Dec 09, 2018 8:51 am

Hello friend, how have you managed to change the ip every so often to pppoe customers?
 
boardman
Member Candidate
Member Candidate
Posts: 260
Joined: Fri May 28, 2004 11:10 pm
Location: Mexico
Contact:

Re: Renew IP address of PPPoE client

Mon Dec 10, 2018 10:45 pm

Hello friend, how have you managed to change the ip every so often to pppoe customers?
Haven't tried it yet...

Who is online

Users browsing this forum: tricksol and 81 guests