Community discussions

 
User avatar
nocmonkee
just joined
Topic Author
Posts: 4
Joined: Thu May 04, 2017 8:07 am

HOWTO: UVERSE and Tunneled ATT IPV6 aka 6RD/6to4 or NATIVE using a PACE RG

Thu May 04, 2017 8:18 am

In order for this to work there are 2 requirements of the ATT 2wire/arris RG. The Model of mine is NVG589 on Uverse Gigapower aka gpon.
First login to the Uverse 2wire/arris RG and have "ip pass through" with "DHCPS-fixed" enabled to put your ATT assigned public ipv4 address on your mikrotik by MAC.
Second in the Uverse 2wire/arris RG disable IPV6 and reboot the ATT RG.
With your public ipv4 address in hand goto this website: http://silmor.de/ipaddrcalc.html#ip46
In 6to4 and 6RD Network Prefix
Change the Provider prefix to 2602:300:/28
Customer IPv4: "Your ATT Public IPV4 IP." aka $ATT_WAN_IPV4_IP
IPv6 Customer prefix: What the calculator spits out when you hit the ISP -> Customer button. "2602:3XX:XXXX:XXXX"

ATT Anycast IP=12.83.49.81

With that info you can fill this in and paste it into terminal and enjoy IPV6 on your UVERSE with your own /60 from ATT.

/interface 6to4
add clamp-tcp-mss=yes disabled=no dont-fragment=no dscp=inherit local-address=$ATT_WAN_IPV4_IP mtu=1480 name=UVERSE remote-address=12.83.49.81
/queue interface
set UVERSE queue=no-queue
/ipv6 pool
add name=pool1 prefix=2602:3XX:XXX:XX1::/64 prefix-length=64
add name=pool2 prefix=2602:3XX:XXX:XX2::/64 prefix-length=64
/ipv6 address
add address=2602:3XX:XXX:XXX::/60 advertise=no disabled=no eui-64=no from-pool="" interface=UVERSE no-dad=no
add address=/64 advertise=yes disabled=no eui-64=no from-pool=pool1 interface=$LANINTERFACE1 no-dad=no
add address=/64 advertise=yes disabled=no eui-64=no from-pool=pool2 interface=$LANINTERFACE2 no-dad=no
/ipv6 firewall filter
add chain=input comment="Allow established connections" connection-state=established
add chain=input comment="Allow related connections" connection-state=related
add chain=input comment="Allow limited ICMP" protocol=icmpv6
add chain=input comment="Allow UDP" protocol=udp
add action=drop chain=input
add chain=forward comment="Allow related connections" connection-state=established,related
/ipv6 nd
set [ find default=yes ] advertise-dns=yes advertise-mac-address=yes disabled=no hop-limit=unspecified interface=all managed-address-configuration=no mtu=unspecified \
other-configuration=yes ra-delay=3s ra-interval=3m20s-10m ra-lifetime=30m reachable-time=unspecified retransmit-interval=unspecified
/ipv6 nd prefix default
set autonomous=yes preferred-lifetime=1w valid-lifetime=4w2d
/ipv6 route
add disabled=no distance=1 dst-address=2000::/3 gateway=UVERSE scope=30 target-scope=10

In order to verify it's working browse http://ipv6test.google.com/
or from cmd/cli ping ipv6.google.com
Last edited by nocmonkee on Mon Jan 08, 2018 9:43 pm, edited 1 time in total.
 
User avatar
nocmonkee
just joined
Topic Author
Posts: 4
Joined: Thu May 04, 2017 8:07 am

Re: HOWTO: UVERSE and Tunneled ATT IPV6 aka 6RD/6to4

Mon Jan 08, 2018 9:42 pm

I had to upgrade to a Pace 5268AC and I was able to get native ipv6 working with it. Mikrotik needs to be configured for dhcp on the wan and the Pace needs to be setup for dmz+. in the Lan tab under "Lan IP Allocation" select the mikrotik and select disable firewall and save. By default my Pace had ipv6 enabled on the Lan side.

/ipv6 settings
set accept-redirects=no accept-router-advertisements=yes
/ipv6 address
add address=::1 from-pool=IPV6-1 interface=LAN
/ipv6 dhcp-client
add add-default-route=yes interface=WAN pool-name=IPV6-1 prefix-hint=::/64 request=address,prefix
/ipv6 firewall filter
add action=accept chain=input comment="Allow established connections" connection-state=established
add action=accept chain=input comment="Allow related connections" connection-state=related
add action=accept chain=input comment="Allow limited ICMP" protocol=icmpv6
add action=accept chain=input comment="Allow UDP" protocol=udp
add action=drop chain=input
add action=accept chain=forward comment="Allow established connections" connection-state=established,related,new
add action=accept chain=forward comment="Allow related connections" connection-state=established,related
/ipv6 nd
set [ find default=yes ] advertise-mac-address=no hop-limit=64 interface=LAN other-configuration=yes

Who is online

Users browsing this forum: No registered users and 40 guests