Community discussions

MUM Europe 2020
 
wfalcon
just joined
Topic Author
Posts: 24
Joined: Thu Mar 23, 2017 3:03 pm

Merge 2 PPPOE WANs

Sun Oct 01, 2017 5:34 pm

Hello guys,
I've subscribed for two internet accounts and the ISP gave me two different credentials to put in a PPOE client.
i have RB951G-2HnD that have the following setup
/interface bridge
add name=Bridge-Local protocol-mode=none
add name=Bridge-UPLink protocol-mode=none
/interface ethernet
set [ find default-name=ether1 ] name=01_UPLINK
set [ find default-name=ether2 ] name=02_UPLINK
set [ find default-name=ether3 ] mac-address=6C:3B:6B:DB:4A:5F name=\
    03_Wan01
set [ find default-name=ether4 ] name=04_Wan02
set [ find default-name=ether5 ] name=05_LAN
/interface pppoe-client
add add-default-route=yes allow=pap,chap disabled=no interface=03_Wan01 \
    name=PPPoE-Out1 password=* use-peer-dns=yes user=*
add add-default-route=yes allow=pap,chap interface=04_Wan02 name=\
    PPPoE-Out2 password=* use-peer-dns=yes user=*
/interface wireless security-profiles
add authentication-types=wpa2-psk eap-methods="" management-protection=\
    allowed mode=dynamic-keys name=Password1 supplicant-identity="" \
    wpa2-pre-shared-key=*
/interface wireless
set [ find default-name=wlan1 ] ampdu-priorities=0,1 band=2ghz-b/g/n \
    channel-width=20/40mhz-Ce disabled=no frequency-mode=superchannel \
    mode=ap-bridge name=WLAN radio-name=WLAN security-profile=Password1 \
    ssid=Test wds-default-bridge=Bridge-Local wds-mode=dynamic
/ip pool
add name=Pool-Local ranges=192.168.100.100-192.168.100.199
/ip dhcp-server
add address-pool=Pool-Local disabled=no interface=Bridge-Local \
    lease-time=1d name=DHCP-Local
/interface bridge port
add bridge=Bridge-UPLink interface=01_UPLINK
add bridge=Bridge-UPLink interface=02_UPLINK
add bridge=Bridge-Local interface=05_LAN
add bridge=Bridge-Local interface=WLAN
/ip address
add address=192.168.100.1/24 interface=Bridge-Local network=\
    192.168.100.0
/ip dhcp-server network
add address=192.168.100.0/24 gateway=192.168.100.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 name=router.lan
/ip firewall nat
add action=masquerade chain=srcnat out-interface=PPPoE-Out1
add action=masquerade chain=srcnat out-interface=PPPoE-Out2
/system clock
set time-zone-name=*
/system ntp client
set enabled=yes primary-ntp=*

how can i merge both WANs
1st WAN = 5MBps + 2nd WAN = 5MBps so i can get 10MBps?

thanks in advance

edit: what i tried: - bonding both wans
- tried to split users each on different pppoe but that's not what i want ( it was a test )
edit2: i have a switch that is taking as input : port1 = ISP main cable that have the 2 accounts
port3 = connected to port3 on the mikrotik
port4 = connected to port4 on the mikrotik
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8345
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: Merge 2 PPPOE WANs  [SOLVED]

Mon Oct 02, 2017 11:23 am

https://wiki.mikrotik.com/wiki/Manual:P ... _Balancing

or, for the start, you may just try
/interface pppoe-client set [find] default-route-distance=5
/ip route add gateway=PPPoE-Out1,PPPoE-Out2
it will balance equally, but problems with secure websites may appear
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
wfalcon
just joined
Topic Author
Posts: 24
Joined: Thu Mar 23, 2017 3:03 pm

Re: Merge 2 PPPOE WANs

Mon Oct 02, 2017 12:11 pm

https://wiki.mikrotik.com/wiki/Manual:P ... _Balancing

or, for the start, you may just try
/interface pppoe-client set [find] default-route-distance=5
/ip route add gateway=PPPoE-Out1,PPPoE-Out2
it will balance equally, but problems with secure websites may appear
thanks for your reply, unfortunately that wont work because i have the following :

i'm thinking of contacting support because i couldnt find anything similar to my situation.. all i see on google or in here are 2 wans on different eth ports while i have 2 accounts on the same eth port
You do not have the required permissions to view the files attached to this post.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8345
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: Merge 2 PPPOE WANs

Mon Oct 02, 2017 1:09 pm

ether3 and ether4 are different ports =)

moreover, you have different pppoe interfaces

this will work. just try.
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
wfalcon
just joined
Topic Author
Posts: 24
Joined: Thu Mar 23, 2017 3:03 pm

Re: Merge 2 PPPOE WANs

Mon Oct 02, 2017 2:20 pm

ether3 and ether4 are different ports =)

moreover, you have different pppoe interfaces

this will work. just try.
i tried exactly what the guide/example says, i ofcourse changed IPs accordingly, but still i'm not able to get them merged
and btw i'm getting conn. time out when enabling both PPPOE interfaces.. if i enable 1 of them at a time i get internet access + full speed ( for 1 account )


edit: i will try the guide again with resetting all configuration with no defaults and i'll reply if it'll work or not.. also i will try another thing which is to get rid f the switch and use the rb951 directly from firebox
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8345
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: Merge 2 PPPOE WANs

Mon Oct 02, 2017 3:03 pm

If some config is not working - post that config with basic diagnostics (not just 'connection timeout', but ping/traceroute). We're not telepathists.
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
wfalcon
just joined
Topic Author
Posts: 24
Joined: Thu Mar 23, 2017 3:03 pm

Re: Merge 2 PPPOE WANs

Sat Oct 14, 2017 3:43 pm

If some config is not working - post that config with basic diagnostics (not just 'connection timeout', but ping/traceroute). We're not telepathists.
Hello friend, sorry for being late as i was testing every possibility.. nothing is working at all unfortunately.
please just look into the export below and tell me whats wrong ofcourse if you can
# oct/14/2017 15:25:50 by RouterOS 6.40.4
# software id = LJG6-T7CB
#
# model = 951G-2HnD
# serial number = 642E061E60F9
/interface bridge
add admin-mac=00:00:00:00:00:00 ageing-time=5m arp=enabled arp-timeout=auto auto-mac=yes disabled=no \
    fast-forward=yes forward-delay=15s max-message-age=20s mtu=auto name=Bridge-Local priority=0x8000 \
    protocol-mode=none transmit-hold-count=6
add admin-mac=00:00:00:00:00:00 ageing-time=5m arp=enabled arp-timeout=auto auto-mac=yes disabled=no \
    fast-forward=yes forward-delay=15s max-message-age=20s mtu=auto name=Bridge-UPLink priority=0x8000 \
    protocol-mode=none transmit-hold-count=6
add admin-mac=00:00:00:00:00:00 ageing-time=5m arp=enabled arp-timeout=auto auto-mac=yes disabled=no \
    fast-forward=yes forward-delay=15s max-message-age=20s mtu=auto name=bridgevwlan priority=0x8000 \
    protocol-mode=none transmit-hold-count=6
/interface ethernet
set [ find default-name=ether1 ] advertise=10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full \
    arp=enabled arp-timeout=auto auto-negotiation=yes bandwidth=unlimited/unlimited disabled=no \
    full-duplex=yes l2mtu=1598 loop-protect=default loop-protect-disable-time=5m \
    loop-protect-send-interval=5s mac-address=6C:3B:6B:DB:4A:5F master-port=none mtu=1500 name=01_UPLINK \
    orig-mac-address=6C:3B:6B:DB:4A:5F rx-flow-control=off speed=100Mbps tx-flow-control=off
set [ find default-name=ether2 ] advertise=10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full \
    arp=enabled arp-timeout=auto auto-negotiation=yes bandwidth=unlimited/unlimited disabled=no \
    full-duplex=yes l2mtu=1598 loop-protect=default loop-protect-disable-time=5m \
    loop-protect-send-interval=5s mac-address=6C:3B:6B:DB:4A:60 master-port=none mtu=1500 name=02_UPLINK \
    orig-mac-address=6C:3B:6B:DB:4A:60 rx-flow-control=off speed=100Mbps tx-flow-control=off
set [ find default-name=ether3 ] advertise=10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full \
    arp=enabled arp-timeout=auto auto-negotiation=yes bandwidth=unlimited/unlimited disabled=no \
    full-duplex=yes l2mtu=1598 loop-protect=default loop-protect-disable-time=5m \
    loop-protect-send-interval=5s mac-address=6C:3B:6B:DB:4A:5F master-port=none mtu=1500 name=03_Wan01 \
    orig-mac-address=6C:3B:6B:DB:4A:61 rx-flow-control=off speed=100Mbps tx-flow-control=off
set [ find default-name=ether4 ] advertise=10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full \
    arp=enabled arp-timeout=auto auto-negotiation=yes bandwidth=unlimited/unlimited disabled=no \
    full-duplex=yes l2mtu=1598 loop-protect=default loop-protect-disable-time=5m \
    loop-protect-send-interval=5s mac-address=6C:3B:6B:DB:4A:62 master-port=none mtu=1500 name=04_Wan02 \
    orig-mac-address=6C:3B:6B:DB:4A:62 rx-flow-control=off speed=100Mbps tx-flow-control=off
set [ find default-name=ether5 ] advertise=10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full \
    arp=enabled arp-timeout=auto auto-negotiation=yes bandwidth=unlimited/unlimited disabled=no \
    full-duplex=yes l2mtu=1598 loop-protect=default loop-protect-disable-time=5m \
    loop-protect-send-interval=5s mac-address=6C:3B:6B:DB:4A:63 master-port=none mtu=1500 name=05_LAN \
    orig-mac-address=6C:3B:6B:DB:4A:63 rx-flow-control=off speed=100Mbps tx-flow-control=off
/ip neighbor discovery
set "01_UPLINK" discover=yes
set "02_UPLINK" discover=yes
set "03_Wan01" discover=yes
set "04_Wan02" discover=yes
set "05_LAN" discover=yes
set Bridge-Local discover=yes
set Bridge-UPLink discover=yes
set bridgevwlan discover=yes
/queue interface
set Bridge-Local queue=no-queue
set Bridge-UPLink queue=no-queue
set bridgevwlan queue=no-queue
/interface ethernet switch
set 0 mirror-source=none mirror-target=none name=switch1
/interface ethernet switch port
set 0 default-vlan-id=auto vlan-header=leave-as-is vlan-mode=disabled
set 1 default-vlan-id=auto vlan-header=leave-as-is vlan-mode=disabled
set 2 default-vlan-id=auto vlan-header=leave-as-is vlan-mode=disabled
set 3 default-vlan-id=auto vlan-header=leave-as-is vlan-mode=disabled
set 4 default-vlan-id=auto vlan-header=leave-as-is vlan-mode=disabled
set 5 default-vlan-id=auto vlan-header=leave-as-is vlan-mode=disabled
/interface list
set [ find name=all ] name=all
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" group-ciphers=aes-ccm \
    group-key-update=5m interim-update=0s management-protection=disabled management-protection-key="" \
    mode=dynamic-keys mschapv2-password="" mschapv2-username="" name=default radius-eap-accounting=no \
    radius-mac-accounting=no radius-mac-authentication=no radius-mac-caching=disabled radius-mac-format=\
    XX:XX:XX:XX:XX:XX radius-mac-mode=as-username static-algo-0=none static-algo-1=none static-algo-2=\
    none static-algo-3=none static-key-0="" static-key-1="" static-key-2="" static-key-3="" \
    static-sta-private-algo=none static-sta-private-key="" static-transmit-key=key-0 supplicant-identity=\
    MikroTik tls-certificate=none tls-mode=no-certificates unicast-ciphers=aes-ccm wpa-pre-shared-key="" \
    wpa2-pre-shared-key=123
add authentication-types=wpa2-psk eap-methods="" group-ciphers=aes-ccm group-key-update=5m \
    interim-update=0s management-protection=disabled management-protection-key="" mode=dynamic-keys \
    mschapv2-password="" mschapv2-username="" name=vwlan radius-eap-accounting=no radius-mac-accounting=\
    no radius-mac-authentication=no radius-mac-caching=disabled radius-mac-format=XX:XX:XX:XX:XX:XX \
    radius-mac-mode=as-username static-algo-0=none static-algo-1=none static-algo-2=none static-algo-3=\
    none static-key-0="" static-key-1="" static-key-2="" static-key-3="" static-sta-private-algo=none \
    static-sta-private-key="" static-transmit-key=key-0 supplicant-identity="" tls-certificate=none \
    tls-mode=no-certificates unicast-ciphers=aes-ccm wpa-pre-shared-key="" wpa2-pre-shared-key=\
    1234
/interface wireless
set [ find default-name=wlan1 ] adaptive-noise-immunity=none allow-sharedkey=no ampdu-priorities=0,1 \
    amsdu-limit=8192 amsdu-threshold=8192 antenna-gain=0 area="" arp=enabled arp-timeout=auto band=\
    2ghz-b/g/n basic-rates-a/g=6Mbps basic-rates-b=1Mbps bridge-mode=enabled channel-width=20/40mhz-Ce \
    compression=no country=no_country_set default-ap-tx-limit=0 default-authentication=yes \
    default-client-tx-limit=0 default-forwarding=yes disable-running-check=no disabled=no \
    disconnect-timeout=3s distance=dynamic frame-lifetime=0 frequency=2412 frequency-mode=superchannel \
    frequency-offset=0 guard-interval=any hide-ssid=no ht-basic-mcs=\
    mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7 ht-supported-mcs="mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,\
    mcs-6,mcs-7,mcs-8,mcs-9,mcs-10,mcs-11,mcs-12,mcs-13,mcs-14,mcs-15,mcs-16,mcs-17,mcs-18,mcs-19,mcs-20,m\
    cs-21,mcs-22,mcs-23" hw-fragmentation-threshold=disabled hw-protection-mode=none \
    hw-protection-threshold=0 hw-retries=7 interworking-profile=disabled keepalive-frames=enabled l2mtu=\
    1600 mac-address=6C:3B:6B:DB:4A:64 max-station-count=2007 mode=ap-bridge mtu=1500 \
    multicast-buffering=enabled multicast-helper=default name=WLAN noise-floor-threshold=default \
    nv2-cell-radius=30 nv2-downlink-ratio=50 nv2-mode=dynamic-downlink nv2-noise-floor-offset=default \
    nv2-preshared-key="" nv2-qos=default nv2-queue-count=2 nv2-security=disabled nv2-sync-secret="" \
    on-fail-retry-time=100ms preamble-mode=both radio-name=WLAN rate-selection=advanced rate-set=default \
    rx-chains=0,1 scan-list=default security-profile=default ssid="test" \
    station-bridge-clone-mac=00:00:00:00:00:00 station-roaming=enabled supported-rates-a/g=\
    6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps supported-rates-b=1Mbps,2Mbps,5.5Mbps,11Mbps \
    tdma-period-size=2 tx-chains=0,1 tx-power-mode=default update-stats-interval=disabled vlan-id=1 \
    vlan-mode=no-tag wds-cost-range=50-150 wds-default-bridge=Bridge-Local wds-default-cost=100 \
    wds-ignore-ssid=no wds-mode=dynamic wireless-protocol=any wmm-support=disabled wps-mode=disabled
/interface wireless manual-tx-power-table
set WLAN manual-tx-powers="1Mbps:17,2Mbps:17,5.5Mbps:17,11Mbps:17,6Mbps:17,9Mbps:17,12Mbps:17,18Mbps:17,24\
    Mbps:17,36Mbps:17,48Mbps:17,54Mbps:17,HT20-0:17,HT20-1:17,HT20-2:17,HT20-3:17,HT20-4:17,HT20-5:17,HT20\
    -6:17,HT20-7:17,HT40-0:17,HT40-1:17,HT40-2:17,HT40-3:17,HT40-4:17,HT40-5:17,HT40-6:17,HT40-7:17"
/interface wireless nstreme
set WLAN disable-csma=no enable-nstreme=no enable-polling=yes framer-limit=3200 framer-policy=none
/ip neighbor discovery
set WLAN discover=yes
/interface wireless
add area="" arp=enabled arp-timeout=auto bridge-mode=enabled default-ap-tx-limit=0 \
    default-authentication=yes default-client-tx-limit=0 default-forwarding=yes disable-running-check=no \
    disabled=no hide-ssid=no interworking-profile=disabled keepalive-frames=disabled l2mtu=1600 \
    mac-address=02:00:00:AA:00:00 master-interface=WLAN max-station-count=2007 mode=ap-bridge mtu=1500 \
    multicast-buffering=disabled multicast-helper=default name=VWLAN security-profile=vwlan ssid=\
    "test2" station-bridge-clone-mac=00:00:00:00:00:00 station-roaming=enabled \
    update-stats-interval=disabled vlan-id=1 vlan-mode=no-tag wds-cost-range=0 wds-default-bridge=\
    bridgevwlan wds-default-cost=0 wds-ignore-ssid=no wds-mode=dynamic wmm-support=disabled wps-mode=\
    disabled
/ip neighbor discovery
set VWLAN discover=yes
/ip dhcp-client option
set clientid code=61 name=clientid value="0x01\$(CLIENT_MAC)"
set hostname code=12 name=hostname value="\$(HOSTNAME)"
/ip hotspot profile
set [ find default=yes ] dns-name="" hotspot-address=0.0.0.0 html-directory=hotspot \
    html-directory-override="" http-cookie-lifetime=3d http-proxy=0.0.0.0:0 login-by=cookie,http-chap \
    name=default rate-limit="" smtp-server=0.0.0.0 split-user-domain=no use-radius=no
/ip hotspot user profile
set [ find default=yes ] add-mac-cookie=yes address-list="" idle-timeout=none !insert-queue-before \
    keepalive-timeout=2m mac-cookie-timeout=3d name=default !parent-queue !queue-type shared-users=1 \
    status-autorefresh=1m transparent-proxy=no
/ip ipsec mode-config
set [ find default=yes ] name=request-only
/ip ipsec policy group
set [ find default=yes ] name=default
/ip ipsec proposal
set [ find default=yes ] auth-algorithms=sha1 disabled=no enc-algorithms=\
    aes-256-cbc,aes-192-cbc,aes-128-cbc lifetime=30m name=default pfs-group=modp1024
/ip pool
add name=Pool-Local ranges=192.168.100.100-192.168.100.199
add name=POOL-VWLAN ranges=192.168.89.10-192.168.89.254
/ip dhcp-server
add address-pool=Pool-Local authoritative=yes bootp-support=static disabled=no interface=Bridge-Local \
    lease-script="" lease-time=1d name=DHCP-Local
add address-pool=POOL-VWLAN authoritative=yes bootp-support=static disabled=no interface=bridgevwlan \
    lease-script="" lease-time=10m name=DHCP-VWLAN
/ppp profile
set *0 address-list="" !bridge !bridge-horizon !bridge-path-cost !bridge-port-priority change-tcp-mss=yes \
    !dns-server !idle-timeout !incoming-filter !insert-queue-before !interface-list !local-address name=\
    default on-down="" on-up="" only-one=default !outgoing-filter !parent-queue !queue-type !rate-limit \
    !remote-address !session-timeout use-compression=default use-encryption=default use-mpls=default \
    use-upnp=default !wins-server
set *FFFFFFFE address-list="" !bridge !bridge-horizon !bridge-path-cost !bridge-port-priority \
    change-tcp-mss=yes !dns-server !idle-timeout !incoming-filter !insert-queue-before !interface-list \
    !local-address name=default-encryption on-down="" on-up="" only-one=default !outgoing-filter \
    !parent-queue !queue-type !rate-limit !remote-address !session-timeout use-compression=default \
    use-encryption=yes use-mpls=default use-upnp=default !wins-server
/interface pppoe-client
add ac-name=aaa add-default-route=yes allow=pap,chap default-route-distance=0 dial-on-demand=no \
    disabled=no interface=03_Wan01 keepalive-timeout=10 max-mru=auto max-mtu=auto mrru=disabled name=\
    PPPoE-Out1 password=asd profile=default service-name="" use-peer-dns=yes user=aa1
add ac-name=aaa add-default-route=yes allow=pap,chap default-route-distance=0 dial-on-demand=no \
    disabled=no interface=03_Wan01 keepalive-timeout=10 max-mru=auto max-mtu=auto mrru=disabled name=\
    PPPoE-Out2 password=asd profile=default service-name="" use-peer-dns=yes user=aa2
/ip neighbor discovery
set PPPoE-Out1 discover=yes
set PPPoE-Out2 discover=yes
/queue interface
set PPPoE-Out1 queue=no-queue
set PPPoE-Out2 queue=no-queue
/queue type
set 0 kind=pfifo name=default pfifo-limit=50
set 1 kind=pfifo name=ethernet-default pfifo-limit=50
set 2 kind=sfq name=wireless-default sfq-allot=1514 sfq-perturb=5
set 3 kind=red name=synchronous-default red-avg-packet=1000 red-burst=20 red-limit=60 red-max-threshold=\
    50 red-min-threshold=10
set 4 kind=sfq name=hotspot-default sfq-allot=1514 sfq-perturb=5
set 5 kind=pcq name=pcq-upload-default pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s \
    pcq-classifier=src-address pcq-dst-address-mask=32 pcq-dst-address6-mask=128 pcq-limit=50KiB \
    pcq-rate=0 pcq-src-address-mask=32 pcq-src-address6-mask=128 pcq-total-limit=2000KiB
set 6 kind=pcq name=pcq-download-default pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s \
    pcq-classifier=dst-address pcq-dst-address-mask=32 pcq-dst-address6-mask=128 pcq-limit=50KiB \
    pcq-rate=0 pcq-src-address-mask=32 pcq-src-address6-mask=128 pcq-total-limit=2000KiB
set 7 kind=none name=only-hardware-queue
set 8 kind=mq-pfifo mq-pfifo-limit=50 name=multi-queue-ethernet-default
set 9 kind=pfifo name=default-small pfifo-limit=10
/queue interface
set "01_UPLINK" queue=only-hardware-queue
set "02_UPLINK" queue=only-hardware-queue
set "03_Wan01" queue=only-hardware-queue
set "04_Wan02" queue=only-hardware-queue
set "05_LAN" queue=only-hardware-queue
set VWLAN queue=wireless-default
set WLAN queue=wireless-default
/routing bgp instance
set default as=65530 client-to-client-reflection=yes !cluster-id !confederation disabled=no \
    ignore-as-path-len=no name=default out-filter="" redistribute-connected=no redistribute-ospf=no \
    redistribute-other-bgp=no redistribute-rip=no redistribute-static=no router-id=0.0.0.0 routing-table=\
    ""
/routing ospf instance
set [ find default=yes ] disabled=no distribute-default=never !domain-id !domain-tag in-filter=ospf-in \
    metric-bgp=auto metric-connected=20 metric-default=1 metric-other-ospf=auto metric-rip=20 \
    metric-static=20 !mpls-te-area !mpls-te-router-id name=default out-filter=ospf-out redistribute-bgp=\
    no redistribute-connected=no redistribute-other-ospf=no redistribute-rip=no redistribute-static=no \
    router-id=0.0.0.0 !routing-table !use-dn
/routing ospf area
set [ find default=yes ] area-id=0.0.0.0 disabled=no instance=default name=backbone type=default
/snmp community
set [ find default=yes ] addresses=0.0.0.0/0 authentication-password="" authentication-protocol=MD5 \
    encryption-password="" encryption-protocol=DES name=public read-access=yes security=none \
    write-access=no
/system logging action
set 0 memory-lines=1000 memory-stop-on-full=no name=memory target=memory
set 1 disk-file-count=2 disk-file-name=log disk-lines-per-file=1000 disk-stop-on-full=no name=disk \
    target=disk
set 2 name=echo remember=yes target=echo
set 3 bsd-syslog=no name=remote remote=0.0.0.0 remote-port=514 src-address=0.0.0.0 syslog-facility=daemon \
    syslog-severity=auto syslog-time-format=bsd-syslog target=remote
/user group
set read name=read policy="local,telnet,ssh,reboot,read,test,winbox,password,web,sniff,sensitive,api,romon\
    ,tikapp,!ftp,!write,!policy,!dude" skin=default
set write name=write policy="local,telnet,ssh,reboot,read,write,test,winbox,password,web,sniff,sensitive,a\
    pi,romon,tikapp,!ftp,!policy,!dude" skin=default
set full name=full policy="local,telnet,ssh,ftp,reboot,read,write,policy,test,winbox,password,web,sniff,se\
    nsitive,api,romon,dude,tikapp" skin=default
/caps-man aaa
set interim-update=disabled mac-caching=disabled mac-format=XX:XX:XX:XX:XX:XX mac-mode=as-username
/caps-man manager
set ca-certificate=none certificate=none enabled=no package-path="" require-peer-certificate=no \
    upgrade-policy=none
/caps-man manager interface
set [ find default=yes ] disabled=no forbid=no interface=all
/certificate settings
set crl-download=yes crl-use=yes
/interface bridge port
add auto-isolate=no bridge=Bridge-UPLink disabled=no edge=auto external-fdb=auto horizon=none interface=\
    01_UPLINK path-cost=10 point-to-point=auto priority=0x80
add auto-isolate=no bridge=Bridge-UPLink disabled=no edge=auto external-fdb=auto horizon=none interface=\
    02_UPLINK path-cost=10 point-to-point=auto priority=0x80
add auto-isolate=no bridge=Bridge-Local disabled=no edge=auto external-fdb=auto horizon=none interface=\
    05_LAN path-cost=10 point-to-point=auto priority=0x80
add auto-isolate=no bridge=Bridge-Local disabled=no edge=auto external-fdb=auto horizon=none interface=\
    WLAN path-cost=10 point-to-point=auto priority=0x80
add auto-isolate=no bridge=bridgevwlan disabled=no edge=auto external-fdb=auto horizon=none interface=\
    VWLAN path-cost=10 point-to-point=auto priority=0x80
/interface bridge settings
set allow-fast-path=yes use-ip-firewall=no use-ip-firewall-for-pppoe=no use-ip-firewall-for-vlan=no
/ip firewall connection tracking
set enabled=auto generic-timeout=10m icmp-timeout=10s tcp-close-timeout=10s tcp-close-wait-timeout=10s \
    tcp-established-timeout=1d tcp-fin-wait-timeout=10s tcp-last-ack-timeout=10s tcp-max-retrans-timeout=\
    5m tcp-syn-received-timeout=5s tcp-syn-sent-timeout=5s tcp-time-wait-timeout=10s tcp-unacked-timeout=\
    5m udp-stream-timeout=3m udp-timeout=10s
/ip neighbor discovery settings
set default=yes default-for-dynamic=no
/ip settings
set accept-redirects=no accept-source-route=no allow-fast-path=yes arp-timeout=30s icmp-rate-limit=10 \
    icmp-rate-mask=0x1818 ip-forward=yes max-neighbor-entries=8192 route-cache=yes rp-filter=no \
    secure-redirects=yes send-redirects=yes tcp-syncookies=no
/interface l2tp-server server
set allow-fast-path=no authentication=pap,chap,mschap1,mschap2 caller-id-type=ip-address default-profile=\
    default-encryption enabled=no ipsec-secret="" keepalive-timeout=30 max-mru=1450 max-mtu=1450 \
    max-sessions=unlimited mrru=disabled one-session-per-host=no use-ipsec=no
/interface ovpn-server server
set auth=sha1,md5 cipher=blowfish128,aes128 default-profile=default enabled=no keepalive-timeout=60 \
    mac-address=FE:8D:C6:FC:A6:5E max-mtu=1500 mode=ip netmask=24 port=1194 require-client-certificate=no
/interface pptp-server server
set authentication=mschap1,mschap2 default-profile=default-encryption enabled=no keepalive-timeout=30 \
    max-mru=1450 max-mtu=1450 mrru=disabled
/interface sstp-server server
set authentication=pap,chap,mschap1,mschap2 certificate=none default-profile=default enabled=no \
    force-aes=no keepalive-timeout=60 max-mru=1500 max-mtu=1500 mrru=disabled pfs=no port=443 \
    tls-version=any verify-client-certificate=no
/interface wireless align
set active-mode=yes audio-max=-20 audio-min=-100 audio-monitor=00:00:00:00:00:00 filter-mac=\
    00:00:00:00:00:00 frame-size=300 frames-per-second=25 receive-all=no ssid-all=no
/interface wireless cap
set bridge=none caps-man-addresses="" caps-man-certificate-common-names="" caps-man-names="" certificate=\
    none discovery-interfaces="" enabled=no interfaces="" lock-to-caps-man=no static-virtual=no
/interface wireless sniffer
set channel-time=200ms file-limit=10 file-name="" memory-limit=10 multiple-channels=no only-headers=no \
    receive-errors=no streaming-enabled=no streaming-max-rate=0 streaming-server=0.0.0.0
/interface wireless snooper
set channel-time=200ms multiple-channels=yes receive-errors=no
/ip accounting
set account-local-traffic=no enabled=no threshold=256
/ip accounting web-access
set accessible-via-web=no address=0.0.0.0/0
/ip address
add address=192.168.100.1/24 disabled=no interface=Bridge-Local network=192.168.100.0
add address=192.168.89.1/24 disabled=no interface=bridgevwlan network=192.168.89.0
/ip cloud
set ddns-enabled=no update-time=yes
/ip cloud advanced
set use-local-address=no
/ip dhcp-server config
set store-leases-disk=5m
/ip dhcp-server network
add address=192.168.89.0/24 caps-manager="" dhcp-option="" dns-server="" gateway=192.168.89.1 ntp-server=\
    "" wins-server=""
add address=192.168.100.0/24 caps-manager="" dhcp-option="" dns-server="" gateway=192.168.100.1 \
    ntp-server="" wins-server=""
/ip dns
set allow-remote-requests=yes cache-max-ttl=1w cache-size=4000KiB max-concurrent-queries=100 \
    max-concurrent-tcp-sessions=20 max-udp-packet-size=4096 query-server-timeout=2s query-total-timeout=\
    10s servers=8.8.8.8
/ip dns static
add address=192.168.100.176 disabled=no name=s.o regexp="" ttl=1d
/ip firewall mangle
add action=mark-connection chain=prerouting !connection-bytes !connection-limit connection-mark=no-mark \
    !connection-nat-state !connection-rate !connection-state !connection-type !content disabled=no !dscp \
    !dst-address !dst-address-list !dst-address-type !dst-limit !dst-port !fragment !hotspot \
    !icmp-options !in-bridge-port !in-bridge-port-list in-interface=03_Wan01 !in-interface-list \
    !ingress-priority !ipsec-policy !ipv4-options !layer7-protocol !limit log=no log-prefix="" \
    new-connection-mark=WAN1_conn !nth !out-bridge-port !out-bridge-port-list !out-interface \
    !out-interface-list !packet-mark !packet-size passthrough=yes !per-connection-classifier !port \
    !priority !protocol !psd !random !routing-mark !routing-table !src-address !src-address-list \
    !src-address-type !src-mac-address !src-port !tcp-flags !tcp-mss !time !ttl
add action=mark-connection chain=prerouting !connection-bytes !connection-limit connection-mark=no-mark \
    !connection-nat-state !connection-rate !connection-state !connection-type !content disabled=no !dscp \
    !dst-address !dst-address-list !dst-address-type !dst-limit !dst-port !fragment !hotspot \
    !icmp-options !in-bridge-port !in-bridge-port-list in-interface=04_Wan02 !in-interface-list \
    !ingress-priority !ipsec-policy !ipv4-options !layer7-protocol !limit log=no log-prefix="" \
    new-connection-mark=WAN2_conn !nth !out-bridge-port !out-bridge-port-list !out-interface \
    !out-interface-list !packet-mark !packet-size passthrough=yes !per-connection-classifier !port \
    !priority !protocol !psd !random !routing-mark !routing-table !src-address !src-address-list \
    !src-address-type !src-mac-address !src-port !tcp-flags !tcp-mss !time !ttl
add action=mark-connection chain=prerouting !connection-bytes !connection-limit connection-mark=no-mark \
    !connection-nat-state !connection-rate !connection-state !connection-type !content disabled=no !dscp \
    !dst-address !dst-address-list dst-address-type=!local !dst-limit !dst-port !fragment !hotspot \
    !icmp-options !in-bridge-port !in-bridge-port-list in-interface=Bridge-Local !in-interface-list \
    !ingress-priority !ipsec-policy !ipv4-options !layer7-protocol !limit log=no log-prefix="" \
    new-connection-mark=WAN1_conn !nth !out-bridge-port !out-bridge-port-list !out-interface \
    !out-interface-list !packet-mark !packet-size passthrough=yes per-connection-classifier=\
    both-addresses:2/0 !port !priority !protocol !psd !random !routing-mark !routing-table !src-address \
    !src-address-list !src-address-type !src-mac-address !src-port !tcp-flags !tcp-mss !time !ttl
add action=mark-connection chain=prerouting !connection-bytes !connection-limit connection-mark=no-mark \
    !connection-nat-state !connection-rate !connection-state !connection-type !content disabled=no !dscp \
    !dst-address !dst-address-list dst-address-type=!local !dst-limit !dst-port !fragment !hotspot \
    !icmp-options !in-bridge-port !in-bridge-port-list in-interface=Bridge-Local !in-interface-list \
    !ingress-priority !ipsec-policy !ipv4-options !layer7-protocol !limit log=no log-prefix="" \
    new-connection-mark=WAN2_conn !nth !out-bridge-port !out-bridge-port-list !out-interface \
    !out-interface-list !packet-mark !packet-size passthrough=yes per-connection-classifier=\
    both-addresses:2/1 !port !priority !protocol !psd !random !routing-mark !routing-table !src-address \
    !src-address-list !src-address-type !src-mac-address !src-port !tcp-flags !tcp-mss !time !ttl
add action=mark-routing chain=prerouting !connection-bytes !connection-limit connection-mark=WAN1_conn \
    !connection-nat-state !connection-rate !connection-state !connection-type !content disabled=no !dscp \
    !dst-address !dst-address-list !dst-address-type !dst-limit !dst-port !fragment !hotspot \
    !icmp-options !in-bridge-port !in-bridge-port-list in-interface=Bridge-Local !in-interface-list \
    !ingress-priority !ipsec-policy !ipv4-options !layer7-protocol !limit log=no log-prefix="" \
    new-routing-mark=to_WAN1 !nth !out-bridge-port !out-bridge-port-list !out-interface \
    !out-interface-list !packet-mark !packet-size passthrough=yes !per-connection-classifier !port \
    !priority !protocol !psd !random !routing-mark !routing-table !src-address !src-address-list \
    !src-address-type !src-mac-address !src-port !tcp-flags !tcp-mss !time !ttl
add action=mark-routing chain=prerouting !connection-bytes !connection-limit connection-mark=WAN2_conn \
    !connection-nat-state !connection-rate !connection-state !connection-type !content disabled=no !dscp \
    !dst-address !dst-address-list !dst-address-type !dst-limit !dst-port !fragment !hotspot \
    !icmp-options !in-bridge-port !in-bridge-port-list in-interface=Bridge-Local !in-interface-list \
    !ingress-priority !ipsec-policy !ipv4-options !layer7-protocol !limit log=no log-prefix="" \
    new-routing-mark=to_WAN2 !nth !out-bridge-port !out-bridge-port-list !out-interface \
    !out-interface-list !packet-mark !packet-size passthrough=yes !per-connection-classifier !port \
    !priority !protocol !psd !random !routing-mark !routing-table !src-address !src-address-list \
    !src-address-type !src-mac-address !src-port !tcp-flags !tcp-mss !time !ttl
add action=mark-routing chain=output connection-mark=WAN1_conn new-routing-mark=to_WAN1
add action=mark-routing chain=output connection-mark=WAN2_conn new-routing-mark=to_WAN2
/ip firewall nat
add action=masquerade chain=srcnat !connection-bytes !connection-limit !connection-mark !connection-rate \
    !connection-type !content disabled=no !dscp !dst-address !dst-address-list !dst-address-type \
    !dst-limit !dst-port !fragment !hotspot !icmp-options !in-bridge-port !in-bridge-port-list \
    !in-interface !in-interface-list !ingress-priority !ipsec-policy !ipv4-options !layer7-protocol \
    !limit log=no log-prefix="" !nth !out-bridge-port !out-bridge-port-list out-interface=PPPoE-Out1 \
    !out-interface-list !packet-mark !packet-size !per-connection-classifier !port !priority !protocol \
    !psd !random !routing-mark !routing-table !src-address !src-address-list !src-address-type \
    !src-mac-address !src-port !tcp-mss !time !to-addresses !to-ports !ttl
add action=masquerade chain=srcnat !connection-bytes !connection-limit !connection-mark !connection-rate \
    !connection-type !content disabled=no !dscp !dst-address !dst-address-list !dst-address-type \
    !dst-limit !dst-port !fragment !hotspot !icmp-options !in-bridge-port !in-bridge-port-list \
    !in-interface !in-interface-list !ingress-priority !ipsec-policy !ipv4-options !layer7-protocol \
    !limit log=no log-prefix="" !nth !out-bridge-port !out-bridge-port-list out-interface=PPPoE-Out2 \
    !out-interface-list !packet-mark !packet-size !per-connection-classifier !port !priority !protocol \
    !psd !random !routing-mark !routing-table !src-address !src-address-list !src-address-type \
    !src-mac-address !src-port !tcp-mss !time !to-addresses !to-ports !ttl
/ip firewall service-port
set ftp disabled=no ports=21
set tftp disabled=no ports=69
set irc disabled=no ports=6667
set h323 disabled=no
set sip disabled=no ports=5060,5061 sip-direct-media=yes sip-timeout=1h
set pptp disabled=no
set udplite disabled=no
set dccp disabled=no
set sctp disabled=no
/ip hotspot service-port
set ftp disabled=no ports=21
/ip hotspot user
set [ find default=yes ] comment="counters and limits for trial users" disabled=no name=default-trial
/ip ipsec policy
set 0 disabled=no dst-address=::/0 group=default proposal=default protocol=all src-address=::/0 template=\
    yes
/ip ipsec user settings
set xauth-use-radius=no
/ip proxy
set always-from-cache=no anonymous=no cache-administrator=webmaster cache-hit-dscp=4 cache-on-disk=no \
    cache-path=web-proxy enabled=no max-cache-object-size=2048KiB max-cache-size=unlimited \
    max-client-connections=600 max-fresh-time=3d max-server-connections=600 parent-proxy=:: \
    parent-proxy-port=0 port=8080 serialize-connections=no src-address=::
/ip route
add !bgp-as-path !bgp-atomic-aggregate !bgp-communities !bgp-local-pref !bgp-med !bgp-origin !bgp-prepend \
    check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=PPPoE-Out1 !route-tag \
    routing-mark=to_WAN1 scope=30 target-scope=10
add !bgp-as-path !bgp-atomic-aggregate !bgp-communities !bgp-local-pref !bgp-med !bgp-origin !bgp-prepend \
    check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=PPPoE-Out2 !route-tag \
    routing-mark=to_WAN2 scope=30 target-scope=10
add !bgp-as-path !bgp-atomic-aggregate !bgp-communities !bgp-local-pref !bgp-med !bgp-origin !bgp-prepend \
    check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=03_Wan01 !route-tag \
    !routing-mark scope=30 target-scope=10
add !bgp-as-path !bgp-atomic-aggregate !bgp-communities !bgp-local-pref !bgp-med !bgp-origin !bgp-prepend \
    check-gateway=ping disabled=no distance=2 dst-address=0.0.0.0/0 gateway=04_Wan02 !route-tag \
    !routing-mark scope=30 target-scope=10
/ip service
set telnet address="" disabled=yes port=23
set ftp address="" disabled=yes port=21
set www address="" disabled=yes port=80
set ssh address="" disabled=yes port=22
set www-ssl address="" certificate=none disabled=yes port=443
set api address="" disabled=yes port=8728
set winbox address="" disabled=no port=8291
set api-ssl address="" certificate=none disabled=yes port=8729
/ip smb
set allow-guests=yes comment=mnb domain=WORKGROUP enabled=yes interfaces=WLAN
/ip smb shares
set [ find default=yes ] comment="default share" directory=/pub disabled=yes max-sessions=10 name=pub
add directory=/disk1 disabled=no max-sessions=50 name=Storage
/ip smb users
set [ find default=yes ] disabled=no name=guest password="" read-only=yes
/ip socks
set connection-idle-timeout=2m enabled=no max-connections=200 port=1080
/ip ssh
set always-allow-password-login=no forwarding-enabled=no host-key-size=2048 strong-crypto=no
/ip traffic-flow
set active-flow-timeout=30m cache-entries=32k enabled=no inactive-flow-timeout=15s interfaces=all
/ip traffic-flow ipfix
set bytes=yes dst-address=yes dst-address-mask=yes dst-mac-address=yes dst-port=yes first-forwarded=yes \
    gateway=yes icmp-code=yes icmp-type=yes igmp-type=yes in-interface=yes ip-header-length=yes \
    ip-total-length=yes ipv6-flow-label=yes is-multicast=yes last-forwarded=yes nat-dst-address=yes \
    nat-dst-port=yes nat-src-address=yes nat-src-port=yes out-interface=yes packets=yes protocol=yes \
    src-address=yes src-address-mask=yes src-mac-address=yes src-port=yes tcp-ack-num=yes tcp-flags=yes \
    tcp-seq-num=yes tcp-window-size=yes tos=yes ttl=yes udp-length=yes
/ip upnp
set allow-disable-external-interface=no enabled=no show-dummy-rule=yes
/mpls
set dynamic-label-range=16-1048575 propagate-ttl=yes
/mpls interface
set [ find default=yes ] disabled=no interface=all mpls-mtu=1508
/mpls ldp
set distribute-for-default-route=no enabled=no hop-limit=255 loop-detect=no lsr-id=0.0.0.0 \
    path-vector-limit=255 transport-address=0.0.0.0 use-explicit-null=no
/port firmware
set directory=firmware ignore-directip-modem=no
/ppp aaa
set accounting=yes interim-update=0s use-circuit-id-in-nas-port-id=no use-radius=no
/radius incoming
set accept=no port=3799
/routing bfd interface
set [ find default=yes ] disabled=no interface=all interval=0.2s min-rx=0.2s multiplier=5
/routing mme
set bidirectional-timeout=2 gateway-class=none gateway-keepalive=1m gateway-selection=no-gateway \
    origination-interval=5s preferred-gateway=0.0.0.0 timeout=1m ttl=50
/routing rip
set distribute-default=never garbage-timer=2m metric-bgp=1 metric-connected=1 metric-default=1 \
    metric-ospf=1 metric-static=1 redistribute-bgp=no redistribute-connected=no redistribute-ospf=no \
    redistribute-static=no routing-table=main timeout-timer=3m update-timer=30s
/snmp
set contact="" enabled=no engine-id="" location="" trap-community=public trap-generators="" trap-target=\
    "" trap-version=1
/system clock
set time-zone-autodetect=yes time-zone-name=somewhere
/system clock manual
set dst-delta=+00:00 dst-end="jan/01/1970 00:00:00" dst-start="jan/01/1970 00:00:00" time-zone=+00:00
/system identity
set name=MikroTik
/system leds
set 0 disabled=no interface=WLAN leds=wlan-led type=wireless-status
/system leds settings
set all-leds-off=never
/system logging
set 0 action=memory disabled=no prefix="" topics=info
set 1 action=memory disabled=no prefix="" topics=error
set 2 action=memory disabled=no prefix="" topics=warning
set 3 action=echo disabled=no prefix="" topics=critical
/system note
set note="" show-at-login=yes
/system ntp client
set enabled=yes primary-ntp=128.138.141.172 secondary-ntp=0.0.0.0 server-dns-names=""
/system resource irq
set 0 cpu=auto
set 1 cpu=auto
set 2 cpu=auto
set 3 cpu=auto
/system routerboard settings
set boot-device=nand-if-fail-then-ethernet boot-protocol=bootp force-backup-booter=no \
    protected-routerboot=disabled reformat-hold-button=20s reformat-hold-button-max=10m silent-boot=no
/system upgrade mirror
set check-interval=1d enabled=no primary-server=0.0.0.0 secondary-server=0.0.0.0 user=""
/system watchdog
set auto-send-supout=no automatic-supout=yes no-ping-delay=5m watch-address=none watchdog-timer=yes
/tool bandwidth-server
set allocate-udp-ports-from=2000 authenticate=yes enabled=yes max-sessions=100
/tool e-mail
set address=0.0.0.0 from=<> password="" port=25 start-tls=no user=""
/tool graphing
set page-refresh=300 store-every=5min
/tool mac-server
set [ find default=yes ] disabled=no interface=all
/tool mac-server mac-winbox
set [ find default=yes ] disabled=no interface=all
/tool mac-server ping
set enabled=yes
/tool romon
set enabled=no id=00:00:00:00:00:00 secrets=""
/tool romon port
set [ find default=yes ] cost=100 disabled=no forbid=no interface=all secrets=""
/tool sms
set allowed-number="" channel=0 keep-max-sms=0 port=none receive-enabled=no secret="" sim-pin=""
/tool sniffer
set file-limit=1000KiB file-name="" filter-cpu="" filter-direction=any filter-interface="" \
    filter-ip-address="" filter-ip-protocol="" filter-ipv6-address="" filter-mac-address="" \
    filter-mac-protocol="" filter-operator-between-entries=or filter-port="" filter-stream=no \
    memory-limit=100KiB memory-scroll=yes only-headers=no streaming-enabled=no streaming-server=0.0.0.0
/tool traffic-generator
set latency-distribution-max=100us measure-out-of-order=yes stats-samples-to-keep=100 test-id=0
/user aaa
set accounting=yes default-group=read exclude-groups="" interim-update=0s use-radius=no
thanks alot

please bare-in mind that the ISP gave me 1 cable with 2 PPPOE accounts that are on the same gateway and they have mac ban (its firewall thingy in which if someone else got my mac, both of us will get disconnected / connection will be dropped and it keeps trying to reconnect until it detects 1 unique mac not cloned because they have list of MACs. ===> my router wont be able to connect unless with a specific mac address)
the IPs of the pppoe accounts automatically gets a dynamic IP with the same network address :
pppoe1 10.11.1.222 (just example but same pool with 1 gateway)
pppoe2 10.11.1.244 (just example but same pool with 1 gateway)
both are on network address = 185.165.24.26 (giving an example)
if both of the interfaces are enabled i'm not able to connect to the internet.
and always 1 of the 2 interfaces gets disconnected for less than a second and reconnects (in case both were enabled)
 
wfalcon
just joined
Topic Author
Posts: 24
Joined: Thu Mar 23, 2017 3:03 pm

Re: Merge 2 PPPOE WANs

Sun Oct 15, 2017 1:11 pm

problem solved
seems that the ISP locked both accounts on the same MAC address thats why i'm getting disconnected whenever i try to enable both PPPOE interfaces
still i used a switch to make each PPPOE go onto different eth port on the router board
then i used PCC Loadbalancing as @Chupaka suggested and its working
https://wiki.mikrotik.com/wiki/Manual:P ... _Balancing

thanks a lot, as it was some stupid thing from my ISP side.

Who is online

Users browsing this forum: Chupaka, crosswind, dad2312, EdPa, eworm, mscarpitti and 167 guests