Community discussions

 
Yozen
just joined
Topic Author
Posts: 1
Joined: Mon Oct 09, 2017 11:21 am

Wifi 2.4GHz is not working with "auto" frequency

Mon Oct 09, 2017 11:51 am

Hello,

I have problem with wifi 2.4 GHz when I set the "auto" frequency.
There are 2 scenarios:
- device can not connect and retrying all over again
- device is connected but it does not have internet access.
Problem is gone when I set frequency manually (does not mater with one, all of them are working: 2412, 2417, 2422, 2427, 2432, 2437, 2442, 2447, 2452)

Resetting the whole configuration for MikroTik is not resolving the issue permanently. It is working with "auto" frequency at the start, but after few hours the problem is re-occurring.

I do not know what is going on. Could somebody help me?
/interface wireless export
# oct/09/2017 10:26:58 by RouterOS 6.41rc38
# software id = PXE9-B04G
#
# model = RouterBOARD 962UiGS-5HacT2HnT
# serial number = 6F1207B4BAB7
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce comment=Kukurydza_Dla_Zuchwalych country=poland \
    default-authentication=no disabled=no distance=indoors frequency=auto mode=ap-bridge name=wlan-2.4 ssid=Kukurydza_Dla_Zuchwalych \
    wireless-protocol=802.11 wps-mode=disabled
set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=20/40/80mhz-Ceee comment=Bylismy_Herosami country=poland \
    default-authentication=no disabled=no distance=indoors frequency=auto mode=ap-bridge name=wlan-5 ssid=Bylismy_Herosami \
    wireless-protocol=802.11 wps-mode=disabled
/interface wireless manual-tx-power-table
set wlan-2.4 comment=Kukurydza_Dla_Zuchwalych
set wlan-5 comment=Bylismy_Herosami
/interface wireless nstreme
set wlan-2.4 comment=Kukurydza_Dla_Zuchwalych
set wlan-5 comment=Bylismy_Herosami
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" mode=dynamic-keys supplicant-identity=MikroTik wpa-pre-shared-key=\
    ************ wpa2-pre-shared-key=************
/interface wireless access-list
add comment=Tele_And_wifi interface=wlan-2.4 mac-address=40:**:40 vlan-mode=no-tag
add comment=Tele_OPX_wifi interface=wlan-2.4 mac-address=C0:EE:**:2E vlan-mode=no-tag
add comment=Brother_Printer_wifi interface=wlan-2.4 mac-address=00:**:F6 vlan-mode=no-tag
add comment=Tele_OP3T_wifi interface=wlan-2.4 mac-address=C0:**:66 vlan-mode=no-tag
add comment=n3ds_wifi interface=wlan-2.4 mac-address=CC:**:9B vlan-mode=no-tag
add comment=n2dsxl_wifi interface=wlan-2.4 mac-address=04:**:19 vlan-mode=no-tag
add comment=Nintendo_Switch_wifi mac-address=7C:**:87 vlan-mode=no-tag
add comment=Sony_PS3_wifi interface=wlan-2.4 mac-address=FC:**:89 vlan-mode=no-tag
add comment=Netbook_wifi interface=wlan-2.4 mac-address=00:**:DB vlan-mode=no-tag
add comment=PS_Vita_wifi interface=wlan-2.4 mac-address=D4:**:AA vlan-mode=no-tag
add comment=Tablet_wifi interface=wlan-2.4 mac-address=00:**:FA vlan-mode=no-tag
add comment=Nintendo_Wii_U_wifi interface=wlan-2.4 mac-address=40:**:71 vlan-mode=no-tag
add comment=Lap_IBM_wifi mac-address=44:**:29 vlan-mode=no-tag
add comment=Lap_wifi interface=wlan-2.4 mac-address=B8:**:F1 vlan-mode=no-tag
add comment=Tele_OPO_wifi interface=wlan-2.4 mac-address=C0:**:85 vlan-mode=no-tag
add comment=Tele_IBM_wifi interface=wlan-2.4 mac-address=8C:**:49 vlan-mode=no-tag
add comment=Toshiba_TV_wifi interface=wlan-2.4 mac-address=C8:**:DE vlan-mode=no-tag
add comment=Lap_wifi mac-address=6C:**:FC
/log print
10:26:12 system,info device changed by root 
10:26:16 wireless,info 00:**:F6@wlan-2.4: connected, signal strength -81 
10:26:18 wireless,info C0:**:2E@wlan-2.4: connected, signal strength -43 
10:26:18 wireless,info C0:**:66@wlan-2.4: connected, signal strength -46 
10:26:20 dhcp,info defconf deassigned 192.168.1.121 from C0:**:2E 
10:26:21 dhcp,info defconf deassigned 192.168.1.122 from C0:**:66 
10:26:23 dhcp,info defconf assigned 192.168.1.122 to C0:**:66 
10:26:28 dhcp,info defconf assigned 192.168.1.121 to C0:**:2E 
10:26:39 wireless,info C0:**:2E@wlan-2.4: disconnected, received deauth: sending station leaving (3) 
10:26:42 wireless,info C0:**:2E@wlan-2.4: connected, signal strength -51 
10:26:42 dhcp,info defconf deassigned 192.168.1.121 from C0:**:2E 
10:26:42 dhcp,info defconf assigned 192.168.1.121 to C0:**:2E 
10:26:48 wireless,info C0:**:2E@wlan-2.4: disconnected, received deauth: sending station leaving (3) 
10:26:49 system,info,account user root logged in from 192.168.1.103 via telnet 
10:26:57 wireless,info C0:**:2E@wlan-2.4: connected, signal strength -48 
10:26:58 dhcp,info defconf deassigned 192.168.1.121 from C0:**:2E 
10:26:58 dhcp,info defconf assigned 192.168.1.121 to C0:**:2E 
10:27:50 wireless,info C0:**:66@wlan-2.4: disconnected, received deauth: sending station leaving (3) 
10:28:01 wireless,info C0:**:66@wlan-2.4: connected, signal strength -54 
10:28:01 dhcp,info defconf deassigned 192.168.1.122 from C0:**:66 
10:28:01 dhcp,info defconf assigned 192.168.1.122 to C0:**:66 
10:28:13 wireless,info C0:**:2E@wlan-2.4: disconnected, received deauth: sending station leaving (3) 
10:28:15 wireless,info C0:**:2E@wlan-2.4: connected, signal strength -46 
10:28:16 dhcp,info defconf deassigned 192.168.1.121 from C0:**:2E 
10:28:16 dhcp,info defconf assigned 192.168.1.121 to C0:**:2E 
10:28:19 wireless,info C0:**:2E@wlan-2.4: disconnected, received deauth: sending station leaving (3) 
10:28:31 wireless,info C0:**:2E@wlan-2.4: connected, signal strength -52 
10:28:31 dhcp,info defconf deassigned 192.168.1.121 from C0:**:2E 
10:28:31 dhcp,info defconf assigned 192.168.1.121 to C0:**:2E 
10:28:40 wireless,info C0:**:2E@wlan-2.4: disconnected, received deauth: sending station leaving (3) 
10:28:42 wireless,info C0:**:2E@wlan-2.4: connected, signal strength -55 
10:28:42 dhcp,info defconf deassigned 192.168.1.121 from C0:**:2E 
10:28:42 dhcp,info defconf assigned 192.168.1.121 to C0:**:2E 
10:28:42 system,info,account user root logged in from 192.168.1.103 via telnet 
10:28:45 wireless,info C0:**:2E@wlan-2.4: disconnected, received deauth: sending station leaving (3)
 
scampbell
Trainer
Trainer
Posts: 457
Joined: Thu Jun 22, 2006 5:20 am
Location: Wellington, NZ
Contact:

Re: Wifi 2.4GHz is not working with "auto" frequency

Mon Oct 09, 2017 9:00 pm

I would not use "auto" frequency. Do a scan and choose the best channel (ideally 2412,2437 or 2462) .

I would also recommend not to use 20/40MHz - try 20MHz only, especially if you are in an urban area with many adjacent AP's.
MTCNA, MTCWE, MTCRE, MTCTCE, MTCSE, MTCINE, Trainer
___________________
Mikrotik Distributor - New Zealand
http://www.campbell.co.nz
 
User avatar
urbinek
Frequent Visitor
Frequent Visitor
Posts: 61
Joined: Mon Oct 25, 2010 4:11 pm

Re: Wifi 2.4GHz is not working with "auto" frequency

Mon Oct 09, 2017 9:04 pm

Auto settings on 20/40MHz in area with 30+ 2.4Ghz network works just fine with mine rb951, so it should for him
cookie monster rlz
 
scampbell
Trainer
Trainer
Posts: 457
Joined: Thu Jun 22, 2006 5:20 am
Location: Wellington, NZ
Contact:

Re: Wifi 2.4GHz is not working with "auto" frequency

Mon Oct 09, 2017 9:36 pm

Auto settings on 20/40MHz in area with 30+ 2.4Ghz network works just fine with mine rb951, so it should for him
For sure it should work, but currently it does not.

So to fault find it is best to go to basic methods and settings, check frequency usage and other AP's in the area and get stability.

Once that is done then re-explore bigger channels, auto features etc. 8)
MTCNA, MTCWE, MTCRE, MTCTCE, MTCSE, MTCINE, Trainer
___________________
Mikrotik Distributor - New Zealand
http://www.campbell.co.nz
 
anaks
just joined
Posts: 10
Joined: Fri Jun 24, 2016 7:59 pm
Location: Russia, Anapa

Re: Wifi 2.4GHz is not working with "auto" frequency

Wed Oct 11, 2017 8:58 am

Forgive me coach, but I use in hotels frequency = auto, the appropriate region, the channel width = 20 MHz, Ce = disabled. From practice - works well. The use of a given frequency manually does not always work well, because there are a lot of neighbors with Wi-Fi routers are configured for automatic channel selection and there is a great chance to get a hindrance in the future. And even if I changed the mode to g/n if no older devices
Remote Assistance, whatsapp or telegram +79181390072

Who is online

Users browsing this forum: No registered users and 6 guests