Community discussions

MUM Europe 2020
 
eriitguy
Member Candidate
Member Candidate
Topic Author
Posts: 197
Joined: Thu Jan 26, 2017 1:16 pm

Mikrotik and Huawei 3372 LTE modem - LTE Passtrough

Wed Oct 18, 2017 11:14 am

Hello!

Starting from RouterOS v6.41 Mikrotik have added LTE Passthrough feature which permit to apply IP configuration directly to the client device.

We have made some tests using Huawei 3372h-153 modem from Moldcell carrier.

Modem model
/system resource usb print detail
2 device="1:2" vendor="HUAWEI_MOBILE" name="HUAWEI_MOBILE" vendor-id="0x12d1"
   device-id="0x14dc" speed="480 Mbps" ports=0 usb-version="2.10"
Modem mode
/interface lte print
Flags: X - disabled, R - running
 0  R name="lte1" mtu=1500 mac-address=0C:5A:8D:32:9E:24
LTE Passthrough configuration
As this modem is listed with LTE passthrough support we have tried to configure it:
/interface lte apn add apn=internet passthrough-interface=ether4
/interface lte set lte1 apn=internet
Now, on the laptop connected to Routerboard ethernet 4 port we got 192.168.8.x/24 IP address.

In such case, this modem with current setup can't be used in order to provide a Public IP address to the end device.

Related forum topics
1. Problem with Huawei E3372 4G modem
2. Huawei E3372 LTE modem
3. Huawei E3372 LTE modem - create lte interface?
4. ** WE WANT A LTE BRIDGE-MODE **
5. Using Huawei E3372 3G/4G stick
6. How to set my Huawei E3372 LTE Dongle to work?

Thank you!
Last edited by eriitguy on Mon Oct 23, 2017 1:11 pm, edited 1 time in total.
 
User avatar
matiaszon
Member
Member
Posts: 305
Joined: Mon Jul 09, 2012 9:26 am

Re: Mikrotik and Huawei 3372 LTE modem - LTE Passtrough

Wed Oct 18, 2017 3:52 pm

I have the same situation. I asked the same question days ago, but nobody knows what to answer.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3427
Joined: Mon May 31, 2004 2:55 pm

Re: Mikrotik and Huawei 3372 LTE modem - LTE Passtrough

Wed Oct 18, 2017 4:26 pm

we are jsut passing through the IP configuration that we get from the modem. If the modem uses NAT and provides local IP then we are passing that IP to the configured interface.
If you can configure the modem to provide public IP then that IP will be passed through.
 
User avatar
matiaszon
Member
Member
Posts: 305
Joined: Mon Jul 09, 2012 9:26 am

Re: Mikrotik and Huawei 3372 LTE modem - LTE Passtrough

Thu Oct 19, 2017 2:10 am

we are jsut passing through the IP configuration that we get from the modem. If the modem uses NAT and provides local IP then we are passing that IP to the configured interface.
If you can configure the modem to provide public IP then that IP will be passed through.
Seriously, from the early beginning most of us wants mikrotik to pass the public IP. Also most of us as an example give Dovado routers, that can passthrough PUBLIC IP to the device directly connected to it. During configuration process you decide on which client (WLAN or LAN) the IP should be assigned. No matter, if your modem is with NAT or not.

Now, to achieve the same, it's needed to make a standard modem from a HiLink (NATed) version... Will it work then???
 
uldis
MikroTik Support
MikroTik Support
Posts: 3427
Joined: Mon May 31, 2004 2:55 pm

Re: Mikrotik and Huawei 3372 LTE modem - LTE Passtrough

Thu Oct 19, 2017 11:43 am

yes, the modem is in the hilink mode. Which mode you want us to support? As we don't support all the device emulation drivers. Please provide to support@mikrotik.com support output file from the mode where the modem should assign the public IP to the LTE interface.
 
pe1chl
Forum Guru
Forum Guru
Posts: 5986
Joined: Mon Jun 08, 2015 12:09 pm

Re: Mikrotik and Huawei 3372 LTE modem - LTE Passtrough

Thu Oct 19, 2017 11:56 am

I sometimes read there should be a mode (not the PPP or the HiLink mode) that allows the use of the
public IP address directly from a system, with drivers for Linux provided by the modem, but it is hard to
find any real info. Of course it would be nicest when the LTE stick appears as an internet link with its
public address (well, as far as the provider gives it, could be a CGNAT behind it) and have no NAT in
the stick.
 
CoolTom
Frequent Visitor
Frequent Visitor
Posts: 63
Joined: Fri Feb 08, 2019 12:15 pm

Re: Mikrotik and Huawei 3372 LTE modem - LTE Passtrough

Fri Feb 08, 2019 12:31 pm

Any success with this?

What I find out after bit researching:

2basic modes working actially with Mikrotik:

1. Stick mode - firmware start with 21.xxxxxx - it appear on USB port and as PPP interface. You are able diap up and if mobile providrer give you public IP you got this public IP on PPP interface in Mikrotik. Negative of this mode is speed limitation of serial access/PPP i can not get more than c. 21Mbps

2. Router/HiLink mode - firmware start with 22.xxxx - it appear as LTE interface with "full" LTE speed, BUT Mikrotik LTE interface if just client of Modem stick router LAN - you will not get public IP as its on WAN port of USB Stick

But if you use mod WebUI firmware, you get more options like DST nat ports or put mikrotik as in DMZ zone, switch off FW ... so at least solution. I used this firmare to convert my E3372h-153 (aka HW ver: CL2E3372HM) into HiLink with option setup DMZ on one client on LAN = Mikrotik interface

E3372h-153_Update_22.200.15.00.00_M_AT_05.10_nv.exe
Update_WEBUI_17.100.17.00.143_HILINK_Mod1.16_V7R2_9x25_V7R11_CPIO.exe

Update_WEBUI_17.100.13.01.03_HILINK_Mod1.0.exe (doesnt have extra tweak as modify TTL to 64 on modem stick, swit ch off autoswitch from web interfare etc.)
 
pe1chl
Forum Guru
Forum Guru
Posts: 5986
Joined: Mon Jun 08, 2015 12:09 pm

Re: Mikrotik and Huawei 3372 LTE modem - LTE Passtrough

Tue Feb 12, 2019 8:39 pm

Port forwardings are normally useless as almost any 4G provider uses dynamic addresses and CGNAT.
(I know there are exceptions)

I use my 3372s in plain HiLink mode and setup an L2TP/IPsec VPN to the central router and access them over the VPN when required.

Who is online

Users browsing this forum: Google [Bot] and 40 guests