Community discussions

 
Arcee
Member Candidate
Member Candidate
Topic Author
Posts: 267
Joined: Fri Jun 27, 2014 2:33 pm

Wireless Data Rates - Optimizing AP

Wed Dec 06, 2017 12:41 am

I will keep it simple with my first question but I'm sure this will evolve into a much larger conversation:

If my highest subscription level as an ISP is 7mb, what should my highest date rate be on my AP?

Key point to note here is that no client will need more than 7mb of bandwidth.

Sent from my Pixel 2 using Tapatalk

 
p3rad0x
Long time Member
Long time Member
Posts: 603
Joined: Fri Sep 18, 2015 5:42 pm
Location: South Africa
Contact:

Re: Wireless Data Rates - Optimizing AP

Thu Dec 07, 2017 12:50 pm

I would say set it as high as possible while retaining a stable link.

What i do is set is set the minimum data rate to prevent rate flapping.

on 5ghz a i set 18Mbps Basic rate and supported 18Mbps + all the other after it.

If it starts giving issues drop the max limit by 1 or the min limit.

Same applies wil 5ghz N, 5Ghz AC is an entire different problem when it comes to data rates
There you go then you touched something ;-) : it only takes a change in wind direction to screw with your nat :-)
 
Arcee
Member Candidate
Member Candidate
Topic Author
Posts: 267
Joined: Fri Jun 27, 2014 2:33 pm

Re: Wireless Data Rates - Optimizing AP

Sun Dec 24, 2017 3:12 am

What about the HT MCS?

If I don't need more than 7mb on any given client, doesn't it make sense to deselect all of the MCS options?
 
User avatar
chechito
Forum Guru
Forum Guru
Posts: 1645
Joined: Sun Aug 24, 2014 3:14 am
Location: Bogota Colombia
Contact:

Re: Wireless Data Rates - Optimizing AP

Sun Dec 24, 2017 4:30 am

i use this setting, i only use N mode with NV2
mcs.png
You do not have the required permissions to view the files attached to this post.
 
Arcee
Member Candidate
Member Candidate
Topic Author
Posts: 267
Joined: Fri Jun 27, 2014 2:33 pm

Re: Wireless Data Rates - Optimizing AP

Sun Dec 24, 2017 4:32 am

1. How many Clients on that AP?

2. What's the max bandwidth per client?
 
andriys
Forum Guru
Forum Guru
Posts: 1073
Joined: Thu Nov 24, 2011 1:59 pm
Location: Kharkiv, Ukraine

Re: Wireless Data Rates - Optimizing AP

Sun Dec 24, 2017 9:52 am

Are your wireless clients allowed to talk to each other?
 
andriys
Forum Guru
Forum Guru
Posts: 1073
Joined: Thu Nov 24, 2011 1:59 pm
Location: Kharkiv, Ukraine

Re: Wireless Data Rates - Optimizing AP

Sun Dec 24, 2017 10:04 am

On a second thought, I wouldn't recommend disabling the higher data rates. Using lower data rates means using more air time, which in turn means more competition for air time with neighbor networks and worse user experience for both your and your neighbors' networks. This considerations, however, might not apply to PtP links.
 
Arcee
Member Candidate
Member Candidate
Topic Author
Posts: 267
Joined: Fri Jun 27, 2014 2:33 pm

Re: Wireless Data Rates - Optimizing AP

Sun Dec 24, 2017 3:42 pm

I'm not concerned bandwidth so much as the clients are reaching the speeds required for my network.

I'm mainly concerned with latency and overall jitter. I'm thinking the culprits are data-rate flapping and clients with low signal strength (>70dB). The subject of data-rates was brought up because I see this as the easiest fix.

I will post my latency and jitter over a two hour period during peak time along with client count and throughput at the AP.

It's not really bad, just looking for ways to tweak and optimize. What I'm experiencing might be perfectly normal.

Sent from my Pixel 2 using Tapatalk

 
mistry7
Forum Guru
Forum Guru
Posts: 1196
Joined: Tue Oct 13, 2009 11:57 am
Location: Germany

Re: Wireless Data Rates - Optimizing AP

Sun Dec 24, 2017 4:17 pm

You ofer 7Mbit Plans?
OK
But the way to limit user data rate is not to limit AP rates.....
latency and jitter is more a think with interference......
 
Arcee
Member Candidate
Member Candidate
Topic Author
Posts: 267
Joined: Fri Jun 27, 2014 2:33 pm

Re: Wireless Data Rates - Optimizing AP

Sun Dec 24, 2017 4:36 pm

Oh no, I'm limiting with queues at the branch router.

Im not asking how to limit data rates or bandwidth. I'm asking how to optimize latency.

Sent from my Pixel 2 using Tapatalk

 
mistry7
Forum Guru
Forum Guru
Posts: 1196
Joined: Tue Oct 13, 2009 11:57 am
Location: Germany

Re: Wireless Data Rates - Optimizing AP

Mon Dec 25, 2017 11:22 am

Nv2 latency?

Post your config
 
Arcee
Member Candidate
Member Candidate
Topic Author
Posts: 267
Joined: Fri Jun 27, 2014 2:33 pm

Re: Wireless Data Rates - Optimizing AP

Mon Dec 25, 2017 3:19 pm

Here is my config:
Config.png
You do not have the required permissions to view the files attached to this post.
 
n21roadie
Forum Guru
Forum Guru
Posts: 1885
Joined: Fri Aug 07, 2009 10:36 pm
Location: Limerick,Ireland

Re: Wireless Data Rates - Optimizing AP

Mon Dec 25, 2017 4:15 pm

At present 6 Mbps is used for NV2 Management Protocol, my question is what impact this has on overall wireless throughput and AP optimizing?
 
mistry7
Forum Guru
Forum Guru
Posts: 1196
Joined: Tue Oct 13, 2009 11:57 am
Location: Germany

Re: Wireless Data Rates - Optimizing AP

Mon Dec 25, 2017 6:41 pm

Open Terminal

Type
"Interface Wireless"
And then "export"
 
Arcee
Member Candidate
Member Candidate
Topic Author
Posts: 267
Joined: Fri Jun 27, 2014 2:33 pm

Re: Wireless Data Rates - Optimizing AP

Thu Dec 28, 2017 12:24 pm

Open Terminal

Type
"Interface Wireless"
And then "export"
# model = 922UAGS-5HPacD

/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa2-psk,wpa2-eap eap-methods="" \
management-protection=allowed mode=dynamic-keys name=[***REMOVED***] \
supplicant-identity="" wpa2-pre-shared-key=[***REMOVED***]

/interface wireless
set [ find default-name=wlan1 ] adaptive-noise-immunity=ap-and-client-mode \
antenna-gain=13 band=5ghz-onlyn basic-rates-a/g=\
18Mbps,24Mbps,36Mbps,48Mbps,54Mbps channel-width=20/40mhz-eC \
default-authentication=no default-forwarding=no disabled=no frequency=\
5440 frequency-mode=superchannel ht-basic-mcs=\
mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7,mcs-8,mcs-9,mcs-10,mcs-11 \
ht-supported-mcs=\
mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7,mcs-8,mcs-9,mcs-10,mcs-11 \
hw-retries=4 mode=ap-bridge nv2-cell-radius=10 nv2-downlink-ratio=80 \
nv2-preshared-key=[***REMOVED***] nv2-security=enabled radio-name=\
[***REMOVED***] rate-set=configured rx-chains=0,1 scan-list=5100-6000 \
security-profile=[***REMOVED***] ssid=[***REMOVED***] supported-rates-a/g=\
18Mbps,24Mbps,36Mbps,48Mbps,54Mbps tdma-period-size=auto tx-chains=0,1 \
wireless-protocol=nv2

/interface wireless access-list
#About 30-40 Access List Clients

/interface wireless connect-list
add interface=wlan1 security-profile=default signal-range=-70..120
 
User avatar
chechito
Forum Guru
Forum Guru
Posts: 1645
Joined: Sun Aug 24, 2014 3:14 am
Location: Bogota Colombia
Contact:

Re: Wireless Data Rates - Optimizing AP

Sun Apr 29, 2018 4:46 pm

try 6.40.8 (bugfix old bridges) and 6.42.1 (current new bridges)
 
Arcee
Member Candidate
Member Candidate
Topic Author
Posts: 267
Joined: Fri Jun 27, 2014 2:33 pm

Re: Wireless Data Rates - Optimizing AP

Thu Jun 14, 2018 5:42 pm

Reviving an old thread.

New question: What affect does lower data-rates have on the overall throughput performance of an PtMP access point (i.e. using just 24mbps and 36mbps rates without any MCS being selected)?

I ask because I recently came to the realization that if none of my end-points need more than 10mbps, then there is no need for a configuration that allows for connection higher than the intended speeds. This also keeps latency down; I like to use the analogy of "shifting gears" in a vehicle frequently.

However, my question is now, does this make the PtMP AP have less overall throughput (collectively with ~30 clients connected)?
 
Raumaster
newbie
Posts: 31
Joined: Fri Sep 28, 2012 2:18 am

Re: Wireless Data Rates - Optimizing AP

Thu Jun 14, 2018 7:48 pm

If you limit the AP to lets say, MCS 1 which gives you 13Mbps @ 20MHz, this is the air rate you are going to be sharing with eveyone! 13Mbps for x amount of clients you have on the AP. Leave it at auto if you don't know what you're doing or limit it to the MCS rate which gives you the best overall CCQ. HereIi limit my APs to MCS 12 because it gives me the speed I need for my clients while keeping a good average CCQ.
 
Arcee
Member Candidate
Member Candidate
Topic Author
Posts: 267
Joined: Fri Jun 27, 2014 2:33 pm

Re: Wireless Data Rates - Optimizing AP

Thu Jun 14, 2018 8:05 pm

If you limit the AP to lets say, MCS 1 which gives you 13Mbps @ 20MHz, this is the air rate you are going to be sharing with eveyone! 13Mbps for x amount of clients you have on the AP. Leave it at auto if you don't know what you're doing or limit it to the MCS rate which gives you the best overall CCQ. HereIi limit my APs to MCS 12 because it gives me the speed I need for my clients while keeping a good average CCQ.
By "Air rate I'm going to be sharing with every" do you mean in this scenario of 13Mbps that my max throughput (all clients combined) will be 13Mbps?

Here's a better example:
Lets say I use a datarate/mcs configuration that allows for up to 24mbps. Can the AP pass traffic for 5 clients maxing out that rate (i.e. 24mbps*5=120mbps)? OR are you saying my overall throughput cap for the AP is now 24mbps?
 
Raumaster
newbie
Posts: 31
Joined: Fri Sep 28, 2012 2:18 am

Re: Wireless Data Rates - Optimizing AP

Thu Jun 14, 2018 8:20 pm

In your scenario, 24Mbps / 5 = Shared bandwidth. in Wireless (802.11, NV2, Nstream, AIRMAX...) the AP is always sharing bandwidth. The actual AP data rate is the amount of available bandwitdh for everyone connected to it, simple as that!

Remember that we're talking about air rate, the wi-fi protocol eats up almost half of the available bandwidth for it to work + other stuff you end up with half of the actual data rate.
 
Arcee
Member Candidate
Member Candidate
Topic Author
Posts: 267
Joined: Fri Jun 27, 2014 2:33 pm

Re: Wireless Data Rates - Optimizing AP

Thu Jun 14, 2018 8:33 pm

Understood.

I would just max out the datarates and MCS options but my recent challenge has been trying to lower latency jitter.

It seem jitter is directly linked to rate switching and if my thoughts are correct, limited the rate options to a select few makes for less jitter. Thoughts?
 
Arcee
Member Candidate
Member Candidate
Topic Author
Posts: 267
Joined: Fri Jun 27, 2014 2:33 pm

Re: Wireless Data Rates - Optimizing AP

Mon Jun 18, 2018 1:29 pm

In your scenario, 24Mbps / 5 = Shared bandwidth. in Wireless (802.11, NV2, Nstream, AIRMAX...) the AP is always sharing bandwidth. The actual AP data rate is the amount of available bandwitdh for everyone connected to it, simple as that!

Remember that we're talking about air rate, the wi-fi protocol eats up almost half of the available bandwidth for it to work + other stuff you end up with half of the actual data rate.
So let's use another scenario:
AP Is set to Datarate of 24mbps and 36mbps and an MCS of 7-15 (Max of ~144mbps).
5 clients connected, three at 24mbps (idle connections) and two at 144mpbs (active connections).
Now what's my estimated overall max throughput?

I understood in the earlier example that the bandwidth is shared and at any given point in time a client's bandwidth is MaxDataRate / Total Client Count. But what about this scenario where some clients (more than have in this example) are not communicating at max rate?

Thanks in advance!
 
WirelessRudy
Forum Guru
Forum Guru
Posts: 3066
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: Wireless Data Rates - Optimizing AP

Tue Jan 22, 2019 5:36 pm

Wireless settings are always a trade-off. Meaning raw speed goes at the expense of latency.

If all your clients connect to 'n' protocol then you could leave the 'a' protocol rates unused but the 6mbps. (That is the basic that should always work)

Then I set the highest mcs rate that keep all clients connected plus one lower. I also set one single chaing mcs data rate that at least gives the same throughput at the lowest dual chain data rate.

In my philosopy increasing data rates give AP more bandwidth to handle single client's traffic so the airtime is released earlier to the next client. Lowering mcs rates will give better stability of the link but since now AP has a smaller data path to handle client traffic.

For instance, if your data rate is set to 20Mb but you have 5 clients all want 7Mb of read data from internet the AP can only serve one client at the time with the 7Mb of traffic (that is sort max tcp traffic for a 20Mb physical data rate). While AP is sending data at the max of 7Mb to client A, the 7Mb traffic for the other clients sits in the AP waiting for their turn to be send to their destination.
If its turn for client B then more data for client A that is still on its way gets now buffered in the AP waiting until its the turn for client A again... when the AP turns to sending to client A again there is already a full buffer of data waiting to be send on the AP while still more is on its way. So soon the AP can't deal with it anymore and the buffer flows over meaning tcp traffic slows at the server and the speed goes down.
Since now AP is continuously busy getting its buffers empty with waiting data to send to the different clients the AP is actually saturated and extra traffic will see more delays so ping times run up too...
This still while there is almost no package losses....

Now, in finding higher PHY (MCS) rates that still give reasonable CCQ (=package losses ratio compared to succeeded package delivery) the buffers get emptied faster, there probably is even time to empty the buffer for a client plus direct send traffic on its way so capacity of AP to deal with all data increased since he can send it out of his buffers faster then source actually supplies (7Mb)
If mcs rates still give good CCQ (thus not too much package losses) this will free the airtime for each client much faster and time is left for others too and ping packages have more change to pass.

I think therefore that its best always to look for highest stable connection rates and then to avoid too much 'flapping' set 4 in the way I'd showed in the beginning.
This theory is even more important when using 802.11 n or 'ac' protocol. You get doulbe the capacity in air rates due NV2 not be very good but to keep latency low you need to keep as much airtime free as possible to lower the change stations start 'fighting' for airtime with AP which creates extra overhead, re-sends and package losses and thus jitter and latency go up.
So althoug I offer 50Mbsp to clients, that rarely use more then 20-30Mbps for short time I try to work with air rates of above 200Mbps. So traffic of stations gets handle really fast by AP thus is can deal with other clients sooner which keeps latency low while I still can fulfil promise of delivery up to 50Mbps to client, even when it are 2 or 3 at the same time! And latency stays relative low....

(Sometimes when there is a big spread in signal strenghts in the P2MP AP's network you need to work with some extra rates. And when their is a really big spread or clients with unstable links I sometimes leave rate setting to 'auto'.)
Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.

Who is online

Users browsing this forum: No registered users and 19 guests