Community discussions

MUM Europe 2020
 
WojtusW5
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 65
Joined: Mon Oct 02, 2017 1:25 pm

Mode button on devices

Sun Mar 25, 2018 7:42 pm

Hi,
I have a question what is the mode button on the routers (for example at top of RB 941) - foto in attachment
When I press the button, there is no action (default and empty configuration).

Thank you in advance for your help
You do not have the required permissions to view the files attached to this post.
I invite you to visit my blog
https://mikrotikon.pl/
 
sid5632
Member
Member
Posts: 356
Joined: Fri Feb 17, 2017 6:05 pm

Re: Mode button on devices

Sun Mar 25, 2018 9:34 pm

It doesn't do anything (currently, and hasn't for 6 months).
See this thread: viewtopic.php?f=2&t=127597
 
User avatar
grusu
Member Candidate
Member Candidate
Posts: 104
Joined: Tue Aug 13, 2013 7:35 am
Location: Bucharest, Romania

Re: Mode button on devices

Mon Mar 26, 2018 8:47 am

Hi,
I have a question what is the mode button on the routers (for example at top of RB 941) - foto in attachment
When I press the button, there is no action (default and empty configuration).

Thank you in advance for your help
I have tested on cAP AC in 6.42 RouterOS version and it works:

/system routerboard mode-button
set enabled=yes on-event=script_reboot
/system script
add name=script_reboot owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source="/system reboot"


In the default configuration is set as:

/system routerboard mode-button set enabled=yes
/system routerboard mode-button set on-event=dark-mode
/system script add name=dark-mode comment="defconf" source={
:if ([system leds settings get all-leds-off] = "never") do={
/system leds settings set all-leds-off=immediate
} else={
/system leds settings set all-leds-off=never

Who is online

Users browsing this forum: No registered users and 20 guests