Community discussions

MikroTik App
 
Nefraim
just joined
Posts: 8
Joined: Fri Apr 13, 2018 10:01 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G (not yet for 2.4GHz) and 5G WiFi

Sat Apr 28, 2018 11:59 am

How about yours in these figures (ping time and transfer rate)?
2.4 GHz band is very dirty. I can not do a clean experiment. My hap ac^2 is receiving a signal from 46 stations near. Best results on channel 13, average 49 Mbit/sec. On channel 6 average 24 Mbit/sec and very unstable. Therefore, 40 MHz can not be used with hi speed. Maybe a mikrotik can improve noise immunity. But such tests as at 5 GHz, at 2.4 GHz in the house can not be carried out.
If you experience different speed when changing 2.4 GHz channels from 1 to 6 or 13 is pointing to another emitter in your area. Mikrotik can try to improve transfer rates but usually in crowded scenarios, changing the channel will be the best solution afaik. This is why you get better result when you changed the channel.

You might want to try to see if another electric equipment isn't messing the 2.4 Ghz channel. My worst experience was when a stupid 2.4 GHz wireless mouse was interfering with my signal. I was blaming the router turns out it was the stupid mouse wireless receiver that was hampering may connection. If I had my wireless mouse on my connection was garbage unplugging the thing everything was fine. Try to see if you don't have any other emiters neear by.
 
Traveller
newbie
Posts: 28
Joined: Thu Apr 05, 2018 10:12 am

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G (not yet for 2.4GHz) and 5G WiFi

Sun Apr 29, 2018 11:12 am

If you experience different speed when changing 2.4 GHz channels from 1 to 6 or 13 is pointing to another emitter in your area. Mikrotik can try to improve transfer rates but usually in crowded scenarios, changing the channel will be the best solution afaik. This is why you get better result when you changed the channel.
Yes. But, for 40 MHz bandwidth i must use two channels with a distance 4 channel: 1 and 5, 6 and 2, 6 and 10 or 9 and 13. I do not have two free channels. I have free only 13 channel. On free channel hAP ac^2 transmits data without failures.
You do not have the required permissions to view the files attached to this post.
 
squeeze
Member Candidate
Member Candidate
Posts: 146
Joined: Thu Mar 22, 2018 7:53 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Mon Apr 30, 2018 6:21 am

After some testing this weekend with a Realtek USB AC adapter and a single client device, I found the following trying to get the best I could from the router without heavy tweaking of the Wireless settings:

  • 2.4 GHz: no significant performance difference from RouterOS 6.42.1 to 6.43rc5. Approx. 130 Mbit/sec download, 85 Mbit/sec upload on average.
  • 5 GHz: up to a 15% performance improvement from RouterOS 6.42.1 to 6.43rc5 (includes running the routerboard firmware upgrade). Approx. 400 Mbit/sec download, 350 Mbit/sec upload.
  • very low 10 Mbit/s UDP stream losses (<0.5%), low to very low jitter (<10ms), zero standard 1s ping packet losses, few large pings (<2%)

Test conditions:

  • low interference, according to spectral scans
  • 1m distant from the wireless client to test router
  • all tests were through the router interfaces (WAN-WLAN) using PC endpoints
  • regulatory domain TX power for 2.4 GHz, default manual-tx-power for 5 GHz

More details on the 6.43rc5 2.4 GHz band status:

  • TX/RX Signal Strength: -25 to -35 dBm
  • Signal to Noise: 70 to 80 db
  • Tx/Rx CCQ: 85% to 100%
  • Tx Rate: 300 Mbps @ 40 MHz
  • Rx Rate: jumps around a lot, anywhere from 6 Mbps to 216 Mbps@40 MHz

So, overall it appears the Mikrotik hAP ac^2 is very good at 5 GHz now for a 2x2 device, especially its upload throughput.

The 2.4 GHz performance could be more symmetrical. That upload could perhaps be improved by another 15%, if the Netgear Orbi is anything to go by.

I'm still intrigued by the 2.4 GHz latency and stability. There seem a lot of conflicting reports. But from my short (<10 minute) tests, I could not find any significant flaws.

I guess there could also be compatibility issues remaining with certain client WiFi chips, given what's happened in the last two patches.
 
User avatar
DanielJB
Frequent Visitor
Frequent Visitor
Posts: 58
Joined: Mon May 27, 2013 3:05 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Mon Apr 30, 2018 11:53 am

1. where there is spectral congestion (eg 2.4GHz networks), I suggest using hw-protection-mode=cts-to-self and hw-protection-threshold=200 (to keep overhead low on TCP ack packets)
2. hw-protection-mode=rts-cts has higher overhead but may give better client->AP throughput if the AP transmit power is significantly higher than the client (100mW vs 30mW) as nearby APs will be able to hear the AP's 'client about to transmit' message
3. conduct spectral scanning to identify low-energy/interference bands (5GHz possible on older Mikrotik 802.11n 5GHz radios)
4. you will see better throughput if SSIDs overlap fully (eg on 2.4GHz, all are on channel 1, 6 and 11) as the collision probability would be lower
5. where there is significant congestion, reduce channel width to minimise retransmissions due to collisions. I feel Mikrotik should make channel width 20MHz default @ 2.4GHz, no?
 
alengrosevic
just joined
Posts: 10
Joined: Fri Mar 30, 2018 12:14 am

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Mon Apr 30, 2018 2:11 pm

@squeeze: Colud you please explain to me how did you, based on your test on distance of 1m, concluded that wireless part is good? On distance of 1m, I would use cable, this is not the type of test that is used for wireless. Put distance of 5m, then 10m, and even if you can 15m between devices. Then put on wall between them. Then you will get real scenarios. Distance of 1m is maybe to see max throughtput od wireless, but if you want to see if this device is good for home/office use, then please test it diferently. In my case, RC5 did improve 5GHz performance, but this is still not finished. After using several AC devices before HAP AC2, I can tell that performance of Wireless part is still behind other competitors.
 
squeeze
Member Candidate
Member Candidate
Posts: 146
Joined: Thu Mar 22, 2018 7:53 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Mon Apr 30, 2018 2:30 pm

@squeeze: Colud you please explain to me how did you, based on your test on distance of 1m, concluded that wireless part is good? On distance of 1m, I would use cable, this is not the type of test that is used for wireless. Put distance of 5m, then 10m, and even if you can 15m between devices. Then put on wall between them. Then you will get real scenarios. Distance of 1m is maybe to see max throughtput od wireless, but if you want to see if this device is good for home/office use, then please test it diferently. In my case, RC5 did improve 5GHz performance, but this is still not finished. After using several AC devices before HAP AC2, I can tell that performance of Wireless part is still behind other competitors.

I did these basic tests because even such had awful performance in multiple aspects before. Note the thread title and past posts ...

Nor was I interested in doing any broader tests of the wireless of this device until such basics worked. There was little point wasting time on it if even the simplest context I could create produced no improvement. Now since it appears worth it, I can test further at my leisure with my use cases, which would be more difficult to compare with others anyway.

If you would like to contribute with your own "real scenarios" tests or explain what you mean by "performance of Wireless part is still behind other competitors", feel free.
 
User avatar
Davis
Member Candidate
Member Candidate
Posts: 109
Joined: Mon Aug 01, 2011 12:27 pm
Location: Latvia, Riga
Contact:

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Tue May 01, 2018 2:32 am

I have noticed that (at least in my specific setup) hAP ac² together with Intel 7260 wifi card has issues with action=set-priority mangle rules.
I had used this mangle rule (rule comes from this MUM presentation) and disabling it in some cases drastically improved performance (e.g. SFTP file download improved from 1-2 MB/s to 9-10 MB/s limited by internet speed):
/ip firewall mangle
add action=set-priority chain=postrouting comment="DSCP to 802.11 WMM" \
    new-priority=from-dscp out-interface=bridge passthrough=yes
Also I have noticed that different versions of Intel drivers behave differently (e.g. 16.5.3.6 seem to offer better and more stable speeds than 18.33.12.2).
 
pepek
just joined
Posts: 23
Joined: Tue Apr 10, 2018 12:14 am
Location: CZ

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Tue May 01, 2018 8:10 am

To anyone (yhfung, strods?) who marked this topic as SOLVED - could you un-mark it please? This problem is not so bad as before, but it is not solved.

Today, I made another test and it showed same speeds as last time (even slightly slower) - but this time, I've disconnected all other wireless devices in office (Access points, phones, wireless mouse...). Also updated Intel WiFi driver to latest one (20.40.0.4 from February 2018 for Dual Band AC 8265). 5G is all clear, 2G gets few networks with RSSI -80dBm, my is -15dbm (in inSSIDer, registration list shows -30dBm for my client)

During this test, I've been disconnected from hAP ac^2 few times, ping is unstable and 802.11ac download is barely faster than 802.11n upload - this is not OK.
2G download speed is half of 2G upload.

SMB server I used is able to feed 1gbps ethernet.
AP setup - all interfaces in bridge, DHCP client on Bridge, band set to only-N (40mhz Ce) and only-AC (80mhz Ceee), protocol 802.11, WPS off, country Czech Republic, WPA2-PSK AES

Ping without any wireless traffic:
Reply from 192.168.7.7: bytes=32 time=12ms TTL=128
Reply from 192.168.7.7: bytes=32 time=19ms TTL=128
Reply from 192.168.7.7: bytes=32 time=16ms TTL=128
Reply from 192.168.7.7: bytes=32 time=2ms TTL=128
Reply from 192.168.7.7: bytes=32 time=2ms TTL=128
Reply from 192.168.7.7: bytes=32 time=2ms TTL=128
Reply from 192.168.7.7: bytes=32 time=2ms TTL=128
Reply from 192.168.7.7: bytes=32 time=2ms TTL=128
Reply from 192.168.7.7: bytes=32 time=2ms TTL=128
Reply from 192.168.7.7: bytes=32 time=2ms TTL=128
Reply from 192.168.7.7: bytes=32 time=2ms TTL=128
Reply from 192.168.7.7: bytes=32 time=21ms TTL=128
Reply from 192.168.7.7: bytes=32 time=24ms TTL=128
Reply from 192.168.7.7: bytes=32 time=2ms TTL=128
Reply from 192.168.7.7: bytes=32 time=283ms TTL=128
Reply from 192.168.7.7: bytes=32 time=2ms TTL=128
Reply from 192.168.7.7: bytes=32 time=2ms TTL=128
Reply from 192.168.7.7: bytes=32 time=2ms TTL=128
Reply from 192.168.7.7: bytes=32 time=2ms TTL=128
Reply from 192.168.7.7: bytes=32 time=2ms TTL=128
Reply from 192.168.7.7: bytes=32 time=2ms TTL=128
Reply from 192.168.7.7: bytes=32 time=2ms TTL=128
Reply from 192.168.7.7: bytes=32 time=2ms TTL=128
Reply from 192.168.7.7: bytes=32 time=3ms TTL=128
Reply from 192.168.7.7: bytes=32 time=18ms TTL=128
Reply from 192.168.7.7: bytes=32 time=18ms TTL=128
Going to send this info to support mail.
 
yhfung
Member Candidate
Member Candidate
Topic Author
Posts: 142
Joined: Tue Nov 20, 2012 6:58 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Tue May 01, 2018 8:28 am

This was not marked by me. I am not sure who marked it resolved.

By the way, have you updated your RouterOS and firmware of hAP ac^2 to at least v6.43rc5?

Now I am able to connect my remote AP station formed by an hAP ac^2 (R1) by another hAP ac^2 (R2) with two layers of concrete walls in between and both R1 and R2 are at a distance of around 10 meters. R2 was connected to AP of R1 using bridge mode. I used my MacBook Pro Retina to connect ether3 of R2. The download speed that I can achieve 168Mbps.
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-300.01 sec  5.86 GBytes   168 Mbits/sec  648             sender
 
pepek
just joined
Posts: 23
Joined: Tue Apr 10, 2018 12:14 am
Location: CZ

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Tue May 01, 2018 8:44 am

Yes, I have updated both - ROS and firmware to 6.43rc5

Can you rename the topic? Add "[NOT-" to the end of topic name? :)

I believe Mikrotik has their test setup with good speeds, but they have serious problems with some clients. I suspect all Intel cards. I'm able to reach 100mbps on single chain 802.11n Airlive AP with Intel client, but i have problems reaching this speed on dual-band Mikrotik. This is something Mikrotik has to work on. Probably cooperate with Intel?

Your test is 2G or 5G?
 
yhfung
Member Candidate
Member Candidate
Topic Author
Posts: 142
Joined: Tue Nov 20, 2012 6:58 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi [Not]

Tue May 01, 2018 9:03 am

Already done as per your request. They were connected via 5G ac link. If you find something strange, besides putting information here, you can also sent it to the Support for help.

YH
 
pepek
just joined
Posts: 23
Joined: Tue Apr 10, 2018 12:14 am
Location: CZ

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi [Not]

Tue May 01, 2018 9:07 am

Mail already sent to support, received automatic reply and waiting...
 
yhfung
Member Candidate
Member Candidate
Topic Author
Posts: 142
Joined: Tue Nov 20, 2012 6:58 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi [Not]

Tue May 01, 2018 10:07 am

It is very strange that I got very good results with my CHUWI notebook, in which Intel ac chip is used. However I forgot the model number. The download speed can reach over 200Mbps. Now I can get only 20Mbps. I have to find out the method to replicate the problem such that the Support Team is able to locate where gives the problem. My MacBook Pro Retina could give me 380Mbps without any difficulties.

YH
 
yhfung
Member Candidate
Member Candidate
Topic Author
Posts: 142
Joined: Tue Nov 20, 2012 6:58 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi [Not]

Tue May 01, 2018 12:31 pm

Since I have four hAP ac^2, I can very whether it could happen only one of them or all of them. Based on the results obtained below, it shows clearly that the issue of download issue has not been resolved. The maximum download rate (File server (iperf3 server) -> WAN -> WLAN -> Laptop PC (MacBook Pro Retina 2015, CHUWI notebook 2017).

As seen in Listing 1, the download speed is only 25Mbps, which is much below 380Mbps of my MacBook Pro Retina 2015. MikroTik Team has to adjust system code to cater for Intel-basd AC adapters.

YH

Listing 1: Download Test on 5G hAP ac^2 with v6.43rc5 RouterOS uisng CHUWI ac interface (Intel Dual-Band Wireless-AC 3165)
Accepted connection from 192.168.55.172, port 51338
[  5] local 192.168.55.203 port 5201 connected to 192.168.55.172 port 51339
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-1.01   sec  3.25 MBytes  27.1 Mbits/sec    0    170 KBytes
[  5]   1.01-2.01   sec  3.00 MBytes  25.2 Mbits/sec    0    268 KBytes
[  5]   2.01-3.00   sec  3.06 MBytes  25.8 Mbits/sec    0    271 KBytes
[  5]   3.00-4.01   sec  2.76 MBytes  23.0 Mbits/sec    0    271 KBytes
[  5]   4.01-5.01   sec  2.76 MBytes  23.1 Mbits/sec    0    271 KBytes
[  5]   5.01-6.01   sec  2.76 MBytes  23.1 Mbits/sec    0    271 KBytes
[  5]   6.01-7.00   sec  3.06 MBytes  25.8 Mbits/sec    0    271 KBytes
[  5]   7.00-8.01   sec  2.76 MBytes  23.1 Mbits/sec    0    271 KBytes
[  5]   8.01-9.01   sec  2.76 MBytes  23.1 Mbits/sec    0    271 KBytes
[  5]   9.01-10.01  sec  2.76 MBytes  23.1 Mbits/sec    0    271 KBytes
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.02  sec  28.9 MBytes  24.2 Mbits/sec    0             sender
 
squeeze
Member Candidate
Member Candidate
Posts: 146
Joined: Thu Mar 22, 2018 7:53 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi [Not]

Tue May 01, 2018 2:27 pm

Listing 1: Download Test on 5G hAP ac^2 with v6.43rc5 RouterOS uisng CHUWI ac interface (Intel Dual-Band Wireless-AC 3165)
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.02  sec  28.9 MBytes  24.2 Mbits/sec    0             sender

You get no "Retr" from your TCP reverse tests? Or are you not using the "-R" iperf3 option?

Maybe you have an MTU problem. Try the following in a command or Powershell:

ping myserver –f –l 1472
ping myserver –f –l 1470
ping myserver –f –l 1460
etc.

Keep reducing the buffer size until you find one that does not bring up an error. Then set the highest you get on that specific client device with:

netsh interface ipv4 set subinterface “wi-fi” mtu=xxxx store=persistent

where xxxx = number you found.
Last edited by squeeze on Tue May 01, 2018 5:02 pm, edited 3 times in total.
 
User avatar
vecernik87
Long time Member
Long time Member
Posts: 678
Joined: Fri Nov 10, 2017 8:19 am

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi [Not]

Tue May 01, 2018 2:38 pm

My speed grealty improved after enabling "throughput booster" in Intel's wireless settings:
device manager -> network adapters -> [your wireless card] -> advanced -> troughput booster -> enabled
I am not certain what does it do but it may have something to do with timing and colission handling. It is said, that enabling will improve your speed if equal speed for all clients is not required.
Maybe Intel simply waits too much in order to let everyone around communicate equally?
 
pepek
just joined
Posts: 23
Joined: Tue Apr 10, 2018 12:14 am
Location: CZ

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi [Not]

Tue May 01, 2018 2:43 pm

No, this setting was not useful for me. (maybe a little, but not significantly)

I had the same speed problems with my previous notebook - Latitude with Intel 7265. I had to replace wlan card to bcm model to get better speed with mikrotik. There was no other speed problem than with mikrotik AP. And I don't want to start changing internal devices on brand new precision...
 
yhfung
Member Candidate
Member Candidate
Topic Author
Posts: 142
Joined: Tue Nov 20, 2012 6:58 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi [Not]

Tue May 01, 2018 4:05 pm

My speed grealty improved after enabling "throughput booster" in Intel's wireless settings:
device manager -> network adapters -> [your wireless card] -> advanced -> troughput booster -> enabled
I am not certain what does it do but it may have something to do with timing and colission handling. It is said, that enabling will improve your speed if equal speed for all clients is not required.
Maybe Intel simply waits too much in order to let everyone around communicate equally?
Thank you for your suggestion, I did follow your idea to adjust the settings. It turned out that the speed boosted to 220Mbps. When I disabled the settings, it still gave me 220Mbps download. It is really strange and not able to be explained. If you found it did not work, try to reboot your PC.

YH
 
yhfung
Member Candidate
Member Candidate
Topic Author
Posts: 142
Joined: Tue Nov 20, 2012 6:58 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi [Not]

Tue May 01, 2018 4:11 pm

Listing 1: Download Test on 5G hAP ac^2 with v6.43rc5 RouterOS uisng CHUWI ac interface (Intel Dual-Band Wireless-AC 3165)
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.02  sec  28.9 MBytes  24.2 Mbits/sec    0             sender
You get no "Retr" from your TCP reverse tests? Or are you not using the "-R" iperf3 option?
I did use the -R option when carry out the iperf3 test. Since the test only ran for a few seconds, it did not have any packets retry for a very short period of time. In the another post, I mentioned that I could obtain higher throughput (220Mbps on Intel-based AC) by applying the suggestion given by other member.

If I have time, I shall follow your mentioned to adjust the MTU to see whether it has any improvement when the speed drops to 2xMbps.

YH
 
alengrosevic
just joined
Posts: 10
Joined: Fri Mar 30, 2018 12:14 am

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi [Not]

Wed May 02, 2018 12:36 am

I have managed to get some improvements with AC2. I use AC2 on his stand to be installed vertically on the table (5m away from computer). Antennas (X99A Titanium MSI) of my AC wireless card were until now verticaly mounted. Today i have tried to mount them horizontally, just for testing. Signal quality has jumped instantly from 70-75% to 90-95%. Transfer is faster and more stabile (even). Connection speed between computer and router has arised from 520 mbit to 780 mbit. Maybe this information can help someone with this problem.
 
yottabit
Member Candidate
Member Candidate
Posts: 174
Joined: Thu Feb 21, 2013 5:56 am

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi [Not]

Wed May 02, 2018 2:29 am

The internal antennas in the hAP ac2 are 90-degrees offset. Try aligning your wireless adapter antennas the same way (1 horizontal, 1 vertical, 0/90 degrees; then +45/-45 degrees), and see if this can make further difference.

Sent from my Pixel XL using Tapatalk


 
morph1
just joined
Posts: 9
Joined: Wed Apr 25, 2018 3:50 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi [Not]

Wed May 02, 2018 11:36 am

i think you should hold your horses. You guys did improve the situation, no doubt. But wouldn't call this issue to be resolved:
photo_2018-05-02_10-35-29.jpg
We are getting somewhere, but as you can see in comparison with other products there is still some room to get even better.
Are we expecting more work on this side or is this the best that can be done?

P.S.: still using the same settings/methods as in my previous post
You do not have the required permissions to view the files attached to this post.
 
yhfung
Member Candidate
Member Candidate
Topic Author
Posts: 142
Joined: Tue Nov 20, 2012 6:58 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Wed May 02, 2018 2:40 pm

morph1,

Many thanks for showing your revised chart including the firmware upgrade on hAP ac^2.

Based on your chart figures, it shows clearly that the ping time is much larger than others. Because of the poor performance in wireless section (not only on hAP ac^2 prodcuts but all MikrotiK WiFi products), there is a shift of products from MikroTik to Ubiquiti. As for me, I of course want MikroTik to improve their WiFi products as quick and as soon as possible.

In the beginning of this thread and other threads, only few people found satisfactory with their hAP ac^2 but majority of us found big problems on hAP ac^2. Why? How comes? I do believe that the WiFi testing on hAP ac^2 in MikroTik was not complete thoroughly. Nevertheless, the major issue was over but minor tuning has to be continued as some members still founds problems in their WiFi adapters.

YH
 
squeeze
Member Candidate
Member Candidate
Posts: 146
Joined: Thu Mar 22, 2018 7:53 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi [Not]

Wed May 02, 2018 2:58 pm

P.S.: still using the same settings/methods as in my previous post

Thanks for the tests. I don't understand the new bottom scale, compared to your previous ones. Is it still 10ms pings and 60k ping count?
 
morph1
just joined
Posts: 9
Joined: Wed Apr 25, 2018 3:50 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi [Not]

Wed May 02, 2018 6:08 pm

P.S.: still using the same settings/methods as in my previous post

Thanks for the tests. I don't understand the new bottom scale, compared to your previous ones. Is it still 10ms pings and 60k ping count?
uhh my bad. totally overseen that we changed the plots :) still using 10ms interval on the pings, 60k of them. so the scale is in [ms]!
The new plot style includes ALL packets.
Since we found out that there is a huge difference in the distribution of the ping responses, we decided to adapt the scale to have all of them included - instead of just the number >10ms.
Hope this helps.
 
alengrosevic
just joined
Posts: 10
Joined: Fri Mar 30, 2018 12:14 am

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi [Not]

Fri May 04, 2018 12:10 pm

The internal antennas in the hAP ac2 are 90-degrees offset. Try aligning your wireless adapter antennas the same way (1 horizontal, 1 vertical, 0/90 degrees; then +45/-45 degrees), and see if this can make further difference.

Sent from my Pixel XL using Tapatalk
I have tried all the combination but the best result was with the antennas positioned horizontally.
 
squeeze
Member Candidate
Member Candidate
Posts: 146
Joined: Thu Mar 22, 2018 7:53 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Sun May 06, 2018 2:58 am

I decided to adapt morph1's low latency testing approach, but for best case scenario, relative stability tests. These were my results.

TL;DR. Mikrotik hAP ac2 has a stability issue with 5 GHz band at 40 MHz channel width (visible also on morph1's results), but all other widths and bands performed well. The original Mikrotik hAP ac has a surprisingly disappointing 2.4 GHz band stability at 20 MHz channel width (often required for those in high interference environment and still using 2.4 GHz devices). Asus are better than I thought, almost a decade ago. :D

Box-and-Whisker Plot of 56-byte data, 10 ms interval, 60k count ICMP pings with three different devices: Mikrotik hAP ac2, Mikrotik hAP ac and Asus RT-N56U as a basic comparison.

I tested 2.4 GHz (default and 20 MHz), and 5 GHz (default, 40 Mhz and 20 MHz) with hAP ac2's wired LAN-to-WAN performance as reference. Default 5 GHz channel width on Mikrotik devices was 80 MHz.

Lower is better:
Image


Standard Box and Whisker parameters used. I don't think morph1 uses the default parameters or has a very different test environment, so cannot compare directly. Analysis tool is Matlab.

The blue box represents the traffic jitter, i.e. non-outlier traffic variation on the connection. Large box = large jitter which is worse for low latency applications.

The red crosses represent outliers that fall so far outside of the total range of the normal traffic, that they can be statistically rejected as random with a 99.3% confidence when the underlying distribution is or tends to the Normal distribution.

The ping range is carefully chosen. A maximum of 40 ms variation is normally desired for streaming applications like VoIP. A maximum of 250 ms delay for other applications like gaming. I zoomed in to 250 ms instead of 500 ms RTT because the worst offenders look the same. The actual maximums observed were sometimes much higher than that, e.g. 2000 ms (2s) for the "ac2 5GHz @ 20/40MHz" configuration and 525 ms for the "ac 2.4GHz @ 20MHz" configuration.

I could have zoomed in to show the jitter more closely for low latency differences, but given the number and distribution of outliers, that is far less important for stability.

Due to the significantly poorer performance of the "ac2 5GHz @ 20/40MHz" and "ac 2.4GHz @ 20MHz" configurations, I actually did them twice to check and took the best run of each. There was no significant difference in either standard deviation or outlier count between these alternate runs.

Test setup is the same as before:
  • PC (client) -> WLAN -> NAT -> WAN (single hop) -> PC (server). No load on WAN or its router
  • RTL8814AU WiFi chip USB 3.0 adapter connected to client PC via USB 3.0 ports
  • Mikrotik devices: regulatory domain TX power for 2.4 GHz, default manual-tx-power for 5 GHz
  • Default configuration for all devices: 2.4 GHz N-only, 5 GHz (auto)
  • Testing generated only 8.4 kB/s traffic
  • Stable link rates
  • No walls separating devices and test client
  • None of the test devices are Internet facing
  • Low interference environment, see spectral scan below. Scan not taken from test device but from the hAP ac outside of testing
  • Firmware: hAP ac2 (RouterOS + firmware: 6.43rc5), hAP ac (RouterOS + firmware: 6.41.3), Asus RT-N56U (30043807378)

Image
Last edited by squeeze on Wed May 16, 2018 2:14 pm, edited 5 times in total.
 
Sheriff1972
just joined
Posts: 20
Joined: Fri Feb 16, 2018 7:48 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Sun May 06, 2018 8:22 am

Amazing detective work! I hope that this gives a focus to the engineering team at MT.
 
hapi
Member Candidate
Member Candidate
Posts: 224
Joined: Fri Mar 11, 2011 11:21 am
Location: Czech Republic

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Sun May 06, 2018 12:45 pm

in 5GHz with "Intel Dual Band Wireless-AC 7265" is tx rate only 54Mbit. In 2.4GHz is full speed.

Image
 
yhfung
Member Candidate
Member Candidate
Topic Author
Posts: 142
Joined: Tue Nov 20, 2012 6:58 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Sun May 06, 2018 3:43 pm

in 5GHz with "Intel Dual Band Wireless-AC 7265" is tx rate only 54Mbit. In 2.4GHz is full speed.

Image
Please consider to use the actual data transfer test tool, for instance iperf3.

Regarding to your Intel AC adapter, please select something link "boost performance" under the advanced tap of your wireless adapter in the device manage of the Windows PC.

YH
 
yhfung
Member Candidate
Member Candidate
Topic Author
Posts: 142
Joined: Tue Nov 20, 2012 6:58 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Mon May 07, 2018 4:17 am

squeeze,

Reading your post in this thread gives more information about the current status of MikroTik WiFi products. As per my memory in other forum, that forum members concluded that MikroTik WiFi routers or APs would not their choices due to extremely poor performance. MikroTik products are good at routing and switching but WiFi. They will choose Ubiquiti APs to work with MikroTik routers or Ubiquiti routers. If we combine their comments and the results presented by you and morph1, it shows a very clear message that the overall performance of general MikroTik WiFi routers and APs is not satisfactory. I do not know whether the MikroTik Management Team knows this WiFi weakness. In order to resolve this poor Wifi performance, MikroTik have to form a good quality plan for their WiFi router and AP products by specifying the specifications for 1) ping test, 2) throughput test, and others against several brands of WiFi devices before they are released for production and sales.

Based on my past embedded firmware development's experience, it seems the interface between WiFi routines and RouterOS is not very good. It seems that the RouterOS do not have time to respond the request from the WiFi routine due to unknown reasons. Although the WiFi performance of hAP ac^2 has already been improved significantly as compared to the very beginning when the products launched to the market, it is still not enough as compared to the other WiFi brands.

I hope MikroTik has to review the interface between the RouterOS and WiFi routines throughly. If they can shorten the ping time, I do believe that the sales of MikroTik WiFi products will be increased tremendously.

YH
 
pepek
just joined
Posts: 23
Joined: Tue Apr 10, 2018 12:14 am
Location: CZ

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Thu May 10, 2018 6:08 pm

It seems, that there will be no speed improvement in near future because of other 6.42.1 problems being fixed in current RCs...
I think that Improving this problem to "somehow usable, not totally crappy" lowered it's priority

Still no response from support on my speed issues from last week...
 
startus
just joined
Posts: 2
Joined: Thu May 10, 2018 10:57 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Thu May 10, 2018 11:21 pm

hi everyone. I am sorry if this is not the right place to ask for an opinion, but I`ve decided to give a try once I`ve checked all the professional feedbacks about MK here and I felt it worths a try due to my outdated knowledge of MK products. My last and current version of RB is the 433AH that I use at home, but I want upgrade for a Giga + dual (2.4 and 5) wireless solution.

I almost bought the hAP ac^2, however after a quick search I`ve found this topic and basically I would like to have an idea if I should give a try and buy the hAP ac^2 (and wait for later improvements) or
buy the hAP AC RB962UiGS-5HacT2HnT model (I did not find a topic with problems for this model, is there any I don`t know?).

Both have the basic requirements I need and money is not a problem. Therefore I would like to know why not buy the hAP AC RB962UiGS-5HacT2HnT instead of the hAP ac^2

P.S. I just installed NAS with gigabit interface at home and I will upgrade the speed of my internet for something around 120mbs if that helps.

Thanks for the help.
 
Bivvy
newbie
Posts: 32
Joined: Sat Feb 04, 2017 1:36 am

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Fri May 11, 2018 8:21 am

Anyone know the first version of the firmware that suffered the poor WiFi problems?
We have >130 clients using HAP ac's and recently started getting complaints about poor speeds.
Bandwidth tests from the router and from PC's plugged straight into the router are all fine - it's just the WiFi that is letting us down.
As the problems started fairly recently and we've just gone through a process of upgrading all firmware to the latest stable release it seems like too much of a coincidence.
Now considering downgrading all firmware to a previous release - just need to know which one to go for...
Thanks
 
yhfung
Member Candidate
Member Candidate
Topic Author
Posts: 142
Joined: Tue Nov 20, 2012 6:58 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Fri May 11, 2018 1:25 pm

Bivvy,

First of all, I guess you are talking about hAP ac^2 instead of hAP ac. They are two different models. Please note that the stable version of RouterOS on hAP ac^2 can not resolve the WiFi issues, you have to upgrade to the release candidate version of v6.43rc5 or above. Please update it to the current firmware of v6.43rc11 and you will find the speed improved significantly.

If you are not talking baout hAP ac^2, there will be other issues associated with the poor performance.

YH
 
yottabit
Member Candidate
Member Candidate
Posts: 174
Joined: Thu Feb 21, 2013 5:56 am

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Fri May 11, 2018 2:32 pm

Startus: the hAP ac model has superior wireless over the hAP ac2, with higher radio power and 3 antenna chains per radio instead of only 2.

But the hAP ac2 has a much more powerful CPU, quad-core ARM v. single-core MIPS.

I am using the ac2 for my router as the ac maxes CPU for me with my QoS rules. If you're going to use QoS and need NAT routing throughput greater than 100 Mbps, I suggest you use the ac2 for routing. And I do have three ac models that I use for wireless coverage and speed (I have the wireless function disabled on my ac2).

Sent from my Pixel XL using Tapatalk


 
startus
just joined
Posts: 2
Joined: Thu May 10, 2018 10:57 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Fri May 11, 2018 4:36 pm

yottabit: Thank you.

Just to clarify my scenario. Most of the time I will be using my desktop + NAS in the LAN side (gigabit) alongside with 5 wireless devices (2 cell phones, 1 tablet, 1 chromecast, and 1 raspberry pi).

From time to time (maybe once in a month) I may use the LAN to make backup`s of my NAS and local video streaming from the NAS, but not constantly.

I will use in the wan side (120mbs down and 20mbs up) with few rules, portforwarding and one VPN session. I also will enable some services in the NAS to be used from the internet, like audio streaming and file sharing (cloud) etc behind the NAT.

I don`t believe I will upgrade my internet in the next 3 years, being said, If I understood correctly, the hAP would do the job right? I think the hAP ac2 can help me as well even with less wireless power. I am afraid the problem with hAP ac2 may not be solved.

Anybody else could share any thoughts?
Thank you in advance.
 
yottabit
Member Candidate
Member Candidate
Posts: 174
Joined: Thu Feb 21, 2013 5:56 am

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Fri May 11, 2018 6:24 pm

Since your upstream speed is so low, you'll be just fine using the hAP ac as a router, even if you implement QoS in the future.

If you ever get 100M+ upstream, *and* want QoS, you can buy a more powerful router for that when you need it (e.g., hAP ac2, or whatever its successor may be).

Sent from my Pixel XL using Tapatalk

 
yhfung
Member Candidate
Member Candidate
Topic Author
Posts: 142
Joined: Tue Nov 20, 2012 6:58 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Mon May 14, 2018 3:51 am

startus,

Both hAP ac and hAP ac^2 can fit your requirements. As the member "yottabit" has mentioned that the main benefits of using hAP ac are the higher WiFi transmission power and throughput. The downside of hAP ac is the routing power.

Since both models can fit your requirement, you may consider to choose the lowest-priced one, that is hAP ac^2.

YH
 
squeeze
Member Candidate
Member Candidate
Posts: 146
Joined: Thu Mar 22, 2018 7:53 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Mon May 14, 2018 2:05 pm

@startus

With release candidate RouterOS software (6.43rc5+) the hAP ac2 WiFi is good enough for anything for a typical consumer - though I would not recommend its WiFi for low latency applications at the moment, e.g. gaming, but you should be using wired for that anyway in most situations.

Since your main use case is less WiFi than strong routing, this actually makes the hAP ac2 absolutely preferable over the hAP ac or any other Mikrotik SOHO device.
 
Bivvy
newbie
Posts: 32
Joined: Sat Feb 04, 2017 1:36 am

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Mon May 14, 2018 6:50 pm

@yottabit - Thanks for your reply.
We're using HAP ac's (RB962UiGS-5HacT2HnT) - until you pointed out the difference I had not realised there were two versions. Sorry if I posted in the wrong place,
In the past fortnight we've had lots of complaints
a) slow WiFi performance
b) unable to connect over the WiFi

Downgrading from 6.42.1 to 6.40.4 seemed to fix the problems, but now I'm not so convinced as one of our customers is still struggling to connect to the WiFi even after the downgrade.
I appreciate that these issues may not be directly related to the original subject of this thread.

I like Mikrotik but can't afford to spend so much effort supporting the client routers...
Ticket raised with Mikrotik tech support but no response yet (although we're still inside the 3 day SLA)

Should I try the latest release candidate?
 
squeeze
Member Candidate
Member Candidate
Posts: 146
Joined: Thu Mar 22, 2018 7:53 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Mon May 14, 2018 6:57 pm

Release candidates are not for production in any form of business environment. Nor are they intended as a substitute for basic troubleshooting.

Since your posts have nothing whatsover to do with the hAP ac2 (it is not even similar architecture, let alone radios), please refrain from bumping this topic. Many people are monitoring this thread for updates and information exclusive to the hAP ac2 and also receive notifications via email. Please respect them and start your own separate thread.

Thank you.
 
aidan
newbie
Posts: 28
Joined: Thu Jun 25, 2015 12:48 am

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Mon May 21, 2018 3:19 pm

Early reports mentioned that the hAP ac^2 and cAP AC have a 10 dBm weaker signal than a wAP AC. Can anyone comment whether 6.43rc has also resolved this problem? Thank you.
 
alengrosevic
just joined
Posts: 10
Joined: Fri Mar 30, 2018 12:14 am

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Wed May 23, 2018 11:34 pm

RC17 is out.
*) wireless - increased stability on hAP ac^2 and cAP ac with legacy data rates;

But after upgrade I cant login thru winbox anymore. It keeps saying wrong username password. Over Web page I can login, but over winbox I cant. Strange...

EDIT: Log from device:

Time May/23/2018 22:30:04
Buffer memory
Topics
system
error
critical
Message login failure for user admin from A4:**:**:**:**:B1 via winbox
 
mistry7
Forum Guru
Forum Guru
Posts: 1399
Joined: Tue Oct 13, 2009 11:57 am
Location: Germany

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Wed May 23, 2018 11:48 pm

RC17 is out.
*) wireless - increased stability on hAP ac^2 and cAP ac with legacy data rates;

But after upgrade I cant login thru winbox anymore. It keeps saying wrong username password. Over Web page I can login, but over winbox I cant. Strange...

EDIT: Log from device:

Time May/23/2018 22:30:04
Buffer memory
Topics
system
error
critical
Message login failure for user admin from A4:**:**:**:**:B1 via winbox
Could be this

winbox - improved authentication process excluding man-in-the-middle possibility (Winbox v3.14 required);

Or this:

user - all passwords are now hashed and encrypted, plaintext passwords are kept for downgrade (will be removed in later upgrades);
 
squeeze
Member Candidate
Member Candidate
Posts: 146
Joined: Thu Mar 22, 2018 7:53 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Thu May 24, 2018 4:52 am

*) wireless - increased stability on hAP ac^2 and cAP ac with legacy data rates;

I am going to wait until something as fundamental as logging in works, then I'll rerun the stability tests. How exciting, I didn't expect Mikrotik to update so fast on these ARM devices!
 
yhfung
Member Candidate
Member Candidate
Topic Author
Posts: 142
Joined: Tue Nov 20, 2012 6:58 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Thu May 24, 2018 6:29 am

I have the same login problem as the others have. However I could login the router using the old version WinBox 2.2.18.

Based on my initial test, the ping time for 5GHz seems better than the previous versions.
 
alengrosevic
just joined
Posts: 10
Joined: Fri Mar 30, 2018 12:14 am

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Thu May 24, 2018 8:31 am

latest available winbox for download is 3.13. I cant find 3.14.

EDIT: Thank you guys for the link! :)
Last edited by alengrosevic on Thu May 24, 2018 1:21 pm, edited 2 times in total.
 
Zulu
just joined
Posts: 1
Joined: Thu May 24, 2018 8:38 am

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Thu May 24, 2018 8:41 am

latest available winbox for download is 3.13. I cant find 3.14.
new beta winbox https://www.mikrotik.com/download/share/winbox.exe
 
yhfung
Member Candidate
Member Candidate
Topic Author
Posts: 142
Joined: Tue Nov 20, 2012 6:58 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Thu May 24, 2018 8:54 am

The line is at the bottom of the release announcement of v6.43rc17.

viewtopic.php?f=21&t=133420&start=100#p663507

In order to access router running this version by Winbox, please download v3.14rc Winbox loader from here:
https://www.mikrotik.com/download/share/winbox.exe
 
squeeze
Member Candidate
Member Candidate
Posts: 146
Joined: Thu Mar 22, 2018 7:53 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Sun Jun 03, 2018 9:51 am

After some weekend performance testing of Release build 6.42.3 wrt. Mikrotik hAP ac2, I found multiple significant improvements.

TL;DR. Apart from a slight worsening in legacy 2.4 GHz @ 20 MHz wireless stability, I believe Mikrotik have largely solved the worst of the hAP ac2 wireless issues.

Using the same exact process and equipment as my Release Candidate 6.43rc5 testing (principally a RTL8814AU WiFi chip USB 3.0 adapter connected to client PC via USB 3.0 ports), here are the peak throughput results for Release 6.42.3:

  • 2.4 GHz peak download throughput: 161 Mbit/s from 135 Mbit/s = +19% improvement
  • 2.4 GHz peak upload throughput: 117 Mbit/s from 86 Mbit/s = +36% improvement (*)
  • 5.0 GHz peak download throughput: 399 Mbit/s from 396 Mbit/s = no change
  • 5.0 GHz peak upload throughput: 417 Mbit/s from 347 Mbit/s = +20% improvement

All results confirmed with three 60 second runs. Peak throughput commands used: iperf3 -N -P10 -t 60 -R (download) and iperf3 -N -P10 -t 60 (upload).

Here is a summary of the results from the stability tests for 6.42rc3:

Image

The stability test results are shown next visually in Box-and-Whisker plots of 56-byte data, 10 ms interval, 60k count ICMP pings for 6.43rc5 compared to 6.42.3. Again, I have included tests of an old Asus RT-N56U for comparison.

Lower is better:

Image

(*) Changing router orientation from horizontal to vertical caused a leap from what appeared to be a decline to 69 Mbit/s, instead to an improvement of 117 Mbit/s in 2.4 GHz upload! Changing orientation for other peak throughput tests did not significantly impact performance.
 
raceboy
newbie
Posts: 40
Joined: Fri Mar 23, 2018 7:23 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Fri Jun 08, 2018 4:22 pm

Hello. Maybe stupid question :) Does Device need to be upgraded also if in managed by Capsman ? Must be server with Capsman upgraded ? Thanks
 
User avatar
seventh
newbie
Posts: 26
Joined: Fri Nov 20, 2009 11:26 am
Location: Russia, Belgorod

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Fri Jun 29, 2018 1:34 pm

Снимок.PNG
Clients - Roborock vacuum cleaner
Laptop Dell
Samsung Galaxy S4

Me best perfomance early, before I view the problem, about 2 months ago:
Полгига по Wi-Fi.PNG
You do not have the required permissions to view the files attached to this post.
Sorry for my English
 
Dolphnmike
just joined
Posts: 1
Joined: Sat Jun 30, 2018 4:44 am

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Sat Jun 30, 2018 4:52 am

I manage a municipal ISP, we have had a steady flow of wifi issues. Many CX complain of doing and disconnecting wifi as well as slow speeds,
I'm already regretting or purchase of 500 hAC2 units. The pending "Broadcom compatibility firmware fix" had better be the silver bullet or we are going to look elsewhere for the next 1000 units in our Network build.
 
anuser
Member
Member
Posts: 441
Joined: Sat Nov 29, 2014 7:27 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Sun Jul 01, 2018 3:49 pm

So you're a CAPSMAN user? I also fighted against group key timeout disconnects. On the access points try:




/interface wireless set adaptive-noise-immunity=ap-and-client-mode wlan2

/interface wireless set adaptive-noise-immunity=ap-and-client-mode wlan1

/interface wireless set amsdu-limit=4096 amsdu-threshold=4096 mode=ap-bridge wps-mode=disabled wlan2

/interface wireless set amsdu-limit=4096 amsdu-threshold=4096 mode=ap-bridge wps-mode=disabled wlan1

/interface wireless set wireless-protocol=802.11 wlan2

/interface wireless set wireless-protocol=802.11 wlan1

/interface wireless set wmm-support=enabled wlan2

/interface wireless set wmm-support=enabled wlan1

After that enable CAPSMAN Mode with group key Timer Set to 5 minutes

What do you use for CAPSMAN controller? CHR or some CCR?
 
Faceless
just joined
Posts: 18
Joined: Sat Mar 03, 2018 4:03 pm
Location: Ukraine
Contact:

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Fri Jul 06, 2018 10:07 pm

/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce \
disabled=no frequency=auto guard-interval=long mode=ap-bridge \
security-profile=foxy ssid=home tx-power=5 tx-power-mode=all-rates-fixed \
wireless-protocol=802.11 wmm-support=enabled
set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=20/40/80mhz-eeeC
disabled=no frequency=auto mode=ap-bridge security-profile=foxy ssid=\
home_5gh wireless-protocol=802.11
add disabled=no keepalive-frames=disabled mac-address=CE:2D:E0:F5:46:75 \
master-interface=wlan1 multicast-buffering=disabled name=FreeWifi_2Ghz \
ssid=FreeWifi_2ghz wds-cost-range=0 wds-default-cost=0 wps-mode=disabled
add disabled=no keepalive-frames=disabled mac-address=CE:2D:E0:F5:46:75 \
master-interface=wlan2 multicast-buffering=disabled name=FreeWifi_5Ghz \
ssid=FreeWifi_5ghz wds-cost-range=0 wds-default-cost=0 wps-mode=disabled
Using 2 or 5ghz Wifi Samsung s6 getting low dowload speed 10-15mbit/s upload 80-100mbit/s RouterOS 6.42.5.Speed does not differ using 2 or 5 G Frequency. Also I can't see TX power Winbox 3.15
on RB941-2nD everything was OK even speed on 2g was better.
You do not have the required permissions to view the files attached to this post.
 
Faceless
just joined
Posts: 18
Joined: Sat Mar 03, 2018 4:03 pm
Location: Ukraine
Contact:

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Sat Jul 07, 2018 1:00 pm

When connected to 5G Hapac2 Samsung S6 using speed test before downloading or viewing youtube video I got speedtest.com 14/90 mb/sec but after viewing youtube I get 80/90 mbit/s speed test.
You do not have the required permissions to view the files attached to this post.
 
gotsprings
Forum Veteran
Forum Veteran
Posts: 906
Joined: Mon May 14, 2012 9:30 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Mon Jul 09, 2018 10:01 pm

The current RouterOS and firmware have gotten a consistent 300/300M over wireless on my hAP AC2. (MUCH IMPROVED ON WHERE IT STARTED.)

This is in WAP mode... Not CAP. I have around 25 devices onnected across the 2 radios.
Last edited by gotsprings on Sun Jul 15, 2018 2:43 pm, edited 1 time in total.
"It ain't what you don't know that gets you into trouble. It's what you know for sure that just ain't so."
Mark Twain
 
radenli
just joined
Posts: 14
Joined: Tue Apr 04, 2017 10:45 am

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Fri Jul 13, 2018 7:12 am

So Is the problem fixed ?
 
abcde
just joined
Posts: 4
Joined: Sun Jul 15, 2018 5:00 am

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Sun Jul 15, 2018 5:04 am

By far no. I get very unstable and slow connection using my laptop with Intel 7260 on RouterOS v6.43rc44. It really frustrates me.
 
trevevs
just joined
Posts: 2
Joined: Wed Jul 18, 2018 4:03 am

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Wed Jul 18, 2018 4:07 am

hi guys
considering buying one of these for general home use.. want to use it for wifi & VPN. Would wifi be ok using latest stock f/w for general home use?
whats best speed anyones got using VPN single tunnel 256bit?
cheers
 
Eugnis
just joined
Posts: 1
Joined: Wed Jul 18, 2018 5:36 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Fri Jul 20, 2018 3:32 am

Hello. Have anyone faced this problem?
For example, to same wifi connected >1 devices. When some of these devices started some light internet activity (browsing, youtube etc), all another devices experience some issues from very high ping to router >800ms up to disconnects. (without activity ping 1-2ms).
When 2 devices connected to different bands, all is ok on both.
That's strange, another routers (Asus or cheap Tp-link) handles same load perfectly with many devices.
Tried many different settings, also tried latest 6.43rc44 - still no positive changes.
 
gotsprings
Forum Veteran
Forum Veteran
Posts: 906
Joined: Mon May 14, 2012 9:30 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Fri Jul 20, 2018 3:07 pm

Hello. Have anyone faced this problem?
For example, to same wifi connected >1 devices. When some of these devices started some light internet activity (browsing, youtube etc), all another devices experience some issues from very high ping to router >800ms up to disconnects. (without activity ping 1-2ms).
When 2 devices connected to different bands, all is ok on both.
That's strange, another routers (Asus or cheap Tp-link) handles same load perfectly with many devices.
Tried many different settings, also tried latest 6.43rc44 - still no positive changes.
I have been running the hAP AC2 at my house for a few weeks now.

It has 17-40 devices across both radios ALL THE TIME. (Depends on how many people are home.)

Right now... I am watching "The Americans" from Amazon Prime on my LG OLED.
My son is downstairs playing FortNight on his Xbox.
He also has a Samsung tablet playing youtube on his lap.
I am typing on my Acer Laptop.
Ryan's Google Home is playing some sort of music he asked for.
And my Pixel XL is next to me.

They are all on the same 5.8 radio.

Running 6.42.5

I was very critical of the cAP AC when I first got it. But somewhere in the 6.42 firmwares... I went from getting throughput in the mid 50M to consistent 300M. By the time I tested a hAP AC2... the firmwares were already up to the 6.42 range.
"It ain't what you don't know that gets you into trouble. It's what you know for sure that just ain't so."
Mark Twain
 
kobuki
Member Candidate
Member Candidate
Posts: 150
Joined: Sat Apr 02, 2011 5:59 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Fri Jul 20, 2018 5:31 pm

hi guys
considering buying one of these for general home use.. want to use it for wifi & VPN. Would wifi be ok using latest stock f/w for general home use?
whats best speed anyones got using VPN single tunnel 256bit?
cheers
See here. I was able to saturate my 110 Mb downstream using AES-128+SHA256, CPU <10%.
 
shcherban
just joined
Posts: 4
Joined: Tue Aug 14, 2018 7:34 am

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Tue Aug 14, 2018 6:48 pm

Hi, all
Recently bought hAP ac2, it turned out a nightmare to get stable fast link on 2.4 radio.
Options tried:
manual channel select
security (aes/tkip/none)
channel widths with different options (Ce/cE/XX)
updating to RC firmware/OS
leaving only N/a/b/g mode
setting transmit power
power source change
There are few APs from neighbours, however there are 2-3 usable channels, where speed seems to be better, but its still slower than cheap tp-link.
I've got only 15-35 mbps on torrent download comparing to 45-55 mbps on tp-link.
Local share is even worse, transfering file from PC to android and vice versa is only 12-18 mbps vs 22-28 mbps on tp-link.
MikroTik's btest shows 100mbps on 'clean' channels in both directions (separate tests, duplex going 100 for download, 3.5-4 for upload), but internet speed and actual transfer speed is much lower.
Wired im able to get 100 mbps, so its not ISP issue.
My network is laptop (some realtek card), desktop (tp-link wl-721N usb adapter), both are capable of 300 mbps (at least it is indicated in connection properties and in other router status) and 40 MHz wifth, and Redmi3S (20 MHz width)
Am i missing something important?
 
Nefraim
just joined
Posts: 8
Joined: Fri Apr 13, 2018 10:01 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Tue Aug 14, 2018 9:12 pm

Make sure you update your wireless card drivers. Check your hardware provider for newer drivers.
I had issues with an intel 7260 card, with slow speed and connectivity issues. After updating drivers to the latest version my issues are gone..
 
Swordforthelord
Frequent Visitor
Frequent Visitor
Posts: 57
Joined: Thu Jul 08, 2010 10:18 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Tue Aug 14, 2018 11:04 pm

Hi, all
Recently bought hAP ac2, it turned out a nightmare to get stable fast link on 2.4 radio.
Options tried:
manual channel select
security (aes/tkip/none)
channel widths with different options (Ce/cE/XX)
updating to RC firmware/OS
leaving only N/a/b/g mode
setting transmit power
power source change
There are few APs from neighbours, however there are 2-3 usable channels, where speed seems to be better, but its still slower than cheap tp-link.
I've got only 15-35 mbps on torrent download comparing to 45-55 mbps on tp-link.
Local share is even worse, transfering file from PC to android and vice versa is only 12-18 mbps vs 22-28 mbps on tp-link.
MikroTik's btest shows 100mbps on 'clean' channels in both directions (separate tests, duplex going 100 for download, 3.5-4 for upload), but internet speed and actual transfer speed is much lower.
Wired im able to get 100 mbps, so its not ISP issue.
My network is laptop (some realtek card), desktop (tp-link wl-721N usb adapter), both are capable of 300 mbps (at least it is indicated in connection properties and in other router status) and 40 MHz wifth, and Redmi3S (20 MHz width)
Am i missing something important?
Did you upgrade both the packages and the firmware to the latest current versions?
 
shcherban
just joined
Posts: 4
Joined: Tue Aug 14, 2018 7:34 am

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Tue Aug 14, 2018 11:29 pm

yep, i've upgraded to latest stable first, then to 6.43rc51 both OS and firmware
 
anuser
Member
Member
Posts: 441
Joined: Sat Nov 29, 2014 7:27 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Wed Aug 15, 2018 10:47 pm

yep, i've upgraded to latest stable first, then to 6.43rc51 both OS and firmware
Try:
/interface wireless set adaptive-noise-immunity=ap-and-client-mode wlan2
/interface wireless set adaptive-noise-immunity=ap-and-client-mode wlan1
 
shcherban
just joined
Posts: 4
Joined: Tue Aug 14, 2018 7:34 am

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Mon Aug 20, 2018 10:36 am

anuser thanks, now i have 90-100 mbps lan-to-wan
file share still slow (22-25 mbps), will try to figure out why
 
PashaT
just joined
Posts: 16
Joined: Sat Feb 01, 2014 1:10 am
Location: Zhytomyr, Ukraine

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Mon Aug 20, 2018 10:47 am

Please retest with latest 6.42.7.
Performance may be different.
 
Lotar
just joined
Posts: 11
Joined: Fri Jun 15, 2012 2:10 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Wed Sep 26, 2018 2:03 pm

Hi,

I just installed os 6.44beta9 (with firmware update)
The wifi performance is very poor.

Currently I use CAPsMAN . I tried anuse suggestion. No luck.
Whatever I try, I get on 5.8 ac about 21mbps download and 46mbps upload. (tested on nexus 6p, and intel wifi 7265 ac laptop) I must be doing something wrong... (that's 802.11g speed)

My capsman settings (for the onboard 5.8 radio) are:

provisioning:
;;; provisioning for local 5.8 radio
radio-mac=(my mac) hw-supported-modes=ac identity-regexp="" common-name-regexp="" ip-address-ranges="" action=create-enabled
master-configuration=AP_main_main_lan_ch36 slave-configurations="" name-format=cap name-prefix=""

channel:
name="5.8_channel036" frequency=5180 control-channel-width=20mhz band=5ghz-n/ac extension-channel=Ceee tx-power=10

configuration:
name="AP_main_lan_ch36" mode=ap ssid="(my ssid)" security=security2_local_lan datapath=datapath_vlan20 channel=5.8_channel036

data path:
name="datapath_vlan20" bridge=bridge20_vlan20

security:
name="security2_local_lan" authentication-types=wpa2-psk encryption=aes-ccm group-encryption=aes-ccm passphrase="(my key)"

This magnificent speed is on all (4) HAP ac2s connected to the capsman.
If anybody has any suggestion, I'm grateful.
 
nescafe2002
Long time Member
Long time Member
Posts: 659
Joined: Tue Aug 11, 2015 12:46 pm
Location: Netherlands

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Wed Sep 26, 2018 2:56 pm

Tx-power=10 seems quite low. Try unsetting that value.
You might also unset control-channel-width, band and extension-channel=Ceee.
I would even unset the fixed channel so the AP can find the least used frequency.
You have no country set, some devices perform better with correct country set.
Not visible, but with CAPsMAN forwarding you don't need to trunk this vlan to APs directly.

It seems you have copy/pasted printed output, next time you can just do a /caps-man export hide-sensitive for copy/paste ready config.
 
Lotar
just joined
Posts: 11
Joined: Fri Jun 15, 2012 2:10 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Wed Sep 26, 2018 10:23 pm

Thank you for the reply nescafe2002 !!

Removing the control-channel-width and extension-channel=Ceee did the trick. Now I get solid 220mbps download and about 100mbps upload. Still not great ac speeds but better then before. (Removing the band and setting the country did not impact the transfer speed).
now the channel looks like this:
name="5.8_channel036" frequency=5180 tx-power=17

Thank you for your help !

p.s.
The tx power is low because the ap is right next to my laptop (testing purposes). I'll increase it when I'll set it up properly.
The trunk/vlans are there for the other Ethernet ports, especially an access port so a directly connected computer can access the network's management vlan.
 
whatever
Member Candidate
Member Candidate
Posts: 152
Joined: Thu Jun 21, 2018 9:29 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Thu Sep 27, 2018 12:07 pm

Try local forwarding (datapath) for even faster speed.
 
anuser
Member
Member
Posts: 441
Joined: Sat Nov 29, 2014 7:27 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Fri Sep 28, 2018 10:56 am

Did you enable those locally on the access point?
/interface wireless set adaptive-noise-immunity=ap-and-client-mode wlan2
/interface wireless set adaptive-noise-immunity=ap-and-client-mode wlan1
 
Lotar
just joined
Posts: 11
Joined: Fri Jun 15, 2012 2:10 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Fri Sep 28, 2018 12:58 pm

Hi,
I'll try local forwarding (datapath) soon.
Yes anuser, enabled locally on all access points.

Will do more testing before deployment...
 
2mail
just joined
Posts: 1
Joined: Sun May 20, 2018 10:58 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Sun Sep 30, 2018 12:36 am

Not sure what u are struggling with ( Poor Performance ) that's why u never get response form Mikrotik support do the correct setup with the routers and believe me u will get mush better performance
i am running between 40 and 60 clients per sector ( Netmetal 5 with AR Elements sector) getting very good throughput with a very stable ping providing my clients from 4Mb to 12Mb
no prob
 
anuser
Member
Member
Posts: 441
Joined: Sat Nov 29, 2014 7:27 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Thu Oct 11, 2018 9:04 pm

Hi, could you please test with latest 6.44 release candidate? For me it seems performance decreased
 
Lotar
just joined
Posts: 11
Joined: Fri Jun 15, 2012 2:10 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Thu Oct 11, 2018 9:50 pm

Hi anuser,

For me, the speed is up with this patch. I get solid 250/125mbps on 5.8ghz (witch is my current internet speed from the ISP) and about 150/100mbps on 2.4ghz.
My current config is this (with blanked macs/radio names):

# oct/11/2018 21:34:46 by RouterOS 6.44beta17
# software id = 1239-VPQ9
#
# model = RBD52G-5HacD2HnD
# serial number =
/caps-man channel
add band=2ghz-g/n frequency=2412 name=2.4_channel001 tx-power=17
add band=2ghz-g/n frequency=2437 name=2.4_channel006 tx-power=17
add band=2ghz-g/n frequency=2462 name=2.4_channel011 tx-power=17
add band=5ghz-n/ac frequency=5180 name=5.8_channel036 tx-power=17
add band=5ghz-n/ac frequency=5260 name=5.8_channel056 tx-power=17
/caps-man security
add authentication-types=wpa-psk,wpa2-psk encryption=aes-ccm,tkip group-encryption=aes-ccm group-key-update=5m name=security1_management
add authentication-types=wpa-psk,wpa2-psk encryption=aes-ccm,tkip group-encryption=aes-ccm group-key-update=5m name=security2_local_lan
add authentication-types=wpa-psk,wpa2-psk encryption=aes-ccm,tkip group-encryption=aes-ccm group-key-update=5m name=security3_guest
/caps-man access-list
add action=accept allow-signal-out-of-range=10s comment="signal ok" disabled=no interface=any signal-range=-80..120 ssid-regexp=""
add action=reject allow-signal-out-of-range=10s comment="bad signal" disabled=no interface=any signal-range=-120..-81 ssid-regexp=""
/caps-man configuration
add channel=2.4_channel001 country=romania datapath=datapath_vlan10 hide-ssid=yes mode=ap name=AP_0_management_ch1 rates.vht-supported-mcs="" security=security1_management ssid=art_management
add channel=2.4_channel001 country=romania datapath=datapath_vlan20a mode=ap name=AP_0_main_lan_ch1 security=security2_local_lan ssid=art_LAN
add channel=2.4_channel001 country=romania datapath=datapath_vlan30 name=AP_0_guest_ch1 security=security3_guest ssid=art_Guest
add channel=5.8_channel036 country=romania datapath=datapath_vlan10 hide-ssid=yes mode=ap name=AP_0_management_ch36 security=security1_management ssid=art_management_5.8
add channel=5.8_channel036 country=romania datapath=datapath_vlan20a mode=ap name=AP_0_main_lan_ch36 security=security2_local_lan ssid=art_LAN_5.8
add channel=5.8_channel036 country=romania datapath=datapath_vlan30 mode=ap name=AP_0_guest_ch36 security=security3_guest ssid=art_Guest_5.8
add channel=2.4_channel006 country=romania datapath=datapath_vlan30 name=AP_1_guest_ch6 security=security3_guest ssid=art_Guest
add channel=5.8_channel036 country=romania datapath=datapath_vlan30 mode=ap name=AP_1_guest_ch36 security=security3_guest ssid=art_Guest_5.8
add channel=2.4_channel006 country=romania datapath=datapath_vlan20a mode=ap name=AP_1_main_lan_ch6 security=security2_local_lan ssid=art_LAN
add channel=2.4_channel006 country=romania datapath=datapath_vlan10 hide-ssid=yes mode=ap name=AP_1_management_ch6 rates.vht-supported-mcs="" security=security1_management ssid=art_management
add channel=5.8_channel036 country=romania datapath=datapath_vlan20a mode=ap name=AP_1_main_lan_ch36 security=security2_local_lan ssid=art_LAN_5.8
add channel=5.8_channel036 country=romania datapath=datapath_vlan10 hide-ssid=yes mode=ap name=AP_1_management_ch36 security=security1_management ssid=art_management_5.8
add channel=2.4_channel011 country=romania datapath=datapath_vlan30 name=AP_2_guest_ch11 security=security3_guest ssid=art_Guest
add channel=5.8_channel036 country=romania datapath=datapath_vlan30 mode=ap name=AP_2_guest_ch36 security=security3_guest ssid=art_Guest_5.8
add channel=5.8_channel036 country=romania datapath=datapath_vlan20a mode=ap name=AP_2_main_lan_ch36 security=security2_local_lan ssid=art_LAN_5.8
add channel=2.4_channel011 country=romania datapath=datapath_vlan20a mode=ap name=AP_2_main_lan_ch11 security=security2_local_lan ssid=art_LAN
add channel=5.8_channel036 country=romania datapath=datapath_vlan10 hide-ssid=yes mode=ap name=AP_2_management_ch36 security=security1_management ssid=art_management_5.8
add channel=2.4_channel011 country=romania datapath=datapath_vlan10 hide-ssid=yes mode=ap name=AP_2_management_ch11 rates.vht-supported-mcs="" security=security1_management ssid=art_management
add channel=2.4_channel001 country=romania datapath=datapath_vlan30 name=AP_3_guest_ch1 security=security3_guest ssid=art_Guest
add channel=5.8_channel036 country=romania datapath=datapath_vlan30 mode=ap name=AP_3_guest_ch36 security=security3_guest ssid=art_Guest_5.8
add channel=2.4_channel001 country=romania datapath=datapath_vlan20a mode=ap name=AP_3_main_lan_ch1 security=security2_local_lan ssid=art_LAN
add channel=5.8_channel036 country=romania datapath=datapath_vlan20a mode=ap name=AP_3_main_lan_ch36 security=security2_local_lan ssid=art_LAN_5.8
add channel=2.4_channel001 country=romania datapath=datapath_vlan10 hide-ssid=yes mode=ap name=AP_3_management_ch1 rates.vht-supported-mcs="" security=security1_management ssid=art_management
add channel=5.8_channel036 country=romania datapath=datapath_vlan10 hide-ssid=yes mode=ap name=AP_3_management_ch36 security=security1_management ssid=art_management_5.8
/caps-man datapath
add bridge=bridge10_vlan10 name=datapath_vlan10
add bridge=bridge30_vlan30 client-to-client-forwarding=no local-forwarding=no name=datapath_vlan30
add bridge=bridge20_vlan20a name=datapath_vlan20a
/caps-man interface
add configuration=AP_1_main_lan_ch6 disabled=no l2mtu=1600 mac-address=XX:XX:XX:XX:XX:XX master-interface=none name=cap1 radio-mac=XX:XX:XX:XX:XX:XX radio-name=XXXXXXXXXXXX
add configuration=AP_1_management_ch6 disabled=no l2mtu=1600 mac-address=XX:XX:XX:XX:XX:XX master-interface=cap1 name=cap2 radio-mac=00:00:00:00:00:00 radio-name=XXXXXXXXXXXX
add configuration=AP_1_guest_ch6 disabled=no l2mtu=1600 mac-address=XX:XX:XX:XX:XX:XX master-interface=cap1 name=cap3 radio-mac=00:00:00:00:00:00 radio-name=XXXXXXXXXXXX
add configuration=AP_1_main_lan_ch36 disabled=no l2mtu=1600 mac-address=XX:XX:XX:XX:XX:XX master-interface=none name=cap4 radio-mac=XX:XX:XX:XX:XX:XX radio-name=XXXXXXXXXXXX
add configuration=AP_1_management_ch36 disabled=no l2mtu=1600 mac-address=XX:XX:XX:XX:XX:XX master-interface=cap4 name=cap5 radio-mac=00:00:00:00:00:00 radio-name=XXXXXXXXXXXX
add configuration=AP_1_guest_ch36 disabled=no l2mtu=1600 mac-address=XX:XX:XX:XX:XX:XX master-interface=cap4 name=cap6 radio-mac=00:00:00:00:00:00 radio-name=XXXXXXXXXXXX
add configuration=AP_2_main_lan_ch11 disabled=no l2mtu=1600 mac-address=XX:XX:XX:XX:XX:XX master-interface=none name=cap7 radio-mac=XX:XX:XX:XX:XX:XX radio-name=XXXXXXXXXXXX
add configuration=AP_2_management_ch11 disabled=no l2mtu=1600 mac-address=XX:XX:XX:XX:XX:XX master-interface=cap7 name=cap8 radio-mac=00:00:00:00:00:00 radio-name=XXXXXXXXXXXX
add configuration=AP_2_guest_ch11 disabled=no l2mtu=1600 mac-address=XX:XX:XX:XX:XX:XX master-interface=cap7 name=cap9 radio-mac=00:00:00:00:00:00 radio-name=XXXXXXXXXXXX
add configuration=AP_2_main_lan_ch36 disabled=no l2mtu=1600 mac-address=XX:XX:XX:XX:XX:XX master-interface=none name=cap10 radio-mac=XX:XX:XX:XX:XX:XX radio-name=XXXXXXXXXXXX
add configuration=AP_0_main_lan_ch1 disabled=no l2mtu=1600 mac-address=XX:XX:XX:XX:XX:XX master-interface=none name=cap11 radio-mac=XX:XX:XX:XX:XX:XX radio-name=XXXXXXXXXXXX
add configuration=AP_0_management_ch1 disabled=no l2mtu=1600 mac-address=XX:XX:XX:XX:XX:XX master-interface=cap11 name=cap12 radio-mac=00:00:00:00:00:00 radio-name=XXXXXXXXXXXX
add configuration=AP_0_guest_ch1 disabled=no l2mtu=1600 mac-address=XX:XX:XX:XX:XX:XX master-interface=cap11 name=cap13 radio-mac=00:00:00:00:00:00 radio-name=XXXXXXXXXXXX
add configuration=AP_0_main_lan_ch36 disabled=no l2mtu=1600 mac-address=XX:XX:XX:XX:XX:XX master-interface=none name=cap14 radio-mac=XX:XX:XX:XX:XX:XX radio-name=XXXXXXXXXXXX
add configuration=AP_0_management_ch36 disabled=no l2mtu=1600 mac-address=XX:XX:XX:XX:XX:XX master-interface=cap14 name=cap15 radio-mac=00:00:00:00:00:00 radio-name=XXXXXXXXXXXX
add configuration=AP_0_guest_ch36 disabled=no l2mtu=1600 mac-address=XX:XX:XX:XX:XX:XX master-interface=cap14 name=cap16 radio-mac=00:00:00:00:00:00 radio-name=XXXXXXXXXXXX
add configuration=AP_2_management_ch36 disabled=no l2mtu=1600 mac-address=XX:XX:XX:XX:XX:XX master-interface=cap10 name=cap17 radio-mac=00:00:00:00:00:00 radio-name=XXXXXXXXXXXX
add configuration=AP_2_guest_ch36 disabled=no l2mtu=1600 mac-address=XX:XX:XX:XX:XX:XX master-interface=cap10 name=cap18 radio-mac=00:00:00:00:00:00 radio-name=BXXXXXXXXXXXX
/caps-man manager
set ca-certificate=auto certificate=auto enabled=yes
/caps-man provisioning
add action=create-enabled comment="provisioning for local 2.4 radio" hw-supported-modes=gn master-configuration=AP_0_main_lan_ch1 radio-mac=XX:XX:XX:XX:XX:XX slave-configurations=AP_0_management_ch1,AP_0_guest_ch1
add action=create-enabled comment="provisioning for local 5.8 radio" master-configuration=AP_0_main_lan_ch36 radio-mac=XX:XX:XX:XX:XX:XX slave-configurations=AP_0_management_ch36
add action=create-enabled comment="provisioning for AP1 2.4" master-configuration=AP_1_main_lan_ch6 radio-mac=XX:XX:XX:XX:XX:XX slave-configurations=AP_1_management_ch6,AP_1_guest_ch6
add action=create-enabled comment="provisioning for AP1 5.8" master-configuration=AP_1_main_lan_ch36 radio-mac=XX:XX:XX:XX:XX:XX slave-configurations=AP_1_management_ch36
add action=create-enabled comment="provisioning for AP2 2.4" master-configuration=AP_2_main_lan_ch11 radio-mac=XX:XX:XX:XX:XX:XX slave-configurations=AP_2_management_ch11,AP_2_guest_ch11
add action=create-enabled comment="provisioning for AP2 5.8" master-configuration=AP_2_main_lan_ch36 radio-mac=XX:XX:XX:XX:XX:XX slave-configurations=AP_2_management_ch36
add action=create-enabled comment="provisioning for AP3 5.8" master-configuration=AP_3_main_lan_ch36 radio-mac=XX:XX:XX:XX:XX:XX slave-configurations=AP_3_management_ch36
add action=create-enabled comment="provisioning for AP3 2.4" master-configuration=AP_3_main_lan_ch1 radio-mac=XX:XX:XX:XX:XX:XX slave-configurations=AP_3_management_ch1,AP_3_guest_ch1

p.s. I know there are a lot of redundant 5.8 configurations (are there to play around with the 5.8 channels...)
 
psychodracon
just joined
Posts: 1
Joined: Sat Jun 15, 2019 8:47 am

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Sat Jun 15, 2019 9:46 am

Hello all,
Any changes on this? I`m new Mikrotik hAP ac^2 user and i`m struggling with poor WiFi performance. My connection from ISP is 300/20 Mbps and i`m getting around 290/20 Mbps using ethernet. But using WiFi 2.4G i`m getting around 90/20 Mbps (1m from router) same for 5G (around 110/20 Mbps). My settings are default only changes that i have made is that i have enabled secruity (WPA2-PSK with AES only).
 
sirotkaslo
just joined
Posts: 1
Joined: Mon Aug 27, 2018 3:50 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Fri Jun 28, 2019 10:17 pm

I'm also still having issues with wireless performance, haven't touched it much, only setup a bridge and a dhcp client on it
 
szhura
just joined
Posts: 2
Joined: Fri May 17, 2019 1:04 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Tue Aug 13, 2019 4:15 pm

i have another problem with wifi. it seemes to drop speed tenfold after several days of working without reboot. reboot solves wifi speed problem but again only for several days. help needed :(
 
gotsprings
Forum Veteran
Forum Veteran
Posts: 906
Joined: Mon May 14, 2012 9:30 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Tue Aug 20, 2019 1:28 pm

i have another problem with wifi. it seemes to drop speed tenfold after several days of working without reboot. reboot solves wifi speed problem but again only for several days. help needed :(
Write a simple scheduler and and script to reboot it every 48 hours.

Professionally... We put a stop on Mikrotik wireless deployments. We kept hitting the same issue. We documented it and Mikrotik reproduced it. They stated they don't have a fix... As pros... That meant no more in the field.

I was incredibly disappointed in Mikrotik about this. I wrote a lot of cool stuff based on Caps-man and can't use any of it now.
"It ain't what you don't know that gets you into trouble. It's what you know for sure that just ain't so."
Mark Twain
 
heidarren
Member Candidate
Member Candidate
Posts: 108
Joined: Mon Aug 05, 2019 9:56 am

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Tue Aug 20, 2019 9:48 pm

My experience with this hAP AC2 with 6.46b28 firmware after fine tune can gets 470mbps with my iPhone XS Max, and 440mbps with my iPad Pro 10'5, upload both 206mbps (My ISP max speed), really nice result even though the speed is not stable, sometimes will drop to sub 300mbps.

The problem is when I switch to CAPsMAN mode it will limit to 380mbps, no matter how I change setting, it caps there, and I noticed one of my CAP's 5GHz Wi-Fi disappear after 2 days of running, it just gone and I can't seems to find it on my phone but CAPsMAN got nothing special and no log was logged, it only works again by removing it from CAPsMAN and reconnect, will monitor few more days to see if this happen again.
 
anuser
Member
Member
Posts: 441
Joined: Sat Nov 29, 2014 7:27 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Wed Aug 21, 2019 5:19 pm

My experience with this hAP AC2 with 6.46b28 firmware after fine tune
Can you please post your "fine tuned" configuration?
 
szhura
just joined
Posts: 2
Joined: Fri May 17, 2019 1:04 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Wed Aug 21, 2019 11:20 pm

i have another problem with wifi. it seemes to drop speed tenfold after several days of working without reboot. reboot solves wifi speed problem but again only for several days. help needed :(
Write a simple scheduler and and script to reboot it every 48 hours.

Professionally... We put a stop on Mikrotik wireless deployments. We kept hitting the same issue. We documented it and Mikrotik reproduced it. They stated they don't have a fix... As pros... That meant no more in the field.

I was incredibly disappointed in Mikrotik about this. I wrote a lot of cool stuff based on Caps-man and can't use any of it now.
it seemes that after updating to 6.45.3 problem has gone. but it needs more testing
 
heidarren
Member Candidate
Member Candidate
Posts: 108
Joined: Mon Aug 05, 2019 9:56 am

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Wed Aug 21, 2019 11:29 pm

My experience with this hAP AC2 with 6.46b28 firmware after fine tune can gets 470mbps with my iPhone XS Max, and 440mbps with my iPad Pro 10'5, upload both 206mbps (My ISP max speed), really nice result even though the speed is not stable, sometimes will drop to sub 300mbps.

The problem is when I switch to CAPsMAN mode it will limit to 380mbps, no matter how I change setting, it caps there, and I noticed one of my CAP's 5GHz Wi-Fi disappear after 2 days of running, it just gone and I can't seems to find it on my phone but CAPsMAN got nothing special and no log was logged, it only works again by removing it from CAPsMAN and reconnect, will monitor few more days to see if this happen again.
It happened again today, about 24 hours of running it, seems it's not accident, something wrong on CAPsMAN in 6.46b28, anyway I'm done with this CAPsMAN, just run it as AP bridge and bye bye CAPsMAN.
 
heidarren
Member Candidate
Member Candidate
Posts: 108
Joined: Mon Aug 05, 2019 9:56 am

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Thu Aug 22, 2019 9:20 am

My experience with this hAP AC2 with 6.46b28 firmware after fine tune
Can you please post your "fine tuned" configuration?
authentication-types=wpa2-psk eap-methods="" group-key-update=1h mode=dynamic-keys name=Darren supplicant-identity="" wpa-pre-shared-key=\
xxxxxxxx wpa2-pre-shared-key=xxxxxxxx
/interface wireless
set [ find default-name=wlan2 ] adaptive-noise-immunity=ap-and-client-mode antenna-gain=2 band=5ghz-onlyac basic-rates-a/g=12Mbps channel-width=\
20/40/80mhz-eeCe country="united states" disabled=no distance=indoors frequency=5220 frequency-mode=regulatory-domain \
hw-fragmentation-threshold=2346 hw-protection-mode=rts-cts hw-protection-threshold=2347 keepalive-frames=disabled mode=ap-bridge \
multicast-buffering=disabled multicast-helper=disabled name=W5G rate-set=configured security-profile=Darren ssid=ChengFamily5G \
supported-rates-a/g=12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps vht-supported-mcs=mcs0-9,mcs0-9 wireless-protocol=802.11 wmm-support=enabled \
wps-mode=disabled
/interface wireless nstreme
set W5G disable-csma=yes
 
santyx32
Frequent Visitor
Frequent Visitor
Posts: 60
Joined: Fri Oct 25, 2019 2:17 am

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Tue Nov 12, 2019 3:54 am

I manage a municipal ISP, we have had a steady flow of wifi issues. Many CX complain of doing and disconnecting wifi as well as slow speeds,
I'm already regretting or purchase of 500 hAC2 units. The pending "Broadcom compatibility firmware fix" had better be the silver bullet or we are going to look elsewhere for the next 1000 units in our Network build.
It's going to be 2020 and the hAP ac2 is still not fully compatible with Broadcom clients like Exynos S10 phones.
 
anuser
Member
Member
Posts: 441
Joined: Sat Nov 29, 2014 7:27 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Wed Nov 13, 2019 8:02 am

RouterOS v6.46beta59 has fixes for wireless. Do they fix your performance problems with hap ac2?
(Not with CAPSMAN, this is full of bugs)
 
gotsprings
Forum Veteran
Forum Veteran
Posts: 906
Joined: Mon May 14, 2012 9:30 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Wed Nov 13, 2019 8:38 pm

RouterOS v6.46beta59 has fixes for wireless. Do they fix your performance problems with hap ac2?
(Not with CAPSMAN, this is full of bugs)
Which Bugs exactly in caps-man?
"It ain't what you don't know that gets you into trouble. It's what you know for sure that just ain't so."
Mark Twain
 
anuser
Member
Member
Posts: 441
Joined: Sat Nov 29, 2014 7:27 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Thu Nov 14, 2019 7:41 am

The pending "Broadcom compatibility firmware fix"
Where did you hear about that special Broadcom compatibiliy firmware fix?
 
santyx32
Frequent Visitor
Frequent Visitor
Posts: 60
Joined: Fri Oct 25, 2019 2:17 am

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Fri Nov 15, 2019 3:18 am

6.46 beta 59 fixes nothing for me, setting AMSDU Limit to 2048 improves the overall stability but there's still 1-2 disconnections per day vs 1 disconnection every 5 minutes.
 
Znevna
Frequent Visitor
Frequent Visitor
Posts: 72
Joined: Mon Sep 23, 2019 1:04 pm

Re: hAP ac^2 Problems---Extremely Poor Performance found in 2.4G and 5G WiFi

Fri Nov 15, 2019 1:56 pm

Thanks for the "AMSDU Limit to 2048" tip. It makes my Huawei Mate 20 Lite like the router a little bit more (atleast I get ~20mbps and even more somewhat stable download on 5GHz, instead of, well, less.)

Who is online

Users browsing this forum: No registered users and 50 guests