Community discussions

 
IntrusDave
Forum Guru
Forum Guru
Topic Author
Posts: 1290
Joined: Fri May 09, 2014 4:36 am
Location: Rancho Cucamonga, CA

6.43rc5 bricked RB1100AHx4

Fri Apr 27, 2018 3:06 am

My testing unit (RB1100AHx4) was bricked today with RouterOS 6.43rc5.
I used WinBox to repartition for 2 partitions (primary and backup)
The router went into a reboot loop with no way to stop it.

Netinstall will not work, as the console shows that system reboots before the interfaces are initialized and therefor can not do bootp.
Console doesn't appear to provide any way to intrude the boot and force a reformat or anything else.

Anyone know any tricks to recovering the RB1100AHx4?
David Joyce
Network & Security Engineer
Intrus Technologies, LLC.
Rancho Cucamonga, CA, USA
 
IntrusDave
Forum Guru
Forum Guru
Topic Author
Posts: 1290
Joined: Fri May 09, 2014 4:36 am
Location: Rancho Cucamonga, CA

Re: 6.43rc5 bricked RB1100AHx4

Fri Apr 27, 2018 3:20 am

Here is the console output
Annapurna Labs stage 2: stage2_eth3_ram_loader v1.65.1
Executing next!
Annapurna Labs stage 2: stage2.5_loader v1.65.1
SPD I2C Address:00000050
Executing next!

-----------------------------------------------------
Stage 3 version: 1.65.1
Commit ID: e88c9c4
CVOS commit ID: d32367c
HAL commit ID: 8b8f7b5
Build date: May 20 2015 19:57:35
-----------------------------------------------------

EEPROM Revision ID = 37
Device ID = a314
Device Info: AL31400X-140
Loading DT to 00100000 (18676 bytes)...
Board config ID: alpine_db (AL-214)
Loading application to 00100000 (43880 bytes)...
Executing application...


RouterBOOT booter 6.43rc5

RouterBOARD 1100Dx4

CPU frequency: 1400 MHz
  Memory size: 1024 MiB
    NAND size: 128 MiB
    NAND partitions: 2
writing settings to flash... OK

loading kernel partition 1... kernel not found or data is corrupted
writing settings to flash... OK

loading kernel partition 0... OK
setting up elf image... OK
jumping to kernel code
Could not mount ubifs filesystem: No such device
opendir: No such file or directory
opendir: No such file or directory
ERROR: no system package found!
Kernel panic - not syncing: Attempted to kill init!
{bf84df0c} panic+0x84/0x1c0
{bf84df44} do_exit+0x80/0x688
{bf84df84} do_group_exit+0x4c/0xc0
{bf84df9c} __wake_up_parent+0x0/0x18
CPU1: stopping
{bf879f5c} handle_IPI+0xf4/0x1e0
{bf879f7c} gic_handle_irq+0x94/0xa4
{bf879f94} __irq_svc+0x40/0x60
Exception stack(0xbf879f98 to 0xbf879fe0)
9f80:                                                       80c95890 00000000
9fa0: bf879fe0 00000000 bf878000 804538c8 8041dab8 80453b48 0000406a 412fc0f4
9fc0: 00000000 00000000 00000000 bf879fe0 8000e8a0 8000e8a4 60000013 ffffffff
{bf879fdc} default_idle+0x24/0x28
{bf879fe4} cpu_idle+0x50/0x8c
{bf879ff4} 0x4019d4
CPU2: stopping
{bf883f5c} handle_IPI+0xf4/0x1e0
{bf883f7c} gic_handle_irq+0x94/0xa4
{bf883f94} __irq_svc+0x40/0x60
Exception stack(0xbf883f98 to 0xbf883fe0)
3f80:                                                       80ca2890 00000000
3fa0: bf883fe0 00000000 bf882000 804538c8 8041dab8 80453b48 0000406a 412fc0f4
3fc0: 00000000 00000000 00000002 bf883fe0 8000e8a0 8000e8a4 60000013 ffffffff
{bf883fdc} default_idle+0x24/0x28
{bf883fe4} cpu_idle+0x50/0x8c
{bf883ff4} 0x4019d4
CPU3: stopping
{bf891f5c} handle_IPI+0xf4/0x1e0
{bf891f7c} gic_handle_irq+0x94/0xa4
{bf891f94} __irq_svc+0x40/0x60
Exception stack(0xbf891f98 to 0xbf891fe0)
1f80:                                                       80caf890 00000000
1fa0: bf891fe0 00000000 bf890000 804538c8 8041dab8 80453b48 0000406a 412fc0f4
1fc0: 00000000 00000000 00000000 bf891fe0 8000e8a0 8000e8a4 60000113 ffffffff
{bf891fdc} default_idle+0x24/0x28
{bf891fe4} cpu_idle+0x50/0x8c
{bf891ff4} 0x4019d4
Rebooting in 1 seconds..
David Joyce
Network & Security Engineer
Intrus Technologies, LLC.
Rancho Cucamonga, CA, USA
 
User avatar
jspool
Member
Member
Posts: 396
Joined: Sun Oct 04, 2009 4:06 am
Location: Oregon

Re: 6.43rc5 bricked RB1100AHx4

Fri Apr 27, 2018 3:39 am

I assume you already tried the backup loader?

-from the manual -
If you start holding the Reset button before applying power, it will also load the backup RouterBOOT loader, in addition
to the above actions. This may help to solve RouterBOOT issues and give you the opportunity to downgrade/
upgrade it while in backup loader mode.
 
IntrusDave
Forum Guru
Forum Guru
Topic Author
Posts: 1290
Joined: Fri May 09, 2014 4:36 am
Location: Rancho Cucamonga, CA

Re: 6.43rc5 bricked RB1100AHx4

Fri Apr 27, 2018 3:41 am

No backup loader.. The router had just rebooted after partitioning, so the backup was still blank.
Also, you can see in the console log, it tried booting from partition 1 and 0.
David Joyce
Network & Security Engineer
Intrus Technologies, LLC.
Rancho Cucamonga, CA, USA
 
User avatar
jspool
Member
Member
Posts: 396
Joined: Sun Oct 04, 2009 4:06 am
Location: Oregon

Re: 6.43rc5 bricked RB1100AHx4

Fri Apr 27, 2018 3:50 am

So the 15 second hold of the reset button during power up does not engage ether13 for netinstall?
 
IntrusDave
Forum Guru
Forum Guru
Topic Author
Posts: 1290
Joined: Fri May 09, 2014 4:36 am
Location: Rancho Cucamonga, CA

Re: 6.43rc5 bricked RB1100AHx4

Fri Apr 27, 2018 5:39 am

tried that. seems to just pause the process, never starts netboot
David Joyce
Network & Security Engineer
Intrus Technologies, LLC.
Rancho Cucamonga, CA, USA
 
User avatar
jspool
Member
Member
Posts: 396
Joined: Sun Oct 04, 2009 4:06 am
Location: Oregon

Re: 6.43rc5 bricked RB1100AHx4

Fri Apr 27, 2018 6:49 am

That's unfortunate. Crazy that its possible to brick the unit doing that. Its doubtful they include any JTAG ability. Their default response is to contact your supplier and arrange a RMA. On a side note I am curious what you think of the x4 aside from the current issue.
 
IntrusDave
Forum Guru
Forum Guru
Topic Author
Posts: 1290
Joined: Fri May 09, 2014 4:36 am
Location: Rancho Cucamonga, CA

Re: 6.43rc5 bricked RB1100AHx4

Fri Apr 27, 2018 6:59 am

Tried that.. They said it's past their coverage and to contact Mikrotik.
David Joyce
Network & Security Engineer
Intrus Technologies, LLC.
Rancho Cucamonga, CA, USA
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: 6.43rc5 bricked RB1100AHx4

Fri Apr 27, 2018 7:00 am

You will have to Netinstall your router. If you are not being able to do that, then provide serial console output which would be made during Netinstall process.

I do not see on serial output how you did determine something like this - "Netinstall will not work, as the console shows that system reboots before the interfaces are initialized". Netinstall should work just fine.
 
User avatar
jspool
Member
Member
Posts: 396
Joined: Sun Oct 04, 2009 4:06 am
Location: Oregon

Re: 6.43rc5 bricked RB1100AHx4

Fri Apr 27, 2018 7:01 am

You will have to Netinstall your router. If you are not being able to do that, then provide serial console output which would be made during Netinstall process.
I think if you read the whole thread you will see his console output and the fact that netinstall is not working.
 
User avatar
jspool
Member
Member
Posts: 396
Joined: Sun Oct 04, 2009 4:06 am
Location: Oregon

Re: 6.43rc5 bricked RB1100AHx4

Fri Apr 27, 2018 7:06 am

Tried that.. They said it's past their coverage and to contact Mikrotik.
Mikrotik products are great when they work and if they stop working your soon in a pin ball machine being bounced around aimlessly. Perhaps things will improve with v7 :lol:
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: 6.43rc5 bricked RB1100AHx4

Fri Apr 27, 2018 7:08 am

Nothing in serial console output is related to Netinstall. Please try it out and report back with the results.
 
IntrusDave
Forum Guru
Forum Guru
Topic Author
Posts: 1290
Joined: Fri May 09, 2014 4:36 am
Location: Rancho Cucamonga, CA

Re: 6.43rc5 bricked RB1100AHx4

Sat Apr 28, 2018 3:06 am

After about 6 hours, I finally got the Routerboot menu. I'm not sure why I was never prompted (press any-key...) before. I ended up getting a stopwatch and power strip. I was powering the router and timing how long to press the reset. It ended up needed to be pressed for no less than 15 minutes. (why?) After I got the menu, I was able to partition, format, and set the boot to ethernet. After that, the menu prompt is displayed every boot.
David Joyce
Network & Security Engineer
Intrus Technologies, LLC.
Rancho Cucamonga, CA, USA
 
User avatar
jspool
Member
Member
Posts: 396
Joined: Sun Oct 04, 2009 4:06 am
Location: Oregon

Re: 6.43rc5 bricked RB1100AHx4

Sat Apr 28, 2018 3:53 am

After about 6 hours, I finally got the Routerboot menu. I'm not sure why I was never prompted (press any-key...) before. I ended up getting a stopwatch and power strip. I was powering the router and timing how long to press the reset. It ended up needed to be pressed for no less than 15 minutes. (why?) After I got the menu, I was able to partition, format, and set the boot to ethernet. After that, the menu prompt is displayed every boot.
Hmm wonder if it was a typo in their code. 15m instead of 15s? Props for sticking it out!
 
IntrusDave
Forum Guru
Forum Guru
Topic Author
Posts: 1290
Joined: Fri May 09, 2014 4:36 am
Location: Rancho Cucamonga, CA

Re: 6.43rc5 bricked RB1100AHx4

Sat Apr 28, 2018 6:43 am

Not sure what happened.. But something with the repartitioning in the latest rc.
David Joyce
Network & Security Engineer
Intrus Technologies, LLC.
Rancho Cucamonga, CA, USA
 
jo2jo
Forum Veteran
Forum Veteran
Posts: 958
Joined: Fri May 26, 2006 1:25 am

Re: 6.43rc5 bricked RB1100AHx4

Sat Sep 22, 2018 1:29 am

is this related to / a fix for the issue u encountered possibly ? :

What's new in 6.43.2 (2018-Sep-18 12:12):
Changes in this release:
*) routerboot - fixed RouterOS booting on devices with particular NAND memory (introduced in v6.43);
:beep :beep :beep
 
DrGEM
just joined
Posts: 1
Joined: Mon Jul 22, 2019 9:34 pm
Location: Moldova Chisinau

Re: 6.43rc5 bricked RB1100AHx4

Tue Jul 23, 2019 12:24 pm

Hello. There is an RB1100AHx4 DudeEdition with boot problem. Here is a log without reset
Annapurna Labs stage 2: stage2_eth3_ram_loader v1.65.1
Executing next!
Annapurna Labs stage 2: stage2.5_loader v1.65.1
SPD I2C Address:00000050
Executing next!
-----------------------------------------------------
Stage 3 version: 1.65.1
Commit ID: e88c9c4
CVOS commit ID: d32367c
HAL commit ID: 8b8f7b5
Build date: May 20 2015 19:57:35
-----------------------------------------------------
EEPROM Revision ID = 37
Device ID = a314
Device Info: AL31400X-140
Loading DT to 00100000 (18676 bytes)...
Board config ID: alpine_db (AL-214)
Loading application to 00100000 (43880 bytes)...
Executing application...
RouterBOOT booter 6.43.16
RouterBOARD 1100Dx4

CPU frequency: 1400 MHz
  Memory size: 1024 MiB
    NAND size: 128 MiB

loading kernel... OK
setting up elf image... OK
jumping to kernel code
a log with a clamped reset
Annapurna Labs stage 2: stage2_eth3_ram_loader v1.65.1
Executing next!
Annapurna Labs stage 2: stage2.5_loader v1.65.1
SPD I2C Address:00000050
Executing next!
-----------------------------------------------------
Stage 3 version: 1.65.1
Commit ID: e88c9c4
CVOS commit ID: d32367c
HAL commit ID: 8b8f7b5
Build date: May 20 2015 19:57:35
-----------------------------------------------------
EEPROM Revision ID = 37
Device ID = a314
Device Info: AL31400X-140
Loading DT to 00100000 (18676 bytes)...
Board config ID: alpine_db (AL-214)
Loading application to 00100000 (43880 bytes)...
Executing application...
RouterBOOT backup booter 3.36.3
RouterBOARD 1100Dx4
CPU frequency: 1400 MHz
  Memory size: 1024 MiB
    NAND size: 128 MiB
RouterOS cleanup...
Reset for 30sec
Annapurna Labs stage 2: stage2_eth3_ram_loader v1.65.1
Executing next!
Annapurna Labs stage 2: stage2.5_loader v1.65.1
SPD I2C Address:00000050
Executing next!
-----------------------------------------------------
Stage 3 version: 1.65.1
Commit ID: e88c9c4
CVOS commit ID: d32367c
HAL commit ID: 8b8f7b5
Build date: May 20 2015 19:57:35
-----------------------------------------------------
EEPROM Revision ID = 37
Device ID = a314
Device Info: AL31400X-140
Loading DT to 00100000 (18676 bytes)...
Board config ID: alpine_db (AL-214)
Loading application to 00100000 (43880 bytes)...
Executing application...
RouterBOOT backup booter 3.36.3
RouterBOARD 1100Dx4
CPU frequency: 1400 MHz
  Memory size: 1024 MiB
    NAND size: 128 MiB
loading kernel... OK
setting up elf image... OK
jumping to kernel code
eFuse hashed modulues does not match the EEPROM hashed modulus
in 13-th port POE/BOOT with clamped reset for 30 sec leds start blinking but in Netinstall device do not appear , What addresses to register in the settings?
192,168,88,1 does not fit. Thank you
sorry for my english.

Who is online

Users browsing this forum: No registered users and 93 guests