Community discussions

 
evilheart
newbie
Topic Author
Posts: 39
Joined: Thu Jul 02, 2015 9:41 pm

youtube bind ip

Fri May 18, 2018 12:44 am

how to bind youtube 1 ip only?

when people try to download anything use 74.125.10.167 ip only

anyone ahve idea?
 
sindy
Forum Guru
Forum Guru
Posts: 1750
Joined: Mon Dec 04, 2017 9:19 pm

Re: youtube bind ip

Fri May 18, 2018 10:58 am

The decision which address to use is Google's, not yours, so the single address may be down.

But you can add youtube.com as an address to an address list. This makes RouterOS resolve that domain name to a list of numeric IP addresses which it adds to the same address list, and update the list each time the previous DNS response expires:
/ip firewall address-list
add list=youtube-watch address=youtube.com
Now depending on what you actually want to do, you can either set
/ip firewall nat
add chain=dstnat action=dst-nat dst-address-list=youtube-watch to-addresses=74.125.10.167
to force all locally originated connection to any of the youtube's addresses through 74.125.10.167, or you may use that address-list in the routing or firewall rules where you intended to use the 74.125.10.167.

But bear in mind that Google uses the same servers for a multitude of services, so the special treatment you intend for youtube.com alone may actually affect also other Google services, like search and gmail.
Instead of writing novels, post /export hide-sensitive. Use find&replace in your favourite text editor to systematically replace each occurrence of any public IP address potentially identifying you by a distinctive pattern such as my.public.ip.1.
 
evilheart
newbie
Topic Author
Posts: 39
Joined: Thu Jul 02, 2015 9:41 pm

Re: youtube bind ip

Fri May 18, 2018 1:29 pm

youtube now use another ip
i have prob i have raw bandwidth 30mbps but my isp give Google Cache only 1.6M i trying to bypass google cache server i see last night this ip i got 30mbps download in youtub so you have any idea?
 
sindy
Forum Guru
Forum Guru
Posts: 1750
Joined: Mon Dec 04, 2017 9:19 pm

Re: youtube bind ip

Fri May 18, 2018 2:29 pm

I've explained my idea already. You can force any request from your Mikrotik's clients to youtube to be redirected to a single address you choose the way I've suggested. Whether it actually meets your goal or not is a different thing, because I don't know what means "google cache at ISP" and how it works in detail.

Whether that chosen address is constantly available or not is a matter of Google's policy, so you may need some long-term tracking to find out and choose an address which Google uses most often for requests coming from your WAN IP address. In such case, the chance that it is available even while the DNS answers do not return it is quite high but not 100%.
Instead of writing novels, post /export hide-sensitive. Use find&replace in your favourite text editor to systematically replace each occurrence of any public IP address potentially identifying you by a distinctive pattern such as my.public.ip.1.
 
evilheart
newbie
Topic Author
Posts: 39
Joined: Thu Jul 02, 2015 9:41 pm

Re: youtube bind ip

Fri May 18, 2018 10:05 pm

then any way to loadblance ? when my people use youtube my intenet use raw bandwidth + Google Global Cache same time possible this then?
 
sindy
Forum Guru
Forum Guru
Posts: 1750
Joined: Mon Dec 04, 2017 9:19 pm

Re: youtube bind ip

Fri May 18, 2018 11:24 pm

then any way to loadblance ? when my people use youtube my intenet use raw bandwidth + Google Global Cache same time possible this then?
Me no understand language tribe your, sorry.

Does your ISP reserve part of your uplink bandwidth for access to Google Cached contents and another part for generic internet access?

And load balancing is normally relevant to multiple uplink configurations, but you haven't mentioned anything like that so far.

So provide a diagram of your network configuration, use other words explain what you mean by "raw bandwidth + Google Global cashe same time", and then maybe expect some answers.
Instead of writing novels, post /export hide-sensitive. Use find&replace in your favourite text editor to systematically replace each occurrence of any public IP address potentially identifying you by a distinctive pattern such as my.public.ip.1.
 
evilheart
newbie
Topic Author
Posts: 39
Joined: Thu Jul 02, 2015 9:41 pm

Re: youtube bind ip

Sat May 19, 2018 11:28 pm

"raw bandwidth = only Internet Real Bandwidth wihtout GCC ",
+ Google Global cache same time

when poeple youtube youtube and gmail anything i want use real bandwidth also

Who is online

Users browsing this forum: No registered users and 36 guests