Community discussions

 
mazzahaker
just joined
Topic Author
Posts: 4
Joined: Fri May 18, 2018 11:54 am

Problem with thread access in ffmpeg

Fri May 18, 2018 12:00 pm

Colleagues!
Good day!
There is a problem that I already despaired of solving.
I have a server that broadcasts various video streams. Also there is a receiver - ffmpeg. It records streaming video, splits it into files and imposes graphics.
When the gateway is a server with FreeBSD, everything is in order.
As soon as I replace it with a Mikrotik, the flow begins to interrupt and write. At the same time - it all works.
What is the problem and where to dig?
I ask for help!

Mikrotik: RouterBOARD 1100
FFMPEG parameters:

ffmpeg -i rtmp://194.*.*.*:1935/**/****** -vf "drawtext='fontfile=/usr/share/fonts/truetype/dejavu/DejaVuSerif.ttf: text=%{localtime}': r=23.976: x=(w-tw)/2: y=h-(2*lh): fontcolor=white: box=1: boxcolor=0x00000099" -vcodec libx264 -x264opts bitrate=1500:vbv-maxrate=1500:vbv-bufsize=3000:nal-hrd=vbr -crf 0 -preset faster -f segment -segment_time 1800 -segment_format ts "capture-%03d.ts"


I suspect that there is a queue overflow, but what and where ...
Thank you!
 
mazzahaker
just joined
Topic Author
Posts: 4
Joined: Fri May 18, 2018 11:54 am

Re: Problem with thread access in ffmpeg

Fri May 25, 2018 10:47 am

What, no one with a similar encounter?
 
R1CH
Forum Veteran
Forum Veteran
Posts: 719
Joined: Sun Oct 01, 2006 11:44 pm

Re: Problem with thread access in ffmpeg

Fri May 25, 2018 2:43 pm

What's the bandwidth of the source stream?
 
mazzahaker
just joined
Topic Author
Posts: 4
Joined: Fri May 18, 2018 11:54 am

Re: Problem with thread access in ffmpeg

Fri May 25, 2018 4:06 pm

What's the bandwidth of the source stream?
Image

Encoding type:
FPS: 25
GOP: 30
Bitrate(kbit): 1800
Encoded size: 1280x720
H.264 Level: high profile
Bitrate control: vbr
The original size that comes in the form of a SDI: 1920x1080 and 25 frames.
I try to transfer both the smaller sizes of a picture, and original.
 
R1CH
Forum Veteran
Forum Veteran
Posts: 719
Joined: Sun Oct 01, 2006 11:44 pm

Re: Problem with thread access in ffmpeg

Sun May 27, 2018 4:10 pm

Very weird. RTMP uses TCP and 1.8mbps should be no problem for any Routerboard. Maybe check MTU etc?
 
mazzahaker
just joined
Topic Author
Posts: 4
Joined: Fri May 18, 2018 11:54 am

Re: Problem with thread access in ffmpeg

Mon May 28, 2018 10:24 am

Very weird. RTMP uses TCP and 1.8mbps should be no problem for any Routerboard. Maybe check MTU etc?
MTU checked and everything is fine with it ... I also checked that the flow control is disabled. I really do not understand what the problem is in this case. On the Internet, too, there are no records of this.

Who is online

Users browsing this forum: mrmut, msatter and 53 guests