Community discussions

 
sergs
just joined
Topic Author
Posts: 1
Joined: Sun May 27, 2018 2:04 pm

RDP redirect

Thu Jun 14, 2018 5:53 pm

Hello!
I have a routerboard RB951G-2HnD
I have a static ip address
Routerboad is connected to the internet via ether 1
In ether 4 I have another Router with it's own subnet 192.168.16.0/24
I want to forward RDP port from specific computer in 192.168.16.0/24 network to the internet so I can connect to the computer it via RDP from the Internet

I've already configured port forwarding on the second router which is connected to the ether4 port

I've already tried this https://wiki.mikrotik.com/wiki/Manual:I ... FTP_server
but haven't succeeded
 
anav
Forum Veteran
Forum Veteran
Posts: 711
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada

Re: RDP redirect

Thu Jun 14, 2018 9:11 pm

Hello!
I have a routerboard RB951G-2HnD
I have a static ip address
Routerboad is connected to the internet via ether 1
In ether 4 I have another Router with it's own subnet 192.168.16.0/24
I want to forward RDP port from specific computer in 192.168.16.0/24 network to the internet so I can connect to the computer it via RDP from the Internet

I've already configured port forwarding on the second router which is connected to the ether4 port

I've already tried this https://wiki.mikrotik.com/wiki/Manual:I ... FTP_server
but haven't succeeded
Basically
need srcnat and dstnat for each router....... and some other things like routing
Lets work through missing information by adding it (made up numbers).

WANIP of primary router ISP static is 172.66.233.12
WAN GW of primary router is 172.66.233.1
LAN DHCP network of primary router is 192.168.2.0/24
LAN gateway IP is 192.168.2.1
LANIP of secondary router (on primary network) is 192.168.2.10 (physically connected on ether4)

WANIP of secondary router is 192.168.2.10 (static wanip)
WAN GW of secondary router is 192.168.2.1
WAN interface on second router is on ether1
LAN DHCP network on router 2 is 192.168.16.0/24
Gateway IP of LAN is 192.168.16.1
IP of computer on this LAN is 192.168.16.5
WAN interface on second router is on ether1

Thus on Router 2..........
/ip firewall nat
add chain=dst-nat in-interface=ether1 dest=192.168.16.5 dest-port=RDP action=dst-nat
add chain=src-nat out=interface=ether1 action=src-nat to-addresses=192.168.2.10

/ip route
add dest=0.0.0.0/0 GWIP=192.168.2.1 distance=1

Thus or Router 1
/ip route
add dest=0.0.0.0/0 gwIP=172.66.233.1 distance=1

/ip firewall nat
add chain=dst-nat in-interface=ether1 dest=168.2.10 dest-port=RDP action=dst-nat
add chain=src-nat out=interface=ether1 action=src-nat to-addresses=172.66.233.12

Who is online

Users browsing this forum: lucianocn and 8 guests