Community discussions

 
DJGlooM
just joined
Topic Author
Posts: 16
Joined: Thu May 15, 2014 2:28 am

CAPsMAN 6.40.8 with newer version CAPs = loops

Thu Jun 14, 2018 8:38 pm

Hi guys! Just wanted to add a small piece of my recent experience, hopefully it'll save someone some time.

Standard client's residence config:
- core router
- gigabit switch
- caps (wap, hap ac2, 951, hap lite etc)

Everything was on 6.40.8, multiport router's ports was bridged old-style master-slave, as this ROS version still supports it. Then hap ac2 came along with 6.41.something version and it was impossible to downgrade to 6.40.8 bugfix. Probably it would be possible with netinstall, but not remotely and I wouldnt risk it.
CAPsMAN partial config looks like this:
/caps-man datapath
add arp=enabled bridge=bridge-lan client-to-client-forwarding=yes local-forwarding=no name=datapath-lan
/caps-man provisioning
add action=create-dynamic-enabled hw-supported-modes=a,an,ac master-configuration=WhiteHouse@5 name-format=identity
add action=create-dynamic-enabled hw-supported-modes=gn master-configuration=WhiteHouse name-format=identity
And on CAPs discovery was set either to ether1 for master-slave commutation, or to bridge-local for new hardware offload method.

So with this configuration there was loop errors with bridge interface MAC address.

Usually I prefer bugfix version in production, but here is clearly bridging method incompatibility, so I had to go to latest 6.42.3 and now it's working fine.

Did anyone try to downgrade mikrotiks lower than factory version with netinstall?
Did anyone resolve a problem like this in other way?

Who is online

Users browsing this forum: binh and 22 guests