Community discussions

 
Spartacus
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 96
Joined: Thu Apr 19, 2018 6:38 pm

SONOS and VLANs

Tue Jun 26, 2018 3:11 pm

Hi everybody,
I need support in setting up a Sonos System accross different VLANs and i don´t know why this doesn´t work:

prerequisite before:
    • all palyers are in vlan99,
    • all controller are in vlan99
    Test scenario
    • moving one player to vlan30

    Implementation of:
    /routing pim interface
    add interface=vlan30
    add interface=vlan99
    
    /ip firewall filter
    #Input
    .....
    #Forward
    add chain=forward connection-state=established,related comment="fasttrack established,related" action=fasttrack-connection
    add chain=forward connection-state=established,related comment="accept established,related" action=accept
    add chain=forward in-interface-list=LAN out-interface-list=WAN protocol=tcp dst-port=25 comment "prevent SPAM" action=drop
    add chain=forward connection-state=invalid comment="drop invalid" action=drop
    add chain=forward comment="Forward Sonos multicast traffic" dst-address=239.255.255.250 action=accept
    add chain=forward comment="Forward Sonos remote control events to players" in-interface=vlan99 out-interface=vlan30 dst-port=1400,4444 protocol=tcp action=accept
    add chain=forward comment="Forward Sonos remote control events from players" in-interface=vlan30 out-interface=vlan99 dst-port=3400,3401,3500 protocol=tcp action=accept
    add chain=forward comment="Forward Sonos UPnP device discovery events from players" in-interface=vlan30 out-interface=vlan99 dst-address=192.168.1.0/24 dst-port=1900,1901 protocol=udp action=accept
    When a restart the player in vlan30 and one controller in vlan99, I can only see players in vlan99 but not the player in vlan30.
    I can also see udp- forward communication between both vlans .

    Can someone help to find the issue?
    Christian
     
    jarda
    Forum Guru
    Forum Guru
    Posts: 7470
    Joined: Mon Oct 22, 2012 4:46 pm

    Re: SONOS and VLANs

    Fri Jun 29, 2018 9:23 am

     
    Spartacus
    Frequent Visitor
    Frequent Visitor
    Topic Author
    Posts: 96
    Joined: Thu Apr 19, 2018 6:38 pm

    Re: SONOS and VLANs

    Sat Jul 14, 2018 11:26 am

    Hi everybody,
    I got it working for three weeks. But since Update to 9.0 I have a lot of troubles. Sometimes the controllers cannot find the players. I also had trouble with the update. It works only if controller and player are in the same subnet.

    It is also not possible to enter a new controller to the system, only ig the controller is in the same subnet. I have configured my system in this way:
    viewtopic.php?t=101244


    Does anyone has an idea?

    Christian

    Who is online

    Users browsing this forum: Google [Bot], mdkberry and 34 guests