Community discussions

 
cyberdott
just joined
Topic Author
Posts: 1
Joined: Wed Jul 04, 2018 11:32 am

VLAN HW offload

Wed Jul 04, 2018 12:33 pm

Just try me on a crs226-24g-2s +. I was aware that this is not a rocket, but I currently have fast Ethernet feeling... far away from gigabit. I assume that I have not configured the whole thing correctly. Currently my interfaces look like this:
Flags: X - disabled, I - inactive, D - dynamic, H - hw-offload 
 # INTERFACE BRIDGE HW PVID PR PATH-COST INTERNA... HORIZON
 0 vlan10 bridge1 10 0x 10 10 none
 1 vlan20 bridge1 20 0x 10 10 none
 2 vlan1 bridge1 1 0x 10 10 none
 3 vlan30 bridge1 30 0x 10 10 none
 4 I ether2 bridge1 yes 10 0x 10 10 none
 5 I ether3 bridge1 yes 10 0x 10 10 none
 6 I ether4 bridge1 yes 10 0x 10 10 none
 7 I ether5 bridge1 yes 10 0x 10 10 none
 8 I ether6 bridge1 yes 10 0x 10 10 none
 9 I ether8 bridge1 yes 10 0x 10 10 none
10 I ether7 bridge1 yes 10 0x 10 10 none
11 I ether9 bridge1 yes 20 0x 10 10 none
12 I ether10 bridge1 yes 20 0x 10 10 none
13 I ether11 bridge1 yes 20 0x 10 10 none
14 ether12 bridge1 yes 20 0x 10 10 none
15 I ether13 bridge1 yes 20 0x 10 10 none
16 I ether14 bridge1 yes 20 0x 10 10 none
17 I ether15 bridge1 yes 20 0x 10 10 none
18 I ether16 bridge1 yes 20 0x 10 10 none
19 I ether17 bridge1 yes 30 0x 10 10 none
20 I ether18 bridge1 yes 30 0x 10 10 none
21 I ether19 bridge1 yes 30 0x 10 10 none
22 I ether20 bridge1 yes 30 0x 10 10 none
23 I ether21 bridge1 yes 30 0x 10 10 none
24 I ether22 bridge1 yes 30 0x 10 10 none
25 I ether23 bridge1 yes 30 0x 10 10 none
26 I ether24 bridge1 yes 30 0x 10 10 none
Even if HW yes stands it does not seem to run over the separate switch chip and overwhelms the CPU. Is there any idea how I can get the whole more effective? Otherwise everything works so far, DHCP does what it is supposed to. Thank you very much!

Here my config:
# jun/30/2018 23:14:40 by RouterOS 6.42.4
# software id = XXXXX
#
# model = CRS226-24G-2S+
# serial number = XXXXXXXXX
/interface bridge
add fast-forward=no name=bridge1 vlan-filtering=yes
/interface vlan
add interface=bridge1 name=vlan1 vlan-id=1
add interface=bridge1 name=vlan10 vlan-id=10
add interface=bridge1 name=vlan20 vlan-id=20
add interface=bridge1 name=vlan30 vlan-id=30
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=pool10 ranges=192.168.10.100-192.168.10.200
add name=pool20 ranges=192.168.20.100-192.168.20.200
add name=pool30 ranges=192.168.30.100-192.168.30.200
/ip dhcp-server
add address-pool=pool10 disabled=no interface=vlan10 lease-time=3d10m name=\
    server10
add address-pool=pool20 disabled=no interface=vlan20 lease-time=3d10m name=\
    server20
add address-pool=pool30 disabled=no interface=vlan30 lease-time=3d10m name=\
    server30
/interface bridge port
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    interface=vlan10 pvid=10
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    interface=vlan20 pvid=20
add bridge=bridge1 interface=vlan1
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    interface=vlan30 pvid=30
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    interface=ether2 pvid=10
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    interface=ether3 pvid=10
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    interface=ether4 pvid=10
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    interface=ether5 pvid=10
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    interface=ether6 pvid=10
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    interface=ether8 pvid=10
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    interface=ether7 pvid=10
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    interface=ether9 pvid=20
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    interface=ether10 pvid=20
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    interface=ether11 pvid=20
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    interface=ether12 pvid=20
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    interface=ether13 pvid=20
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    interface=ether14 pvid=20
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    interface=ether15 pvid=20
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    interface=ether16 pvid=20
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    interface=ether17 pvid=30
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    interface=ether18 pvid=30
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    interface=ether19 pvid=30
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    interface=ether20 pvid=30
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    interface=ether21 pvid=30
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    interface=ether22 pvid=30
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    interface=ether23 pvid=30
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    interface=ether24 pvid=30
/interface bridge vlan
add bridge=bridge1 tagged=bridge1,vlan1 vlan-ids=1
add bridge=bridge1 tagged=bridge1,vlan10 untagged=\
    ether2,ether3,ether4,ether5,ether6,ether7,ether8 vlan-ids=10
add bridge=bridge1 tagged=vlan20,bridge1 untagged=\
    ether9,ether10,ether11,ether12,ether13,ether14,ether15,ether16 vlan-ids=20
add bridge=bridge1 tagged=bridge1,vlan30 untagged=\
    ether17,ether18,ether19,ether20,ether21,ether22,ether23,ether24 vlan-ids=30
/ip address
add address=192.168.50.254/24 interface=ether1 network=192.168.50.0
add address=192.168.1.254/24 interface=vlan1 network=192.168.1.0
add address=192.168.10.254/24 interface=vlan10 network=192.168.10.0
add address=192.168.20.254/24 interface=vlan20 network=192.168.20.0
add address=192.168.30.254/24 interface=vlan30 network=192.168.30.0
/ip dhcp-server network
add address=192.168.10.0/24 dns-server=192.168.50.1,8.8.8.8 gateway=\
    192.168.10.254 netmask=24
add address=192.168.20.0/24 dns-server=192.168.50.1,8.8.8.8 gateway=\
    192.168.20.254 netmask=24
add address=192.168.30.0/24 dns-server=192.168.50.1,8.8.8.8 gateway=\
    192.168.30.254 netmask=24
/ip route
add distance=1 gateway=192.168.50.1
/system clock
set time-zone-name=Europe/Berlin
/system routerboard settings
set silent-boot=no
 
diddie17
Frequent Visitor
Frequent Visitor
Posts: 68
Joined: Thu Sep 14, 2017 8:53 pm
Location: UK

Re: VLAN HW offload

Thu Jul 05, 2018 9:02 pm

Looks to me like you have VLAN Filtering turned on.

Based on this https://wiki.mikrotik.com/wiki/Manual:S ... p_Features turning on VLAN filtering on a CRS2XX turns off HW offload
 
User avatar
Steveocee
Forum Guru
Forum Guru
Posts: 1110
Joined: Tue Jul 21, 2015 10:09 pm
Location: UK
Contact:

Re: VLAN HW offload

Sat Jul 07, 2018 10:56 pm

This filtering would need to go through the very underpowered CPU. CRS226 are great at switching but anything through CPU is painful. I am just beginning swapping all of ours for CRS326 due to the poor performances.
Steve "Steveocee" Carter
PC Gamer, Airsofter, MikroTik Nerd
My Website - My MikroTik Tutorials
 
User avatar
chechito
Forum Guru
Forum Guru
Posts: 1743
Joined: Sun Aug 24, 2014 3:14 am
Location: Bogota Colombia
Contact:

Re: VLAN HW offload

Sun Jul 08, 2018 3:42 am

CRS 226 is the most versatile and powerfull switch MIkrotik have

but

hard to configure

only use bridge menu to group ports for switching

you have to configure VLans by the Switch menu to get full wire-speed (thats the objective with a switch)

use this guide
https://wiki.mikrotik.com/wiki/Manual:C ... tches#VLAN

if you confugure VLans by bridge menu, you will have a very slow 26 port, single core software bridge/router

Who is online

Users browsing this forum: No registered users and 52 guests