Community discussions

 
Jacka
Member Candidate
Member Candidate
Topic Author
Posts: 112
Joined: Thu Jan 13, 2011 11:34 am

RB2011UiAS-2HnD - poor wireless performance

Fri Jul 13, 2018 3:47 pm

Hi all,

I cannot get good wireless performance from my Mikrotik board, I'm standing with my Notebook (that uses Qualcomm Atheros AR956x adapter) next to the router and all I can get is ~55Mbps using Mikrotik Bandwidth Test app. Can someone point me to what I changes I need to make in my config so I'll get some improvements. Maybe I need to change the channel width or the wireless protocol ? Thank you in advance.
*The AP is used in an office with about 10 wireless devices connect to it.
RouterOS: 6.43rc44
[admin@MikroTik] > interface wireless export
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa2-psk eap-methods="" management-protection=allowed mode=dynamic-keys name=New2 supplicant-identity="" wpa2-pre-shared-key=*************
/interface wireless
set [ find default-name=wlan1 ] adaptive-noise-immunity=ap-and-client-mode amsdu-limit=2048 band=2ghz-onlyn country=romania default-forwarding=no disabled=no distance=indoors frequency=2422 hw-protection-mode=rts-cts mode=ap-bridge preamble-mode=\
    short security-profile=New2 ssid=G&G wireless-protocol=802.11 wps-mode=disabled
add mac-address=E6:8D:8C:00:CA:D8 master-interface=wlan1 name=wlan2 security-profile=virtual-ap ssid=Guests wds-cost-range=0 wds-default-cost=0 wps-mode=disabled
[admin@MikroTik] > 

Image

Image

Image
 
whitbread
Frequent Visitor
Frequent Visitor
Posts: 96
Joined: Fri Nov 08, 2013 9:55 pm

Re: RB2011UiAS-2HnD - DO NOT USE RB's bandwidth test on device to be measured!

Sat Jul 14, 2018 10:16 am

You must not use RB as Traffic Generator itself when trying to measure wireless performance on the same device as this uses up CPU.

So you are measuring the measuring performance instead of the wireless or whatsoever performance.
 
Jacka
Member Candidate
Member Candidate
Topic Author
Posts: 112
Joined: Thu Jan 13, 2011 11:34 am

Re: RB2011UiAS-2HnD - poor wireless performance

Sat Jul 14, 2018 9:29 pm

speeetest.com gives me same results. My AP is not performing to well and this is a issue. Can someone give me an advice? What's wrong in my config?
 
kakaxa
just joined
Posts: 12
Joined: Thu Feb 01, 2018 5:46 am

Re: RB2011UiAS-2HnD - poor wireless performance

Sat Jul 14, 2018 10:10 pm

 
whitbread
Frequent Visitor
Frequent Visitor
Posts: 96
Joined: Fri Nov 08, 2013 9:55 pm

Re: RB2011UiAS-2HnD - poor wireless performance

Sun Jul 15, 2018 1:17 am

If CPU is not limiting by being used by bandwidth test, then I would start playing with the following values:
- Band: my suggestion would be G/N only
- Channel Width: must be 20/40 to achieve good results
- power: if distance is low, high power is reducing bandwidth (use status -> ccq to determine optimal values
can be adjusted by frequency mode and antenna gain and on tx power itself
- hw protection mode: 'none' is best in my env

Plus: There are a lot of settings on your pc to play with...

Please export full wireless configuration.
 
Jacka
Member Candidate
Member Candidate
Topic Author
Posts: 112
Joined: Thu Jan 13, 2011 11:34 am

Re: RB2011UiAS-2HnD - poor wireless performance

Fri Jul 20, 2018 3:54 pm

Please export full wireless configuration.

Thank you for posting. This is everything what wireless export gives me:
[admin@MikroTik] > interface wireless export
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa2-psk eap-methods="" management-protection=allowed mode=dynamic-keys name=New2 supplicant-identity="" wpa2-pre-shared-key=*************
/interface wireless
set [ find default-name=wlan1 ] adaptive-noise-immunity=ap-and-client-mode amsdu-limit=2048 band=2ghz-onlyn country=romania default-forwarding=no disabled=no distance=indoors frequency=2422 hw-protection-mode=rts-cts mode=ap-bridge preamble-mode=\
    short security-profile=New2 ssid=G&G wireless-protocol=802.11 wps-mode=disabled
add mac-address=E6:8D:8C:00:CA:D8 master-interface=wlan1 name=wlan2 security-profile=virtual-ap ssid=Guests wds-cost-range=0 wds-default-cost=0 wps-mode=disabled
[admin@MikroTik] > 

 
UpRunTech
Frequent Visitor
Frequent Visitor
Posts: 57
Joined: Fri Jul 27, 2012 12:11 pm

Re: RB2011UiAS-2HnD - poor wireless performance

Sat Jul 21, 2018 2:37 pm

What operating system are you using? I predominantly use Linux on my laptop that has a "Broadcom Corporation BCM4352 802.11ac" adapter in it. At 2.4GHz on Linux it's driver performance is woeful (but this is known), even with the slight speed improvement that resulted from the latest driver updates in ROS. I have heard other Linux Wifi drivers are lacklustre too.

Copying files in Linux Mint to my SAMBA file server gets about 3.5MB/s on a 20MHz channel. In Windows on the same laptop it's over 7MB/s and in the past in Windows I have had over 14MB/s on a 40MHz channel.

I'd suggest to really test your Routerboard use a clear 20MHz channel from a few metres away and use iperf2 or iperf3 to test the speed between 2 computers (one on the LAN and one on Wifi) and leave the Routerboard CPU to just do bridging/routing/wifi. And use Windows on the Wifi machine.

Also, while you are testing remove or turn off all other clients connecting to the same AP to remove airtime competition.

Here is a verbose dump of mine. I use only 802.11N, no RTS/CTS, and preamble is 'both'.
/interface wireless
set [ find default-name=wlan1 ] adaptive-noise-immunity=ap-and-client-mode allow-sharedkey=no ampdu-priorities=0 \
    amsdu-limit=8192 amsdu-threshold=8192 antenna-gain=0 antenna-mode=ant-a area="" arp=enabled arp-timeout=auto band=\
    2ghz-onlyn basic-rates-a/g=6Mbps basic-rates-b=1Mbps bridge-mode=enabled channel-width=20mhz compression=no country=\
    australia default-ap-tx-limit=0 default-authentication=yes default-client-tx-limit=0 default-forwarding=yes \
    disable-running-check=no disabled=no disconnect-timeout=3s distance=indoors frame-lifetime=0 frequency=2462 \
    frequency-mode=manual-txpower frequency-offset=0 guard-interval=any hide-ssid=no ht-basic-mcs=\
    mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7 ht-supported-mcs="mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7,mcs\
    -8,mcs-9,mcs-10,mcs-11,mcs-12,mcs-13,mcs-14,mcs-15,mcs-16,mcs-17,mcs-18,mcs-19,mcs-20,mcs-21,mcs-22,mcs-23" \
    hw-fragmentation-threshold=disabled hw-protection-mode=none hw-protection-threshold=0 hw-retries=7 \
    interworking-profile=disabled keepalive-frames=enabled l2mtu=1600 mac-address=XX:XX:XX:XX:XX:XX max-station-count=\
    2007 mode=ap-bridge mtu=1500 multicast-buffering=enabled multicast-helper=full name=wlan1 noise-floor-threshold=\
    default nv2-cell-radius=30 nv2-downlink-ratio=50 nv2-mode=dynamic-downlink nv2-noise-floor-offset=default \
    nv2-preshared-key="" nv2-qos=default nv2-queue-count=2 nv2-security=disabled nv2-sync-secret="" on-fail-retry-time=\
    100ms preamble-mode=both radio-name=000C42FC9DD1 rate-selection=advanced rate-set=default rx-chains=0,1 scan-list=\
    default secondary-channel="" security-profile=default ssid=XXXXXXXXX station-bridge-clone-mac=00:00:00:00:00:00 \
    station-roaming=enabled supported-rates-a/g=6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps supported-rates-b=\
    1Mbps,2Mbps,5.5Mbps,11Mbps tdma-period-size=2 tx-chains=0,1 tx-power-mode=default update-stats-interval=disabled \
    vlan-id=1 vlan-mode=no-tag wds-cost-range=50-150 wds-default-bridge=none wds-default-cost=100 wds-ignore-ssid=no \
    wds-mode=disabled wireless-protocol=802.11 wmm-support=enabled wps-mode=push-button

Who is online

Users browsing this forum: Kindis, mjAUT, uldis and 15 guests