Community discussions

 
fsjunior
just joined
Topic Author
Posts: 5
Joined: Wed Nov 18, 2015 5:07 pm

Windows client connected to RB411AR conflict with another client

Fri Jul 13, 2018 10:50 pm

Hi,

I'm trying to connect three different clients to my AP (RB411AR) but I'm having a VERY strange behavior with it.

My AP is configurated with ap-bridge mode and WPA2-PSK-AES. I set the IP address of 1.0.227.17/16 in the wlan interface.

So, i'm trying to connect three different clients:
An Windows computer (I've tried Windows 7 and 10 in different computers with the same behavior) with IP 1.0.225.17/16
An ESP8266 board with IP 1.0.229.17/16
A Linux computer with IP 1.0.226.16/16

The strange part: all three devices connect in the AP bridge and are shown in the registration table. But, apparently, the Windows and ESP8266 are having a conflict.

I can reach (and ping) the AP, Windows Computer and ESP8266 with Linux computer. But Windows computer cannot reach at the same time the ESP8266 and the other devices. The Windows computer can ping the AP and Linux computer at same time, but cannot ping the ESP8266.

The really strange part: sometimes randomly, the Windows computer stop to reach AP and Linux and start to only talk with ESP8266 (while, at the time, Linux can still reach AP and ESP8266).

So, basically, Linux can reach everything with no problems, but windows seems to swap between reaching the ESP8266 and reaching all the other devices (but all devices are always shown in registration table in AP).

The really really incredible strange part: when I configure the AP with a security profile with "none" mode, all devices can reach all other devices with no problem.

Anyone have any idea of what is causing this? I don't know even where to start to find a solution for this problem.

Some additional information: I checked this in RouterOS 6.35.4 and 6.40.8 with the same problem and I have the same setup (ESP8266 and Windows Computer) with RB 911G-2GHz in ap-bridge mode with WPA2-PSK-AES, which works really well. But unfortunately I cannot use RB 911G in this project, I need to use RB411.

Edit:

I found another thing: If I disable WMM Support in AP, the Windows computer can reach the ESP8266 normally. If I enable, this strange behavior starts. This can explain why the same setup worked in RB911G: in 911G, I do not configure WMM Support to enabled.

Here the AP configuration exported with "compact" option:
# jan/02/1970 00:16:27 by RouterOS 6.40.8
# software id = 0H3S-L11D
#
# model = 411AR
# serial number = 629305EEC9A9
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa-psk,wpa2-psk eap-methods="" \
    management-protection=allowed mode=dynamic-keys name=profile1 \
    supplicant-identity="" wpa-pre-shared-key="pass" \
    wpa2-pre-shared-key="pass"
/interface wireless
set [ find default-name=wlan1 ] disabled=no mode=ap-bridge security-profile=\
    profile1 ssid=ssid wireless-protocol=802.11 wmm-support=enabled
/ip address
add address=1.0.227.17/16 interface=wlan1 network=1.0.0.0

Who is online

Users browsing this forum: No registered users and 1 guest