Community discussions

 
subzer0
just joined
Topic Author
Posts: 8
Joined: Sat Jul 14, 2018 1:09 pm

Script to reduce Wi-Fi transmitter power on schedule/at night

Sat Jul 14, 2018 1:16 pm

Hello,
I have hAP ac² running Routeros v6.42.6, and I want to reduce Wi-Fi transmitter power on schedule/at night because the router is located in a bed room.
I've found this: https://tushev.org/articles/linux-bsd/2 ... k-routeros

The script there is only for wlan1. my hAP ac² has wlan1 & wlan2.
I don't know how to edit the script so it would reduce WI-FI transmitter power on both wlan1 & wlan2.
If someone can help editing the script to fit hAP ac² v6.42.6 it would be really appreciated :)

Thank you all!

Here is the script
# Script to turn down radio power based on a schedule
# Schedule this script to run every 15-30 minutes to make
# certain the changeover has occurred.
# User variables are listed below:
#####################################
## Set the Radio NormalPower and LowPower times here ##
:local RadioNormalPowerTime "08:00";
:local RadioLowPowerTime "00:30";
:local LowPower 6;
:local NormalPower 17;
:local RadioName "wlan1";
:local RadioPowerState;
:local RadioPower;
#####################################
:local CurrentTime [/system clock get time];
:set RadioPower [:put [/interface wireless get value-name=tx-power $RadioName]];
:if ($RadioPower = $LowPower) do {
		:set RadioPowerState 0;
} else {
	:if ($RadioPower > $NormalPower) do {
		:set RadioPowerState 2;
	} else {
		:set RadioPowerState 1;
	}
}
# Where the NormalPower time is set earlier than the LowPower time #
:if ($RadioNormalPowerTime < $RadioLowPowerTime) do {
# 	NormalPower interval #
	:if (($CurrentTime > $RadioNormalPowerTime) and ($CurrentTime < $RadioLowPowerTime)) do {	
		:if ($RadioPowerState=0) do {
			:log info "[$CurrentTime] Switching to NormalPower";
			:put [/interface wireless set $RadioName tx-power=$NormalPower];
		}
# 	LowPower interval #		
	} else {	
#		We should go to LowPower in any case at LowPower interval #
		:if ($RadioPowerState!=0) do {
			:log info "[$CurrentTime] Switching to LowPower";
			:put [/interface wireless set $RadioName tx-power=$LowPower];
		}
	}
}
# Where the NormalPower time is set later than the LowPower time #
:if ($RadioNormalPowerTime > $RadioLowPowerTime) do {
# 	LowPower interval #
	:if (($CurrentTime < $RadioNormalPowerTime) and ($CurrentTime > $RadioLowPowerTime)) do {
#		We should go to LowPower in any case at LowPower interval #
		:if ($RadioPowerState!=0) do {
			:log info "[$CurrentTime] Switching to LowPower";
			:put [/interface wireless set $RadioName tx-power=$LowPower];
		}
# 	NormalPower interval #
	} else {	
		:if ($RadioPowerState=0) do {
			:log info "[$CurrentTime] Switching to NormalPower";
			:put [/interface wireless set $RadioName tx-power=$NormalPower];
		}
	}
}
 
nescafe2002
Member
Member
Posts: 324
Joined: Tue Aug 11, 2015 12:46 pm
Location: Netherlands

Re: Script to reduce Wi-Fi transmitter power on schedule/at night

Sat Jul 14, 2018 2:09 pm

You could schedule it twice.. one for wlan1 and another for wlan2.
 
subzer0
just joined
Topic Author
Posts: 8
Joined: Sat Jul 14, 2018 1:09 pm

Re: Script to reduce Wi-Fi transmitter power on schedule/at night

Sat Jul 14, 2018 2:28 pm

Thank you, that's also an option. but i think that 1 script is neater :) (if possible)
anyone knows why the script should be scheduled to run every 15-30 minutes? (he says to make certain the changeover has occurred)
But if it runs every 15-30 min - does it affect the performance of my hAP ac²?

Thank you
 
nescafe2002
Member
Member
Posts: 324
Joined: Tue Aug 11, 2015 12:46 pm
Location: Netherlands

Re: Script to reduce Wi-Fi transmitter power on schedule/at night

Sat Jul 14, 2018 5:06 pm

If it's stupid and it works, it ain't stupid. Or untidy for that matter. Script seems to update only when necessary, so performance won't be an issue even when scheduled every minute.
 
diddie17
Frequent Visitor
Frequent Visitor
Posts: 68
Joined: Thu Sep 14, 2017 8:53 pm
Location: UK

Re: Script to reduce Wi-Fi transmitter power on schedule/at night

Sat Jul 14, 2018 7:31 pm

I can't test it and I haven't got a hAP ac² to run it on anyway, but assuming the script works on your hAP ac² as is, and you don't want to schedule them seperately, it looks like the quick and dirty way is probably just to add another radio name in parallel and just duplicate the commands.

You will need to update the script and test yourself, but I would be making changes similar to the following and giving it a try. I have little scripting experience, but I do have a devlopment background and on that basis I don't see why it wouldn't work.

At the top where the variables are I would insert a second radio name -
:local NormalPower 17;
:local RadioName "wlan1";
:local RadioName2 "wlan2";
:local RadioPowerState;
Then every time a command is sent to RadioName to switch power, I would try duplicating the line for RadioName2.
		:if ($RadioPowerState=0) do {
			:log info "[$CurrentTime] Switching to NormalPower";
			:put [/interface wireless set $RadioName tx-power=$NormalPower];
			:put [/interface wireless set $RadioName2 tx-power=$NormalPower];
		}
 
diddie17
Frequent Visitor
Frequent Visitor
Posts: 68
Joined: Thu Sep 14, 2017 8:53 pm
Location: UK

Re: Script to reduce Wi-Fi transmitter power on schedule/at night

Sat Jul 14, 2018 7:36 pm

Just as a thought, that does make the assumption that low power and normal power are the same values for wlan1 and wlan 2. If they aren't you would need to add extra variables for low power and normal power for wlan2 as well.
 
subzer0
just joined
Topic Author
Posts: 8
Joined: Sat Jul 14, 2018 1:09 pm

Re: Script to reduce Wi-Fi transmitter power on schedule/at night

Sat Jul 14, 2018 7:47 pm

How can i check the values of wlan1 & wlan2 prior to the changes? (I'm new to routeros)

Thank you
 
diddie17
Frequent Visitor
Frequent Visitor
Posts: 68
Joined: Thu Sep 14, 2017 8:53 pm
Location: UK

Re: Script to reduce Wi-Fi transmitter power on schedule/at night

Sat Jul 14, 2018 8:13 pm

I've just had a look on my hAP ac and both wlan1 and wlan2 (2.4Ghz and 5Ghz) seem to run at 17ish as normal power, which is what the script uses, so I guess it will be fine.

I just logged into winbox, went into wireless, double clicked on wlan1 and looked at the TxPower and current TXPower tabs. You may have to maximize the window to see the tabs, or scroll over to the right, there are a lot of tabs. You may also have to change some of the values on the TxPower tab if it's set to default (I changed to manual to see them), but as long as you cancel rather than hit ok it's not an issue.

I'm sure you'll be fine with using the normal power value there, but as I've never seen a hAP AC2 it's worth double checking to be 100% safe.
 
subzer0
just joined
Topic Author
Posts: 8
Joined: Sat Jul 14, 2018 1:09 pm

Re: Script to reduce Wi-Fi transmitter power on schedule/at night

Sat Jul 14, 2018 8:32 pm

diddie17, I've tried to look also, but i didn't see any figures
under 'tx power' both are default
I've attached both wlan1 & wlan2 screenshots
why is it like that?

Thank you
You do not have the required permissions to view the files attached to this post.
 
sid5632
Member Candidate
Member Candidate
Posts: 248
Joined: Fri Feb 17, 2017 6:05 pm

Re: Script to reduce Wi-Fi transmitter power on schedule/at night

Sat Jul 14, 2018 10:13 pm

I want to reduce Wi-Fi transmitter power on schedule/at night because the router is located in a bed room.
What on earth for?
Does the 'excess' power keep someone awake or what?
Or maybe you think it causes cancer or something?
 
diddie17
Frequent Visitor
Frequent Visitor
Posts: 68
Joined: Thu Sep 14, 2017 8:53 pm
Location: UK

Re: Script to reduce Wi-Fi transmitter power on schedule/at night

Sat Jul 14, 2018 11:08 pm

I've just checked it will be fine, just go with the script and use the default power levels in the script.
 
Samot
Frequent Visitor
Frequent Visitor
Posts: 70
Joined: Sat Nov 25, 2017 10:01 pm

Re: Script to reduce Wi-Fi transmitter power on schedule/at night

Sun Jul 15, 2018 4:17 pm

I want to reduce Wi-Fi transmitter power on schedule/at night because the router is located in a bed room.
What on earth for?
Does the 'excess' power keep someone awake or what?
Or maybe you think it causes cancer or something?
I'm with sid5632 on this. Why do you need to decrease the TX power of the wifi at night? What is the goal/benefit trying to be gained here with this? Because there is also the fact that if you're messing with the TX, the RX needs to be adjusted as well or it can cause issues.

I'm kind of getting a feeling the idea of reducing the TX is for something that could be done without adjusting the TX. So what is the goal with this?
 
subzer0
just joined
Topic Author
Posts: 8
Joined: Sat Jul 14, 2018 1:09 pm

Re: Script to reduce Wi-Fi transmitter power on schedule/at night

Sun Jul 15, 2018 9:13 pm

Hey,
The goal is to reduce the emf emf radiation as the router is in a bed room.
So you think it is better to use a script the shuts off wlan1 & wlan2 at night? (Do you have such a script?)

Thank you
 
User avatar
k6ccc
Member
Member
Posts: 350
Joined: Fri May 13, 2016 12:01 am
Location: Glendora, CA, USA (near Los Angeles)

Re: Script to reduce Wi-Fi transmitter power on schedule/at night

Sun Jul 15, 2018 9:43 pm

Hey,
The goal is to reduce the emf emf radiation as the router is in a bed room.

Unless you are sleeping with your head laying on the antenna, that is a complete non issue.
Don't worry about it.
RB750Gr3, RB750r2, CRS326-24G-2S (in SwitchOS), CSS326-24G-2S, CSS106-5G-1S, RB260GS
Not sure if I beat them in submission, or they beat me into submission


Jim
 
subzer0
just joined
Topic Author
Posts: 8
Joined: Sat Jul 14, 2018 1:09 pm

Re: Script to reduce Wi-Fi transmitter power on schedule/at night

Sun Jul 15, 2018 10:32 pm

even if someone sleeps only 1 meter away from the router?
 
mkx
Long time Member
Long time Member
Posts: 624
Joined: Thu Mar 03, 2016 10:23 pm

Re: Script to reduce Wi-Fi transmitter power on schedule/at night

Sun Jul 15, 2018 10:52 pm

If you worry about it, you should definitely do something about it. Either schedule wifi switch off, or better option: relocate router out of bedroom. Bedroom should be place for other activities :wink:
BR,
Metod
 
Samot
Frequent Visitor
Frequent Visitor
Posts: 70
Joined: Sat Nov 25, 2017 10:01 pm

Re: Script to reduce Wi-Fi transmitter power on schedule/at night

Sun Jul 15, 2018 11:23 pm

even if someone sleeps only 1 meter away from the router?
Yes, it is a non-issue.
 
sid5632
Member Candidate
Member Candidate
Posts: 248
Joined: Fri Feb 17, 2017 6:05 pm

Re: Script to reduce Wi-Fi transmitter power on schedule/at night

Mon Jul 16, 2018 12:25 am

Most people go around all day with a phone in their pocket, right next to their gonads, and that doesn't seem to bother anyone.
Might be useful if it did, as there are far too many people in the world already.

You do wonder where folk get their bizarre ideas from sometimes...
 
User avatar
k6ccc
Member
Member
Posts: 350
Joined: Fri May 13, 2016 12:01 am
Location: Glendora, CA, USA (near Los Angeles)

Re: Script to reduce Wi-Fi transmitter power on schedule/at night

Mon Jul 16, 2018 1:04 am

even if someone sleeps only 1 meter away from the router?

If you're really worried that much, move the router a bit, but even at a foot or two, it's really a non-issue.
RB750Gr3, RB750r2, CRS326-24G-2S (in SwitchOS), CSS326-24G-2S, CSS106-5G-1S, RB260GS
Not sure if I beat them in submission, or they beat me into submission


Jim
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 23451
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Script to reduce Wi-Fi transmitter power on schedule/at night

Mon Jul 16, 2018 11:59 am

The WiFi device generally has much much lower transmit power than the phones in your house. Also, there is plenty of other stuff in the air, that you can't control. Unless in the desert with no cell towers ...
No answer to your question? How to write posts
 
lano
just joined
Posts: 2
Joined: Mon Jul 16, 2018 12:00 pm

Re: Script to reduce Wi-Fi transmitter power on schedule/at night

Mon Jul 16, 2018 12:04 pm

how do i change my mac andress using cpu on my wilres ap station wlan1 inteface?
i already have a code but it is not valid or not working ,please help?

Code: Select all

# define char table
:global chArray 0abcdef0123456789abcdef012345abcdef0123456789abcdef0123456789abcdef0123456789abcdef0123456789abcdef0123456789abcdef012345
:local strPass "";


#get counters
#:local chz1num [/system clock get time ];
#:local chz2num [/system clock get time ];
:local chz3num [/system clock get time ];
:local chz4num [/system clock get time ];
:local chz5num [/system clock get time ];
:local chz6num [/system clock get time ];
:local chz7num [/system resource get cpu-load ];
:local chz8num [/system resource get cpu-load ];
:local chz9num [/system resource get uptime ];
:local chz10num [/system resource get uptime ];
:local chz11num [/system resource get uptime ];
:local chz12num [/system resource get cpu-load ];


:local ch1num 0;
:local ch2num 0;
:local ch3num [:pick $chz3num 6 8];
:local ch4num [:pick $chz4num 6 8];
:local ch5num [:pick $chz5num 6 8];
:local ch6num [:pick $chz6num 6 8];
:local ch7num [:pick $chz7num];
:local ch8num [:pick $chz8num];
:local ch9num [:pick $chz9num 5 7];
:local ch10num [:pick $chz10num 2 4];
:local ch11num [:pick $chz11num 8 10];
:local ch12num [:pick $chz12num];

# generate password
:set strPass ( [:tostr [ :pick $chArray $ch1num ]] . [:tostr [:pick $chArray $ch2num ]] . [:tostr [:pick $chArray ($ch3num+$chz12num) ]] . [:tostr [:pick $chArray ($ch4num*2) ]] . [:tostr [:pick $chArray ($ch5num+16) ]] . [:tostr [:pick $chArray ($ch6num+4) ]] . [:tostr [:pick $chArray ($ch7num+12) ]] . [:tostr [:pick $chArray $ch8num ]] . [:tostr [:pick $chArray $ch9num ]] . [:tostr [:pick $chArray $ch10num ]] . [:tostr [:pick $chArray $ch11num ]] . [:tostr [:pick $chArray $ch12num ]] );

/interface wireless set wlan1 mac-address=$strPass;
:log warning $strPass;
#the end
 
mkx
Long time Member
Long time Member
Posts: 624
Joined: Thu Mar 03, 2016 10:23 pm

Re: Script to reduce Wi-Fi transmitter power on schedule/at night

Mon Jul 16, 2018 3:09 pm

The WiFi device generally has much much lower transmit power than the phones in your house. Also, there is plenty of other stuff in the air, that you can't control. Unless in the desert with no cell towers ...
The above statement is slightly misleading (if not un-true). Mobile phones have quite limited TX power. These are limitations for European technologies and bands:
  • GSM on 900MHz is limited to 33 dBm (2W) and GSM on 1800 MHz is limited to 30 dBm (1W)
  • UMTS and LTE are limited to 20-26 dBm (100-400 mW)
In region with reasonably good signal reception actual TX power used is lower than limit stated above. In multi-cell networks interference suppression is a big deal (especially in single-frequency networks such as UMTS and LTE) and easiest way of dealing it is by using tight power-control. It comes with a nice side-effect of reduced battery power consumption.

WiFi TX power is generally of same order of magnitude as with UMTS/LTE.

So one can't say that WiFi TX power is "much much lower transmit power than the phones" because they are comparable.

Then one needs to account for free-space path loss, which is most of times inverse proportional to cube of distance. Meaning that signal at distance of 2 metres is 8 times less than at distance of 1 metre. The big misconception of general public is result of not knowing this. So actual EMF exposure can be quite high when having transmitting phone at one's ears compared to exposure received from mobile base station at distance of 20 metres even though TX power of a base station can be 100-times higher (but the distance is some 10.000-times larger).
Another big misconception of general public (working in other direction than the before-mentioned one) lies in the fact that phone mostly transmits when in use (either during phone call or while using data) while base station transmits at all times (albeit with only part of total power when no user is using services from that particular base station). In this regard, WiFi AP is comparable to base station, it transmits beacon all the time.

As I already wrote: if user is concerned about EMF exposure, he/she should do something about it, possibly relocate AP to another room.

A footnote: personally I don't believe that high frequency EMF as used for modern telecommunications is highly harmful. But for those concerned I advise to take precautions, if not for peace of mind.
BR,
Metod
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 23451
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Script to reduce Wi-Fi transmitter power on schedule/at night

Mon Jul 16, 2018 3:15 pm

GSM on 1800 MHz is limited to 30 dBm (1W)
is a home AP usually not much lower power ?
No answer to your question? How to write posts
 
mkx
Long time Member
Long time Member
Posts: 624
Joined: Thu Mar 03, 2016 10:23 pm

Re: Script to reduce Wi-Fi transmitter power on schedule/at night

Mon Jul 16, 2018 3:42 pm

GSM on 1800 MHz is limited to 30 dBm (1W)
is a home AP usually not much lower power ?
It is. But what is proportion of users with GSM-only phones or that only have GSM coverage? In our network, which is by no means the most advanced in EU, we estimate to have less than 20% of those users. As I wrote as well, there's power control in play even in GSM and our stats show that TX power, used by phones, is lower than 10dBm (10mW, quite lower than usual AP setting) 99% of transmit time.

And, when talking about GSM: one should not forget that GSM is actually TDMA technology with "duty cycle" of 1:8 (for voice calls, GPRS/EDGE has higher "duty cycle" due to multi-TS usage). Power limit of 30/33 dBm is absolute limit and considering "duty cycle", average TX power for GSM phones is 9 dB less (21-24 dBm) which is, surprisingly, comparable to WiFi TX power again.

Sure there's a quantity where GSM is not as shiny: electric field strength (expressed in units of V/m). TX power is dispersed over wide frequency bandwidth with modern technologies (3.84 MHz + whatever penetrates into guard band at UMTS, 5-20MHz per LTE carrier, 11 MHz at legacy WiFi, up to 160MHz with 802.11ac) while GSM frequency bandwidth is "merely" 200kHz. Which means that at same TX power, electric field strength of GSM signal is some 100-times (give or take) higher than that of modern technologies.
I believe, however, that most of research that does show correlation, indicates correlation between potential diseases and total energy of EMF absorbed - total energy is proportional to TX power regardless of frequency band width. Health hazards, where high V/m comes in play, appear at really high strengths of electrical field and "consumer-grade" equipment is not capable of producing those.
BR,
Metod
 
subzer0
just joined
Topic Author
Posts: 8
Joined: Sat Jul 14, 2018 1:09 pm

Re: Script to reduce Wi-Fi transmitter power on schedule/at night

Tue Jul 17, 2018 11:29 am

Thank you all for your replies.
First- I cannot relocate the router as the optic fiber point is in that bedroom.
So as I understand you advice to leave it as is - with the WiFi on.

Thank you
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 23451
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Script to reduce Wi-Fi transmitter power on schedule/at night

Tue Jul 17, 2018 11:45 am

You can simply reduce the TX power a little bit, while it still works satisfactory. An easy way to reduce power is to set antenna gain above zero. It will reduce tx power to compensate (even though you actually don't have a high gain antenna). Then it will be totally fine and safe.
No answer to your question? How to write posts
 
subzer0
just joined
Topic Author
Posts: 8
Joined: Sat Jul 14, 2018 1:09 pm

Re: Script to reduce Wi-Fi transmitter power on schedule/at night

Tue Jul 17, 2018 12:06 pm

normis thank you for your reply
Where do I find the antenna gain setting?
Is there a script for that?

Thank you!
 
Samot
Frequent Visitor
Frequent Visitor
Posts: 70
Joined: Sat Nov 25, 2017 10:01 pm

Re: Script to reduce Wi-Fi transmitter power on schedule/at night

Tue Jul 17, 2018 1:44 pm

There is absolutely no need for this. I seriously do not recommend mucking around with these settings as you'll find yourself with issues down the road when something screws up.

Let's be clear on this: Washer/Dryers, A/C units, Water Heaters, DECT/cordless phones, Microwaves, Bluetooth, Remote Controls, Mobile Phones, Florescent based lights, etc, etc, etc, etc. All of these things result in EM be generated. To sit around and try to lower the TX/power or whatever to "reduce EMF" is a total waste if the A/C unit is any where near your room, even on the outside. It is also a waste if any of those things I listed (or even more I didn't) are in your area. These are all putting out EM and since EM can travel and go through walls, that means your neighbors running any of those things can generate EM in your area.

There are numerous things around you that generate more EM than your wifi router. Not only that, the W.H.O. and other research bodies have done numerous studies and tests and discovered that a wifi router or other low band EM (DECT phones, washer/dryer, etc) devices are not high enough in EM to be of any real damage. The complaints people have about wifi/EM hurting their brains cannot be directly linked to things like wifi routers or other devices that generate EM.

Again this is a non-issue.
 
p3rad0x
Long time Member
Long time Member
Posts: 581
Joined: Fri Sep 18, 2015 5:42 pm
Location: South Africa
Contact:

Re: Script to reduce Wi-Fi transmitter power on schedule/at night

Tue Jul 17, 2018 2:00 pm

Don't worry,

The router wont give you a brain tumor any time soon
There you go then you touched something ;-) : it only takes a change in wind direction to screw with your nat :-)
 
ozone
just joined
Posts: 13
Joined: Wed Jul 18, 2018 1:23 am

Re: Script to reduce Wi-Fi transmitter power on schedule/at night

Sat Jul 21, 2018 9:09 pm

Hi,

Sorry that I'm late to this party, but I was wondering if it would be possible to detect if a client wants to connect, and only THEN increase transmitting power of the AP?
Eg. through the registration list.
(and decrease if there is no more clients)

Not that I'm worried for my health, but just a nice proof of concept on how to detect the existence of wifi-clients in a RoS script.
I could think of other nice things to be based on this :)

Interested to see the replies for this from the scripting guru's on this forum.

Regards
 
ozone
just joined
Posts: 13
Joined: Wed Jul 18, 2018 1:23 am

Re: Script to reduce Wi-Fi transmitter power on schedule/at night

Mon Jul 23, 2018 8:08 pm

Got a little creative and started playing around myself....

Came up with this:
:global clients [/interface wireless registration-table print count-only]
if ($clients>0)  do={ /interface wireless set [ find default-name=wlan1 ] tx-power=26 } else={ /interface wireless set [ find default-name=wlan1 ] tx-power=12 }
..sets power to 12dbm when no clients are connected, and 26 when they are. Also assumes a fixed power output setting ("all rates fixed")
You can make a script out of this and schedule it VERY regularly (so that power is increased fast when needed).

The limits here are arbitrary, could be that in certain conditions they need to be adjusted. For instance, the lower limit shouldn't be so low that clients cannot connect anymore. And the upper limit of 26might be more than your device can handle, or than is allowed in your country.

Also, I tested it with 2.4G. But at 5G there is likely a radar check that is being run after power change. And this leads to long periods of disconnection. During this period the # clients is 0, and so power will be turned to low again (and triggering another radar check).
Therefore I doubt that this will work well for 5G unless used on a frequency without radarcheck or under "superchannel" mode.

edit:
Still needs some refinement: even setting a powervalue that is already selected, triggers a disconnect/reconnect. This is not nice....
Must be something like "if clients>0 and currentpower=max, then do nothing, else set power to min". etc.....
 
sid5632
Member Candidate
Member Candidate
Posts: 248
Joined: Fri Feb 17, 2017 6:05 pm

Re: Script to reduce Wi-Fi transmitter power on schedule/at night

Mon Jul 23, 2018 10:03 pm

even setting a powervalue that is already selected, triggers a disconnect/reconnect. This is not nice....
This whole business is completely and utterly STUPID. STOP doing it. Then all the 'not nice' things go away as well.
 
ozone
just joined
Posts: 13
Joined: Wed Jul 18, 2018 1:23 am

Re: Script to reduce Wi-Fi transmitter power on schedule/at night

Mon Jul 23, 2018 11:38 pm

Ahhh, always nice to see people calling you names instead of actually contributing something.

Especially as that person apparently lacks the capacities to read a entire 2 posts back to see that I mention that I actually don't believe that the radiation is a problem, but that I was in fact interested to see if someone here knew how to script a wifi-registration-list test (that indeed CAN be used to reduce power as the original poster of this thread asked, so I posted it here).

Since nobody answered after two days, I thought I give it a shot myself, and experimented my first idea together in about 30 minutes. That is what I posted to share with the crowd.
Enough to put other people that might be interested on the right track too, possibly even enthusiastic about other options that this may create.

This is what technical fora are all about.... sharing KNOWLEDGE.... (If you want to rant, go to facebook or twitter and knock yourself out)

If you are not interested in this script, just ignore it. Don't try to kill off any if not all creativity regarding RoS awesome scripting tool, and the sharing of information about it.
In your case Sid, I would advise you to just continue to the RoS quickset feature. For you, that's probably more than enough.
 
Samot
Frequent Visitor
Frequent Visitor
Posts: 70
Joined: Sat Nov 25, 2017 10:01 pm

Re: Script to reduce Wi-Fi transmitter power on schedule/at night

Tue Jul 24, 2018 5:19 am

This is what technical fora are all about.... sharing KNOWLEDGE.... (If you want to rant, go to facebook or twitter and knock yourself out)
Yes and a bunch of people with knowledge are saying this is a non-issue and shouldn't be something to worry about. None of us here are against sharing knowledge with others, quite the opposite. There are plenty of use here though that are against sharing poor knowledge because poor knowledge begets more poor knowledge.

Also, for the record, I do not see anyone calling you names or stupid. The concept/idea/logic behind it was called stupid but not you. Just keep in mind a lot of APs do not allow the user to mess with these settings because people with no or poor knowledge of RF/wifi can break things. Mikrotik's are meant to be used by those with at least a basic to strong knowledge on things. In most cases more to the strong side of the scale.

I've lost count of how many techs I've wished I could Men In Black flashy-thing all the bad knowledge out of their head because they are stuck on that as their base. All that does it cause them to draw wrong or misleading conclusions on problems and their solution can either be a total kludge or make things worse.
 
ozone
just joined
Posts: 13
Joined: Wed Jul 18, 2018 1:23 am

Re: Script to reduce Wi-Fi transmitter power on schedule/at night

Thu Jul 26, 2018 7:10 am

I'm not going into this discussion any further regarding whether we should pursue this because some people think it is stupid.
Nor regardless whether some people think calling people, their ideas, or their technical solutions, "utterly stupid" is within common decency.

My point is that is we need to share scripting info (in this case about how to read the registration table the best way), since the last few years real guru's tend to react less and less. And with it, proliferation from scripting knowledge is also less and less.... (btw, I don't say the old guru's "don't want to" anymore, they probably just moved on to other things in their lives)

In the old days, I even did not have to make an account to ask these things myself, as the guru's were explaining just about everything here. I learned a truckload of knowledge that way.
But I missed/can't find the part how to use the registration table info in scripting... Apparently it wasn't ever discussed in depth. And like I typed before, you can do much more that way than just reduce power.

And sure, with scripts, an unskilled person can kill just about any functionality in RoS. Not just with registration table scripts. And general scripting questions are not banned either.
With knowledge comes power, with power comes responsibility.

Therefore, I reiterate:.... guru's and guru-apprentices .... please discuss registration-table scripting!!!!
Learn. Think. Create. SHARE!!
And also mention the pitfalls.
But don't be censored by the mere opinions of the few!

And if you really feel so bad about it.. Just ignore and move on. Don't poison this thread.

Who is online

Users browsing this forum: No registered users and 13 guests