Community discussions

 
whitbread
Frequent Visitor
Frequent Visitor
Posts: 96
Joined: Fri Nov 08, 2013 9:55 pm

Re: v6.43 [current] is released!

Thu Sep 13, 2018 9:59 pm

*) bridge - improved performance when bridge VLAN filtering is used without hardware offloading;
Just testet 6.43 on a hap ac2 - everything went smooth so far.

As I am struggling for the best way to deal with my setup I did performance tests anyway. Just wanted to let you know that there is a performance improvement when using VLAN aware bridges but you have to use a magnifying glass. My values did increase from 360 to 380 Mbps w/o IP-Filtering and 345 to 365 Mbps w/ IP-Filtering, unfortunately far away from wire speed.
So bad you cannot use switch chip together with bridges anymore :(
 
kriszos
just joined
Posts: 7
Joined: Thu Dec 21, 2017 3:08 pm

Re: v6.43 [current] is released!

Thu Sep 13, 2018 10:05 pm

I updated my hAP ac^2 from 6.42.7 and upgraded firmware
after update my cpu usage rise from 2% to 30% and dhcp stopped working. export also hang out after /interface wireless. reboots doesn't helps. Downgraded to 6.42.7 now is working fine again.
I updated it again with same result.
 
mkx
Forum Veteran
Forum Veteran
Posts: 854
Joined: Thu Mar 03, 2016 10:23 pm

Re: v6.43 [current] is released!

Thu Sep 13, 2018 11:12 pm

So bad you cannot use switch chip together with bridges anymore :(
You can definitely use VLANs in "hybrid" mode ... do the VLAN filtering on switch chip (/interface ethernet switch) and "new bridge" (without using bridge vlan functionality) with individual ports as members.

Regarding low speed: I suspect your configuration is not optimal. I conducted some tests using VLANs on bridge (SW implementation) and I could achieve wire speed for port-to-port transfers (without any filtering) while CPU utilization was around 30% of a single core (8% overall CPU utilization).
BR,
Metod
 
Railander
just joined
Posts: 21
Joined: Thu Jun 16, 2016 11:30 pm

Re: v6.43 [current] is released!

Thu Sep 13, 2018 11:30 pm

Don't know if it's already been mentioned, but I can no longer change the name of a user in /user
It's not only the default user, it applies even to newly created users.
> user set admin name=test
failure: user name can't be changed
 
ozone
just joined
Posts: 14
Joined: Wed Jul 18, 2018 1:23 am

Re: v6.43 [current] is released!

Thu Sep 13, 2018 11:46 pm

Upgraded Hap-lite (rb941) from 6.42.6 to 6.43 (Ros+Routerboot), and now internal dhcpv4-client (from an external DNSMASQ server) does not work anymore.
The RB does not get an valid IP anymore. (stays on "searching").
If you reboot the hap-lite, the hap-lite DOES get an IP... But when you request an IP while running, you do not.
If DHCP-server is another routerboard, no issue exists, only with DNSMASQ dhcp-server.

Tried also upgrading a HAP-ac to 6.43, then there is NO DHCPv4-client issue with external dnsmasq DHCP-servers. (with identical config as hap-lite)

Second issue on hap-lite is the reduced wifi performance. Drops about 30%.

Went back to 6.42.7 on hap-lite, and internal dhcpv4-client works again (from dnsmasq), and wifi speed is back up.

Thirdly, HAP-lite still has no ramdisk functionality like HAP-ac, so upgrading is a real pain in the *ss!
If you have a few saved config files on there, you can be happy to get upgrading working with ONLY system and wireless package.
Anything beyond that, and disk is full. No errormessage though, so a reboot then usually ends up in a bricked device where only netinstall will help out.
Had this a few times already on the hap-lite.
16MB flash is simply to small :(
 
ozone
just joined
Posts: 14
Joined: Wed Jul 18, 2018 1:23 am

Re: v6.43 [current] is released!

Fri Sep 14, 2018 12:04 am

Oh Yeah,

Anyone tested what happens when you choose "SWos" in system->routerboard->settings->boot-os ?
(on a device that normally does not support that)

:)
 
schadom
Member Candidate
Member Candidate
Posts: 103
Joined: Sun Jun 25, 2017 2:47 am
Location: Austria

Re: v6.43 [current] is released!

Fri Sep 14, 2018 1:52 am

Upgraded two CCRs to 6.43 and no issues (including the described ones above) so far.
Only thing we noticed that the OpenVPN bridge was disabled after upgrading and we had to re-enable it manually.

*) winbox - fixed "sfp-connector-type" value presence under "Interface/Ethernet";
S-RJ01 SFP's are still shown with "Connector Type: LC" on 6.43 and Winbox v3.17 at least in our case.
 
Cal5582
just joined
Posts: 14
Joined: Wed Feb 28, 2018 5:04 pm

Re: v6.43 [current] is released!

Fri Sep 14, 2018 2:32 am

just had 6.43 break my RBM11G + R11e-5HacT wireless access point. after the update my mpcie card would no longer pick up but would display a red and yellow light. tried reseating card but no luck. restored back to mmips 6.42.7 and everything came back up and worked. looks to be a software issue. any way i can report this bug?
 
ste
Forum Guru
Forum Guru
Posts: 1698
Joined: Sun Feb 13, 2005 11:21 pm

Re: v6.43 [current] is released!

Fri Sep 14, 2018 9:09 am

Updated a new CCR to 6.43. Added some bridges and then some vlans to the bridges. One vlan does not show as slave of the bridge. I guess a problem of the bridge changes. So I downgraded to stable. This bricked the ccr. Hangs with starting services. Netinstalled 6.43 and started over. So sure stable and long term matches the truth ?

Just a small rant after wasting 2 hours with "stable" software. Just call it "current" again ...
 
dg1kwa
just joined
Posts: 11
Joined: Tue Aug 17, 2010 12:32 pm
Location: Monheim

Re: v6.43 [current] is released!

Fri Sep 14, 2018 10:18 am

L2TP/IPsec works properly for me on 6.42.7 and 6.43, must be something specific to your configuration or network. Have you sent a supout.rif file to support@mikrotik.com?
when I have a little time I send. I not change any configuration last time.
 
Companion
newbie
Posts: 48
Joined: Wed Mar 15, 2017 2:37 pm

Re: v6.43 [current] is released!

Fri Sep 14, 2018 11:49 am

After updating CCR1009 to 6.43 there is a problem with port stability! Has anyone else encountered such a problem?
You do not have the required permissions to view the files attached to this post.
 
User avatar
osc86
just joined
Posts: 13
Joined: Wed Aug 09, 2017 1:15 pm

Re: v6.43 [current] is released!

Fri Sep 14, 2018 12:09 pm

After updating CCR1009 to 6.43 there is a problem with port stability! Has anyone else encountered such a problem?
I doubt this is a software issue. Seems only one port is affected.
I don't have such a problem on my CCR1009.
 
lomayani
just joined
Posts: 16
Joined: Sat Jun 17, 2017 7:21 am

Re: v6.43 [current] is released!

Fri Sep 14, 2018 12:46 pm

I updated my hAP ac^2 from 6.42.7 and upgraded firmware
after update my cpu usage rise from 2% to 30% and dhcp stopped working. export also hang out after /interface wireless. reboots doesn't helps. Downgraded to 6.42.7 now is working fine again.
I updated it again with same result.
I seen the issue with dhcp stop working. check in dhcp server if you have dhcp server configured with unknown interface, if you have remove that and upgrade to 6.43. When you have dhcp-server configured with unkwnon interface and upgrade to 6.43 will cause dhcp to stop working
 
whitbread
Frequent Visitor
Frequent Visitor
Posts: 96
Joined: Fri Nov 08, 2013 9:55 pm

Re: v6.43 [current] is released!

Fri Sep 14, 2018 2:18 pm

So bad you cannot use switch chip together with bridges anymore :(
You can definitely use VLANs in "hybrid" mode ... do the VLAN filtering on switch chip (/interface ethernet switch) and "new bridge" (without using bridge vlan functionality) with individual ports as members.
Not sure if I understand you correctly - using bridge with hw offloading, then bridging vlan interfaces of 'switch bridge' to new plain bridges? I am using this config on my rb2011, but I thought it is blacklisted by Mikrotik?!?

Regarding low speed: I suspect your configuration is not optimal. I conducted some tests using VLANs on bridge (SW implementation) and I could achieve wire speed for port-to-port transfers (without any filtering) while CPU utilization was around 30% of a single core (8% overall CPU utilization).
Not sure if we are talking about the same here - I am doing real world tests with tcp and smb reaching 114MB/s when switching or bridging, but I need the filtering. So at the moment you turn on IP filtering with some rules present, performance breaks down to ~50% while cpu on hap ac2 is maxed out. Using VLAN aware bridges is even worse.
 
User avatar
Splash
Member Candidate
Member Candidate
Posts: 144
Joined: Fri Oct 16, 2015 10:09 am
Location: Johannesburg, South Africa

Re: v6.43 [current] is released!

Fri Sep 14, 2018 2:51 pm

After updating CCR1009 to 6.43 there is a problem with port stability! Has anyone else encountered such a problem?
Nope, CCR1016, CCR1036 and CCR1072's all behaving.....
MTCNA, MTCRE, MTCINE, MTCTCE, MTCIPv6E, MTCUME
 
thg3x
just joined
Posts: 11
Joined: Sat Apr 15, 2017 1:40 pm

Re: v6.43 [current] is released!

Fri Sep 14, 2018 2:54 pm


"DHCPv6 PD Pool (PPP Profile) not work anymore."

i'v got this problem too.
When connection established, dinamic DHCPv6 server creating, but client not get address from pool.
I had the same problem.
The dynamic server is created, but the client router does not receive the pool.
 
mkx
Forum Veteran
Forum Veteran
Posts: 854
Joined: Thu Mar 03, 2016 10:23 pm

Re: v6.43 [current] is released!

Fri Sep 14, 2018 3:52 pm

You can definitely use VLANs in "hybrid" mode ... do the VLAN filtering on switch chip (/interface ethernet switch) and "new bridge" (without using bridge vlan functionality) with individual ports as members.
Not sure if I understand you correctly - using bridge with hw offloading, then bridging vlan interfaces of 'switch bridge' to new plain bridges? I am using this config on my rb2011, but I thought it is blacklisted by Mikrotik?!?
I mean the setup I discussed in this thread where I posted functionally identical setups, both done on then current ROS 6.42.7, one using switch chip VLAN and the other using bridge VLAN setup.

Regarding low speed: I suspect your configuration is not optimal. I conducted some tests using VLANs on bridge (SW implementation) and I could achieve wire speed for port-to-port transfers (without any filtering) while CPU utilization was around 30% of a single core (8% overall CPU utilization).
Not sure if we are talking about the same here - I am doing real world tests with tcp and smb reaching 114MB/s when switching or bridging, but I need the filtering. So at the moment you turn on IP filtering with some rules present, performance breaks down to ~50% while cpu on hap ac2 is maxed out. Using VLAN aware bridges is even worse.
I'm not sure about it either. I did this test:
WinPC <-- access port with PVID=42 --> RBD52G <-- trunk port --> RB951G <-- access port with PVID=42 --> LinPC
So both end machines used usual untagged access and both "border" routerboards did VLAN tagging/untagging. I was running iperf both TCP and UDP. And I could achieve wire speed transfers (but I had to tune iperf parameters to get there so obviously performance does depend on client setup). I posted some results of my tests here.
BR,
Metod
 
User avatar
alexvdbaan
Trainer
Trainer
Posts: 35
Joined: Sun Feb 22, 2015 12:12 pm
Location: Amsterdam, Netherlands
Contact:

Re: v6.43 [current] is released!

Fri Sep 14, 2018 4:10 pm

@MikroTik support, do you have any feedback on the question below?
bridge - add dynamic CAP interface to tagged ports if "vlan-mode=use-tag" is enabled;

Great work MT team!

I was wondering if you could elaborate on the dynamic vlan function? I can see that the Caps interfaces are included in the bridge and that the active interfaces are tagged in the dynamic vlan entry for PVID 1. I would expect that the dynamic caps interfaces are dynamically added to all the bridge vlan entries. I have also tried to add the Capsman interfaces in their own interface list. However the newly created interface list woith all the dynamic caps interfaces can not be selected in the bridge vlan entry.

Below the config for my test setup on 6.43
/interface bridge
add fast-forward=no name=Lo0 protocol-mode=none
add fast-forward=no name=bridge protocol-mode=none vlan-filtering=yes
/interface bridge port
add bridge=bridge interface=ether1
add bridge=bridge interface=ether2 pvid=666
add bridge=bridge interface=ether3
add bridge=bridge interface=ether4
add bridge=bridge interface=ether5
/interface bridge settings
set allow-fast-path=no
/interface bridge vlan
add bridge=bridge tagged=bridge,ether1 untagged=ether2 vlan-ids=666
add bridge=bridge tagged=bridge,ether1 vlan-ids=200
add bridge=bridge tagged=bridge,ether4,ether5 vlan-ids=10,20,30,667

/caps-man datapath
add bridge=bridge client-to-client-forwarding=yes local-forwarding=no name=vl10-data vlan-id=10 vlan-mode=use-tag
add bridge=bridge client-to-client-forwarding=yes local-forwarding=no name=vl20-data vlan-id=20 vlan-mode=use-tag
add bridge=bridge client-to-client-forwarding=yes local-forwarding=no name=vl30-data vlan-id=30 vlan-mode=use-tag
add bridge=bridge client-to-client-forwarding=yes local-forwarding=no name=radius-data vlan-mode=use-tag
/caps-man security
add authentication-types=wpa2-eap disable-pmkid=yes eap-methods=passthrough encryption=aes-ccm group-encryption=aes-ccm group-key-update=1h name=Radius-Sec
/caps-man configuration
add country=netherlands datapath=radius-data distance=indoors hide-ssid=no mode=ap name=DynVlan security=Radius-Sec ssid=AllVlan
/caps-man manager
set ca-certificate=auto certificate=auto enabled=yes package-path=/upgrade upgrade-policy=require-same-version
/caps-man manager interface
set [ find default=yes ] forbid=yes
add disabled=no interface=vl667
/caps-man provisioning
add action=create-dynamic-enabled hw-supported-modes=ac master-configuration=DynVlan name-format=prefix-identity name-prefix=5Ghz-
add action=create-dynamic-enabled hw-supported-modes=gn master-configuration=DynVlan name-format=prefix-identity name-prefix=2.4Ghz-
 
DummyPLUG
Frequent Visitor
Frequent Visitor
Posts: 50
Joined: Wed Jan 03, 2018 10:17 am

Re: v6.43 [current] is released!

Fri Sep 14, 2018 5:31 pm

CCR1009, just found out all the "last link up time" is the current time in winbox (except those have link down will be in future), anyone have the same issue?
 
posetr
just joined
Posts: 7
Joined: Thu Feb 14, 2013 6:00 pm

Re: v6.43 [current] is released!

Fri Sep 14, 2018 10:23 pm

Hello , i am having difficuties about ccr1036-12g-4s when get udp attack with 0 length .

Using RouterOS 6.4 and here is the tcp dump of attack :

21:10:26.299021 IP 132.155.220.60.39812 > x.x.x.x.44710: UDP, length 0
21:10:26.299034 IP 180.19.33.203.lxi-evntsvc > x.x.x.x.2342: UDP, length 0
21:10:26.299035 IP 56.24.15.219.6200 > x.x.x.x.1234: UDP, length 0
21:10:26.299036 IP 11.90.77.183.23051 > x.x.x.x.44710: UDP, length 0
21:10:26.299057 IP 28.110.53.197.28188 > x.x.x.x.44710: UDP, length 0
21:10:26.299062 IP 215.92.148.235.23767 > x.x.x.x.3453: UDP, length 0
21:10:26.299064 IP 0.19.41.141.4864 > x.x.x.x.80: UDP, length 0
21:10:26.299065 IP 137.132.25.40.33929 > x.x.x.x.44710: UDP, length 0
21:10:26.299065 IP 49.38.104.169.9777 > x.x.x.x.110: UDP, length 0
21:10:26.299067 IP 203.183.15.186.47051 > x.x.x.x.44710: UDP, length 0
21:10:26.299185 IP 51.163.222.160.41779 > x.x.x.x.44710: UDP, length 0
21:10:26.299191 IP 0.33.48.114.8448 > x.x.x.x.4432: UDP, length 0
21:10:26.299193 IP 143.96.62.38.24719 > x.x.x.x.447: UDP, length 0

I have added many rule like :

0 chain=forward action=drop connection-state=invalid protocol=udp log=yes
log-prefix="log-paket"

1 chain=forward action=drop protocol=udp connection-bytes=0-10 log=yes
log-prefix="udp-attack"


It makes routerboard freeze and unaccesible, please help me to solve that.

No logs.
 
mkx
Forum Veteran
Forum Veteran
Posts: 854
Joined: Thu Mar 03, 2016 10:23 pm

Re: v6.43 [current] is released!

Fri Sep 14, 2018 10:37 pm

It really depends on scale of attack (and possibly there's some mis-handling of zero size UDP packets in ROS). But I'd say that major contribution to service failure is that you're logging each malformed UDP packet. Try to silently drop it, it might help your CCR to survive.
BR,
Metod
 
User avatar
ognjen
just joined
Posts: 21
Joined: Wed Nov 15, 2017 10:31 am
Location: Serbia

Re: v6.43 [current] is released!

Sat Sep 15, 2018 8:57 am

I don't have a problem with upgrade OS and fimware. Everything work fine (Dhcp, DNS, vlan, PPPoE, PPTP, L2TP, OVPN, CAPsMAN, Bridge, Wireless 802.11 over 5Ghz and 2.4GHz, Queue, Tools..). I don't under you guys, what u do to get a problem? :D

Joking apart.. I just see problem with scripts when try to start, but when check Don't requir Permissions problem is resolved.

Routers and switches what i upgrad is:
1x RB3011UiAS
2x RB2011UiAS
1x RB433
2x RBwAP2nDr2
1x CRS125-24G-1S-2HnD
3x RBwAPG-5HacT2Hnd
5x RB921GS-5HPacD r2 (mANTBox 19s)
2x RBLHGG-5acD-XL
1x CRS326-24G-2s+
2x RB SXT 5nD r2
4x RB750

Edit:
Who have problem with login on v6.43 need to upgrade winbox:
Image
Be careful with MikroTik Firewall because you can cut the line [yourself - MikroTik] :shock:
 
kriszos
just joined
Posts: 7
Joined: Thu Dec 21, 2017 3:08 pm

Re: v6.43 [current] is released!

Sat Sep 15, 2018 9:22 am

I updated my hAP ac^2 from 6.42.7 and upgraded firmware
after update my cpu usage rise from 2% to 30% and dhcp stopped working. export also hang out after /interface wireless. reboots doesn't helps. Downgraded to 6.42.7 now is working fine again.
I updated it again with same result.
I seen the issue with dhcp stop working. check in dhcp server if you have dhcp server configured with unknown interface, if you have remove that and upgrade to 6.43. When you have dhcp-server configured with unkwnon interface and upgrade to 6.43 will cause dhcp to stop working
I indeed has dhcp on unkown interface. deleted it but that doesn't resolve the problem. After update to 6.43 I cant even make supout.rif file because it hangs at 1% while cpu usage is at 30%.
/tool profile shows tha cpu is used mostly by "unclassified", "spi" and "management"
Anybody has any ideas? I would like to not need to use netinstall.
 
Kindis
Member Candidate
Member Candidate
Posts: 201
Joined: Tue Nov 01, 2011 6:54 pm

Re: v6.43 [current] is released!

Sat Sep 15, 2018 10:51 am

I'm very happy with this build I must say. Must be the best .0 build ever provided. Been running it since launch and a lot of things are better. OSPF is faster for some reason but it may come down to the huge improvements to CHR under Hyper-V. Granted I do not have a advanced environment and do not use IPsec yet so other may have other experiences but overall I'm very happy and good job Mikrotik!!
 
steen
Member
Member
Posts: 444
Joined: Sat Oct 23, 2010 2:15 am
Location: Sweden
Contact:

Re: v6.43 [current] is released!

Sat Sep 15, 2018 10:59 am

Hello Folks!

This is a humble question, someone might have tested this ros version with wifi and nv2 on older mipsbe (ARM) devices like RB411, RB433, RB800 etc. and SXT, SEXTANT, QRT5 ?

Is this wifi problem fixed yet in this version ?

Version greater than 6.41.3 fully fails with wifi and nv2 hand has to be net installed in order to get back to working versions.
 
User avatar
DimaFIX
just joined
Posts: 5
Joined: Wed Apr 18, 2018 7:46 pm
Location: Ukraine

Re: v6.43 [current] is released!

Sun Sep 16, 2018 5:13 am

Changing the identity on hAp ac² crashes the router with an error: "kernel failure in previous boot".
 
mkx
Forum Veteran
Forum Veteran
Posts: 854
Joined: Thu Mar 03, 2016 10:23 pm

Re: v6.43 [current] is released!

Sun Sep 16, 2018 11:56 am

Changing the identity on hAp ac² crashes the router with an error: "kernel failure in previous boot".
You mean changing identity name as in
/system identity set name="some other name"
The above command doesn't crash my hAP ac² ... running ROS 6..43.
BR,
Metod
 
User avatar
DimaFIX
just joined
Posts: 5
Joined: Wed Apr 18, 2018 7:46 pm
Location: Ukraine

Re: v6.43 [current] is released!

Sun Sep 16, 2018 12:17 pm

Changing the identity on hAp ac² crashes the router with an error: "kernel failure in previous boot".
You mean changing identity name as in
/system identity set name="some other name"
The above command doesn't crash my hAP ac² ... running ROS 6..43.
Yes. I have problem with this option.
 
dvm
just joined
Posts: 10
Joined: Thu Feb 01, 2018 9:54 am

Re: v6.43 [current] is released!

Sun Sep 16, 2018 3:32 pm

Changing the identity on hAp ac² crashes the router with an error: "kernel failure in previous boot".
I can not reproduce this issue on my hAP ac^2 with ROS 6.43 (both CLI and WinBox).
 
User avatar
DimaFIX
just joined
Posts: 5
Joined: Wed Apr 18, 2018 7:46 pm
Location: Ukraine

Re: v6.43 [current] is released!

Sun Sep 16, 2018 4:08 pm

I can not reproduce this issue on my hAP ac^2 with ROS 6.43 (both CLI and WinBox).
I don't know what the problem is. At me this problem is shown every time, even on a default config.
 
jasonx
just joined
Posts: 2
Joined: Sun Sep 16, 2018 7:07 pm

Re: v6.43 [current] is released!

Sun Sep 16, 2018 7:16 pm

Hi,

on 6.43 current.

dhcp server bindings not working

ip pool used prefix shows pppoe's ipv6

but on dhcp server bindings don't received ipv6 pppoe

somebody with this problem?
 
mducharme
Trainer
Trainer
Posts: 624
Joined: Tue Jul 19, 2016 6:45 pm

Re: v6.43 [current] is released!

Sun Sep 16, 2018 10:14 pm

Hi,

on 6.43 current.

dhcp server bindings not working

ip pool used prefix shows pppoe's ipv6

but on dhcp server bindings don't received ipv6 pppoe

somebody with this problem?
We have this problem sometimes on 6.42.6 dhcpv6 server where it is like the dhcpv6 binding disappears without being cleaned from the pool. We even had it happen with ipv4 dhcp where suddenly it was like all dhcp leases disappeared without disappearing from the ipv4 pool used addresses, causing pools to fill up before they should since suddenly hundreds of systems network received new leases. I opened a ticket but mikrotik just suspects some problem on our network. Open a ticket and maybe it will help them track the issue.
 
alexsap
just joined
Posts: 1
Joined: Mon Sep 17, 2018 12:09 am

Re: v6.43 [current] is released!

Mon Sep 17, 2018 12:18 am

We have a huge memory leak on the new 6.43 code running on our CRS326's. We use vlan. Within 12hrs the device reboots due to low memory.
You do not have the required permissions to view the files attached to this post.
 
User avatar
acald3ron
just joined
Posts: 17
Joined: Tue Jan 06, 2015 8:26 am
Location: Rosarito, México
Contact:

Re: v6.43 [current] is released!

Mon Sep 17, 2018 6:11 am

Powebox problem: mikrotik router rebooted without proper shutdown
 
venthyl
just joined
Posts: 19
Joined: Thu Nov 03, 2011 3:12 pm

Re: v6.43 [current] is released!

Mon Sep 17, 2018 10:54 am

Hello , i am having difficuties about ccr1036-12g-4s when get udp attack with 0 length .

Using RouterOS 6.4 and here is the tcp dump of attack :

21:10:26.299021 IP 132.155.220.60.39812 > x.x.x.x.44710: UDP, length 0
21:10:26.299034 IP 180.19.33.203.lxi-evntsvc > x.x.x.x.2342: UDP, length 0
21:10:26.299035 IP 56.24.15.219.6200 > x.x.x.x.1234: UDP, length 0
21:10:26.299036 IP 11.90.77.183.23051 > x.x.x.x.44710: UDP, length 0
21:10:26.299057 IP 28.110.53.197.28188 > x.x.x.x.44710: UDP, length 0
21:10:26.299062 IP 215.92.148.235.23767 > x.x.x.x.3453: UDP, length 0
21:10:26.299064 IP 0.19.41.141.4864 > x.x.x.x.80: UDP, length 0
21:10:26.299065 IP 137.132.25.40.33929 > x.x.x.x.44710: UDP, length 0
21:10:26.299065 IP 49.38.104.169.9777 > x.x.x.x.110: UDP, length 0
21:10:26.299067 IP 203.183.15.186.47051 > x.x.x.x.44710: UDP, length 0
21:10:26.299185 IP 51.163.222.160.41779 > x.x.x.x.44710: UDP, length 0
21:10:26.299191 IP 0.33.48.114.8448 > x.x.x.x.4432: UDP, length 0
21:10:26.299193 IP 143.96.62.38.24719 > x.x.x.x.447: UDP, length 0

I have added many rule like :

0 chain=forward action=drop connection-state=invalid protocol=udp log=yes
log-prefix="log-paket"

1 chain=forward action=drop protocol=udp connection-bytes=0-10 log=yes
log-prefix="udp-attack"


It makes routerboard freeze and unaccesible, please help me to solve that.

No logs.

Hi i have similar problem

yesterday night
with no reason all Arm or 6.42.x devices hang up,
stop pass traffic,
stop respond even on mac ping
in the same time
manual power cycle was needed.

on one 450x device was ip watchdog, even this wasnt help.

450gx4 - bridge only ip local 192.168.5.x
450gx4- multibridge nat firewall different ips public ip firewalled
450gx2- router no bridge ip to core network 172.16. public ip firewalled

lhg60g - p2p link ip 192.168.88.x

6.42.1-6.42.7 verson on rb

Core network is network with
bridge wireless antennas,
and isolated by mikrotik routers to customers
every router in core network see each other in l2 (no vlan)

there is about 80 other mikrotik routers to serve internet
and 90 wds links soft below 6.42 nothing happend
no other arm devices

Any ideas ?

Regards
 
bbs2web
Member Candidate
Member Candidate
Posts: 163
Joined: Sun Apr 22, 2012 6:25 pm
Location: Johannesburg, South Africa
Contact:

Re: v6.43 [current] is released!

Mon Sep 17, 2018 1:03 pm

How does on obtain the default settings for menu items?

The '/system default-configuration print' command details the default initialisation script and does not show default values.

6.43 on a hAP ac (962UiGS-5HacT2HnT):
[davidh@router] > /int ethernet export 
# sep/17/2018 11:59:56 by RouterOS 6.43
# software id = 4KLB-K1IB
#
# model = RouterBOARD 962UiGS-5HacT2HnT
# serial number = 6737060E2E31
/interface ethernet
set [ find default-name=sfp1 ] advertise=\
    10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full

PS: Would be useful to '/int ethernet export default'
 
chaostya
just joined
Posts: 1
Joined: Mon Sep 17, 2018 1:12 pm

Re: v6.43 [current] is released!

Mon Sep 17, 2018 1:17 pm

CRS125-24G-1S-2HnD
After update to 6.43 (including firmware update)
"router was rebooted without proper shutdown by watchdog timer" happened once for now.
 
dvm
just joined
Posts: 10
Joined: Thu Feb 01, 2018 9:54 am

Re: v6.43 [current] is released!

Mon Sep 17, 2018 1:45 pm

How does on obtain the default settings for menu items?

The '/system default-configuration print' command details the default initialisation script and does not show default values.
1. Backup or export current config.
2. Disconnect router from internet and reset config without applying default configuration.
3. Connect to router via MAC.
3. /export verbose file=all_defaults, save this file for future reference
4. Restore backup or import config from step 1.
 
bbs2web
Member Candidate
Member Candidate
Posts: 163
Joined: Sun Apr 22, 2012 6:25 pm
Location: Johannesburg, South Africa
Contact:

Re: v6.43 [current] is released!

Mon Sep 17, 2018 2:11 pm

Thanks for your suggestions but that's fairly obvious. MikroTik change defaults in RouterOS releases and don't document changes properly (multi-line change log entries would be a start, linking changes to a bug tracking system would be much better). I still think it would be useful to have a command along the lines of '/int ether export default' so that one can adjust configurations after performing software and firmware updates.
How does on obtain the default settings for menu items?

The '/system default-configuration print' command details the default initialisation script and does not show default values.
1. Backup or export current config.
2. Disconnect router from internet and reset config without applying default configuration.
3. Connect to router via MAC.
3. /export verbose file=all_defaults, save this file for future reference
4. Restore backup or import config from step 1.
 
nin
just joined
Posts: 22
Joined: Sat Feb 20, 2010 9:02 pm

Re: v6.43 [current] is released!

Mon Sep 17, 2018 7:33 pm

I cannot upgrade to 6.43. I think something messed up with packets installed - please see the picture!
https://www.imagebanana.com/s/1183/icxyABjR.html

Please help me!

PS. CCR1016-12G
 
mkx
Forum Veteran
Forum Veteran
Posts: 854
Joined: Thu Mar 03, 2016 10:23 pm

Re: v6.43 [current] is released!

Mon Sep 17, 2018 8:17 pm

I cannot upgrade to 6.43. I think something messed up with packets installed
The wireless package is installed both in basic bundle and as separate package. Until you resolve this issue, you can not upgrade to newer version. Whatever you try, first create backup and text configuration export (/export file=<file.rsc>) and get them off your CCR.
You have at least two possibilities (in order of preference of MT staff I guess):
  1. uninstall the extra wireless package, the lower one on your screenshot.
  2. install separate packages - get ZIP file from download section of mikrotik pages. Upload all needed packages except wireless. After reboot CCR will be running ROS 6.37. I guess you don't need wireless package at all, but if you feel like installing it, install it after ROS is already running upgraded.
  3. netinstall CCR
BR,
Metod
 
nin
just joined
Posts: 22
Joined: Sat Feb 20, 2010 9:02 pm

Re: v6.43 [current] is released!

Mon Sep 17, 2018 10:20 pm

"The wireless package is installed both in basic bundle and as separate package."
Exactly this should absolutely never be possible!
 
nin
just joined
Posts: 22
Joined: Sat Feb 20, 2010 9:02 pm

Re: v6.43 [current] is released!

Mon Sep 17, 2018 10:21 pm

1. uninstall the extra wireless package, the lower one on your screenshot. -> FAILS.
 
nin
just joined
Posts: 22
Joined: Sat Feb 20, 2010 9:02 pm

Re: v6.43 [current] is released!

Mon Sep 17, 2018 10:25 pm

2, install separate packages - get ZIP file from download section of mikrotik pages. Upload all needed packages except wireless. After reboot CCR will be running ROS 6.37. I guess you don't need wireless package at all, but if you feel like installing it, install it after ROS is already running upgraded. -> FAILS!
 
nin
just joined
Posts: 22
Joined: Sat Feb 20, 2010 9:02 pm

Re: v6.43 [current] is released!

Mon Sep 17, 2018 10:52 pm

I need to learn about netinstall. It is too late here. Thanks I will come back asap.
 
Cal5582
just joined
Posts: 14
Joined: Wed Feb 28, 2018 5:04 pm

Re: v6.43 [current] is released!

Mon Sep 17, 2018 11:19 pm

any update on wireless cards not detecting on mmips devices?
 
User avatar
Splash
Member Candidate
Member Candidate
Posts: 144
Joined: Fri Oct 16, 2015 10:09 am
Location: Johannesburg, South Africa

Re: v6.43 [current] is released!

Tue Sep 18, 2018 11:38 am

We have a huge memory leak on the new 6.43 code running on our CRS326's. We use vlan. Within 12hrs the device reboots due to low memory.
I reported this too with CRS317's and the only way I could resolve it was to downgrade back to 6.42.7. The fix is supposed to be coming out in the next beta.
They took some support files during the memory filling up and seem to think they have identified the issue.
MTCNA, MTCRE, MTCINE, MTCTCE, MTCIPv6E, MTCUME
 
ithierack
just joined
Posts: 9
Joined: Sat Mar 05, 2016 1:17 pm

Re: v6.43 [current] is released!

Tue Sep 18, 2018 11:51 am

CCR1009, just found out all the "last link up time" is the current time in winbox (except those have link down will be in future), anyone have the same issue?
Same here, also an CCR1009. Web-Interface displays correct, WinBox some time in the future. I think, it's only an "cosmetic problem" with WinBox.
 
nin
just joined
Posts: 22
Joined: Sat Feb 20, 2010 9:02 pm

Re: v6.43 [current] is released!

Tue Sep 18, 2018 12:00 pm

3. netinstall CCR -> WORKED!

I am running now 6.43.1 and all went smoothly.
Thanks for your help!
 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 262
Joined: Thu Dec 11, 2014 8:53 am

Re: v6.43 [current] is released!

Tue Sep 18, 2018 12:01 pm

New version 6.43.1 has been released in stable RouterOS channel:

viewtopic.php?f=21&t=139353

Who is online

Users browsing this forum: fposavec and 6 guests