Community discussions

 
askripka
just joined
Topic Author
Posts: 2
Joined: Sat Sep 15, 2018 3:25 pm

How to configure VPN on my Microtik?

Sat Sep 15, 2018 3:31 pm

Hi guys.

I have ip, port, login and password from proxy-provider.
How to configure this proxy interface on my router?

I've readed a lot of manuals but I can`t find proxy setup with some specific port, login and password.
Can somebody help me?
Last edited by askripka on Sat Oct 13, 2018 9:47 pm, edited 1 time in total.
 
nostromog
newbie
Posts: 41
Joined: Wed Jul 18, 2018 3:39 pm

Re: How to configure VPN on my Microtik?

Mon Sep 17, 2018 8:37 pm

You need to know the technology of your provider. RouterOS offers you
# L2TP client
/interface l2tp-client add name="my-provider" connect-to="ip" user="myusername" password="mypassword"
# Open VPN client
/interface ovpn-client add... #same options
# SSTP client
/interface sstp-client add... #same options
# PPTO client
/interface pptp-client add...  #same options
This pseudocode is for the terminal. In the WebFig interface they are under Interfaces -> Add new drop down

They all are based on PPP, and share the /ppp profile if they gave you any special ppp options, etc.
They also have additional parameters, depending on thecnology: certificates, ipsec stuff...

You can also manufacture yourself some other vpn alternatives, using things like ipsec, ipip tunnels, eoip, ... but the most commons are the ones above.
 
askripka
just joined
Topic Author
Posts: 2
Joined: Sat Sep 15, 2018 3:25 pm

Re: How to configure VPN on my Microtik?

Sat Oct 13, 2018 8:14 pm

I have IP, PORT (65233), USERNAME, PASSWORD in Proxy settings, gived to me from provider.
I cant find any connection type in RouterOS, where I can specify specific PORT.
Only ip, username, pas - and its not working.

How to configure this proxy server WITH IP, PORT, USERNAME, PASSWORD for specific site list?
Can you provide step by step instruction please?
You need to know the technology of your provider. RouterOS offers you
# L2TP client
/interface l2tp-client add name="my-provider" connect-to="ip" user="myusername" password="mypassword"
# Open VPN client
/interface ovpn-client add... #same options
# SSTP client
/interface sstp-client add... #same options
# PPTO client
/interface pptp-client add...  #same options
This pseudocode is for the terminal. In the WebFig interface they are under Interfaces -> Add new drop down

They all are based on PPP, and share the /ppp profile if they gave you any special ppp options, etc.
They also have additional parameters, depending on thecnology: certificates, ipsec stuff...

You can also manufacture yourself some other vpn alternatives, using things like ipsec, ipip tunnels, eoip, ... but the most commons are the ones above.

Who is online

Users browsing this forum: Google [Bot] and 20 guests