Community discussions

 
JP100
just joined
Topic Author
Posts: 5
Joined: Sat Sep 22, 2018 5:57 pm

iPhone XS and Mikrotik hAP ac

Sat Sep 22, 2018 6:29 pm

Hello,

I have a mikrotik hap ac and iPhone XS connects for wifi ac without problems. But some applications give connection error and the safari does not open web pages. Iphone X, 6S, Macbook Pro and other wifi devices work without problems.
On the other hand the iPhone XS connects to another ISP's wifi router and all applications work very well on Internet.
Is it a bug from Mikrotik or IOS 12?

Thank you,
 
mistry7
Forum Veteran
Forum Veteran
Posts: 960
Joined: Tue Oct 13, 2009 11:57 am
Location: Germany

Re: iPhone XS and Mikrotik hAP ac

Sat Sep 22, 2018 9:13 pm

I’m yousing my iPhone with ios12 and have no Problems with Mikrotik
 
JP100
just joined
Topic Author
Posts: 5
Joined: Sat Sep 22, 2018 5:57 pm

Re: iPhone XS and Mikrotik hAP ac

Sat Sep 22, 2018 9:21 pm

I’m yousing my iPhone with ios12 and have no Problems with Mikrotik
iPhone XS? I am a good customer of mikrotik products and I needed developers to see if it is a bug :(
 
nescafe2002
Member
Member
Posts: 486
Joined: Tue Aug 11, 2015 12:46 pm
Location: Netherlands

Re: iPhone XS and Mikrotik hAP ac

Sat Sep 22, 2018 10:44 pm

This is not an official MikroTik support forum. Either post your configuration to let other users review your settings ( /export hide-sensitive ) or contact Mikrotik support directly via e-mail or support ticket online ( https://mikrotik.com/client/support ).
 
JP100
just joined
Topic Author
Posts: 5
Joined: Sat Sep 22, 2018 5:57 pm

Re: iPhone XS and Mikrotik hAP ac

Sat Sep 22, 2018 11:07 pm

This is not an official MikroTik support forum. Either post your configuration to let other users review your settings ( /export hide-sensitive ) or contact Mikrotik support directly via e-mail or support ticket online ( https://mikrotik.com/client/support ).
Thank you,
Configuration is ok, only iPhone XS have problem with mikrotik router...
 
User avatar
BartoszP
Forum Guru
Forum Guru
Posts: 1626
Joined: Mon Jun 16, 2014 1:13 pm
Location: Poland

Re: iPhone XS and Mikrotik hAP ac

Sun Sep 23, 2018 1:07 am

Real admins use real keyboards.
 
fattytuna
just joined
Posts: 2
Joined: Sun Sep 23, 2018 7:17 am

Re: iPhone XS and Mikrotik hAP ac

Sun Sep 23, 2018 7:29 am

I've had a similar problem. Just got an iPhone XS. It works fine while connected to a different 2.4GHz access point. When I connect to the Mikrotik HAP AC 5GHz, the connection would stop functioning after a few minutes.

After a little experimenting, changing the 5GHz radio from "A/N/AC" to just "A/N" (see screenshot) seemed to help, though I wonder if I'm sacrificing some connection speed.

It would be nice to figure out how to make the AC band function properly.
You do not have the required permissions to view the files attached to this post.
 
User avatar
BartoszP
Forum Guru
Forum Guru
Posts: 1626
Joined: Mon Jun 16, 2014 1:13 pm
Location: Poland

Re: iPhone XS and Mikrotik hAP ac

Sun Sep 23, 2018 1:47 pm

Try to change channel width.
Real admins use real keyboards.
 
JP100
just joined
Topic Author
Posts: 5
Joined: Sat Sep 22, 2018 5:57 pm

Re: iPhone XS and Mikrotik hAP ac

Sun Sep 23, 2018 2:12 pm

I've had a similar problem. Just got an iPhone XS. It works fine while connected to a different 2.4GHz access point. When I connect to the Mikrotik HAP AC 5GHz, the connection would stop functioning after a few minutes.

After a little experimenting, changing the 5GHz radio from "A/N/AC" to just "A/N" (see screenshot) seemed to help, though I wonder if I'm sacrificing some connection speed.

It would be nice to figure out how to make the AC band function properly.
Try this: Add to the WPA2-PSK TKIP encryption and connect to the wifi, after that deactivate the TKIP again. And it works ... Does anyone understand this Bug?
 
fattytuna
just joined
Posts: 2
Joined: Sun Sep 23, 2018 7:17 am

Re: iPhone XS and Mikrotik hAP ac

Wed Sep 26, 2018 6:15 pm

I tried going through all of the Channel Width options, leaving the router on the N/AC band. My iPhone & MacBook (which otherwise didn't have any problems) was unable to see the access point on most of the widths except 20/40MHz Ce.

I haven't tried playing with the TKIP setting yet.

Does anyone have any ideas for getting debugging information? There isn't very much in the routerboad logs as it is.
 
JP100
just joined
Topic Author
Posts: 5
Joined: Sat Sep 22, 2018 5:57 pm

Re: iPhone XS and Mikrotik hAP ac

Wed Sep 26, 2018 9:04 pm

I tried going through all of the Channel Width options, leaving the router on the N/AC band. My iPhone & MacBook (which otherwise didn't have any problems) was unable to see the access point on most of the widths except 20/40MHz Ce.

I haven't tried playing with the TKIP setting yet.

Does anyone have any ideas for getting debugging information? There isn't very much in the routerboad logs as it is.
Apple and mikrotik are already seeing my problem.

see this:

iPhone XS and XS Max Owners Complain of Wi-Fi and LTE Connectivity Issues:

https://forums.macrumors.com/threads/ip ... s.2142500/
 
User avatar
harvey
Frequent Visitor
Frequent Visitor
Posts: 87
Joined: Thu Apr 05, 2012 8:16 pm

Re: iPhone XS and Mikrotik hAP ac

Mon Oct 01, 2018 11:24 am

I too am having issue with an iPhone XS Max connecting to a HAP AC and HAP AC2 both running 6.43.2.

Macbook Pro, iPhone 7 Plus and iPad Pro all working fine.

Current Wifi Setup from the AC2:-
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa2-psk eap-methods="" management-protection=allowed \
    mode=dynamic-keys name=main supplicant-identity=""
add authentication-types=wpa2-psk eap-methods="" management-protection=allowed \
    mode=dynamic-keys name=guest supplicant-identity=""
add authentication-types=wpa2-psk eap-methods="" management-protection=allowed \
    mode=dynamic-keys name=kids supplicant-identity=""
add authentication-types=wpa2-psk eap-methods="" management-protection=allowed \
    mode=dynamic-keys name=iot supplicant-identity=""
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-onlyn channel-width=20/40mhz-Ce \
    disabled=no mode=ap-bridge name=wlan1-main security-profile=main ssid=ap1 \
    wireless-protocol=802.11
set [ find default-name=wlan2 ] band=5ghz-n/ac channel-width=20/40/80mhz-eeeC \
    disabled=no frequency=auto mode=ap-bridge name=wlan2-main security-profile=\
    main ssid=ap1 wireless-protocol=802.11
add disabled=no keepalive-frames=disabled mac-address=BA:69:F4:33:5E:B6 \
    master-interface=wlan1-main multicast-buffering=disabled name=wlan1-guest \
    security-profile=guest ssid=ap1-guest wds-cost-range=0 wds-default-cost=0 \
    wps-mode=disabled
add keepalive-frames=disabled mac-address=BA:69:F4:33:5E:B8 master-interface=\
    wlan1-main multicast-buffering=disabled name=wlan1-iot security-profile=iot \
    ssid=ap1-iot wds-cost-range=0 wds-default-cost=0 wps-mode=disabled
add disabled=no keepalive-frames=disabled mac-address=BA:69:F4:33:5E:B7 \
    master-interface=wlan1-main multicast-buffering=disabled name=wlan1-kids \
    security-profile=kids ssid=ap1-kids wds-cost-range=0 wds-default-cost=0 \
    wps-mode=disabled
add disabled=no keepalive-frames=disabled mac-address=BA:69:F4:33:5E:B9 \
    master-interface=wlan2-main multicast-buffering=disabled name=wlan2-guest \
    security-profile=guest ssid=ap1-guest wds-cost-range=0 wds-default-cost=0 \
    wps-mode=disabled
add keepalive-frames=disabled mac-address=BA:69:F4:33:5E:BB master-interface=\
    wlan2-main multicast-buffering=disabled name=wlan2-iot security-profile=iot \
    ssid=ap1-iot wds-cost-range=0 wds-default-cost=0 wps-mode=disabled
add disabled=no keepalive-frames=disabled mac-address=BA:69:F4:33:5E:BA \
    master-interface=wlan2-main multicast-buffering=disabled name=wlan2-kids \
    security-profile=kids ssid=ap1-kids wds-cost-range=0 wds-default-cost=0 \
    wps-mode=disabled
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 23608
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: iPhone XS and Mikrotik hAP ac

Mon Oct 01, 2018 11:33 am

Users of the new iPhones are reporting the issues with all routers. They guess that the phones prefer 2GHz in some cases, and other issues. Wait for iOS 12.0.1 or something like that. It is a well discussed issue and not related to MikroTik
No answer to your question? How to write posts
 
User avatar
harvey
Frequent Visitor
Frequent Visitor
Posts: 87
Joined: Thu Apr 05, 2012 8:16 pm

Re: iPhone XS and Mikrotik hAP ac

Mon Oct 01, 2018 11:38 am

The only other oddity which I found, when the iPhone XS loses network connectivity I can still ping via IP address e.g. 8.8.8.8 but google.com will not respond. I tried overwriting the DNS on the phone to something out on the WAN e.g. 1.1.1.1 but didn't seem to make a difference.

Sometimes the wifi just works flawlessly and sometime it does nothing.

I can see the iPhone XS will also only connect to 2.4Ghz when you have both bands with the same SSID as suggested by other reports. I have tried creating a 5ghz only SSID using Virtual AP and connected the iPhone XS to that. I'll see if that helps at all and report back.

In my office we use a Mikrotik CCR with Unifi AC AP's and didn't have any issue there.
 
User avatar
harvey
Frequent Visitor
Frequent Visitor
Posts: 87
Joined: Thu Apr 05, 2012 8:16 pm

Re: iPhone XS and Mikrotik hAP ac

Sun Oct 07, 2018 1:49 am

Creating a 5Ghz only network on the hap ac2 did not help. In vain I setup up a spare Unifi AC Pro and the iPhone XS wifi works perfectly. I'm struggling to see how this is not Mikrotik related?

This seems separate and unrelated to the other iPhone XS wireless issues reported generally.
 
netispguy
newbie
Posts: 35
Joined: Sun Feb 25, 2018 4:29 am

Re: iPhone XS and Mikrotik hAP ac

Thu Oct 11, 2018 4:49 am

+1 for having problems with both the iPhone Xs and XsMax on the Mikrotik framework on 5GHz/80MHz AC. All other iPhones (X, 8, 7), iPads and MacBooks working fine. Running routeros 6.43.2.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 23608
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: iPhone XS and Mikrotik hAP ac

Thu Oct 11, 2018 10:41 am

Try latest iOS 12.0.1 where the wifi issues are supposed to be fixed.
No answer to your question? How to write posts
 
netispguy
newbie
Posts: 35
Joined: Sun Feb 25, 2018 4:29 am

Re: iPhone XS and Mikrotik hAP ac

Thu Oct 11, 2018 3:47 pm

12.0.1 does NOT fix the problem. We still have the problem after upgrading both an iPhoneXs and iPhoneXsMax. I have fully tested and we still see the same problem when attached to a 5GHz radio using 20/40/80MHz A/N/AC. Setting the radio to 5GHz A/N does work, at the cost of less performance. It looks like AC is the issue.

What did improve after the 12.0.0.1 upgrade was that these new iPhones do select a the 5GHz band when you have two radios (5GHz and 2.4GHz) broadcasting the same SSID. That was a problem also, but now works correctly.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 23608
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: iPhone XS and Mikrotik hAP ac

Thu Oct 11, 2018 3:48 pm

So what is the problem that remains in 12.0.1 ?
Enabele wireless debug logs and make supout.rif files when you see the issue, email the files to mikrotik support. Maybe there is also something to improve in RouterOS side.
No answer to your question? How to write posts
 
netispguy
newbie
Posts: 35
Joined: Sun Feb 25, 2018 4:29 am

Re: iPhone XS and Mikrotik hAP ac

Thu Oct 11, 2018 4:04 pm

The problem is continuous across all of our Mikrotik APs. I have verified that these Apple devices work across other platforms (Cisco, etc. ). I am dealing with Apple Tier II and III support and they have come to the same conclusion.

All I have to do is attach to an 80MHz AC radio and the problem starts up immediately. Reconfiguring to just 40MHz A/N works. I can just do a few minute log and it will be there. All 2.4GHz configs work with no problem.

Also strange Is that if we attach to our core router using a L2TP VPN connection, the problem goes away even if you are attached to an 80MHz AC connection. Strange.

I have a ticket open with tech support, but they have not request log yet.
 
User avatar
harvey
Frequent Visitor
Frequent Visitor
Posts: 87
Joined: Thu Apr 05, 2012 8:16 pm

Re: iPhone XS and Mikrotik hAP ac

Thu Oct 11, 2018 5:37 pm

I have been able to resolve the issue by making some configuration changes on the Mikrotik. I'm currently running AC at 5Ghz/80Mhz and seems fine. the only difference I can see is `country="united kingdom"` and `frequency-mode=regulatory-domain` :-

Before, Not working:-
set [ find default-name=wlan2 ] band=5ghz-n/ac channel-width=20/40/80mhz-eeeC \
    disabled=no frequency=auto mode=ap-bridge name=wlan2-main security-profile=\
    main ssid=ap1 wireless-protocol=802.11
Now, Working:-
set [ find default-name=wlan2 ] band=5ghz-n/ac channel-width=20/40/80mhz-eeeC \
    country="united kingdom" disabled=no frequency=auto requency-mode=regulatory-domain \
    mode=ap-bridge name=wlan2-main security-profile=main ssid=ap1 wireless-protocol=802.11
Not sure if this helps anyone else.
 
User avatar
harvey
Frequent Visitor
Frequent Visitor
Posts: 87
Joined: Thu Apr 05, 2012 8:16 pm

Re: iPhone XS and Mikrotik hAP ac

Thu Oct 11, 2018 5:41 pm

The only other change I made was to apply Frequency Mode, Country (as per 5Gz) and Antenna Gain to 2 on the 2.4 Ghz Network
 
User avatar
harvey
Frequent Visitor
Frequent Visitor
Posts: 87
Joined: Thu Apr 05, 2012 8:16 pm

Re: iPhone XS and Mikrotik hAP ac

Thu Oct 11, 2018 5:46 pm

Actually, I'm more convinced it's something to do with Hurricane Electric IPv6 Tunnel. I just remembered I had also disabled this. As soon as I re-enabled it the issue returned. This post already highlighted this issue viewtopic.php?p=691678#p688505

Can there be a relation between Wifi and IPv6 tunnels?
 
netispguy
newbie
Posts: 35
Joined: Sun Feb 25, 2018 4:29 am

Re: iPhone XS and Mikrotik hAP ac

Thu Oct 11, 2018 6:01 pm

Unfortunately, the units sold in the US are fixed to "united states3" and "regulatory-domain". You cannot buy the international version over here any more.

I just got off the phone with Apple engineering, and they are insistent that this is a Mikrotik issue. It's the only manufacture they are getting complaints with at this point.

Since more of these new Apple iPhones are arriving here on almost a daily basis, I am going to have to disable 80MHz across my platform. This will impact all of my users in a big way (since laptops and other devices like the better performance of the 80Mhz AC). Just this morning I had two users who told me they were going to disable Wifi (and just use GSM) until I had this resolved.

I am not sure what else I can do until this issue is resolved. I do not want to be in the middle of a finger pointing war between Apple and Mikrotik.

If anyone from Mikrotik is watching this thread, can you please advise us?
 
netispguy
newbie
Posts: 35
Joined: Sun Feb 25, 2018 4:29 am

Re: iPhone XS and Mikrotik hAP ac

Thu Oct 11, 2018 6:04 pm

We do not use any IPv6 tunnels. All of our IPv6 is native using a fixed prefix we get from our ISP (Comcast Business).

However, I did report earlier that if you enable a VPN from these new iPhones to our L2TP interface, everything seems to work... which I find very strange.
 
netispguy
newbie
Posts: 35
Joined: Sun Feb 25, 2018 4:29 am

Re: iPhone XS and Mikrotik hAP ac

Fri Oct 12, 2018 1:46 am

Well, another day of frustrated users....

I have had to demote all of my APs 5GHz radios to 5GHz-A/N @ 20/40Mhz (eC). No more AC until this is resolved. Now all the new Apple Xs and XsMax work with no issue; however, every single device (laptops, tablets, etc) are impacted with much less performance. Apple IOS solved a few connectivity problems, but not this one.

Please Mikrotik, comment on a potential timeframe for a fix, or advise otherwise. I have submitted Ticket#2018101122002554.
 
netispguy
newbie
Posts: 35
Joined: Sun Feb 25, 2018 4:29 am

Re: iPhone XS and Mikrotik hAP ac

Sat Oct 13, 2018 5:26 pm

There seems to be another thread about this subject in Wireless Networking:

viewtopic.php?f=7&t=139608&sid=e5df6717 ... 3ef01e5112

Version 6.44beta14 has been released.
*) wireless - improved stability for 802.11ac;

-->> Confirming that 6.44beta does NOT resolve this issue:
 
freezer
just joined
Posts: 20
Joined: Tue Mar 20, 2018 8:17 pm
Contact:

Re: iPhone XS and Mikrotik hAP ac

Mon Oct 15, 2018 11:52 pm

I have exactly same problem with my iPhoneXS (bought from official european distributor). Problem exists on iOS 12.0 and 12.0.1.

My Mikrotik cAP AC is running 6.43.2 - software and firmware, and previously was running one of the recent 6.43 release candidates.
This is specific problem of Mikrotik and iPhoneXS, as my other phones (iPhone X, iPad Pro) running same iOS version (12.0.1) are working fine with this Mikrotik AP, also my ASUS RT-AC86U is working properly with iPhoneXS.

This setup (cAP AC) was stable for months and only iPhoneXS is having problems here.

I'm using:

5GHz-A/N/AC
20/40/80MHz XXXX
5180
L2MTU 1600
MTU 1500
-Greg
Skype: freezer_szczecin
 
netispguy
newbie
Posts: 35
Joined: Sun Feb 25, 2018 4:29 am

Re: iPhone XS and Mikrotik hAP ac

Tue Oct 16, 2018 12:18 am

This topic is also being discussed in the "wireless" section:

viewtopic.php?f=7&t=139608
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5699
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: iPhone XS and Mikrotik hAP ac

Tue Oct 16, 2018 3:36 pm

Will lock this, continue in wireless section

Who is online

Users browsing this forum: No registered users and 63 guests