Community discussions

Problems with CRS317-1G-16S+ (SwOS only)

I have SFP problems
1 (25%)
I have FAN problems
1 (25%)
I have RSTP problems
1 (25%)
I have web interface slow down problem
1 (25%)
I'm happy with this device. No problems at all
No votes
I'm using RouterOS instead of SwOS
No votes
 
Total votes: 4
 
User avatar
RusConSPb
newbie
Topic Author
Posts: 27
Joined: Thu May 03, 2012 4:17 pm
Location: Helsinki, Finland

CRS317-1G-16S+ FAN, SPF and RSTP problems

Sat Nov 10, 2018 3:51 pm

Hello everybody!

We have CRS317-1G-16S+ in our lab (actually it should be already in production but we have a lot of problems with this device)

After delivery we upgraded it RouterOS to latest 6.43.4. No settings, default config removed. Then we switched to SwOS boot, factory SwOS firmware was 2.7, manual upgraded to 2.8. Very simple configuration for testing:

SFP modules installed (all Mikrotik brand):
Image

For testing purpose 5 VLANs was configured (1, 405, 410, 420, 430):

Image

VLAN tab :
Image

SFP5 connected to CSR328-24P-4S+ (to SFP1)

SFP16 connected to CCR1036-8G-2S+ (to SFP2 trunk port, VLAN Bridge Filtering configured according to latest (after 6.41) manuals)

all other installed SFP are disconnected

RSTP is ON on all ports, IGMP Snooping is ON in System menu and for all VLANs but not VLAN1

After reboot everything is working as it should. Few hours later we not able to connect from PC connected to CCR to web interface of CRS317 and CRS328. Cooper MGMT port is still working and we are able to connect to CRS317. All ports on CRS328 are working and web interface accessible.

If we go to "Health" menu of CRS317 when SFP doesn't work already we can see:
Image

But normal state after reboot is:
Image

No errors on ports, nothing else suspicious to mention. This switch doesn't have any logging in SwOS mode. But - Web interface extremely slow.

After reboot CRS317 everything fine again for few hours or minutes. Can't say exact time to "SFP death". But it happened every time.

Something wrong with this device, if it's not able to work as simple switch... is it only me or everyone have such problems with this (amazing on paper) device?

Now we try to disable RSTP on all ports and disable IGMP snooping on all VLANs. 16 hours everything working, SFP links accessible, but web interface became slow again, FAN1 RPM - 14080!!! FAN2 - 0

Any chance it will be fixed soon? Maybe we are doing something wrong? Can anybody help?

PS: From our point of view this device is not ready for production at all, SwOS is kind of Beta testing challenge... We have bunch of this switches and we are going to send them back if solution will not be found soon.
 
User avatar
RusConSPb
newbie
Topic Author
Posts: 27
Joined: Thu May 03, 2012 4:17 pm
Location: Helsinki, Finland

Re: CRS317-1G-16S+ FAN, SPF and RSTP problems

Tue Nov 13, 2018 1:50 pm

Anyone? Mikrotik team? I thought it was a support forum...
 
User avatar
mozerd
Member Candidate
Member Candidate
Posts: 119
Joined: Thu Oct 05, 2017 3:39 pm
Location: Canada
Contact:

Re: CRS317-1G-16S+ FAN, SPF and RSTP problems

Tue Nov 13, 2018 3:05 pm

Anyone? Mikrotik team? I thought it was a support forum...
Perhaps MikroTik Support will see your post and respond but I suggest that if you want quicker action contact Mikrotik Support via an emai and they will open a ticket and respond to your info. I do not currently use MikroTik switches so I cannot comment on your issue.

You can contact MikroTik Support at the following address support@mikrotik.com
 
User avatar
RusConSPb
newbie
Topic Author
Posts: 27
Joined: Thu May 03, 2012 4:17 pm
Location: Helsinki, Finland

Re: CRS317-1G-16S+ FAN, SPF and RSTP problems

Tue Nov 13, 2018 8:04 pm

Anyone? Mikrotik team? I thought it was a support forum...
Perhaps MikroTik Support will see your post and respond but I suggest that if you want quicker action contact Mikrotik Support via an emai and they will open a ticket and respond to your info. I do not currently use MikroTik switches so I cannot comment on your issue.

You can contact MikroTik Support at the following address support@mikrotik.com
All i want to know - will they fix it soon or not. There are a lot of other posts about same problems, Mikrotik continue to sell this product but don't want to make it work as it should with SwOS.

MIKROTIK, please tell us - should we wait a bit and you will fix it, or should we take another vendor?
 
anav
Forum Veteran
Forum Veteran
Posts: 952
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada

Re: CRS317-1G-16S+ FAN, SPF and RSTP problems

Tue Nov 13, 2018 9:33 pm

At least you have the options of using RouterOS. On my 260GS models its only SwOS :-((((((( emoji- crying, emoji - hitting myself in the head with a bat for buying them
 
User avatar
RusConSPb
newbie
Topic Author
Posts: 27
Joined: Thu May 03, 2012 4:17 pm
Location: Helsinki, Finland

Re: CRS317-1G-16S+ FAN, SPF and RSTP problems

Wed Nov 14, 2018 1:19 pm

At least you have the options of using RouterOS. On my 260GS models its only SwOS :-((((((( emoji- crying, emoji - hitting myself in the head with a bat for buying them
Will it solve our problems? RouterOS is good in CRS317 or it's hardware problem?
 
User avatar
mozerd
Member Candidate
Member Candidate
Posts: 119
Joined: Thu Oct 05, 2017 3:39 pm
Location: Canada
Contact:

Re: CRS317-1G-16S+ FAN, SPF and RSTP problems

Wed Nov 14, 2018 3:31 pm

At least you have the options of using RouterOS. On my 260GS models its only SwOS :-((((((( emoji- crying, emoji - hitting myself in the head with a bat for buying them
Will it solve our problems? RouterOS is good in CRS317 or it's hardware problem?
At this stage it would be interesting to find out if RouterOS would solve your problem ... Why don't you give it a try and see what happens?
 
User avatar
RusConSPb
newbie
Topic Author
Posts: 27
Joined: Thu May 03, 2012 4:17 pm
Location: Helsinki, Finland

Re: CRS317-1G-16S+ FAN, SPF and RSTP problems

Wed Nov 14, 2018 4:36 pm

At this stage it would be interesting to find out if RouterOS would solve your problem ... Why don't you give it a try and see what happens?
Very good question. Our company paid a lot for this products and they MUST work as advertised and we don't get paid for beta-testing by Mikrotik. I'm totally sure that such testing should be done by Mikrotik. Look at D-Link forum - they react in 24 hours and they try to reproduce errors in own lab. This is professional approach. Mikrotik does not even consider it necessary to respond in their own forum. At the moment we don't have time and people to "play" with this CRSs. Maybe I will spend next weekend (my private time) for this kind of experiments.
 
User avatar
mozerd
Member Candidate
Member Candidate
Posts: 119
Joined: Thu Oct 05, 2017 3:39 pm
Location: Canada
Contact:

Re: CRS317-1G-16S+ FAN, SPF and RSTP problems

Wed Nov 14, 2018 5:20 pm

At this stage it would be interesting to find out if RouterOS would solve your problem ... Why don't you give it a try and see what happens?
Very good question. Our company paid a lot for this products and they MUST work as advertised and we don't get paid for beta-testing by Mikrotik. I'm totally sure that such testing should be done by Mikrotik. Look at D-Link forum - they react in 24 hours and they try to reproduce errors in own lab. This is professional approach. Mikrotik does not even consider it necessary to respond in their own forum. At the moment we don't have time and people to "play" with this CRSs. Maybe I will spend next weekend (my private time) for this kind of experiments.
Its a shame that MikroTik support has not as yet participated in this thread ... You provided excellent evidence of the problem --- So I do agree with you that a morte professional approach would be welcome. If it was me I would immediately try RouterOS and see if that solves the issue because I want my productions systems working properly ASAP without further delay.

Who is online

Users browsing this forum: No registered users and 1 guest