Community discussions

 
vipsss09
just joined
Topic Author
Posts: 1
Joined: Wed Dec 05, 2018 9:56 pm

AirPrint doesn't work

Wed Dec 05, 2018 10:45 pm

Hello everyone

I bought new Mikrotik hAP ac lite router. Upgraded firmware to last stable version 6.43.7. Setup router with Quick Set (other default setups give same results)
img1.png

connect iPhone and printer Canon MF232w (what support AirPrint) to same wireless but iPhone can't find this printer.
Printer successfull connecting to wi-fi, getting IP from same subnet, I can ping printer, but can't print with AirPrint. AirPrint on printer works fine, becouse if I connect printer to other wi-fi router I can print from iPhone

Here is wireless settings
img2.png

Here is my current export
/export hide-sensitive 
# jan/02/1970 00:33:32 by RouterOS 6.43.7
# software id = FA5Y-B7HN
#
# model = RouterBOARD 952Ui-5ac2nD
/interface bridge
add name=bridge1
/interface wireless
set [ find default-name=wlan1 ] country=ukraine disabled=no mode=ap-bridge \
    ssid=MTIK2 wireless-protocol=802.11
set [ find default-name=wlan2 ] country=ukraine disabled=no mode=ap-bridge \
    ssid=MTIK5 wireless-protocol=802.11
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk mode=\
    dynamic-keys supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/ip pool
add name=dhcp ranges=192.168.1.3-192.168.1.254
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge1 name=dhcp1
/interface bridge port
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
add bridge=bridge1 interface=wlan2
add bridge=bridge1 interface=wlan1
/interface list member
add interface=ether1 list=WAN
add interface=bridge1 list=LAN
/ip address
add address=192.168.1.1/24 interface=ether2 network=192.168.1.0
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=ether1
/ip dhcp-server network
add address=192.168.1.0/24 gateway=192.168.1.1 netmask=24
/ip firewall nat
add action=masquerade chain=srcnat out-interface-list=WAN
/ip upnp
set enabled=yes
/ip upnp interfaces
add interface=bridge1 type=internal
add interface=ether1 type=external


what I should do for enable AirPrint?
You do not have the required permissions to view the files attached to this post.
 
sibi1979
just joined
Posts: 6
Joined: Mon Jul 08, 2019 1:06 pm
Location: Belgium

Re: AirPrint doesn't work

Wed Jul 31, 2019 7:07 pm

Did you find a solution ?
I have the same issue where the ap's are managed by capsman.
 
User avatar
cdiedrich
Forum Veteran
Forum Veteran
Posts: 899
Joined: Thu Feb 13, 2014 2:03 pm
Location: Basel, Switzerland // Bremen, Germany
Contact:

Re: AirPrint doesn't work

Thu Aug 01, 2019 3:00 pm

Setting multicast-helper from 'default' or 'disabled' to 'full' should solve the issue.
Additionally, check if lower rates are disabled - I had this issue more than once when el-cheapo WiFi printers only worked reliably when lower rates were re-enabled.
-Chris
Christopher Diedrich
MTCNA, MTCUME, MTCWE
Basel, Switzerland
Bremen, Germany

There are 10 types of people: Those who understand binary and those who don't.
There are two types of people: Those who can extrapolate from incomplete data
 
sibi1979
just joined
Posts: 6
Joined: Mon Jul 08, 2019 1:06 pm
Location: Belgium

Re: AirPrint doesn't work

Thu Aug 01, 2019 4:35 pm

Hey -Chris,
Thanks for the feedback and "bonjour".
Just an additional question on the answer you gave. I didn't specify anything (I didn't thick the boxes).
Is this correct ?

Thanks and greetings,

Sibi
 
User avatar
cdiedrich
Forum Veteran
Forum Veteran
Posts: 899
Joined: Thu Feb 13, 2014 2:03 pm
Location: Basel, Switzerland // Bremen, Germany
Contact:

Re: AirPrint doesn't work

Thu Aug 01, 2019 4:47 pm

If you didn't touch the data rates, then it should be good.
-Chris
Christopher Diedrich
MTCNA, MTCUME, MTCWE
Basel, Switzerland
Bremen, Germany

There are 10 types of people: Those who understand binary and those who don't.
There are two types of people: Those who can extrapolate from incomplete data
 
sibi1979
just joined
Posts: 6
Joined: Mon Jul 08, 2019 1:06 pm
Location: Belgium

Re: AirPrint doesn't work

Thu Aug 01, 2019 5:11 pm

Thanks -Chris
Do you have some time to have a small talk about the mikrotik wireless ap and your experience with it ?
I would be very happy with it. I didn't find how to contact you directly.

Greetings,

Sibi
 
rumorconsumer
just joined
Posts: 5
Joined: Sun Aug 04, 2019 7:01 am

Re: AirPrint doesn't work

Sun Aug 04, 2019 7:03 am

Setting multicast-helper from 'default' or 'disabled' to 'full' should solve the issue.
Additionally, check if lower rates are disabled - I had this issue more than once when el-cheapo WiFi printers only worked reliably when lower rates were re-enabled.
-Chris


Can you say how exactly you get this setting to change? Can I do it through the Webfig?
 
sibi1979
just joined
Posts: 6
Joined: Mon Jul 08, 2019 1:06 pm
Location: Belgium

Re: AirPrint doesn't work

Sun Aug 04, 2019 9:43 pm

It is under

Capsman - configurations - datapath

In the Mikrotik app

Who is online

Users browsing this forum: No registered users and 14 guests