Community discussions

 
Yves
just joined
Topic Author
Posts: 4
Joined: Tue Dec 04, 2018 9:29 am

L2TP / IPSec Issue only with Android 9

Fri Dec 07, 2018 12:53 pm

Hi there,

I got a very strange issue since I got my new phone Huawei Mate 20 Pro.... (all my other Devices I could test this on... unfortunatly not another Android 9 - are working). Including CentOS, Fedora, Win10, MacOS....

I can connect to the L2TP / IPsec on the ROS but after +/- 60 seconds ROS starts sending control messages Type HELLO to the Android Phone which for some wierd reason don't get ACK back (my other Anroids always send ACK) and then after I think 6 messages and no ACK the ROS drops the connection as you can see here:

l2tp,debug,packet sent control message to x.x.x.x:37524 from x.x.x.x:1701
l2tp,debug,packet tunnel-id=62045, session-id=0, ns=2, nr=4
l2tp,debug,packet (M) Message-Type=HELLO
l2tp,debug,packet sent control message to x.x.x.x:37524 from x.x.x.x:1701
l2tp,debug,packet tunnel-id=62045, session-id=0, ns=2, nr=4
l2tp,debug,packet (M) Message-Type=HELLO
l2tp,debug,packet sent control message to x.x.x.x:37524 from x.x.x.x:1701
l2tp,debug,packet tunnel-id=62045, session-id=0, ns=2, nr=4
l2tp,debug,packet (M) Message-Type=HELLO
l2tp,debug,packet sent control message to x.x.x.x:37524 from x.x.x.x:1701
l2tp,debug,packet tunnel-id=62045, session-id=0, ns=2, nr=4
l2tp,debug,packet (M) Message-Type=HELLO
l2tp,debug,packet sent control message to x.x.x.x:37524 from x.x.x.x:1701
l2tp,debug,packet tunnel-id=62045, session-id=0, ns=2, nr=4
l2tp,debug,packet (M) Message-Type=HELLO
l2tp,debug,packet sent control message to x.x.x.x:37524 from x.x.x.x:1701
l2tp,debug,packet tunnel-id=62045, session-id=0, ns=2, nr=4
l2tp,debug,packet (M) Message-Type=HELLO
l2tp,debug tunnel 15 received no replies, disconnecting
l2tp,debug tunnel 15 entering state: dead
l2tp,debug session 1 entering state: dead
l2tp,ppp,debug <x.x.x.x>: LCP lowerdown
l2tp,ppp,debug <x.x.x.x>: LCP closed
l2tp,ppp,debug <x.x.x.x>: CCP lowerdown
l2tp,ppp,debug <x.x.x.x>: BCP lowerdown
l2tp,ppp,debug <x.x.x.x>: BCP down event in starting state
l2tp,ppp,debug <x.x.x.x>: IPCP lowerdown
l2tp,ppp,debug <x.x.x.x>: IPCP closed
l2tp,ppp,debug <x.x.x.x>: IPV6CP lowerdown
l2tp,ppp,debug <x.x.x.x>: IPV6CP down event in starting state
l2tp,ppp,debug <x.x.x.x>: MPLSCP lowerdown
l2tp,ppp,debug <x.x.x.x>: CCP close
l2tp,ppp,debug <x.x.x.x>: BCP close
l2tp,ppp,debug <x.x.x.x>: IPCP close
l2tp,ppp,debug <x.x.x.x>: IPV6CP close
l2tp,ppp,debug <x.x.x.x>: MPLSCP close

Any idea what is going on? Bug of Huawei? Or Android 9?

Cheers,
Yves
 
Yves
just joined
Topic Author
Posts: 4
Joined: Tue Dec 04, 2018 9:29 am

Re: L2TP / IPSec Issue only with Android 9

Sat Dec 08, 2018 6:42 pm

So quick update.... I went today quickly to me friend who has a new Pixel 3 XL (also Android 9) and we had the excat same issues.

Which brought me to google this topic a little bit further with these results:

VPN breaks under Android 8.1.0 and 9
L2TP VPN and Android Pie - ARGH
Pixel 3 Won't Connect to VPN
L2TP VPN to USG drops out after 90 seconds with Android 8.0 client

All with these same issues, all with the issue not solved!

Does anyone with an Android 9 phone have the same experience? Also who does need to be asked to solve that issue? Google? Where should I post that to get a bigger audience to solve that faster?

Thanks for your help
Yves

Who is online

Users browsing this forum: No registered users and 77 guests