Community discussions

 
Rytis
just joined
Topic Author
Posts: 2
Joined: Wed Jan 09, 2019 11:09 pm

WISP AP DHCP server does not work

Wed Jan 09, 2019 11:34 pm

Hello,

A newbie question. I am trying to make a WISP AP with a DHCP server. I need to bridge lan port with wlan. I did a DHCP server on a bridge however it does not give an IP address to any wireless device trying to connect to AP. Could you help me out?

code:
# jan/02/1970 00:23:10 by RouterOS 6.43.8
# software id = GX9W-RIZM
#
# model = Metal G-52SHPacn
# serial number = 7284063BE953
/interface bridge
add name=bridge1
/interface wireless
set [ find default-name=wlan1 ] disabled=no mode=ap-bridge name=grock ssid=\
grock wireless-protocol=802.11
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk mode=dynamic-keys \
supplicant-identity=MikroTik wpa-pre-shared-key=garsistas \
wpa2-pre-shared-key=garsistas
/ip dhcp-server
add disabled=no interface=bridge1 name=server1
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=grock
/interface list member
add interface=ether1 list=WAN
add interface=grock list=LAN
/ip address
add address=10.0.1.1/24 interface=grock network=10.0.1.0
/ip dns
set servers=10.0.1.1
/ip route
add distance=1 gateway=10.0.1.1
 
User avatar
bramwittendorp
Frequent Visitor
Frequent Visitor
Posts: 96
Joined: Thu Jun 16, 2016 3:48 pm
Location: The Netherlands
Contact:

Re: WISP AP DHCP server does not work  [SOLVED]

Thu Jan 10, 2019 4:04 pm

Your config is incomplete if this is your full configuration.

Please use the DHCP Server setup option in Winbox or follow the guide found in the Wiki: https://wiki.mikrotik.com/wiki/Manual:IP/DHCP_Server.

You're now just running a DHCP server, without any Pool (addresses to hand out) or any other options.
Bram - MikroTik enthusiast - MTCNA / MTCRE / MTCWE / MTCIPv6E
Don't be shy, share your /export hide-sensitive and make sure to read this.
 
Rytis
just joined
Topic Author
Posts: 2
Joined: Wed Jan 09, 2019 11:09 pm

Re: WISP AP DHCP server does not work

Fri Jan 11, 2019 11:55 am

Oh thanks. got it sorted.

Who is online

Users browsing this forum: No registered users and 17 guests