Community discussions

 
becs
MikroTik Support
MikroTik Support
Topic Author
Posts: 477
Joined: Thu Jul 07, 2011 8:26 am

SwOS version 2.9 released!

Mon Jan 14, 2019 5:32 pm

SwOS version 2.9 released
http://www.mikrotik.com/download
What's new in v2.9:

*) CRS326 & CRS328 & CRS317: make sure that RSTP BPDU packets are always untagged;
*) CRS328-4C-20S-4S+: make 1G fiber SFP modules work;
*) CRS328-4C-20S-4S+: fixed PSU numbering;
*) CRS328-4C-20S-4S+: light up fault LED on fan failure;
*) CRS328-4C-20S-4S+: make fiber optic SFP modules work;
*) CRS328-24P-4S+: light up fault LED on fan failure;
*) CRS317: make fault led light up on fan failure;
*) CSS106: fixed rx/tx unicast packet counter;
*) CSS106: make low speed ports not block high speed port traffic;
*) make forced ethernet speeds work;
*) added ability to block unknown multicast packets on port;
*) fixed reporting of secondary FAN speeds;
*) fixed problem where sometimes all VLANs or ACLs were not saved;
*) fixed DHCP snooping to forward packets when they are bigger than 300 bytes;
*) made DHCP snooping remove DHCP agent information option from DHCP replies;
*) made DHCP snooping respect port isolation;
*) fixed SFP module wrong info problem;
*) made LACP work together with RSTP;
*) made upgrading over serial work;
 
becs
MikroTik Support
MikroTik Support
Topic Author
Posts: 477
Joined: Thu Jul 07, 2011 8:26 am

Re: SwOS version 2.9 released!

Mon Jan 14, 2019 5:46 pm

Known issue:
*) CRS328-24P-4S+ upgrade from the SwOS does not work in this version
Upgrade using SwOS firmware file "swos-css328p-2.9.bin" from https://mikrotik.com/download should be used instead.
 
RobertF
just joined
Posts: 9
Joined: Sun Dec 03, 2017 1:24 pm

Re: SwOS version 2.9 released!

Mon Jan 14, 2019 6:20 pm

Hello becs,

It is really frustrating. I copied my posting from v 2.8...

German IPTV (Entertain TV, MR401/201) still not working at all with this SwOS version (CSS326). No IGMP v3.
Picture freezes after a few seconds.

Independent of setting IGMP snooping.

Using together with FritzBox 7590.

Latest usable version is 2.4 (with packet flood on all ports due to missing IGMP)

Please implement IGMP v3 in next update.
Thanks.

Robert
 
eddieb
Member Candidate
Member Candidate
Posts: 126
Joined: Thu Aug 28, 2014 10:53 am
Location: Netherlands

Re: SwOS version 2.9 released!

Tue Jan 15, 2019 8:21 am

Updated all my RB260GS(CSS106-5G-1S) to 2.9 without any issues.
Running 6.45.1 (stable) on :
CCR1009-8G-1S (2x ipsec/l2tp site-to-site, ipsec/l2tp roadwarrior, dhcpd, dns), CRS125-24G-1S, RB1100, RB962UiGS-5HacT2HnT (10pc), RB931-2nD, RB951, RB750GL ,RB2011UAS-RM, CHR running dude (CHR running in VirtualBox on OSX)
 
User avatar
abrodkin
just joined
Posts: 12
Joined: Wed Nov 08, 2017 10:30 am

Re: SwOS version 2.9 released!

Tue Jan 15, 2019 9:02 am

Hello becs,

It is really frustrating. I copied my posting from v 2.8...

German IPTV (Entertain TV, MR401/201) still not working at all with this SwOS version (CSS326). No IGMP v3.
Picture freezes after a few seconds.

Independent of setting IGMP snooping.

Using together with FritzBox 7590.

Latest usable version is 2.4 (with packet flood on all ports due to missing IGMP)

Please implement IGMP v3 in next update.
Thanks.

Robert
So given this comment and no mention of IGMP in official changelog we may safely conclude IGMP is not yet fixed.
God job Mikrotik team!

I'm staying on v2.4 until IGMP is fixed.
 
storp
newbie
Posts: 47
Joined: Tue Nov 24, 2015 2:53 pm

Re: SwOS version 2.9 released!

Tue Jan 15, 2019 11:06 am

Any fixes for the issues with RX overruns and RX FCS errors included in this release?
 
Njumaen
newbie
Posts: 36
Joined: Wed Feb 24, 2016 8:41 pm

Re: SwOS version 2.9 released!

Tue Jan 15, 2019 3:03 pm

Where can I find the 2.8 files? I want to check if some strange behaviour of my rb260gsp is related to the update
 
biatche
Member Candidate
Member Candidate
Posts: 128
Joined: Tue Oct 13, 2015 6:50 am

Re: SwOS version 2.9 released!

Tue Jan 15, 2019 3:33 pm

I've been patient version after version since 2.3

Each time I upgrade, there's endless issues. Resetting resets to 2.0 and then I'd have to pray and hope it'd upgrade to the latest with my settings intact, and then having to restore again.

This is on CSS326. Can mikrotik somehow allow RouterOS to be installed on CSS326 because honestly, SwOS is complete garbage. Yes I'm annoyed. You already have a good 1 year to fix the product and its still garbage.
 
User avatar
kosyot
just joined
Posts: 20
Joined: Wed Jan 16, 2019 1:28 pm
Contact:

Re: SwOS version 2.9 released!

Wed Jan 16, 2019 1:37 pm

Hi all,
Is there prove of bugs fixing appeared @2.8 for CRS317-1G-16S+ ?
Especial freezing of switch, which forced us all to downgrade to 2.7?
 
fernaandogarcia
just joined
Posts: 6
Joined: Tue May 26, 2015 3:09 pm

Re: SwOS version 2.9 released!

Wed Jan 16, 2019 2:21 pm

I have a CRS317 that in version 2.8 often crashed the management, it was very slow access. The traffic flowed normal but the management looked strange.

This issue has been resolved with version 2.9.
 
becs
MikroTik Support
MikroTik Support
Topic Author
Posts: 477
Joined: Thu Jul 07, 2011 8:26 am

Re: SwOS version 2.9 released!

Wed Jan 16, 2019 2:35 pm

@RobertF and @abrodkin
SwOS has supported IGMP v1,v2,v3 since v2.5, also many issues have been addressed since then and now in v2.9 there is an additional port option to disable unknown multicast flooding. We are not aware of common IGMP Snooping problems anymore.
If you experience problems using IGMP Snooping in SwOS, please, write to MikroTik support so your cases can be individually investigated.

@storp
Yes, the v2.9 contains the latest improvements for 10G -> 1G performance issues and they can help regarding Rx Overruns in other setups as well.

@Njumaen
SwOS v2.8 for RB260:
https://download.mikrotik.com/swos2/css ... 1s-2.8.bin
 
User avatar
k6ccc
Member
Member
Posts: 459
Joined: Fri May 13, 2016 12:01 am
Location: Glendora, CA, USA (near Los Angeles)

Re: SwOS version 2.9 released!

Wed Jan 16, 2019 6:29 pm

Updated my CSS106-5G-1S from 2.8 and all appears to be working. However, after the upgrade, this is what the Upgrade page says:
Firmware
Current Installed Version	2.9 (built at Mon Jan 07 2019 03:04:37 GMT-0800 (GMT-08:00))
Latest Available Version	2.9 (built at Mon Jan 14 2019 02:29:12 GMT-0800 (GMT-08:00))
At the bottom, it says that there is an upgrade available. Tried the upgrade again and it still comes up with the 07 January version and not the 14 January version.
I have not upgraded the other three switches yet.
RB750Gr3, RB750r2, CRS326-24G-2S (in SwitchOS), CSS326-24G-2S, CSS106-5G-1S, RB260GS
Not sure if I beat them in submission, or they beat me into submission


Jim
 
User avatar
Cha0s
Forum Veteran
Forum Veteran
Posts: 875
Joined: Tue Oct 11, 2005 4:53 pm

Re: SwOS version 2.9 released!

Wed Jan 16, 2019 8:19 pm

Same here
 
User avatar
Cha0s
Forum Veteran
Forum Veteran
Posts: 875
Joined: Tue Oct 11, 2005 4:53 pm

Re: SwOS version 2.9 released!

Thu Jan 17, 2019 2:47 am

Upgrading from 2.8 to 2.9 on a CSS106-5G-1S causes severe traffic drop between 1G ports and 100Mbit ports. It's random from 0 to 40Mbps.
Reverting back to 2.8 traffic increased back to steady 100Mbps.
 
biatche
Member Candidate
Member Candidate
Posts: 128
Joined: Tue Oct 13, 2015 6:50 am

Re: SwOS version 2.9 released!

Thu Jan 17, 2019 6:19 am

I can't any longer access webui on vlan management port... coming from 2.7..... do i need to reset settings?.... what settings are required to be able to access webui from vlan99?

i did set the management port on the system page.
 
becs
MikroTik Support
MikroTik Support
Topic Author
Posts: 477
Joined: Thu Jul 07, 2011 8:26 am

Re: SwOS version 2.9 released!

Thu Jan 17, 2019 8:27 am

Upgrading from 2.8 to 2.9 on a CSS106-5G-1S causes severe traffic drop between 1G ports and 100Mbit ports. It's random from 0 to 40Mbps.
Reverting back to 2.8 traffic increased back to steady 100Mbps.
Are there any errors in interface stats when using v2.8 or v2.9?
 
Njumaen
newbie
Posts: 36
Joined: Wed Feb 24, 2016 8:41 pm

Re: SwOS version 2.9 released!

Thu Jan 17, 2019 10:01 am

The issues (random video playback lags -wirered- or loosing wireless connection) vanished with downgrade to 2.8 of my two rb260gsp.

Before downgrading I looked for transmission errors, but none were shown.

Ralf.
 
User avatar
Cha0s
Forum Veteran
Forum Veteran
Posts: 875
Joined: Tue Oct 11, 2005 4:53 pm

Re: SwOS version 2.9 released!

Thu Jan 17, 2019 12:40 pm

Upgrading from 2.8 to 2.9 on a CSS106-5G-1S causes severe traffic drop between 1G ports and 100Mbit ports. It's random from 0 to 40Mbps.
Reverting back to 2.8 traffic increased back to steady 100Mbps.
Are there any errors in interface stats when using v2.8 or v2.9?
No errors at all on any port.
 
User avatar
kosyot
just joined
Posts: 20
Joined: Wed Jan 16, 2019 1:28 pm
Contact:

Re: SwOS version 2.9 released!

Fri Jan 18, 2019 11:00 am

Any with CRS317 & 2.9 ?
 
User avatar
indnti
Frequent Visitor
Frequent Visitor
Posts: 64
Joined: Thu Nov 09, 2006 11:53 am

Re: SwOS version 2.9 released!

Sun Jan 20, 2019 12:37 am

[quote=kosyot post_id=709676 time=1547802033 user_id=136437]
Any with CRS317 & 2.9 ?
[/quote]

Yes. Works.
 
rofrigo2
just joined
Posts: 22
Joined: Tue Oct 31, 2017 4:36 am

Re: SwOS version 2.9 released!

Sun Jan 20, 2019 1:28 am

As far as I understood from some posts above, the multicast issues are not fixed?
Shall I stay at 2.4 then?
 
User avatar
kosyot
just joined
Posts: 20
Joined: Wed Jan 16, 2019 1:28 pm
Contact:

Re: SwOS version 2.9 released!

Mon Jan 21, 2019 10:18 am

Any with CRS317 & 2.9 ?
Yes. Works.
Same story :(
CRS317-1G-16S+ with SwOS 2.9:
  • connection to the switch stopped every 3-5 min (no ping, no web, serial - working)
  • leds on ports not blinking - all ON
  • after hour on stopped all traffic thru switch - must be rebooted by serial console
back to last working version on SwOS - 2.7.

very disappointed indeed again...
 
zainabiden
just joined
Posts: 1
Joined: Tue Jan 22, 2019 12:36 pm
Location: London
Contact:

Re: SwOS version 2.9 released!

Tue Jan 22, 2019 12:39 pm

Upgrading from 2.8 to 2.9 on a CSS106-5G-1S causes severe traffic drop between 1G ports and 100Mbit ports. It's random from 0 to 40Mbps.
Reverting back to 2.8 traffic increased back to steady 100Mbps.
Are there any errors in interface stats when using v2.8 or v2.9?
No errors at all on any port.
Agree
 
smash102
newbie
Posts: 29
Joined: Sun Sep 15, 2013 4:51 am

Re: SwOS version 2.9 released!

Tue Jan 22, 2019 9:11 pm

Upgraded about 4 of our RB260 series switches (2 of each) to this code.
The ACL page will not SAVE any changes.
Random bandwidth.
Reverting back to 2.8 code.
I do not recommend upgrading to 2.9.
 
storp
newbie
Posts: 47
Joined: Tue Nov 24, 2015 2:53 pm

Re: SwOS version 2.9 released!

Wed Jan 23, 2019 10:31 am

Upgraded two CSS326 from 2.7 and it worked fine. Still having RX overruns.
 
User avatar
kosyot
just joined
Posts: 20
Joined: Wed Jan 16, 2019 1:28 pm
Contact:

Re: SwOS version 2.9 released!

Wed Jan 23, 2019 11:13 am

Upgraded two CSS326 from 2.7 and it worked fine. Still having RX overruns.
I can confirm that CSS326 working fine with 2.9 and there is still RX overruns.
Have no problem with CSS106 too, can't say same for CRS317....
 
usedtobegood
just joined
Posts: 1
Joined: Mon Jan 21, 2019 11:08 am

Re: SwOS version 2.9 released!

Wed Jan 23, 2019 12:28 pm

Hi,
reading that no IGMP (Snooping) Problems are know in the latest 2.9 Firmware release, made me a bit angry...

I currently use several Dell (eg. Powerconnect 7024, 6248) switches and for the Office (because it is silent) a Mikrotik CSS326-24G-2S+RM.
There a dozen or so VLANs configured but only VLAN30 is used for IGMP Snooping, which is needed for the IPTV Product from German Telekom (currently i am still using the old T-Entertain Platform, in a couple of weeks this platform will be shut down by DTAG and only the newer EntertainTV platform is still usable - we'll see whats still working then...)

But making a Point: VLAN 30 with IGMP Snooping activatet works great with the Dell switches. With the IPTV Receivers zapping is a pleasure, you can see (or better you can't) the switch from unicast to broadcast, which occours after a couple of seconds from the Platform, a smooth transition.
With the Mikrotik there is a 5-10 second gap when the unicast switches to broadcast. In these Seconds the Picture freezes, the IGMP group is (too slowly) joined, and after that everyhing is working fine again.

Im am very disappointed that Mikrotik seems to be very inexperienced in the whole IGMP subject. Even the cheapest IGMPv3 Snooping compatible Switches from Netgear (GS105E) work way better in this szenario than the 'rather' expensive and theoretically way more sophisticated Mikrotik Switch :-(

Hope this will be solved soon - but since I bought the switch (back last year) it almost layd unused in its box waiting to be usable :-(

Cheers

UsedToBeGood
 
User avatar
Deantwo
Member Candidate
Member Candidate
Posts: 288
Joined: Tue Sep 30, 2014 4:07 pm

Re: SwOS version 2.9 released!

Wed Jan 23, 2019 1:35 pm

reading that no IGMP (Snooping) Problems are know in the latest 2.9 Firmware release, made me a bit angry...
As @becs just said;
@RobertF and @abrodkin
SwOS has supported IGMP v1,v2,v3 since v2.5, also many issues have been addressed since then and now in v2.9 there is an additional port option to disable unknown multicast flooding. We are not aware of common IGMP Snooping problems anymore.
If you experience problems using IGMP Snooping in SwOS, please, write to MikroTik support so your cases can be individually investigated.
Send an email to support@mikrotik.com with details of the issue, and then they will investigate your case.
Continuing to complain here doesn't really help anyone.
I wish my FTP was FTL.
 
RobertF
just joined
Posts: 9
Joined: Sun Dec 03, 2017 1:24 pm

Re: SwOS version 2.9 released!

Wed Jan 23, 2019 7:14 pm

@becs Thanks for the offer to solve the IGMP issue via direct support.

I already have been in contact with support more than one year ago using version 2.6. Answer:
SwOS does not support IGMP v3 and there is no fix until v3 is implemented.
IGMP v3 is on the feature list and it will not be implemented in near future.

IGMP changes are not mentioned in release notes for 2.7, 2.8 or 2.9 except this one:
"CSS106: forward IGMP query messages even when IGMP snooping is disabled;"

@Deantwo: I complain about the German IPTV IGMP issue in the forum to save time of other CSS326 users.

Cheers
Robert
 
casey42387
just joined
Posts: 1
Joined: Mon Jan 28, 2019 6:55 am

Re: SwOS version 2.9 released!

Mon Jan 28, 2019 7:04 am

Anyone have a download link to previous versions of SwOS for the CRS305-1G-4S+?

I'm trying to do some loop testing and going from 2.8.x to 2.9 nuked the link status lights and internal link status for SFP+ ports (e.g. SFP1 to SFP2).
 
riks
just joined
Posts: 1
Joined: Mon Jan 28, 2019 10:46 am

Re: SwOS version 2.9 released!

Mon Jan 28, 2019 10:49 am

i have the same problem i can not update to version 2.9 from 14 jan , also after a few hours the fans are spinning up and down and the fault led is burning current version of switch os is 2.9 7 jan switch CRS317-1G-16S+RM
 
nicoguido
just joined
Posts: 5
Joined: Tue Jul 24, 2018 11:27 pm

Re: SwOS version 2.9 released!

Mon Jan 28, 2019 11:14 pm

Hi,
I did some tests on a CRS317 with switchos 2.9 (I usually use routeros).
The test wasn't long, because straight after starting with switchos, some iot (netatmo weather station) and the logitech harmony hub were unreachable.
I think harmony hubs are using zeroconf or mDNS.
I played with igmp parameters (vlans and system panels), but nothing went back to normal.
So I'm back to routeros. At least it works (if igmp snooping is disabled on the bridge. With it enabled, it works partially, with strange behaviors).
I'll try the next release.
 
quentin
just joined
Posts: 3
Joined: Mon Feb 11, 2019 9:29 am

Re: SwOS version 2.9 released!

Mon Feb 11, 2019 9:34 am

I can't any longer access webui on vlan management port... coming from 2.7..... do i need to reset settings?.... what settings are required to be able to access webui from vlan99?

i did set the management port on the system page.
Same thing happened to me when upgrading from 2.8 to 2.9; the switch that was previously accessible is suddenly not responding to ARP requests (and therefore the web UI is inaccessible). It's still sending out MNDP packets, though - I see it in the Neighbors list on all my RouterOS devices.
 
ymw
just joined
Posts: 1
Joined: Wed Jan 30, 2019 9:56 pm

Re: SwOS version 2.9 released!

Tue Feb 12, 2019 9:01 am

After upgrading my CSS326-24P-4S+RM to OS 2.9, my sfp+ ports stopped working with my direct attach 10G transceivers. I have two pairs of those direct attach copper transceivers that were working fine before, now both are not recognized. One pair is a Cisco SFP-H10GB-CU3M. The other is an Optech.The sfp+ ports are confirmed to be still workng working OK with the new OS using some Finisar opto trasceivers. Any suggestion on how to proceed? I was connecting to the sfp+ ports on a CRS328-24P-4S+RM.
 
illussion
just joined
Posts: 4
Joined: Mon Feb 04, 2019 4:05 pm
Location: Ukraine

Re: SwOS version 2.9 released!

Tue Feb 12, 2019 10:56 am

Where the button "Reset Counters" in Errors page RB260GSP? What with Rx Overruns and TX pauses ?
 
8cqv
Frequent Visitor
Frequent Visitor
Posts: 53
Joined: Tue Mar 06, 2018 5:25 pm

Re: SwOS version 2.9 released!

Wed Feb 27, 2019 7:19 am

Fan control still completely broken for CRS328.

SwOS is a bit of a joke isn’t it really? How can fundamental problems not be addressed, especially with so much delay between releases?
 
Siorg
just joined
Posts: 3
Joined: Mon Jul 14, 2014 7:18 pm

Re: SwOS version 2.9 released!

Thu Mar 07, 2019 4:48 pm

Upgrading to 2.9 caused mikrotik SplusDA0003 direct link cable failure. No link anymore.
 
User avatar
chechito
Forum Guru
Forum Guru
Posts: 1650
Joined: Sun Aug 24, 2014 3:14 am
Location: Bogota Colombia
Contact:

Re: SwOS version 2.9 released!

Fri Mar 08, 2019 10:36 pm

some body have the 2.8 version for RB260GSP ??
 
User avatar
chechito
Forum Guru
Forum Guru
Posts: 1650
Joined: Sun Aug 24, 2014 3:14 am
Location: Bogota Colombia
Contact:

Re: SwOS version 2.9 released!

Fri Mar 08, 2019 10:37 pm

Upgrading from 2.8 to 2.9 on a CSS106-5G-1S causes severe traffic drop between 1G ports and 100Mbit ports. It's random from 0 to 40Mbps.
Reverting back to 2.8 traffic increased back to steady 100Mbps.


exactly the same problem on RB260GSP

some body have the 2.8 version for this device?
 
User avatar
chechito
Forum Guru
Forum Guru
Posts: 1650
Joined: Sun Aug 24, 2014 3:14 am
Location: Bogota Colombia
Contact:

Re: SwOS version 2.9 released!

Fri Mar 08, 2019 10:56 pm

@RobertF and @abrodkin
SwOS has supported IGMP v1,v2,v3 since v2.5, also many issues have been addressed since then and now in v2.9 there is an additional port option to disable unknown multicast flooding. We are not aware of common IGMP Snooping problems anymore.
If you experience problems using IGMP Snooping in SwOS, please, write to MikroTik support so your cases can be individually investigated.

@storp
Yes, the v2.9 contains the latest improvements for 10G -> 1G performance issues and they can help regarding Rx Overruns in other setups as well.

@Njumaen
SwOS v2.8 for RB260:
https://download.mikrotik.com/swos2/css ... 1s-2.8.bin
im trying to downgrade a rb260gsp CSS106-1G-4P-1S with this file but switch cease to operate and reboot is needed to get it online again but still on 2.9
 
Paternot
Long time Member
Long time Member
Posts: 572
Joined: Thu Jun 02, 2016 4:01 am
Location: Niterói / Brazil

Re: SwOS version 2.9 released!

Fri Mar 08, 2019 11:32 pm

@RobertF and @abrodkin
SwOS has supported IGMP v1,v2,v3 since v2.5, also many issues have been addressed since then and now in v2.9 there is an additional port option to disable unknown multicast flooding. We are not aware of common IGMP Snooping problems anymore.
If you experience problems using IGMP Snooping in SwOS, please, write to MikroTik support so your cases can be individually investigated.

@storp
Yes, the v2.9 contains the latest improvements for 10G -> 1G performance issues and they can help regarding Rx Overruns in other setups as well.

@Njumaen
SwOS v2.8 for RB260:
https://download.mikrotik.com/swos2/css ... 1s-2.8.bin
im trying to downgrade a rb260gsp CSS106-1G-4P-1S with this file but switch cease to operate and reboot is needed to get it online again but still on 2.9
Do You have backups? If I remember correctly, when You reset a switch to factory default it goes back to the original firmware too.
 
User avatar
chechito
Forum Guru
Forum Guru
Posts: 1650
Joined: Sun Aug 24, 2014 3:14 am
Location: Bogota Colombia
Contact:

Re: SwOS version 2.9 released!

Sat Mar 09, 2019 1:26 am

@RobertF and @abrodkin
SwOS has supported IGMP v1,v2,v3 since v2.5, also many issues have been addressed since then and now in v2.9 there is an additional port option to disable unknown multicast flooding. We are not aware of common IGMP Snooping problems anymore.
If you experience problems using IGMP Snooping in SwOS, please, write to MikroTik support so your cases can be individually investigated.

@storp
Yes, the v2.9 contains the latest improvements for 10G -> 1G performance issues and they can help regarding Rx Overruns in other setups as well.

@Njumaen
SwOS v2.8 for RB260:
https://download.mikrotik.com/swos2/css ... 1s-2.8.bin
im trying to downgrade a rb260gsp CSS106-1G-4P-1S with this file but switch cease to operate and reboot is needed to get it online again but still on 2.9
Do You have backups? If I remember correctly, when You reset a switch to factory default it goes back to the original firmware too.
thx a lot

i had to reset to factory (2.7) then i was able to upgrade to 2.8
 
User avatar
chechito
Forum Guru
Forum Guru
Posts: 1650
Joined: Sun Aug 24, 2014 3:14 am
Location: Bogota Colombia
Contact:

Re: SwOS version 2.9 released!

Sat Mar 09, 2019 1:33 am

Upgrading from 2.8 to 2.9 on a CSS106-5G-1S causes severe traffic drop between 1G ports and 100Mbit ports. It's random from 0 to 40Mbps.
Reverting back to 2.8 traffic increased back to steady 100Mbps.
even on 2.8 the problem exists in 2.9 just gets worse

conecting rb260 to main router gigabit full duplex

testing in 2,7 if a client on a downlink port of the switch is at 100m full duplex i cant surpas 75-85mbps of download (upload test 95mbps ok) on speedtest, switching the client to 1g full duplex gets 150mbps on speedtest (that was the internet connection available)

testing in 2,8 gets 25-40 mbps of download on speedtest

testing on 2.9 gets 5-10 mbps of download on speedtest

the funny (not so funny) thing is that because of this issue we tested a CRS 326-328 with routeros or sw-os and suffer from the same issue, (25-40 mbps of download)

looks like a common behavior on mikrotik switch's
Last edited by chechito on Sun Mar 17, 2019 10:42 pm, edited 1 time in total.
 
interprime
just joined
Posts: 15
Joined: Wed Jun 08, 2011 1:08 pm

Re: SwOS version 2.9 released!

Sun Mar 17, 2019 9:45 pm

Upgrading from 2.8 to 2.9 on a CSS106-5G-1S causes severe traffic drop between 1G ports and 100Mbit ports. It's random from 0 to 40Mbps.
Reverting back to 2.8 traffic increased back to steady 100Mbps.


exactly the same problem on RB260GSP

some body have the 2.8 version for this device?

same problem
 
andycher
just joined
Posts: 1
Joined: Wed Mar 27, 2019 11:50 am

Re: SwOS version 2.9 released!

Wed Mar 27, 2019 11:58 am

CSS326-24G-2S+

1Gbit SFP module does not work in auto mode.

Image

Image
 
Tobei
just joined
Posts: 20
Joined: Sun Sep 11, 2016 3:25 pm

Re: SwOS version 2.9 released!

Thu Apr 04, 2019 11:17 pm

Hi,
  • Board Name: CSS106-1G-4P-1S
  • Current Installed Version 2.9 (built at Mon Jan 07 2019 12:04:37 GMT+0100
ACL functionality is broken! On Version 2.8 it is working, so please fix this soon!

Regards Tobias
 
heviejob
Member Candidate
Member Candidate
Posts: 168
Joined: Mon Nov 30, 2009 4:54 pm

Re: SwOS version 2.9 released!

Sat Apr 13, 2019 12:26 am

The issues (random video playback lags -wirered- or loosing wireless connection) vanished with downgrade to 2.8 of my two rb260gsp.

Before downgrading I looked for transmission errors, but none were shown.

Ralf.
I had the same issue after upgrading to 2.9. The experience was so bad It cost me, several customers. I downgraded to 2.8 and went back to normal. I had checked for any errors but there were none.
It made me hard reset core CCR and reconfigured it but still, slow connections persisted. Only a downgrade sorted it out.
 
Kornawell
just joined
Posts: 5
Joined: Tue Dec 04, 2018 4:03 pm

Re: SwOS version 2.9 released!

Sun Apr 21, 2019 12:08 pm

Thanks, guys, I was thinking to upgrade to the last version, and check out this topic before it. Gonna stay on the previous version. Before the issue will be solved.
Regards Kornawell
Last edited by Kornawell on Tue Apr 23, 2019 8:06 pm, edited 1 time in total.
 
anav
Forum Guru
Forum Guru
Posts: 2829
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada

Re: SwOS version 2.9 released!

Sun Apr 21, 2019 4:58 pm

Thats funny as version 2.9 is the only version I will run as its more stable and works compared to the older ones. To be fair, this thing tries ones patience but once setup properly it keeps on working.
I'd rather manage rats than software. Follow my advice at your own risk! (Sob & mkx forced me to write that!)
 
mjpswe
just joined
Posts: 3
Joined: Thu May 02, 2019 11:12 pm

Re: SwOS version 2.9 released!

Thu May 02, 2019 11:17 pm

Hi,

Have a CRS309-1G-8S+ runnig SwOS 2.9 built on 7 Jan, it says there is an upgrade from 21 Feb I click on upgrade and reboot it restart but dont upgrade.
Can I download the file anywhere and do a manual upgrade?

Who is online

Users browsing this forum: No registered users and 3 guests