Community discussions

 
User avatar
Sn1p3r
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 50
Joined: Thu Mar 10, 2011 5:50 pm
Location: Croatia
Contact:

VLAN - how to?

Wed Feb 13, 2019 11:11 pm

Hello,

Mikrotik VLAN system is a bit different then on all other devices.
I have the setup working for me, but I'm not quite sure that it's the proper way.

How guys would you set this scenario?

Let's say on ether8 you have Cisco switch which is tagging IDs 17 and 100 and sending to Mikrotik?
How to properly receive those packets, and forward it to port 9 to other Mikrotik?

How do you actually TAG an untagged traffic on specific port?
Anything I receive on port 8 to TAG to ID 15?

I've seen couple solutions, bridging, add VLAN interface to bridge, add VLAN interface directly to port?
It's a bit confusing :)


My current setup:

Untagged traffic coming to port 7 - and it's tagging it to 13.
Traffic should go TAGGED to sfp port 1.
How to do it?
 
User avatar
pcunite
Forum Veteran
Forum Veteran
Posts: 879
Joined: Sat May 25, 2013 5:13 am
Location: USA

Re: VLAN - how to?

Thu Feb 14, 2019 1:09 am

To help you with this, its beneficial to use standard terms. I think you're asking the following? You can see more examples in my signature. There is some setup not shown in the examples below. But, this is a start.

Cisco Port 8 is a Trunk port. So, you want MikroTik port 8 to be Trunk?

# Set ingress
/interface bridge port add bridge=BR1 interface=ether8 pvid=1
# Set egress
/interface bridge vlan set bridge=BR1 tagged=ether8 vlan-ids=17,100


You want an Access port of 15?

# Set ingress
/interface bridge port add bridge=BR1 interface=ether9 pvid=15
# Set egress
/interface bridge vlan set bridge=BR1 untagged=ether9 vlan-ids=15

Who is online

Users browsing this forum: No registered users and 2 guests