Community discussions

 
Martooo
just joined
Topic Author
Posts: 9
Joined: Wed Mar 21, 2018 2:11 pm

NEW Public Bandwith Test Server

Thu Feb 14, 2019 3:32 am

Hello mikrotik fans,

I will be bringing up a btest server soon. I have preprared one RB800 and a 1Gbit connection dedicated only for the sake of testing.
It is ready, but I want to limit the usage somehow before I post it public. I have created filter rule for input that puts your IP in ban address list for X period of time.

I can't figure out how to limit the test sessions per time. You can basically let it run indefinately. Can you tell me how to disconnect every btest connection for example on 5min?
 
nescafe2002
Long time Member
Long time Member
Posts: 622
Joined: Tue Aug 11, 2015 12:46 pm
Location: Netherlands

Re: NEW Public Bandwith Test Server

Thu Feb 14, 2019 1:21 pm

Nice work!

You can check out the configuration of TomjNorthIdaho posted here:

viewtopic.php?f=2&t=104266&p=690150#p690150
/ip firewall raw
add action=accept chain=prerouting comment="testers accepted" src-address-list=tester
add action=drop chain=prerouting comment="previous testers drop" src-address-list=previous
add action=add-src-to-address-list address-list=tester address-list-timeout=2m chain=prerouting comment="add to tester" dst-port=2000-2100 protocol=tcp
add action=add-src-to-address-list address-list=tester address-list-timeout=2m chain=prerouting comment="add to tester" dst-port=2000-2100 protocol=udp
add action=add-src-to-address-list address-list=previous address-list-timeout=15m chain=prerouting comment="add to previous" dst-port=2000-2100 log=yes protocol=tcp
add action=add-src-to-address-list address-list=previous address-list-timeout=15m chain=prerouting comment="add to previous" dst-port=2000-2100 log=yes protocol=udp

This will limit tests to 2m every 15m per ip address.
 
neutronlaser
Member Candidate
Member Candidate
Posts: 212
Joined: Thu Jan 18, 2018 5:18 pm

Re: NEW Public Bandwith Test Server

Thu Feb 14, 2019 1:33 pm

It's almost like Mikrotik should run one
 
Martooo
just joined
Topic Author
Posts: 9
Joined: Wed Mar 21, 2018 2:11 pm

Re: NEW Public Bandwith Test Server

Thu Feb 14, 2019 6:04 pm

I did check his config and set it up nicely. Everything works except when the timer runs out for "testing" address list it wouldnt drop the traffic server>client only the other way. This issue appears only when testing UDP. With TCP test there is no problem. I worked on this for about 6 hours last night and I couldnt find a solution. Anyone else experenced this iisue?

Should I provide any screenshots?
 
nescafe2002
Long time Member
Long time Member
Posts: 622
Joined: Tue Aug 11, 2015 12:46 pm
Location: Netherlands

Re: NEW Public Bandwith Test Server

Thu Feb 14, 2019 6:09 pm

Have you enabled fasttrack? I will probably bypass raw firewall, however doesn't explain why tcp is working.

Please do no post screenshots, just export config ( /export hide-sensitive ) and paste in code blocks.

Also.. TomjNorthIdaho mentioned more than a terabyte of traffic per month hosting public bandwidth server.
Are you sure your connection can handle such large amount of traffic?
 
Martooo
just joined
Topic Author
Posts: 9
Joined: Wed Mar 21, 2018 2:11 pm

Re: NEW Public Bandwith Test Server

Fri Feb 15, 2019 12:25 pm

I have enabled fasttrack, but it doesn't count packets so I guess i doesn't apply for this.

I will post config as soon as I can.

The mikrotik will be in a datacenter for the clients to test their bandwith and also for public use. So yes the network behind it will handle alot ;)
 
User avatar
CZFan
Forum Guru
Forum Guru
Posts: 1392
Joined: Sun Oct 09, 2016 8:25 pm
Location: South Africa, Randburg
Contact:

Re: NEW Public Bandwith Test Server

Fri Feb 15, 2019 11:52 pm

It's almost like Mikrotik should run one

Please forward the bandwidth test link for Cisco, Juniper, Huawei, Zyxel, TP-Link, ....
MTCNA, MTCTCE, MTCRE & MTCINE
 
Martooo
just joined
Topic Author
Posts: 9
Joined: Wed Mar 21, 2018 2:11 pm

Re: NEW Public Bandwith Test Server

Tue Feb 26, 2019 4:01 am

Hello again.
It seems I fixed it and it's now working as expected. RAW rules needed tweaking. I will post before and after output so you can compare:

Before:
[user@Server] /ip firewall> raw print
Flags: X - disabled, I - invalid, D - dynamic
0 D ;;; special dummy rule to show fasttrack counters
chain=prerouting action=passthrough
1 ;;; testers accepted
chain=prerouting action=accept log=no log-prefix="" src-address-list=tester
2 ;;; previous testers drop
chain=prerouting action=drop log=no log-prefix="" src-address-list=previous
3 ;;; add to tester
chain=prerouting action=add-src-to-address-list dst-port=2000-3000 log=no log-prefix="" protocol=tcp address-list=tester address-list-timeout=15m
4 ;;; add to tester
chain=prerouting action=add-src-to-address-list dst-port=2000-3000 log=no log-prefix="" protocol=udp address-list=tester address-list-timeout=15m
5 ;;; add to previous
chain=prerouting action=add-src-to-address-list dst-port=2000-3000 log=yes log-prefix="" protocol=tcp address-list=previous address-list-timeout=1d
6 ;;; add to previous
chain=prerouting action=add-src-to-address-list dst-port=2000-3000 log=yes log-prefix="" protocol=udp address-list=previous address-list-timeout=1d

After:
[user@Server] /ip firewall> raw print
Flags: X - disabled, I - invalid, D - dynamic
0 D ;;; special dummy rule to show fasttrack counters
chain=prerouting action=passthrough
1 ;;; testers accepted
chain=prerouting action=accept log=no log-prefix="" src-address-list=tester
2 ;;; testers accepted
chain=output action=accept log=no log-prefix="" dst-address-list=tester
3 ;;; previous testers drop
chain=output action=drop log=no log-prefix="" dst-address-list=previous
4 ;;; previous testers drop
chain=prerouting action=drop log=no log-prefix="" src-address-list=previous
5 ;;; add to tester
chain=prerouting action=add-src-to-address-list dst-port=2000-3000 log=no log-prefix="" protocol=tcp address-list=tester address-list-timeout=15m
6 ;;; add to tester
chain=prerouting action=add-src-to-address-list dst-port=2000-3000 log=no log-prefix="" protocol=udp address-list=tester address-list-timeout=15m
7 ;;; add to previous
chain=prerouting action=add-src-to-address-list dst-port=2000-3000 log=no log-prefix="" protocol=tcp address-list=previous address-list-timeout=1d
8 ;;; add to previous
chain=prerouting action=add-src-to-address-list dst-port=2000-3000 log=no log-prefix="" protocol=udp address-list=previous address-list-timeout=1d
 
Martooo
just joined
Topic Author
Posts: 9
Joined: Wed Mar 21, 2018 2:11 pm

Re: NEW Public Bandwith Test Server

Tue Feb 26, 2019 4:05 am

You can test the server at:

IP: 87.121.0.45
U: neterra
P: neterra

Special thanks to Neterra Telecommunications for sponsoring and providing the hardware and the connectivity for this btest server.

15min. testing time and 24h ban (this was their request).

Please share results when you test. Cheers ;)
 
User avatar
vecernik87
Long time Member
Long time Member
Posts: 642
Joined: Fri Nov 10, 2017 8:19 am

Re: NEW Public Bandwith Test Server

Tue Feb 26, 2019 4:49 am

IP: 87.121.0.45
it says "can't connect" for UDP and "test unsupported" for TCP.
Are you certain it works fine?
 
nescafe2002
Long time Member
Long time Member
Posts: 622
Joined: Tue Aug 11, 2015 12:46 pm
Location: Netherlands

Re: NEW Public Bandwith Test Server

Tue Feb 26, 2019 5:14 am

Works fine here:

RB3011 @ 500Mbps
[admin@MikroTik] > /tool bandwidth-test 87.121.0.45 user=neterra password=neterra direction=both
                status: running
              duration: 57s
            tx-current: 543.9Mbps
  tx-10-second-average: 543.6Mbps
      tx-total-average: 456.1Mbps
            rx-current: 543.6Mbps
  rx-10-second-average: 543.5Mbps
      rx-total-average: 406.0Mbps
          lost-packets: 4653
           random-data: no
             direction: both
               tx-size: 1500
               rx-size: 1500

Cannot post 1Gbps result in upcoming 24 hours :)
 
Martooo
just joined
Topic Author
Posts: 9
Joined: Wed Mar 21, 2018 2:11 pm

Re: NEW Public Bandwith Test Server

Tue Feb 26, 2019 3:30 pm

Thanks nescafe2002 for testing. It's interesting how much CPU will be consumed on full bandwidth. Today max was 660mbps and the cpu was around 30%. Tell me from which IP you are testing so I can remove you from ban list for another try :D
 
nescafe2002
Long time Member
Long time Member
Posts: 622
Joined: Tue Aug 11, 2015 12:46 pm
Location: Netherlands

Re: NEW Public Bandwith Test Server

Tue Feb 26, 2019 5:37 pm

Reset to default configuration & got a fresh ip :)

RB4011 @ 1Gbps
[admin@MikroTik] > /tool bandwidth-test 87.121.0.45 user=neterra password=neterra direction=both
                    ;;; results can be limited by cpu, note that traffic generation/termination performance might 
                        not be representative of forwarding performance
                status: running
              duration: 59s
            tx-current: 696.0Mbps
  tx-10-second-average: 693.7Mbps
      tx-total-average: 685.8Mbps
            rx-current: 965.2Mbps
  rx-10-second-average: 972.7Mbps
      rx-total-average: 963.8Mbps
          lost-packets: 4774
           random-data: no
             direction: both
               tx-size: 1500
               rx-size: 1500
      connection-count: 20
        local-cpu-load: 42%
       remote-cpu-load: 100%
 
Martooo
just joined
Topic Author
Posts: 9
Joined: Wed Mar 21, 2018 2:11 pm

Re: NEW Public Bandwith Test Server

Tue Feb 26, 2019 5:53 pm

Seems fine for me :D
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Posts: 985
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: NEW Public Bandwith Test Server

Tue Feb 26, 2019 9:39 pm

Nice btest server :)

I just ran some btest's from my 207.32.194.24 btest server to your new btest server.
FYI: UDP is pretty much immune to distance (because it is mostly a fire-and-forget protocol) , and TCP can be sensitive to distance because TCP requires return ACK packets.
Here are the results:
You do not have the required permissions to view the files attached to this post.
 
Martooo
just joined
Topic Author
Posts: 9
Joined: Wed Mar 21, 2018 2:11 pm

Re: NEW Public Bandwith Test Server

Wed Feb 27, 2019 8:09 pm

Nice btest server :)

I just ran some btest's from my 207.32.194.24 btest server to your new btest server.
FYI: UDP is pretty much immune to distance (because it is mostly a fire-and-forget protocol) , and TCP can be sensitive to distance because TCP requires return ACK packets.
Here are the results:
Great 10x for the test :)

Hope it is used a lot :D Do you think the RB800 will come weak if pushed? I can see it doesn't go higher than 70% cpu when being used for tests with 900mbps.
 
Ramstin
just joined
Posts: 6
Joined: Thu Dec 06, 2018 10:18 pm

Re: NEW Public Bandwith Test Server

Thu Feb 28, 2019 12:31 am

is this server still working?

im getting "connecting...."

code used:
/tool bandwidth-test 87.121.0.45 user=neterra password=neterra direction=both
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Posts: 985
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: NEW Public Bandwith Test Server

Thu Feb 28, 2019 2:56 am

Nice btest server :)

I just ran some btest's from my 207.32.194.24 btest server to your new btest server.
FYI: UDP is pretty much immune to distance (because it is mostly a fire-and-forget protocol) , and TCP can be sensitive to distance because TCP requires return ACK packets.
Here are the results:
Great 10x for the test :)

Hope it is used a lot :D Do you think the RB800 will come weak if pushed? I can see it doesn't go higher than 70% cpu when being used for tests with 900mbps.
RB-800 - don't know --- guess you can just wait and see …
North Idaho Tom Jones
 
Martooo
just joined
Topic Author
Posts: 9
Joined: Wed Mar 21, 2018 2:11 pm

Re: NEW Public Bandwith Test Server

Fri Mar 01, 2019 2:44 pm

is this server still working?

im getting "connecting...."

code used:
/tool bandwidth-test 87.121.0.45 user=neterra password=neterra direction=both
Now it is. Try again :)
 
biland
just joined
Posts: 19
Joined: Thu Jan 26, 2012 1:01 pm
Location: tuxtepec, mexico
Contact:

Re: NEW Public Bandwith Test Server

Mon Mar 04, 2019 8:12 pm

is the server running on stable or long term ?
, lately you can test only if you have the same version of the packages
 
hardings
newbie
Posts: 30
Joined: Fri Feb 26, 2010 11:13 am
Location: Melbourne Australia

Re: NEW Public Bandwith Test Server

Tue Mar 05, 2019 12:53 am

Just tried yor btest and am getting:
/tool bandwidth-test 87.121.0.45 user=neterra password=neterra direction=both
status: can not connect
duration: 0s
etc.
I your btest server also demanding a latest version of ROS?

If so it makes it somewhat unusable for me and many I know.
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Posts: 985
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: NEW Public Bandwith Test Server

Tue Mar 05, 2019 1:44 am

Just tried yor btest and am getting:
/tool bandwidth-test 87.121.0.45 user=neterra password=neterra direction=both
status: can not connect
duration: 0s
etc.
I your btest server also demanding a latest version of ROS?

If so it makes it somewhat unusable for me and many I know.
6.43.8 works for me to this btest server
-and-
6.43.12 works for me to this btest server
-and-
6.44 works for me to this btest server
 
hardings
newbie
Posts: 30
Joined: Fri Feb 26, 2010 11:13 am
Location: Melbourne Australia

Re: NEW Public Bandwith Test Server

Tue Mar 05, 2019 2:03 am

6.43.8 works for me to this btest server
-and-
6.43.12 works for me to this btest server
-and-
6.44 works for me to this btest server
I am running many routers with pre 6.40 and those I have tried don't connect.
The problem is with an arbitrary change of authentication method courtesy of Mikrotik.
It would not be a problem if there was no user/pass rquired.
Given one has to come here to get the IP, and the user/pass is in clear text, and there is overuse mitigation in place, I can't see the point of requiring a user/pass, especially when it excludes many Mikrotik devices in the field.
But that's just me (and many I know).
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Posts: 985
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: NEW Public Bandwith Test Server

Tue Mar 05, 2019 2:26 am

6.43.8 works for me to this btest server
-and-
6.43.12 works for me to this btest server
-and-
6.44 works for me to this btest server
I am running many routers with pre 6.40 and those I have tried don't connect.
The problem is with an arbitrary change of authentication method courtesy of Mikrotik.
It would not be a problem if there was no user/pass rquired.
Given one has to come here to get the IP, and the user/pass is in clear text, and there is overuse mitigation in place, I can't see the point of requiring a user/pass, especially when it excludes many Mikrotik devices in the field.
But that's just me (and many I know).
Re: The problem is with an arbitrary change of authentication method courtesy of Mikrotik. re pre 6.40
I'm not up to speed with ROS version and authentication changes. What part of authentication does not work properly after an upgrade ?
 
hardings
newbie
Posts: 30
Joined: Fri Feb 26, 2010 11:13 am
Location: Melbourne Australia

Re: NEW Public Bandwith Test Server

Tue Mar 05, 2019 2:41 am

Re: The problem is with an arbitrary change of authentication method courtesy of Mikrotik. re pre 6.40
I'm not up to speed with ROS version and authentication changes. What part of authentication does not work properly after an upgrade ?
Take a look at:
viewtopic.php?f=2&t=104266&p=686117&hil ... ty#p686117
 
alfred998
newbie
Posts: 31
Joined: Fri Apr 27, 2018 4:58 pm

Re: NEW Public Bandwith Test Server

Thu Apr 18, 2019 10:13 pm

Is it still active ? i am getting stuck at 'connecting..'
Ping works
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Posts: 985
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: NEW Public Bandwith Test Server

Thu Apr 18, 2019 11:55 pm

Is it still active ? i am getting stuck at 'connecting..'
Ping works
Yes - my 207.32.194.24 public access btest server is on-line and working correctly.

- Check the version of your Mikrotik , you may need to upgrade it
- The user name is --> btest
- The password is --> btest
 
alfred998
newbie
Posts: 31
Joined: Fri Apr 27, 2018 4:58 pm

Re: NEW Public Bandwith Test Server

Fri Apr 19, 2019 1:22 am

Yes I was able to test with 207.32.194.24. I was asking about 87.121.0.45
 
Zwe
just joined
Posts: 11
Joined: Thu Jan 11, 2018 11:19 am
Location: Myanmar,Mandalay
Contact:

Re: NEW Public Bandwith Test Server

Fri Apr 19, 2019 6:26 am

Yes, it's working.
 
mfr476
Member Candidate
Member Candidate
Posts: 170
Joined: Thu Oct 11, 2018 4:51 pm

Re: NEW Public Bandwith Test Server

Fri Apr 19, 2019 10:02 pm

Thanks a lot!!!
 
alfred998
newbie
Posts: 31
Joined: Fri Apr 27, 2018 4:58 pm

Re: NEW Public Bandwith Test Server

Tue Apr 23, 2019 6:42 pm

For some reason I still get stuck at status: connecting.. Maybe a configuration problem on my side ?

Image

Same with 207.32.194.24 and both time out on ping although I havent tried a test in the last 24h

This is my firewall config (newbie alert)
/ip firewall filter
add action=accept chain=input comment="defconf: accept established,related,untracked" connection-state=established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=drop chain=input comment="defconf: drop all not coming from LAN" in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related
add action=accept chain=forward comment="defconf: accept established,related, untracked" connection-state=established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
add action=drop chain=forward comment="defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new in-interface-list=WAN
add action=drop chain=input comment="defconf: drop WAN DNS UDP req" dst-port=53 in-interface=ether1 protocol=udp
add action=drop chain=input comment="defconf: drop WAN DNS TCP req" dst-port=53 in-interface=ether1 protocol=tcp
 
hardings
newbie
Posts: 30
Joined: Fri Feb 26, 2010 11:13 am
Location: Melbourne Australia

Re: NEW Public Bandwith Test Server

Wed Apr 24, 2019 2:21 am

For some reason I still get stuck at status: connecting.. Maybe a configuration problem on my side ?
ROS version?
 
alfred998
newbie
Posts: 31
Joined: Fri Apr 27, 2018 4:58 pm

Re: NEW Public Bandwith Test Server

Wed Apr 24, 2019 10:03 am

it's the latest, 6.44.2, RB750Gr3
 
hardings
newbie
Posts: 30
Joined: Fri Feb 26, 2010 11:13 am
Location: Melbourne Australia

Re: NEW Public Bandwith Test Server

Wed Apr 24, 2019 10:27 am

it's the latest, 6.44.2, RB750Gr3
Then that's not the reason :-)
 
ALX1S
newbie
Posts: 40
Joined: Mon Apr 27, 2015 5:28 pm
Location: Buenos Aires, Argentina

Re: NEW Public Bandwith Test Server

Wed May 15, 2019 9:59 pm

HI,

First of all, thanks for your testing server, is great-full having some trusty point to scope when making bandwidth and link stability tests.

I am not being able to connect to it, It could be another reason i am not being able to connect to it?

Model: RB433
ROS: 6.40.8

Alexis.
 
antonmance
just joined
Posts: 9
Joined: Sun May 06, 2018 6:45 pm

Re: NEW Public Bandwith Test Server

Wed Jun 19, 2019 5:37 pm

Thanks, works very well. RB3011 v644.2
 
masterpianist
just joined
Posts: 16
Joined: Wed Sep 12, 2018 10:19 am

Re: NEW Public Bandwith Test Server

Mon Sep 16, 2019 2:20 pm

You can test the server at:

IP: 87.121.0.45
U: neterra
P: neterra

Special thanks to Neterra Telecommunications for sponsoring and providing the hardware and the connectivity for this btest server.

15min. testing time and 24h ban (this was their request).

Please share results when you test. Cheers ;)
transmitting and receiving 800mb
Thanks, it worked like a charm. Have a nice day sir !
 
User avatar
CZFan
Forum Guru
Forum Guru
Posts: 1392
Joined: Sun Oct 09, 2016 8:25 pm
Location: South Africa, Randburg
Contact:

Re: NEW Public Bandwith Test Server

Tue Sep 17, 2019 1:38 pm

Seems to not work for me, goes into running state, but then nothing happens
Nterra Test.JPG
You do not have the required permissions to view the files attached to this post.
MTCNA, MTCTCE, MTCRE & MTCINE
 
marisspringis
just joined
Posts: 6
Joined: Wed Dec 12, 2018 2:17 pm

Re: NEW Public Bandwith Test Server

Tue Sep 17, 2019 2:39 pm

just tested, everything works fine

Code: Select all

> /tool bandwidth-test 87.121.0.45 user=neterra password=net
erra direction=both
;;; results can be limited by cpu, note that traffic
generation/termination performance might not be
representative of forwarding performance
status: running
duration: 2m57s
tx-current: 601.2Mbps
tx-10-second-average: 605.1Mbps
tx-total-average: 603.1Mbps
rx-current: 602.5Mbps
rx-10-second-average: 604.7Mbps
rx-total-average: 607.2Mbps
lost-packets: 5416
random-data: no
direction: both
tx-size: 1500
rx-size: 1500
connection-count: 20
local-cpu-load: 57%
remote-cpu-load: 100%
p.s remote CPU load 100% is that ok? you mentioned before that it doesn't get higher than 70%

Who is online

Users browsing this forum: No registered users and 12 guests