Community discussions

MikroTik App
 
garethiowc
just joined
Topic Author
Posts: 9
Joined: Wed Dec 03, 2014 12:33 am

EOIP

Fri May 17, 2019 2:34 pm

Hi all,

I have an EOIP tunnel that's been working fine for about 6 months and now it keeps dropping.
In the log i see "Bridge port received packet with own address as source address."

Main Site -
main site.png

# may/17/2019 08:43:46 by RouterOS 6.43
# software id = FD5Z-C7QU
#
# model = 2011UiAS

/interface bridge
add fast-forward=no name=VPLS_Bridge
add admin-mac=E4:8D:8C:2A:16:C3 auto-mac=no fast-forward=no name="Wan Bridge" \
    protocol-mode=none
add fast-forward=no name=loopback
/interface ethernet
set [ find default-name=ether9 ] comment="Watchguard m270"
set [ find default-name=ether10 ] comment=WAN
/interface eoip
add mac-address=02:54:A6:B0:A2:F5 name=eoip-tunnel1 remote-address=10.30.1.6 \
    tunnel-id=2526
/interface vpls
add disabled=no l2mtu=1500 mac-address=02:FE:32:9B:29:1F name=vpls1 \
    remote-peer=10.25.26.2 vpls-id=2:5
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/routing ospf instance
set [ find default=yes ] redistribute-connected=as-type-1 router-id=\
    10.25.26.1
/interface bridge port
add bridge="Wan Bridge" interface=ether10 trusted=yes
add bridge="Wan Bridge" interface=ether9 trusted=yes
add bridge=VPLS_Bridge interface=ether1 trusted=yes
add bridge=VPLS_Bridge interface=eoip-tunnel1 trusted=yes
/ip neighbor discovery-settings
set discover-interface-list=all
/ip address
add address=10.30.1.2/30 interface="Wan Bridge" network=10.30.1.0
add address=10.25.26.1 interface=loopback network=10.25.26.1
/ip dns
set allow-remote-requests=yes servers=8.8.8.8
/ip firewall service-port
set ftp disabled=yes
set tftp disabled=yes
set irc disabled=yes
set h323 disabled=yes
set sip disabled=yes
set pptp disabled=yes
set udplite disabled=yes
set dccp disabled=yes
set sctp disabled=yes
/ip route
add distance=1 gateway=10.30.1.1
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set ssh disabled=yes
set api disabled=yes
set winbox address=
set api-ssl disabled=yes
/lcd
set backlight-timeout=never
/lcd interface
set sfp1 disabled=yes
set ether1 disabled=yes
set ether2 disabled=yes
set ether3 disabled=yes
set ether4 disabled=yes
set ether5 disabled=yes
set ether6 disabled=yes
set ether7 disabled=yes
set ether8 disabled=yes
set ether9 disabled=yes
/mpls interface
set [ find default=yes ] mpls-mtu=1592
/mpls ldp
set enabled=yes lsr-id=10.25.26.1 transport-address=10.25.26.1
/mpls ldp interface
add interface="Wan Bridge"
/routing ospf interface
add interface=loopback network-type=broadcast
add interface="Wan Bridge" network-type=point-to-point
/routing ospf network
add area=backbone network=10.30.1.0/30
add area=backbone network=10.25.26.1/32
/system ntp client
set enabled=yes primary-ntp=10.25.25.1
/system routerboard settings
set silent-boot=no

End Site -
end site.png


# may/17/2019 09:44:33 by RouterOS 6.44.3
# software id = MKH7-2GV7
#
# model = RouterBOARD 941-2nD
# serial number = 
/interface bridge
add fast-forward=no name=VPLS_Bridge protocol-mode=none
add fast-forward=no name=loopback
/interface ethernet
set [ find default-name=ether1 ] advertise=\
    10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full comment=WAN
set [ find default-name=ether2 ] advertise=\
    10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full
set [ find default-name=ether3 ] advertise=\
    10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full
set [ find default-name=ether4 ] advertise=\
    10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full
/interface wireless
set [ find default-name=wlan1 ] ssid=MikroTik
/interface eoip
add mac-address=02:A5:3D:3D:38:D2 name=eoip-tunnel1 remote-address=10.30.1.2 \
    tunnel-id=2526
/interface vpls
add disabled=no l2mtu=1500 mac-address=02:7A:F1:28:03:74 name=vpls1 \
    remote-peer=10.25.26.1 vpls-id=2:5
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp_pool0 ranges=10.10.10.2-10.10.10.254
/queue simple
add max-limit=10M/10M name=queue1 target=ether1
/routing ospf instance
set [ find default=yes ] redistribute-connected=as-type-1 router-id=\
    10.25.26.2
/interface bridge port
add bridge=VPLS_Bridge interface=ether2
add bridge=VPLS_Bridge interface=eoip-tunnel1
/ip address
add address=10.30.1.6/30 interface=ether1 network=10.30.1.4
add address=10.25.26.2 interface=loopback network=10.25.26.2
/ip dhcp-server network
add address=10.10.10.0/24 gateway=10.10.10.1
/ip firewall filter
add action=drop chain=input dst-port=53 in-interface=ether1 protocol=tcp
add action=drop chain=input dst-port=53 in-interface=ether1 protocol=udp
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1 src-address=\
    10.10.10.1-10.10.10.254
/ip firewall service-port
set ftp disabled=yes
set tftp disabled=yes
set irc disabled=yes
set h323 disabled=yes
set sip disabled=yes
set pptp disabled=yes
set udplite disabled=yes
set dccp disabled=yes
set sctp disabled=yes
/ip route
add distance=1 gateway=10.30.1.5
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set ssh disabled=yes
set api disabled=yes
set winbox address=
set api-ssl disabled=yes
/mpls interface
set [ find default=yes ] mpls-mtu=1592
/mpls ldp
set enabled=yes lsr-id=10.25.26.2 transport-address=10.25.26.2
/mpls ldp interface
add interface=ether1
/routing ospf interface
add interface=ether1 network-type=point-to-point
/routing ospf network
add area=backbone network=10.25.26.2/32
add area=backbone network=10.30.1.4/30
/system clock
set time-zone-name=Europe/London

/system ntp client
set enabled=yes primary-ntp=10.25.25.1


Setup Diagram
main site.png
Any help would be great as i'm really stuck

Thanks
Gareth
You do not have the required permissions to view the files attached to this post.
 
tdw
Member
Member
Posts: 388
Joined: Sat May 05, 2018 11:55 am

Re: EOIP

Fri May 17, 2019 3:36 pm

Your diagram doesn't show which ports are connected to which devices so the topology isn't easy to figure out. Have you changed anything since it was working, e.g. upgraded firmware on anything.

Who is online

Users browsing this forum: micin and 48 guests