Community discussions

 
jwilkinson6028
just joined
Topic Author
Posts: 8
Joined: Wed Feb 10, 2016 9:21 pm

IPSec Broken after upgrade to 6.44.3

Fri May 17, 2019 6:38 pm

I have a CCR 1016 that was on version 6.44.1 and I upgraded it to 6.44.3. After the upgrade IPSec is completely broken. I cannot add policies, peers, profiles, or anything IPSec related. all previous configurations are not working. The only thing in the logs is an l2tp error "could not add IPsec policy: std failure: timeout(13)". If I try to add anything to IPSec in the GUI or via CLI it fails.

I tried to downgrade back to the original 6.44.1 but that still has the same errors. I am stuck as I cannot get anything to work at the moment.
 
Marino
Frequent Visitor
Frequent Visitor
Posts: 51
Joined: Sun Jun 14, 2015 7:26 pm

Re: IPSec Broken after upgrade to 6.44.3

Fri May 17, 2019 6:46 pm

I have a CCR 1016 that was on version 6.44.1 and I upgraded it to 6.44.3. After the upgrade IPSec is completely broken. I cannot add policies, peers, profiles, or anything IPSec related. all previous configurations are not working. The only thing in the logs is an l2tp error "could not add IPsec policy: std failure: timeout(13)". If I try to add anything to IPSec in the GUI or via CLI it fails.

I tried to downgrade back to the original 6.44.1 but that still has the same errors. I am stuck as I cannot get anything to work at the moment.
I had the same on a CHR installation. Had to go back to 6.43.14 and a backup made with a 6.43 version in the past.
 
User avatar
inteq
Frequent Visitor
Frequent Visitor
Posts: 88
Joined: Wed Feb 25, 2015 8:15 pm

Re: IPSec Broken after upgrade to 6.44.3

Fri May 17, 2019 7:32 pm

IPSec works just fine here with 6.44.3 on several routers/models. Did not see that error on any of them.
The only only thing that might make a difference is that I went from 6.44.2 to 6.44.3 and not from 6.44.1 to 6.44.3.
The only change I see in 6.44.3 since 6.44.1 is:
*) ipsec - fixed freshly created identity not taken in action (introduced in v6.44);
*) ipsec - fixed possible configuration corruption after import (introduced in v6.44);
 
jwilkinson6028
just joined
Topic Author
Posts: 8
Joined: Wed Feb 10, 2016 9:21 pm

Re: IPSec Broken after upgrade to 6.44.3

Fri May 17, 2019 8:05 pm

I have 10 or so CCRs and I have upgraded most of them from 6.44.1 to 6.44.3 without any issues. This is the first time I have ever had an issue with upgrading a router in the 5 or so years I have been using Mikrotik.
 
Marino
Frequent Visitor
Frequent Visitor
Posts: 51
Joined: Sun Jun 14, 2015 7:26 pm

Re: IPSec Broken after upgrade to 6.44.3

Fri May 17, 2019 8:40 pm

I have 10 or so CCRs and I have upgraded most of them from 6.44.1 to 6.44.3 without any issues. This is the first time I have ever had an issue with upgrading a router in the 5 or so years I have been using Mikrotik.
Did you use version 6.44 on the router too? The first time I lost the configuration was after a reboot with this version. I had to restore a backup. After that I had the problem again when upgrading from 6.44.2 to 6.44.3.

Who is online

Users browsing this forum: No registered users and 41 guests