Community discussions

 
ehbowen
newbie
Topic Author
Posts: 35
Joined: Tue Sep 05, 2017 6:13 am
Location: Houston, Texas
Contact:

Temporarily disabling 5GHz wi-fi band on hAP ac router

Sun Jun 09, 2019 4:15 am

I have an IoT device (weather station) which is not connecting to my router any longer (it worked properly for five months, but no more). I've attempted a reset to factory defaults and restarted it several times, but no joy. The manufacturer does not know how to support MikroTik but states that the device will only connect on 2.4GHz and does not support 5GHz; they will not warranty their device until I can demonstrate that it is attempting to connect on the proper band.

I've tried going into the "Interfaces" tab and disabling one of the WLAN interfaces at a time, but it appears that no matter which one I disable the other defaults back to 5GHz. I'm still getting acquainted with RouterOS and haven't figured out how to get into it in any more depth. Some assistance would be appreciated. At present I have it set up for dual-band AP (same SSID, both bands) with an additional SSID for a guest network. Thanks for any help.
Image There are very few problems which cannot be solved by a suitable application of high explosives....
 
td32
Frequent Visitor
Frequent Visitor
Posts: 83
Joined: Fri Nov 18, 2016 5:55 am

Re: Temporarily disabling 5GHz wi-fi band on hAP ac router

Sun Jun 09, 2019 4:48 am

I've tried going into the "Interfaces" tab and disabling one of the WLAN interfaces at a time, but it appears that no matter which one I disable the other defaults back to 5GHz.
There is no way for this to happen, default wlan1 interface is 2.4GHz and wlan2 is the 5Ghz only
If your IoT is only 2.4Ghz there is now way for it to try to connect to your 5Ghz network, so disabling wlan2 or not doesn't matter at all since your IoT cant really see the 5Ghz signal.
try and look what are the supported channels on 2.4Ghz for you IoT, normally US 1-11 and EU 1-13, then set a fixed channel to the wlan1 interface in the supported range of your IoT.
 
mkx
Forum Guru
Forum Guru
Posts: 2482
Joined: Thu Mar 03, 2016 10:23 pm

Re: Temporarily disabling 5GHz wi-fi band on hAP ac router

Sun Jun 09, 2019 11:52 am

Adding to what @td32 wrote: I've seen cases when a wireless device refused to "see" SSID operating on channel 13 even though it supported it ... until device determined it was actually allowed to use channel 13 (one example: it was a pristne new LG G4 mobile phone which wouldn't see WAP until I inserted SIM card so it could connect to mobile network giving it information of approximate where abouts).

So try to set frequency on your 2.4 GHz WAP to some of lower values and see if weather station starts to "see" ...
BR,
Metod

Who is online

Users browsing this forum: No registered users and 7 guests